FutureNet

NXR,WXRシリーズ

IPv6編

7.「v6プラス」接続設定

7-3. 「v6プラス」接続設定3

日本ネットワークイネイブラー株式会社(以下JPNE社)が提供する「v6プラス」を利用する設定例です。この設定例では、DHCPv6-PDでIPv6プレフィックスの払い出しが行われることを想定しています。
※「v6プラス」は、日本ネットワークイネイブラー株式会社の登録商標(または商標)です。

 

【対象機種】NXR-G200シリーズ(2020/10現在)
最新の対応状況は、各製品の更新履歴やユーザーズガイドをご確認ください。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 補足 付録

 

【 構成図 】

  • IPv6プレフィックス、DNSサーバアドレスはDHCPv6で取得します。
  • ルータ配下の端末にはIPv6プレフィックスはRAで、DNSサーバアドレスはRA,DHCPv6で広告します。またIPv4アドレスはDHCPで配布します。

 

【 設定例 】

nxrg240#configure terminal
nxrg240(config)#ipv6 dhcp-client ipv6dhcpc
nxrg240(config-dhcp6c)#ia-pd dhcpv6pd
nxrg240(config-dhcp6c)#option-request dns-servers
nxrg240(config-dhcp6c)#exit
nxrg240(config)#ipv6 dhcp-server ipv6dhcps
nxrg240(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1
nxrg240(config-dhcp6s)#exit
nxrg240(config)#mape-rule v6plus type jpne auto
nxrg240(config-map)#exit
nxrg240(config)#interface map 0
nxrg240(config-map)#tunnel mode ipipv6 mape-rule v6plus
nxrg240(config-map)#ip spi-filter
nxrg240(config-map)#ip tcp adjust-mss auto
nxrg240(config-map)#no tunnel encap-limit
nxrg240(config-map)#exit
nxrg240(config)#ip route 0.0.0.0/0 map 0
nxrg240(config)#ipv6 route ::/0 dhcp ethernet 1
nxrg240(config)#ipv6 access-list eth1_in permit any any icmpv6
nxrg240(config)#ipv6 access-list eth1_in permit any any udp any 546
nxrg240(config)#ipv6 access-list eth1_in permit any any 4
nxrg240(config)#interface ethernet 0
nxrg240(config-if)#ip address 192.168.10.1/24
nxrg240(config-if)#ipv6 address dhcpv6pd ::/64 mape-rule v6plus
nxrg240(config-if)#ipv6 nd send-ra
nxrg240(config-if)#ipv6 nd other-config-flag
nxrg240(config-if)#ipv6 nd ra-dns-server dhcp-client ethernet 1
nxrg240(config-if)#ipv6 dhcp server ipv6dhcps
nxrg240(config-if)#ip access-linkdown
nxrg240(config-if)#ipv6 access-linkdown
nxrg240(config-if)#exit
nxrg240(config)#dhcp-server 1
nxrg240(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg240(config-dhcps)#gateway 192.168.10.1
nxrg240(config-dhcps)#dns-server 192.168.10.1
nxrg240(config-dhcps)#exit
nxrg240(config)#interface ethernet 1
nxrg240(config-if)#no ip address
nxrg240(config-if)#ipv6 dhcp client ipv6dhcpc
nxrg240(config-if)#ipv6 access-group in eth1_in
nxrg240(config-if)#ipv6 spi-filter
nxrg240(config-if)#exit
nxrg240(config)#dns
nxrg240(config-dns)#service enable
nxrg240(config-dns)#edns-query enable
nxrg240(config-dns)#exit
nxrg240(config)#fast-forwarding enable
nxrg240(config)#exit
nxrg240#save config

 

【 設定例解説 】

1. <DHCPv6クライアント設定>
nxrg240(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

nxrg240(config-dhcp6c)#ia-pd dhcpv6pd

Identity Association for Prefix Delegation(IAPD)を有効にし、IPv6プレフィックスの名前を定義します。

nxrg240(config-dhcp6c)#option-request dns-servers

DHCPv6サーバに対してDNSサーバアドレスの通知を要求するように設定します。

 

2. <DHCPv6サーバ設定>
nxrg240(config)#ipv6 dhcp-server ipv6dhcps

DHCPv6サーバ設定の名前を定義します。

nxrg240(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1

DHCPv6 Reply送信時に、DNSサーバアドレスを通知するように設定します。
(☞) この設定例ではDHCPv6クライアントで取得したDNSサーバアドレスを広告します。

 

3. <MAP-Eルール設定>
nxrg240(config)#mape-rule v6plus type jpne auto

MAP-Eルール名をv6plusとし、MAP-Eのルールタイプをjpne,取得方法をautoに設定します。

 

4. <map0インタフェース設定>
nxrg240(config)#interface map 0
nxrg240(config-map)#tunnel mode ipipv6 mape-rule v6plus

map0インタフェースでトンネルモードとMAP-Eルール名を設定します。

nxrg240(config-map)#ip spi-filter

IPv4ステートフルパケットインスペクションを有効にします。

nxrg240(config-map)#ip tcp adjust-mss auto

IPv4 TCP MSSの調整機能をオートに設定します。

nxrg240(config-map)#no tunnel encap-limit

encap-limit設定を無効にします。

 

5. <IPv4スタティックルート設定>
nxrg240(config)#ip route 0.0.0.0/0 map 0

IPv4デフォルトルートを設定します。

 

6. <IPv6スタティックルート設定>
nxrg240(config)#ipv6 route ::/0 dhcp ethernet 1

IPv6デフォルトルートを設定します。

 

7. <IPv6アクセスリスト設定>
nxrg240(config)#ipv6 access-list eth1_in permit any any icmpv6
nxrg240(config)#ipv6 access-list eth1_in permit any any udp any 546
nxrg240(config)#ipv6 access-list eth1_in permit any any 4

IPv6アクセスリストeth1_inを以下のルールで設定します。

  • ICMPv6を許可
  • 宛先UDPポート546番(DHCPv6クライアント)を許可
  • IPIP(プロトコル番号4)を許可

(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

8. <LAN側(ethernet0)インタフェース設定>
nxrg240(config)#interface ethernet 0
nxrg240(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

nxrg240(config-if)#ipv6 address dhcpv6pd ::/64 mape-rule v6plus

ethernet0インタフェースのIPv6アドレスを設定します。なおインタフェースIDにはMAP-Eルール名を設定します。

nxrg240(config-if)#ipv6 nd send-ra

IPv6 RA(Router Advertisement)を送信するように設定します。

nxrg240(config-if)#ipv6 nd other-config-flag

RAパケットのOフラグ(other-config-flag)を設定します。

nxrg240(config-if)#ipv6 nd ra-dns-server dhcp-client ethernet 1

RA送信時、RDNSS(Recursive DNS Server)を送信するように設定します。
(☞) この設定例ではDHCPv6クライアントで取得したDNSサーバアドレスを広告します。

nxrg240(config-if)#ipv6 dhcp server ipv6dhcps

DHCPv6サーバ名を指定し、DHCPv6サーバを有効にします。

nxrg240(config-if)#ip access-linkdown

IPアクセスリンクダウンを有効にします。

nxrg240(config-if)#ipv6 access-linkdown

IPv6アクセスリンクダウンを有効にします。

 

9. <IPv4 DHCPサーバ設定>
nxrg240(config)#dhcp-server 1
nxrg240(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg240(config-dhcps)#gateway 192.168.10.1
nxrg240(config-dhcps)#dns-server 192.168.10.1

IPv4 DHCPサーバを設定します。

 

10. <ethernet1インタフェース設定>
nxrg240(config)#interface ethernet 1
nxrg240(config-if)#no ip address

ethernet1インタフェースのIPv4アドレスを無効にします。

nxrg240(config-if)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

nxrg240(config-if)#ipv6 access-group in eth1_in

IPv6アクセスグループのinフィルタにIPv6アクセスリストeth1_inを設定します。

nxrg240(config-if)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

 

11. <DNS設定>
nxrg240(config)#dns
nxrg240(config-dns)#service enable

DNSサービスを有効にします。

nxrg240(config-dns)#edns-query enable

EDNSを有効にします。

 

12. <ファストフォワーディング設定>
nxrg240(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

 

13. <設定の保存>
nxrg240#save config

設定内容を保存します。

 

【 端末の設定例 】

IPv4 アドレス DHCPサーバから自動取得
サブネットマスク
デフォルトゲートウェイ
DNSサーバアドレス
IPv6 プレフィックス ルータからRAで取得
アドレス プレフィックス情報を元に自動生成
デフォルトゲートウェイ ルータからRAで取得
DNSサーバアドレス ルータからDHCPv6で取得

 

【 補足 】

map0インタフェースにMAPルールで割り当てられたIPv4アドレスを割り当てる場合、下記のように設定します。

<map0インタフェースのIPv4アドレス設定>
nxrg240(config)#interface map 0
nxrg240(config-map)#ip address mape-rule

 

【 付録 】