FutureNet

NXR,WXRシリーズ

IPv6編

7.「v6プラス」接続設定

7-1. 「v6プラス」接続設定1

日本ネットワークイネイブラー株式会社(以下JPNE社)が提供する「v6プラス」を利用する設定例です。この設定例ではひかり電話契約なしの場合を想定しています。
※「v6プラス」は、日本ネットワークイネイブラー株式会社の登録商標(または商標)です。

 

【対象機種】NXR-650,NXR-610Xシリーズ,NXR-530,NXR-160/LW,NXR-G180/L-CA,NXR-G200シリーズ,NXR-G110シリーズ(2022/1現在)
最新の対応状況は、各製品の更新履歴やユーザーズガイドをご確認ください。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 補足 付録

 

【 構成図 】

 

  • ひかり電話契約なしの場合、IPv6プレフィックスはRAで、DNSサーバアドレスはDHCPv6で取得します。
  • ルータ配下の端末にはIPv6プレフィックスはRAで、DNSサーバアドレスはDHCPv6で広告します。またIPv4アドレスはDHCPで配布します。
    ※IPv6DNSサーバアドレスをRAで広告できる機種もあります。詳細はこちら

 

【 設定例 】

nxr530#configure terminal
nxr530(config)#ipv6 dhcp-client IPv6DHCPC
nxr530(config-dhcp6c)#information-only enable
nxr530(config-dhcp6c)#option-request dns-servers
nxr530(config-dhcp6c)#exit
nxr530(config)#ipv6 dhcp-server IPv6DHCPS
nxr530(config-dhcp6s)#option-send dns-server add ipv6 dhcp-client ethernet 1
nxr530(config-dhcp6s)#exit
nxr530(config)#mape-rule v6PLUS type jpne auto
nxr530(config-map)#exit
nxr530(config)#interface map 0
nxr530(config-map)#tunnel mode ipipv6 mape-rule v6PLUS
nxr530(config-map)#ip spi-filter
nxr530(config-map)#ip tcp adjust-mss auto
nxr530(config-map)#no tunnel encap-limit
nxr530(config-map)#exit
nxr530(config)#ip route 0.0.0.0/0 map 0
nxr530(config)#ipv6 access-list eth1_IN permit any any icmpv6
nxr530(config)#ipv6 access-list eth1_IN permit any any udp any 546
nxr530(config)#ipv6 access-list eth1_IN permit any any 4
nxr530(config)#interface ethernet 0
nxr530(config-if)#ip address 192.168.10.1/24
nxr530(config-if)#ipv6 address autoconfig interface-id mape-rule v6PLUS
nxr530(config-if)#ipv6 nd send-ra
nxr530(config-if)#ipv6 nd other-config-flag
nxr530(config-if)#ipv6 dhcp server IPv6DHCPS
nxr530(config-if)#ip access-linkdown
nxr530(config-if)#ipv6 access-linkdown
nxr530(config-if)#exit
nxr530(config)#dhcp-server 1
nxr530(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxr530(config-dhcps)#gateway 192.168.10.1
nxr530(config-dhcps)#dns-server 192.168.10.1
nxr530(config-dhcps)#exit
nxr530(config)#interface ethernet 1
nxr530(config-if)#no ip address
nxr530(config-if)#ipv6 nd accept-ra proxy ethernet 0
nxr530(config-if)#ipv6 dhcp client IPv6DHCPC
nxr530(config-if)#ipv6 access-group in eth1_IN
nxr530(config-if)#ipv6 spi-filter
nxr530(config-if)#exit
nxr530(config)#dns
nxr530(config-dns)#service enable
nxr530(config-dns)#edns-query enable
nxr530(config-dns)#exit
nxr530(config)#fast-forwarding enable
nxr530(config)#exit
nxr530#save config

 

【 設定例解説 】

1. <DHCPv6クライアント設定>
nxr530(config)#ipv6 dhcp-client IPv6DHCPC

DHCPv6クライアント設定の名前を定義します。

nxr530(config-dhcp6c)#information-only enable

information-only機能を有効にします。

nxr530(config-dhcp6c)#option-request dns-servers

DHCPv6サーバに対してDNSサーバアドレスの通知を要求するように設定します。

 

2. <DHCPv6サーバ設定>
nxr530(config)#ipv6 dhcp-server IPv6DHCPS

DHCPv6サーバ設定の名前を定義します。

nxr530(config-dhcp6s)#option-send dns-server add ipv6 dhcp-client ethernet 1

DHCPv6 Reply送信時に、DNSサーバアドレスを通知するように設定します。
(☞) この設定例ではDHCPv6クライアントで取得したDNSサーバアドレスを広告します。

 

3. <MAP-Eルール設定>
nxr530(config)#mape-rule v6PLUS type jpne auto

MAP-Eルール名をv6PLUSとし、MAP-Eのルールタイプをjpne,取得方法をautoに設定します。

 

4. <map0インタフェース設定>
nxr530(config)#interface map 0
nxr530(config-map)#tunnel mode ipipv6 mape-rule v6PLUS

map0インタフェースでトンネルモードとMAP-Eルール名を設定します。

nxr530(config-map)#ip spi-filter

IPv4ステートフルパケットインスペクションを有効にします。

nxr530(config-map)#ip tcp adjust-mss auto

IPv4 TCP MSSの調整機能をオートに設定します。

nxr530(config-map)#no tunnel encap-limit

encap-limit設定を無効にします。

 

5. <IPv4スタティックルート設定>
nxr530(config)#ip route 0.0.0.0/0 map 0

IPv4デフォルトルートを設定します。

 

6. <IPv6アクセスリスト設定>
nxr530(config)#ipv6 access-list eth1_IN permit any any icmpv6
nxr530(config)#ipv6 access-list eth1_IN permit any any udp any 546
nxr530(config)#ipv6 access-list eth1_IN permit any any 4

IPv6アクセスリストeth1_INを以下のルールで設定します。

  • ICMPv6を許可
  • 宛先UDPポート546番(DHCPv6クライアント)を許可
  • プロトコル番号4(IPIP)を許可

(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

7. <LAN側(ethernet0)インタフェース設定>
nxr530(config)#interface ethernet 0
nxr530(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

nxr530(config-if)#ipv6 address autoconfig interface-id mape-rule v6PLUS

ethernet0インタフェースのIPv6アドレスを設定します。なおインタフェースIDにはMAP-Eルール名を設定します。

nxr530(config-if)#ipv6 nd send-ra

IPv6 RA(Router Advertisement)を送信するように設定します。

nxr530(config-if)#ipv6 nd other-config-flag

RAパケットのOフラグ(other-config-flag)を設定します。

nxr530(config-if)#ipv6 dhcp server IPv6DHCPS

DHCPv6サーバ名を指定し、DHCPv6サーバを有効にします。

nxr530(config-if)#ip access-linkdown

IPアクセスリンクダウンを有効にします。

nxr530(config-if)#ipv6 access-linkdown

IPv6アクセスリンクダウンを有効にします。

 

8. <IPv4 DHCPサーバ設定>
nxr530(config)#dhcp-server 1
nxr530(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxr530(config-dhcps)#gateway 192.168.10.1
nxr530(config-dhcps)#dns-server 192.168.10.1

IPv4 DHCPサーバを設定します。

 

9. <ethernet1インタフェース設定>
nxr530(config)#interface ethernet 1
nxr530(config-if)#no ip address

ethernet1インタフェースのIPv4アドレスを無効にします。

nxr530(config-if)#ipv6 nd accept-ra proxy ethernet 0

RAプロキシを有効にします。

nxr530(config-if)#ipv6 dhcp client IPv6DHCPC

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

nxr530(config-if)#ipv6 access-group in eth1_IN

IPv6アクセスグループのinフィルタにIPv6アクセスリストeth1_INを設定します。

nxr530(config-if)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

 

10. <DNS設定>
nxr530(config)#dns
nxr530(config-dns)#service enable

DNSサービスを有効にします。

nxr530(config-dns)#edns-query enable

EDNSを有効にします。

 

11. <ファストフォワーディング設定>
nxr530(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

 

12. <設定の保存>
nxr530#save config

設定内容を保存します。

 

【 端末の設定例 】

IPv4 アドレス DHCPサーバから自動取得
サブネットマスク
デフォルトゲートウェイ
DNSサーバアドレス
IPv6 プレフィックス ルータからRAで取得
アドレス プレフィックス情報を元に自動生成
デフォルトゲートウェイ ルータからRAで取得
DNSサーバアドレス ルータからDHCPv6で取得

 

【 補足 】

〔map0インタフェースのIPv4アドレス設定〕

map0インタフェースにMAPルールで割り当てられたIPv4アドレスを割り当てる場合、下記のように設定します。

<map0インタフェースのIPv4アドレス設定>
(config)#interface map 0
(config-map)#ip address mape-rule

 

〔RDNSS設定〕

一部機種ではRA送信時、RDNSS(Recursive DNS Server)を送信することができます。

【対象機種】NXR-650,NXR-610Xシリーズ,NXR-530,NXR-160/LW,NXR-G200シリーズ,NXR-G110シリーズ(2022/1現在)
最新の対応状況は、各製品の更新履歴やユーザーズガイドをご確認ください。

<RDNSS設定>
(config)#interface ethernet 0
(config-if)#ipv6 nd ra-dns-server dhcp-client ethernet 1

RA送信時、RDNSSを送信するように設定します。
(☞) この例ではDHCPv6クライアントで取得したDNSサーバアドレスを広告します。

 

〔任意のIPv6DNSサーバアドレスの広告設定〕

ルータ配下の端末に任意のIPv6DNSサーバアドレスを広告することも可能です。

<DHCPv6サーバ設定>
(config)#ipv6 dhcp-server IPv6DHCPS
(config-dhcp6s)#option-send dns-server address 2001:db8::1

DHCPv6 Reply送信時に、指定したDNSサーバアドレスを通知するように設定します。

 

<RDNSS設定>

【対象機種】NXR-650,NXR-610Xシリーズ,NXR-530,NXR-160/LW,NXR-G200シリーズ,NXR-G110シリーズ(2022/1現在)
最新の対応状況は、各製品の更新履歴やユーザーズガイドをご確認ください。

(config)#interface ethernet 0
(config-if)#ipv6 nd ra-dns-server 2001:db8::1

RA送信時、指定したDNSサーバアドレスを送信するように設定します。

 

【 付録 】