FutureNet

NXR,WXRシリーズ

IPv6編

7.「v6プラス」接続設定

7-4. 「v6プラス」を利用したIPsec接続設定

日本ネットワークイネイブラー株式会社(以下JPNE社)が提供する「v6プラス」のIPv4通信用に作成したIPv4 over IPv6トンネル上でIPsec接続する設定例です。なおこの例では、ひかり電話契約なしの回線を「v6プラス」側拠点で利用することを想定しています。
※「v6プラス」は、日本ネットワークイネイブラー株式会社の登録商標(または商標)です。

 

【対象機種】NXR-650,NXR-530,NXR-G180/L-CA,NXR-G200シリーズ,NXR-G110シリーズ

 

コンテンツ
構成図 設定フロー 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • ルータNXR_Bは、ひかり電話契約なしの回線のため、IPv6プレフィックスはRAで、DNSサーバアドレスはDHCPv6で取得します。またルータ配下の端末にはIPv6プレフィックスはRAで、DNSサーバアドレスはDHCPv6で広告します。またIPv4アドレスはDHCPで配布します。

 

【 設定フロー 】

〔NXR_Bの設定フロー〕

 

【 設定例 】

〔NXR_Aの設定〕

nxr350#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr350(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24
NXR_A(config-if)#exit
NXR_A(config)#ip route 192.168.20.0/24 tunnel 1 1
NXR_A(config)#ip route 192.168.20.0/24 null 254
NXR_A(config)#ip route 0.0.0.0/0 203.0.113.2
NXR_A(config)#ip access-list eth1_in permit any 203.0.113.1 udp any 500
NXR_A(config)#ip access-list eth1_in permit any 203.0.113.1 udp any 4500
NXR_A(config)#ipsec nat-traversal enable
% restart ipsec service to take affect.
NXR_A(config)#ipsec access-list ipsec_acl ip any any
NXR_A(config)#ipsec local policy 1
NXR_A(config-ipsec-local)#address ip
NXR_A(config-ipsec-local)#exit
NXR_A(config)#ipsec isakmp policy 1
NXR_A(config-ipsec-isakmp)#description NXR_B
NXR_A(config-ipsec-isakmp)#authentication pre-share ipseckey
NXR_A(config-ipsec-isakmp)#hash sha256
NXR_A(config-ipsec-isakmp)#encryption aes128
NXR_A(config-ipsec-isakmp)#group 5
NXR_A(config-ipsec-isakmp)#lifetime 10800
NXR_A(config-ipsec-isakmp)#isakmp-mode aggressive
NXR_A(config-ipsec-isakmp)#remote address ip any
NXR_A(config-ipsec-isakmp)#remote identity fqdn nxrb
NXR_A(config-ipsec-isakmp)#keepalive 30 3 periodic clear
NXR_A(config-ipsec-isakmp)#local policy 1
NXR_A(config-ipsec-isakmp)#exit
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode ipsec ipv4
NXR_A(config-tunnel)#tunnel protection ipsec policy 1
NXR_A(config-tunnel)#ip tcp adjust-mss auto
NXR_A(config-tunnel)#exit
NXR_A(config)#ipsec tunnel policy 1
NXR_A(config-ipsec-tunnel)#description NXR_B
NXR_A(config-ipsec-tunnel)#negotiation-mode responder
NXR_A(config-ipsec-tunnel)#set transform esp-aes128 esp-sha256-hmac
NXR_A(config-ipsec-tunnel)#set pfs group5
NXR_A(config-ipsec-tunnel)#set sa lifetime 3600
NXR_A(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_A(config-ipsec-tunnel)#match address ipsec_acl
NXR_A(config-ipsec-tunnel)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#ip address 203.0.113.1/30
NXR_A(config-if)#ip access-group in eth1_in
NXR_A(config-if)#ip masquerade
NXR_A(config-if)#ip spi-filter
NXR_A(config-if)#ip tcp adjust-mss auto
NXR_A(config-if)#ipsec policy 1
NXR_A(config-if)#exit
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#address 203.0.113.253
NXR_A(config-dns)#address 203.0.113.254
NXR_A(config-dns)#exit
NXR_A(config)#fast-forwarding enable
NXR_A(config)#exit
NXR_A#save config

 

〔NXR_Bの設定〕

nxrg240#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg240(config)#hostname NXR_B
NXR_B(config)#ip route 192.168.10.0/24 tunnel 1
NXR_B(config)#ip route 192.168.10.0/24 null 254
NXR_B(config)#ip route 0.0.0.0/0 map 0
NXR_B(config)#ipv6 access-list eth1_in permit any any icmpv6
NXR_B(config)#ipv6 access-list eth1_in permit any any udp any 546
NXR_B(config)#ipv6 access-list eth1_in permit any any 4
NXR_B(config)#ipsec nat-traversal enable
% restart ipsec service to take affect.
NXR_B(config)#ipsec access-list ipsec_acl ip any any
NXR_B(config)#ipsec local policy 1
NXR_B(config-ipsec-local)#address ip
NXR_B(config-ipsec-local)#self-identity fqdn nxrb
NXR_B(config-ipsec-local)#exit
NXR_B(config)#ipsec isakmp policy 1
NXR_B(config-ipsec-isakmp)#description NXR_A
NXR_B(config-ipsec-isakmp)#authentication pre-share ipseckey
NXR_B(config-ipsec-isakmp)#hash sha256
NXR_B(config-ipsec-isakmp)#encryption aes128
NXR_B(config-ipsec-isakmp)#group 5
NXR_B(config-ipsec-isakmp)#lifetime 10800
NXR_B(config-ipsec-isakmp)#isakmp-mode aggressive
NXR_B(config-ipsec-isakmp)#remote address ip 203.0.113.1
NXR_B(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR_B(config-ipsec-isakmp)#local policy 1
NXR_B(config-ipsec-isakmp)#exit
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode ipsec ipv4
NXR_B(config-tunnel)#tunnel protection ipsec policy 1
NXR_B(config-tunnel)#ip tcp adjust-mss auto
NXR_B(config-tunnel)#exit
NXR_B(config)#ipsec tunnel policy 1
NXR_B(config-ipsec-tunnel)#description NXR_A
NXR_B(config-ipsec-tunnel)#negotiation-mode auto
NXR_B(config-ipsec-tunnel)#set transform esp-aes128 esp-sha256-hmac
NXR_B(config-ipsec-tunnel)#set pfs group5
NXR_B(config-ipsec-tunnel)#set sa lifetime 3600
NXR_B(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_B(config-ipsec-tunnel)#match address ipsec_acl
NXR_B(config-ipsec-tunnel)#exit
NXR_B(config)#ipv6 dhcp-client ipv6dhcpc
NXR_B(config-dhcp6c)#information-only enable
NXR_B(config-dhcp6c)#option-request dns-servers
NXR_B(config-dhcp6c)#exit
NXR_B(config)#ipv6 dhcp-server ipv6dhcps
NXR_B(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1
NXR_B(config-dhcp6s)#exit
NXR_B(config)#mape-rule v6plus type jpne auto
NXR_B(config)#interface map 0
NXR_B(config-map)#ip address mape-rule
NXR_B(config-map)#tunnel mode ipipv6 mape-rule v6plus
NXR_B(config-map)#ip spi-filter
NXR_B(config-map)#ip tcp adjust-mss auto
NXR_B(config-map)#no tunnel encap-limit
NXR_B(config-map)#ipsec policy 1
NXR_B(config-map)#exit
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.20.1/24
NXR_B(config-if)#ipv6 address autoconfig interface-id mape-rule v6plus
NXR_B(config-if)#ipv6 nd send-ra
NXR_B(config-if)#ipv6 nd other-config-flag
NXR_B(config-if)#ipv6 dhcp server ipv6dhcps
NXR_B(config-if)#exit
NXR_B(config)#dhcp-server 1
NXR_B(config-dhcps)#network 192.168.20.0/24 range 192.168.20.200 192.168.20.210
NXR_B(config-dhcps)#gateway 192.168.20.1
NXR_B(config-dhcps)#dns-server 192.168.20.1
NXR_B(config-dhcps)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#ipv6 nd accept-ra proxy ethernet 0
NXR_B(config-if)#ipv6 dhcp client ipv6dhcpc
NXR_B(config-if)#ipv6 access-group in eth1_in
NXR_B(config-if)#ipv6 spi-filter
NXR_B(config-if)#exit
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#edns-query enable
NXR_B(config-dns)#exit
NXR_B(config)#fast-forwarding enable
NXR_B(config)#exit
NXR_B#save config

 

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxr350(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_A(config)#ip route 192.168.20.0/24 tunnel 1 1
NXR_A(config)#ip route 192.168.20.0/24 null 254

192.168.20.0/24向けのルートを設定します。なおIPsec SA確立時はトンネル1インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。
(☞) nullインタフェースが出力インタフェースとして有効な場合、パケットが出力されることはありません(ドロップされます)。

NXR_A(config)#ip route 0.0.0.0/0 203.0.113.2

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_A(config)#ip access-list eth1_in permit any 203.0.113.1 udp any 500
NXR_A(config)#ip access-list eth1_in permit any 203.0.113.1 udp any 4500

IPアクセスリスト名をeth1_inとします。そして宛先IPアドレス203.0.113.1,宛先UDPポート番号500、4500のパケットを許可します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

5. <IPsec NATトラバーサル設定>
NXR_A(config)#ipsec nat-traversal enable

NATトラバーサルを有効にします。

 

6. <IPsecアクセスリスト設定>
NXR_A(config)#ipsec access-list ipsec_acl ip any any

ipsec_aclという名前のIPsecアクセスリストを設定します。なお送信元IPアドレス,宛先IPアドレスともにanyとします。

 

7. <IPsecローカルポリシー設定>
NXR_A(config)#ipsec local policy 1
NXR_A(config-ipsec-local)#address ip

IPsecトンネルの送信元IPアドレスにip(IPv4)を設定します。

 

8. <IPsec ISAKMPポリシー設定>
NXR_A(config)#ipsec isakmp policy 1
NXR_A(config-ipsec-isakmp)#description NXR_B
NXR_A(config-ipsec-isakmp)#authentication pre-share ipseckey

ISAKMPポリシー1の説明としてNXR_B、認証方式としてpre-share(事前共有鍵)を選択し、事前共有鍵ipseckeyを設定します。なお事前共有鍵はNXR_Bのipsec isakmp policy 1と共通の値を設定します。

NXR_A(config-ipsec-isakmp)#hash sha256
NXR_A(config-ipsec-isakmp)#encryption aes128
NXR_A(config-ipsec-isakmp)#group 5
NXR_A(config-ipsec-isakmp)#lifetime 10800
NXR_A(config-ipsec-isakmp)#isakmp-mode aggressive

認証アルゴリズムとしてsha256、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして10800秒、フェーズ1のネゴシエーションモードとしてアグレッシブモードを設定します。

NXR_A(config-ipsec-isakmp)#remote address ip any
NXR_A(config-ipsec-isakmp)#remote identity fqdn nxrb
NXR_A(config-ipsec-isakmp)#keepalive 30 3 periodic clear
NXR_A(config-ipsec-isakmp)#local policy 1

リモートアドレスにanyを設定します。またリモートIDをFQDN方式でnxrbとし、NXR_BのセルフIDと同じIDを設定します。そしてIKE KeepAlive(DPD)を監視間隔30秒,リトライ回数3回とし、keepalive失敗時にSAを削除するように設定します。さらにIPsecローカルポリシー1と関連づけを行います。

 

9. <トンネル1インタフェース設定>
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode ipsec ipv4
NXR_A(config-tunnel)#tunnel protection ipsec policy 1
NXR_A(config-tunnel)#ip tcp adjust-mss auto

トンネル1インタフェースでトンネルモードをipsec ipv4、使用するIPsecトンネルポリシーとして1を設定します。またTCP MSSの調整機能をオートに設定します。

 

10. <IPsec トンネルポリシー設定>
NXR_A(config)#ipsec tunnel policy 1
NXR_A(config-ipsec-tunnel)#description NXR_B
NXR_A(config-ipsec-tunnel)#negotiation-mode responder

IPsecトンネルポリシー1の説明としてNXR_B、ネゴシエーションモードとしてresponderを設定します。

NXR_A(config-ipsec-tunnel)#set transform esp-aes128 esp-sha256-hmac
NXR_A(config-ipsec-tunnel)#set pfs group5
NXR_A(config-ipsec-tunnel)#set sa lifetime 3600

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha256、PFSを有効にし、かつDHグループとしてgroup5、IPsec SAのライフタイムとして3600秒を設定します。

NXR_A(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_A(config-ipsec-tunnel)#match address ipsec_acl

ISAKMPポリシー1と関連づけを行い、IPsecアクセスリストipsec_aclを設定します。

 

11. <WAN側(ethernet1)インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#ip address 203.0.113.1/30

ethernet1インタフェースのIPアドレスを設定します。

NXR_A(config-if)#ip access-group in eth1_in
NXR_A(config-if)#ip masquerade
NXR_A(config-if)#ip spi-filter
NXR_A(config-if)#ip tcp adjust-mss auto

IPアクセスリストeth1_inをinフィルタに適用します。またIPマスカレード、ステートフルパケットインスペクションを有効に設定します。そしてTCP MSSの調整機能をオートに設定します。

NXR_A(config-if)#ipsec policy 1

IPsecトンネルのエンドポイントとなるためIPsecローカルポリシー1を設定します。

 

12. <DNS設定>
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#address 203.0.113.253
NXR_A(config-dns)#address 203.0.113.254

DNSサービスを有効にします。またプロバイダから指定されたプライマリ,セカンダリのDNSサーバアドレスを設定します。

 

13. <ファストフォワーディング設定>
NXR_A(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを有効にすることでパケット転送を高速に処理することができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg240(config)#hostname NXR_B

ホスト名を設定します。

 

2. <スタティックルート設定>
NXR_B(config)#ip route 192.168.10.0/24 tunnel 1
NXR_B(config)#ip route 192.168.10.0/24 null 254

192.168.10.0/24向けのルートを設定します。なおIPsec SA確立時はトンネル1インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。

NXR_B(config)#ip route 0.0.0.0/0 map 0

デフォルトルートを設定します。

 

3. <IPv6アクセスリスト設定>
NXR_B(config)#ipv6 access-list eth1_in permit any any icmpv6
NXR_B(config)#ipv6 access-list eth1_in permit any any udp any 546
NXR_B(config)#ipv6 access-list eth1_in permit any any 4

IPv6アクセスリスト名をeth1_inとし、ICMPv6、宛先UDPポート546番(DHCPv6クライアント)およびIPinIP(プロトコル番号4)を許可します。

 

4. <IPsec NATトラバーサル設定>
NXR_B(config)#ipsec nat-traversal enable

NATトラバーサルを有効にします。

 

5. <IPsecアクセスリスト設定>
NXR_B(config)#ipsec access-list ipsec_acl ip any any

ipsec_aclという名前のIPsecアクセスリストを設定します。なお送信元IPアドレス,宛先IPアドレスともにanyとします。

 

6. <IPsecローカルポリシー設定>
NXR_B(config)#ipsec local policy 1
NXR_B(config-ipsec-local)#address ip
NXR_B(config-ipsec-local)#self-identity fqdn nxrb

IPsecトンネルの送信元IPアドレスにip(IPv4)を設定します。またセルフIDをFQDN方式でnxrbとし、NXR_AのリモートIDと同じIDを設定します。

 

7. <IPsec ISAKMPポリシー設定>
NXR_B(config)#ipsec isakmp policy 1
NXR_B(config-ipsec-isakmp)#description NXR_A
NXR_B(config-ipsec-isakmp)#authentication pre-share ipseckey

ISAKMPポリシー1の説明としてNXR_A、認証方式としてpre-share(事前共有鍵)を選択し、事前共有鍵ipseckeyを設定します。なお事前共有鍵はNXR_Aのipsec isakmp policy 1と共通の値を設定します。

NXR_B(config-ipsec-isakmp)#hash sha256
NXR_B(config-ipsec-isakmp)#encryption aes128
NXR_B(config-ipsec-isakmp)#group 5
NXR_B(config-ipsec-isakmp)#lifetime 10800
NXR_B(config-ipsec-isakmp)#isakmp-mode aggressive

認証アルゴリズムとしてsha256、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして10800秒、フェーズ1のネゴシエーションモードとしてアグレッシブモードを設定します。

NXR_B(config-ipsec-isakmp)#remote address ip 203.0.113.1
NXR_B(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR_B(config-ipsec-isakmp)#local policy 1

リモートアドレスにNXR_AのWAN側IPアドレスを設定します。またIKE KeepAlive(DPD)を監視間隔30秒,リトライ回数3回とし、keepalive失敗時にSAを削除しIKEのネゴシエーションを開始するように設定します。そしてIPsecローカルポリシー1と関連づけを行います。

 

8. <トンネル1インタフェース設定>
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode ipsec ipv4
NXR_B(config-tunnel)#tunnel protection ipsec policy 1
NXR_B(config-tunnel)#ip tcp adjust-mss auto

トンネル1インタフェースでトンネルモードをipsec ipv4、使用するIPsecトンネルポリシーとして1を設定します。またTCP MSSの調整機能をオートに設定します。

 

9. <IPsec トンネルポリシー設定>
NXR_B(config)#ipsec tunnel policy 1
NXR_B(config-ipsec-tunnel)#description NXR_A
NXR_B(config-ipsec-tunnel)#negotiation-mode auto

IPsecトンネルポリシー1の説明としてNXR_A、ネゴシエーションモードとしてautoを設定します。

NXR_B(config-ipsec-tunnel)#set transform esp-aes128 esp-sha256-hmac
NXR_B(config-ipsec-tunnel)#set pfs group5
NXR_B(config-ipsec-tunnel)#set sa lifetime 3600

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha256、PFSを有効にし、かつDHグループとしてgroup5、IPsec SAのライフタイムとして3600秒を設定します。

NXR_B(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_B(config-ipsec-tunnel)#match address ipsec_acl

ISAKMPポリシー1と関連づけを行い、IPsecアクセスリストipsec_aclを設定します。

 

10. <DHCPv6クライアント設定>
NXR_B(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

NXR_B(config-dhcp6c)#information-only enable
NXR_B(config-dhcp6c)#option-request dns-servers

information-only機能を有効にします。またDHCPv6サーバに対してDNSサーバアドレスの通知を要求するように設定します。

 

11. <DHCPv6サーバ設定>
NXR_B(config)#ipv6 dhcp-server ipv6dhcps
NXR_B(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1

DHCPv6サーバ設定の名前を定義します。
またDHCPv6 Reply送信時に、DNSサーバアドレスを通知するように設定します。
(☞) この設定例ではDHCPv6クライアントで取得したDNSサーバアドレスを広告します。

 

12. <MAP-Eルール設定>
NXR_B(config)#mape-rule v6plus type jpne auto

MAP-Eルール名をv6plusとし、MAP-Eのルールタイプをjpne,取得方法をautoに設定します。

 

13. <map0インタフェース設定>
NXR_B(config)#interface map 0
NXR_B(config-map)#ip address mape-rule
NXR_B(config-map)#tunnel mode ipipv6 mape-rule v6plus

map0インタフェースにMAPルールで割り当てられたIPv4アドレスを割り当てます。またトンネルモードとMAP-Eルール名を設定します。

NXR_B(config-map)#ip spi-filter
NXR_B(config-map)#ip tcp adjust-mss auto

ステートフルパケットインスペクションを有効にします。またTCP MSSの調整機能をオートに設定します。

NXR_B(config-map)#no tunnel encap-limit

encap-limit設定を無効にします。

NXR_B(config-map)#ipsec policy 1

IPsecトンネルのエンドポイントとなるためIPsecローカルポリシー1を設定します。

 

14. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.20.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

NXR_B(config-if)#ipv6 address autoconfig interface-id mape-rule v6plus

ethernet0インタフェースのIPv6アドレスを設定します。なおインタフェースIDにはMAP-Eルール名を設定します。

NXR_B(config-if)#ipv6 nd send-ra
NXR_B(config-if)#ipv6 nd other-config-flag

IPv6 RA(Router Advertisement)を送信するように設定します。またRAパケットのOフラグ(other-config-flag)を設定します。

NXR_B(config-if)#ipv6 dhcp server ipv6dhcps

DHCPv6サーバ名を指定し、DHCPv6サーバを有効にします。

 

15. <DHCPサーバ設定>
NXR_B(config)#dhcp-server 1
NXR_B(config-dhcps)#network 192.168.20.0/24 range 192.168.20.200 192.168.20.210
NXR_B(config-dhcps)#gateway 192.168.20.1
NXR_B(config-dhcps)#dns-server 192.168.20.1

DHCPサーバを設定します。

 

16. <ethernet1インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address

ethernet1インタフェースのIPv4アドレスを無効にします。

NXR_B(config-if)#ipv6 nd accept-ra proxy ethernet 0

RAプロキシを有効にします。

NXR_B(config-if)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

NXR_B(config-if)#ipv6 access-group in eth1_in

IPv6アクセスリストeth1_inをinフィルタに適用します。

NXR_B(config-if)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

 

17. <DNS設定>
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#edns-query enable

DNSサービスを有効にします。またEDNSも有効にします。

 

18. <ファストフォワーディング設定>
NXR_B(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

 

【 端末の設定例 】

192.168.10.0/24 192.168.20.0/24
IPv4 アドレス 192.168.10.100 DHCPサーバから自動取得
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1
DNSサーバアドレス 192.168.10.1
IPv6 プレフィックス ルータからRAで取得
アドレス プレフィックス情報を元に自動生成
デフォルトゲートウェイ ルータからRAで取得
DNSサーバアドレス ルータからDHCPv6で取得

 

【 付録 】