FutureNet

NXR,WXRシリーズ

WANインタフェース編

9. 冗長化設定

9-2. PPPoE冗長化構成(回線冗長)+PBR設定

この設定例では、PPPoE回線の冗長化を行います。またポリシーベースルーティング(以下PBR)機能を利用し、送信元IPアドレスを元にパケットの出力先を決定します。

 

【対象機種】NXR-1300シリーズ,NXR-650,NXR-530,NXR-350,NXR-230/C,NXR-G260,NXR-G240シリーズ,WXR-250(2021/12現在)

最新の対応状況は、各製品の更新履歴やユーザーズガイドをご確認ください。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • この例ではISP_A側回線のインタフェースをppp0、ISP_B側回線のインタフェースをppp1とします。
  • 各回線の監視方法には、LCPキープアライブを使用します。
    (☞) LCPキープアライブはデフォルト有効です。

 

〔正常時〕

fnw_wan_redundancy_pppoe-redundancy-pbr_normal

  • PPPoE回線はともに常時接続とします。
  • 通信経路はPBR機能で送信元IPアドレスを元に決定します。

 

〔ISP_A側回線障害時〕

fnw_wan_redundancy_pppoe-redundancy-pbr_ppp0-down

  • ISP_A側回線障害時、ppp0側の通信経路は無効となり、ppp1側で通信を継続します。
    (☞) ISP_A側回線の障害は、ppp0インタフェースがダウンすることを想定しています。

※ ISP_B側回線障害時、ppp1側の通信経路は無効となり、ppp0側で通信を継続します。

 

【 設定例 】

nxr530#configure terminal
nxr530(config)#ip policy access-list ppp0_pbr_out 192.168.10.0/25 any
nxr530(config)#ip policy access-list ppp1_pbr_out 192.168.10.128/25 any
nxr530(config)#route-map pbr permit 1
nxr530(config-route-map)#match ip address ppp0_pbr_out
nxr530(config-route-map)#set interface ppp 0
nxr530(config-route-map)#exit
nxr530(config)#route-map pbr permit 2
nxr530(config-route-map)#match ip address ppp1_pbr_out
nxr530(config-route-map)#set interface ppp 1
nxr530(config-route-map)#exit
nxr530(config)#interface ethernet 0
nxr530(config-if)#ip address 192.168.10.1/24
nxr530(config-if)#ip policy route-map pbr
nxr530(config-if)#exit
nxr530(config)#ip route 0.0.0.0/0 ppp 0 1
nxr530(config)#ip route 0.0.0.0/0 ppp 1 10
nxr530(config)#ppp account username [ISP_A接続用ユーザID] password [ISP_A接続用パスワード]
nxr530(config)#ppp account username [ISP_B接続用ユーザID] password [ISP_B接続用パスワード]
nxr530(config)#interface ppp 0
nxr530(config-ppp)#ip address negotiated
nxr530(config-ppp)#ip masquerade
nxr530(config-ppp)#ip spi-filter
nxr530(config-ppp)#ip tcp adjust-mss auto
nxr530(config-ppp)#ppp username [ISP_A接続用ユーザID]
nxr530(config-ppp)#exit
nxr530(config)#interface ppp 1
nxr530(config-ppp)#ip address negotiated
nxr530(config-ppp)#ip masquerade
nxr530(config-ppp)#ip spi-filter
nxr530(config-ppp)#ip tcp adjust-mss auto
nxr530(config-ppp)#ppp username [ISP_B接続用ユーザID]
nxr530(config-ppp)#exit
nxr530(config)#interface ethernet 1
nxr530(config-if)#no ip address
nxr530(config-if)#pppoe-client ppp 0
nxr530(config-if)#exit
nxr530(config)#interface ethernet 2
nxr530(config-if)#no ip address
nxr530(config-if)#pppoe-client ppp 1
nxr530(config-if)#exit
nxr530(config)#dns
nxr530(config-dns)#service enable
nxr530(config-dns)#priority ppp 0 1
nxr530(config-dns)#priority ppp 1 10
nxr530(config-dns)#exit
nxr530(config)#fast-forwarding enable
nxr530(config)#exit
nxr530#save config

 

【 設定例解説 】

1. <IPポリシアクセスリスト設定>
nxr530(config)#ip policy access-list ppp0_pbr_out 192.168.10.0/25 any

IPポリシーアクセスリストppp0_pbr_outを以下のルールで設定します。

  • 送信元IPアドレス192.168.10.0/25
nxr530(config)#ip policy access-list ppp1_pbr_out 192.168.10.128/25 any

IPポリシーアクセスリストppp1_pbr_outを以下のルールで設定します。

  • 送信元IPアドレス192.168.10.128/25

(☞) IPポリシーアクセスリストを設定しただけではポリシーベースルーティングとして有効にはなりません。ルートマップ設定およびパケット受信インタフェースでルートマップの登録が必要になります。

 

2. <ルートマップ設定>
nxr530(config)#route-map pbr permit 1

ルートマップ名pbrのNo.1のルールを作成します。

nxr530(config-route-map)#match ip address ppp0_pbr_out

条件にIPポリシーアクセスリストで設定したppp0_pbr_outを設定します。

nxr530(config-route-map)#set interface ppp 0

条件に合致した場合、ppp0をネクストホップとします。

nxr530(config)#route-map pbr permit 2

ルートマップ名pbrのNo.2のルールを作成します。

nxr530(config-route-map)#match ip address ppp1_pbr_out

条件にIPポリシーアクセスリストで設定したppp1_pbr_outを設定します。

nxr530(config-route-map)#set interface ppp 1

条件に合致した場合、ppp1をネクストホップとします。

 

3. <LAN側(ethernet0)インタフェース設定>
nxr530(config)#interface ethernet 0
nxr530(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

nxr530(config-if)#ip policy route-map pbr

ポリシーベースルーティング用のルートマップを登録します。

 

4. <スタティックルート設定>
nxr530(config)#ip route 0.0.0.0/0 ppp 0 1
nxr530(config)#ip route 0.0.0.0/0 ppp 1 10

デフォルトルートを設定します。ディスタンス値を設定することで経路の優先度をppp0→ppp1の順にします。

 

5. <PPPアカウント設定>
nxr530(config)#ppp account username [ISP_A接続用ユーザID] password [ISP_A接続用パスワード]

ISP_A接続用ユーザID,パスワードを設定します。

nxr530(config)#ppp account username [ISP_B接続用ユーザID] password [ISP_B接続用パスワード]

ISP_B接続用ユーザID,パスワードを設定します。

 

6. <WAN側(ppp0)インタフェース設定>
nxr530(config)#interface ppp 0
nxr530(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスにnegotiatedを設定します。

nxr530(config-ppp)#ip masquerade
nxr530(config-ppp)#ip spi-filter

IPマスカレード、ステートフルパケットインスペクションを有効にします。

nxr530(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

nxr530(config-ppp)#ppp username [ISP_A接続用ユーザID]

ISP_A接続用ユーザIDを設定します。

 

7. <WAN側(ppp1)インタフェース設定>
nxr530(config)#interface ppp 1
nxr530(config-ppp)#ip address negotiated

ppp1インタフェースのIPアドレスにnegotiatedを設定します。

nxr530(config-ppp)#ip masquerade
nxr530(config-ppp)#ip spi-filter

IPマスカレード、ステートフルパケットインスペクションを有効にします。

nxr530(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

nxr530(config-ppp)#ppp username [ISP_B接続用ユーザID]

ISP_B接続用ユーザIDを設定します。

 

8. <ethernet1インタフェース設定>
nxr530(config)#interface ethernet 1
nxr530(config-if)#no ip address
nxr530(config-if)#pppoe-client ppp 0

PPPoEクライアントにppp0を設定します。

 

9. <ethernet2インタフェース設定>
nxr530(config)#interface ethernet 2
nxr530(config-if)#no ip address
nxr530(config-if)#pppoe-client ppp 1

PPPoEクライアントにppp1を設定します。

 

10. <DNS設定>
nxr530(config)#dns
nxr530(config-dns)#service enable

DNSサービスを有効にします。

nxr530(config-dns)#priority ppp 0 1
nxr530(config-dns)#priority ppp 1 10

DNSサーバの優先度を変更します。
ppp0インタフェースで取得したDNSサーバアドレスを、ppp1インタフェースで取得したDNSサーバアドレスよりも優先するように設定します。
(☞) デフォルトではppp0,ppp1それぞれでDNSサーバアドレスを取得した場合、優先度はppp1→ppp0の順になります。

 

11. <ファストフォワーディング設定>
 nxr530(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

 

12. <設定の保存>
nxr530#save config

設定内容を保存します。

 

【 端末の設定例 】

IPアドレス 192.168.10.100
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1
DNSサーバ

 

【 付録 】