FutureNet

NXR,WXRシリーズ

NAT・フィルタ編

2. NAT設定

2-3. 宛先NAT(DNAT)設定

宛先NAT(DNAT)を使用してLAN内にあるWWWサーバを外部に公開する設定例です。

 

コンテンツ
構成図 設定フロー 設定例 設定例解説 端末の設定例 補足 付録

 

【 構成図 】

  • この設定例では、接続しているISPのDNSサーバアドレスを以下とします。
    プライマリDNSサーバ:203.0.113.253
    セカンダリDNSサーバ:203.0.113.254

 

【 設定フロー 】

 

【 設定例 】

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24
nxrg100(config-if)#exit
nxrg100(config)#ip route 0.0.0.0/0 203.0.113.2
nxrg100(config)#ip dnat eth1_dnat tcp any any 203.0.113.1 80 192.168.10.10
nxrg100(config)#ip access-list eth1_forward-in permit any 192.168.10.10 tcp any 80
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#ip address 203.0.113.1/30
nxrg100(config-if)#ip dnat-group eth1_dnat
nxrg100(config-if)#ip access-group forward-in eth1_forward-in
nxrg100(config-if)#ip masquerade
nxrg100(config-if)#ip spi-filter
nxrg100(config-if)#ip tcp adjust-mss auto
nxrg100(config-if)#exit
nxrg100(config)#dns
nxrg100(config-dns)#service enable
nxrg100(config-dns)#address 203.0.113.253
nxrg100(config-dns)#address 203.0.113.254
nxrg100(config-dns)#exit
nxrg100(config)#fast-forwarding enable
nxrg100(config)#exit
nxrg100#save config

 

【 設定例解説 】

1. <LAN側(ethernet0)インタフェース設定>
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

2. <スタティックルート設定>
nxrg100(config)#ip route 0.0.0.0/0 203.0.113.2

デフォルトルートを設定します。

 

3. <DNAT設定>
nxrg100(config)#ip dnat eth1_dnat tcp any any 203.0.113.1 80 192.168.10.10

DNATの動作ルールを作成します。
DNAT名をeth1_dnatとします。そして宛先IPアドレス203.0.113.1,宛先TCPポート番号80のパケットの宛先IPアドレスを192.168.10.10に変換します。
(☞) DNATを設定しただけでは、宛先IPアドレスの変換機能は有効になりません。宛先IPアドレスの変換を行うインタフェースでの登録が必要になります。

 

4. <IPアクセスリスト設定>
nxrg100(config)#ip access-list eth1_forward-in permit any 192.168.10.10 tcp any 80

フィルタの動作を規定するルールリストを作成します。
IPアクセスリスト名をeth1_forward-inとします。そして宛先IPアドレス192.168.10.10,宛先TCPポート番号80のパケットを許可します。
(☞) IPアクセスリストを設定しただけでは、フィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

5. <WAN側(ethernet1)インタフェース設定>
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#ip address 203.0.113.1/30

ethernet1インタフェースのIPアドレスを設定します。

nxrg100(config-if)#ip dnat-group eth1_dnat

DNATで設定したeth1_dnatを適用します。これによりethernet1インタフェースでDNATで設定したIPアドレス変換が行われます。

nxrg100(config-if)#ip access-group forward-in eth1_forward-in

IPアクセスリストeth1_forward-inをforward-inフィルタに適用します。

nxrg100(config-if)#ip masquerade
nxrg100(config-if)#ip spi-filter
nxrg100(config-if)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効にします。またTCP MSSの調整機能をオートに設定します。

 

6. <DNS設定>
nxrg100(config)#dns
nxrg100(config-dns)#service enable
nxrg100(config-dns)#address 203.0.113.253
nxrg100(config-dns)#address 203.0.113.254

DNSサービスを有効にします。またプロバイダから指定されたプライマリ,セカンダリのDNSサーバアドレスを設定します。

 

7. <ファストフォワーディング設定>
nxrg100(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを有効にすることでパケット転送を高速に処理することができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 端末の設定例 】

IPアドレス 192.168.10.10
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1
DNSサーバ

 

【 補足 】

NXR-G100/WMはホストとWiMAXモジュールから構成されています。またホストとWiMAXモジュールはLAN(USB)接続されており、WiMAX網から払い出されたIPアドレスはWiMAXモジュールに登録されます。そしてDNAT設定を行うホスト側にはWiMAXモジュールからローカルIPアドレスが割り当てられます。そのためDNAT設定でWiMAX網から払い出されたIPアドレスを指定することはできません。
以下はNXR-G100/WMを利用した場合のDNAT設定例になります。

<NXR-G100/WMでの宛先NAT(DNAT)設定>
nxrg100(config)#ip dnat wimax0_dnat tcp any any any 80 192.168.10.10

DNATの動作ルールを作成します。
DNAT名をwimax0_dnatとします。そして宛先TCPポート番号80のパケットの宛先IPアドレスを192.168.10.10に変換します。
(☞) DNATを設定しただけでは、宛先IPアドレスの変換機能は有効になりません。宛先IPアドレスの変換を行うインタフェースでの登録が必要になります。
(☞) 宛先IPアドレスはanyを設定します。

nxrg100(config)#ip access-list wimax0_forward-in permit any 192.168.10.10 tcp any 80

IPアクセスリスト名をwimax0_forward-inとします。そして宛先IPアドレス192.168.10.10,宛先TCPポート番号80のパケットを許可します。
(☞) IPアクセスリストを設定しただけでは、フィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

nxrg100(config)#interface wimax 0
nxrg100(config-wimax)#ip dnat-group wimax0_dnat
nxrg100(config-wimax)#ip access-group forward-in wimax0_forward-in

wimax0インタフェースにおいてDNAT設定で設定したwimax0_dnatを適用します。これによりwimax0インタフェースでDNATによるIPアドレス変換が行われます。またIPアクセスリストwimax0_forward-inをforward-inフィルタに適用します。
その他WiMAX設定についてはWANインタフェース編 WiMAX設定のNXR-G100/WM WiMAX接続設定をご参照ください。

 

【 付録 】