FutureNet

NXR,WXRシリーズ

L2TPv3編

2. L2TPv3応用設定

2-3. L2TPv3接続設定(タグVLANの利用3)

スイッチングハブ内蔵モデルで各ハブポートをVLAN毎にグループ化しL2TPv3接続する設定例です。スイッチングハブ内蔵モデルでは各ハブポートをVLAN毎にグループ化し、かつVLANトランクを設定することができます。さらに各VLAN毎にXconnectインタフェースおよびL2TPv3セッションを作成することができます。

 

【 構成図 】

  • ethernet0インタフェースのハブポートを以下のように設定します。
    ハブのポート番号 VLANグループ
    ポート1 VLAN10
    ポート2
    ポート3 VLAN20
    ポート4
  • ethernet0インタフェースではVLAN ID 10, 20のインタフェースを作成し、各VLANインタフェースをXconnectインタフェースとします。
  • 対向ルータ1台に対して複数のXconnectインタフェースを設定するため、リモートエンドIDはL2TPv3セッション毎に異なる値を設定します。
  • この設定例ではそれぞれのルータ配下においてVLAN間ルーティングが可能になっています。

 

【 設定データ 】

〔NXR_Aの設定〕

設定項目 設定内容
ホスト名 NXR_A
LAN側インタフェース ethernet0 vid 10のIPアドレス 192.168.10.1/24
ethernet0 vid 20のIPアドレス 192.168.20.1/24
スイッチポート ポート1 PVID 10
VLANID 10(untagged)
ポート2 PVID 10
VLANID 10(untagged)
ポート3 PVID 20
VLANID 20(untagged)
ポート4 PVID 20
VLANID 20(untagged)
ルータポート PVID 1
リンク トランク
VLANID 10(tagged),20(tagged)
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 10.10.10.1/32
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
TCP MSS調整 オート
ISP接続用ユーザID test1@example.jp
ISP接続用パスワード test1pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in 動作 許可
送信元IPアドレス any
宛先IPアドレス 10.10.10.1
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxra
ルータID 172.20.10.1
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 NXR_B
リモートホスト名 nxrb
リモートルータID 172.20.20.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_B
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0 vid 10
リモートエンドID 1
TCP MSS調整 オート
L2TPv3 Xconnect2 名前 NXR_B
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0 vid 20
リモートエンドID 2
TCP MSS調整 オート
DNS サービス 有効
FastFowarding 有効
L2TPv3 FastFowarding 有効

〔NXR_Bの設定〕

設定項目 設定内容
ホスト名 NXR_B
LAN側インタフェース ethernet0 vid 10のIPアドレス 192.168.10.2/24
ethernet0 vid 20のIPアドレス 192.168.20.2/24
スイッチポート ポート1 PVID 10
VLANID 10(untagged)
ポート2 PVID 10
VLANID 10(untagged)
ポート3 PVID 20
VLANID 20(untagged)
ポート4 PVID 20
VLANID 20(untagged)
ルータポート PVID 1
リンク トランク
VLANID 10(tagged),20(tagged)
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
TCP MSS調整 オート
ISP接続用ユーザID test2@example.jp
ISP接続用パスワード test2pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in 動作 許可
送信元IPアドレス 10.10.10.1
宛先IPアドレス any
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxrb
ルータID 172.20.20.1
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 NXR_A
リモートトンネルアドレス 10.10.10.1
リモートホスト名 nxra
リモートルータID 172.20.10.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_A
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0 vid 10
リモートエンドID 1
再送間隔 30秒
TCP MSS調整 オート
L2TPv3 Xconnect2 名前 NXR_A
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0 vid 20
リモートエンドID 2
再送間隔 30秒
TCP MSS調整 オート
DNS サービス 有効
FastFowarding 有効
L2TPv3 FastFowarding 有効

【 設定例 】

〔NXR_Aの設定〕

nxr350#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr350(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#vlan-database vid 1
NXR_A(config-if)#vlan-database vid 10
NXR_A(config-if)#vlan-database vid 20
NXR_A(config-if)#switchport 1 default-vlan-id 10
NXR_A(config-if)#switchport 1 vlan 10 untagged
NXR_A(config-if)#no switchport 1 vlan 1
NXR_A(config-if)#switchport 2 default-vlan-id 10
NXR_A(config-if)#switchport 2 vlan 10 untagged
NXR_A(config-if)#no switchport 2 vlan 1
NXR_A(config-if)#switchport 3 default-vlan-id 20
NXR_A(config-if)#switchport 3 vlan 20 untagged
NXR_A(config-if)#no switchport 3 vlan 1
NXR_A(config-if)#switchport 4 default-vlan-id 20
NXR_A(config-if)#switchport 4 vlan 20 untagged
NXR_A(config-if)#no switchport 4 vlan 1
NXR_A(config-if)#switchport router link trunk
NXR_A(config-if)#switchport router vlan 10 tagged
NXR_A(config-if)#switchport router vlan 20 tagged
NXR_A(config-if)#exit
NXR_A(config)#interface ethernet 0 vid 10
NXR_A(config-vlan)#ip address 192.168.10.1/24
NXR_A(config-vlan)#exit
NXR_A(config)#interface ethernet 0 vid 20
NXR_A(config-vlan)#ip address 192.168.20.1/24
NXR_A(config-vlan)#exit
NXR_A(config)#ip route 0.0.0.0/0 ppp 0
NXR_A(config)#ip access-list ppp0_in permit any 10.10.10.1 115
NXR_A(config)#ppp account username test1@example.jp password test1pass
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 10.10.10.1/32
NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test1@example.jp
NXR_A(config-ppp)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#exit
NXR_A(config)#l2tpv3 hostname nxra
NXR_A(config)#l2tpv3 router-id 172.20.10.1
NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B
NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A(config-l2tpv3-tunnel)#exit
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1
NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0 vid 10
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A(config-l2tpv3-xconnect)#exit
NXR_A(config)#l2tpv3 xconnect 2
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1
NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0 vid 20
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 2
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A(config-l2tpv3-xconnect)#exit
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#exit
NXR_A(config)#fast-forwarding enable
NXR_A(config)#l2tpv3 fast-forwarding enable
NXR_A(config)#exit
NXR_A#save config

〔NXR_Bの設定〕

nxrg240#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg240(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#vlan-database vid 1
NXR_B(config-if)#vlan-database vid 10
NXR_B(config-if)#vlan-database vid 20
NXR_B(config-if)#switchport 1 default-vlan-id 10
NXR_B(config-if)#switchport 1 vlan 10 untagged
NXR_B(config-if)#no switchport 1 vlan 1
NXR_B(config-if)#switchport 2 default-vlan-id 10
NXR_B(config-if)#switchport 2 vlan 10 untagged
NXR_B(config-if)#no switchport 2 vlan 1
NXR_B(config-if)#switchport 3 default-vlan-id 20
NXR_B(config-if)#switchport 3 vlan 20 untagged
NXR_B(config-if)#no switchport 3 vlan 1
NXR_B(config-if)#switchport 4 default-vlan-id 20
NXR_B(config-if)#switchport 4 vlan 20 untagged
NXR_B(config-if)#no switchport 4 vlan 1
NXR_B(config-if)#switchport router link trunk
NXR_B(config-if)#switchport router vlan 10 tagged
NXR_B(config-if)#switchport router vlan 20 tagged
NXR_B(config-if)#exit
NXR_B(config)#interface ethernet 0 vid 10
NXR_B(config-vlan)#ip address 192.168.10.2/24
NXR_B(config-vlan)#exit
NXR_B(config)#interface ethernet 0 vid 20
NXR_B(config-vlan)#ip address 192.168.20.2/24
NXR_B(config-vlan)#exit
NXR_B(config)#ip route 0.0.0.0/0 ppp 0
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any 115
NXR_B(config)#ppp account username test2@example.jp password test2pass
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated
NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ppp username test2@example.jp
NXR_B(config-ppp)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0
NXR_B(config-if)#exit
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 172.20.20.1
NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery enable
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address 10.10.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_B(config-l2tpv3-tunnel)#exit
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0 vid 10
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#l2tpv3 xconnect 2
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0 vid 20
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 2
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#exit
NXR_B(config)#fast-forwarding enable
NXR_B(config)#l2tpv3 fast-forwarding enable
NXR_B(config)#exit
NXR_B#save config

 

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxr350(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#vlan-database vid 1
NXR_A(config-if)#vlan-database vid 10
NXR_A(config-if)#vlan-database vid 20

スイッチポートで使用するVLAN IDを設定します。

NXR_A(config-if)#switchport 1 default-vlan-id 10

スイッチポート1のPVIDを設定します。

NXR_A(config-if)#switchport 1 vlan 10 untagged

スイッチポート1のVLANID10をuntaggedに設定します。

NXR_A(config-if)#no switchport 1 vlan 1

スイッチポート1でVLANID1を削除します。

NXR_A(config-if)#switchport 2 default-vlan-id 10

スイッチポート2のPVIDを設定します。

NXR_A(config-if)#switchport 2 vlan 10 untagged

スイッチポート2のVLANID10をuntaggedに設定します。

NXR_A(config-if)#no switchport 2 vlan 1

スイッチポート2でVLANID1を削除します。

NXR_A(config-if)#switchport 3 default-vlan-id 20

スイッチポート3のPVIDを設定します。

NXR_A(config-if)#switchport 3 vlan 20 untagged

スイッチポート3のVLANID20をuntaggedに設定します。

NXR_A(config-if)#no switchport 3 vlan 1

スイッチポート3でVLANID1を削除します。

NXR_A(config-if)#switchport 4 default-vlan-id 20

スイッチポート4のPVIDを設定します。

NXR_A(config-if)#switchport 4 vlan 20 untagged

スイッチポート4のVLANID20をuntaggedに設定します。

NXR_A(config-if)#no switchport 4 vlan 1

スイッチポート4でVLANID1を削除します。

NXR_A(config-if)#switchport router link trunk

ルータポートのリンクをトランクに設定します。
(☞) リンクをトランクに設定することで、複数のVLANトラフィックを転送することができます。なお転送するフレームには、フレームを受信したアクセスリンクのPVIDをVLANタグに付加し、タグ無しフレームは破棄されます。

NXR_A(config-if)#switchport router vlan 10 tagged
NXR_A(config-if)#switchport router vlan 20 tagged

ルータポートのVLANID10,20をtaggedに設定します。

 

3. <LAN側(ethernet0.10)インタフェース設定>
NXR_A(config)#interface ethernet 0 vid 10
NXR_A(config-vlan)#ip address 192.168.10.1/24

ethernet0.10インタフェースのIPアドレスを設定します。

 

4. <LAN側(ethernet0.20)インタフェース設定>
NXR_A(config)#interface ethernet 0 vid 20
NXR_A(config-vlan)#ip address 192.168.20.1/24

ethernet0.20インタフェースのIPアドレスを設定します。

 

5. <スタティックルート設定>
NXR_A(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

6. <IPアクセスリスト設定>
NXR_A(config)#ip access-list ppp0_in permit any 10.10.10.1 115

IPアクセスリスト名をppp0_inとし、ルータNXR_AのWAN側IPアドレス10.10.10.1宛のL2TPパケット(プロトコル番号115)を許可します。
なおこのIPアクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

7. <PPPアカウント設定>
NXR_A(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

8. <WAN側(ppp0)インタフェース設定>
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 10.10.10.1/32

ppp0インタフェースのIPアドレスを設定します。

NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またIPアクセスリストppp0_inをinフィルタに適用します。そしてTCP MSSの調整機能をオートに設定します。

NXR_A(config-ppp)#ppp username test1@example.jp

ISP接続用ユーザIDを設定します。

 

9. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

10. <L2TPv3設定>
NXR_A(config)#l2tpv3 hostname nxra
NXR_A(config)#l2tpv3 router-id 172.20.10.1

L2TPv3のホスト名としてnxraを設定します。またルータIDを設定します。

NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery

MACアドレス学習機能を有効にし、エージングタイムを設定します。またPath MTU Discoveryを有効にします。

 

11. <L2TPv3トンネル設定>
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B

L2TPv3トンネル1の説明としてNXR_Bを設定します。なおルータNXR_BのWAN側IPアドレスが動的IPアドレスのため、リモートトンネルアドレスは設定しません。

NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf

ルータNXR_BのL2TPv3ホスト名およびルータIDを設定します。そしてベンダIDとしてietfを設定します。
(☞) ルータNXR_BのL2TPv3設定にあるホスト名,ルータIDと同一の値を設定します。

 

12. <L2TPv3 Xconnect1設定>
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_B、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0 vid 10
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0.10インタフェースおよびリモートエンドIDを設定します。またTCP MSSの調整機能をオートに設定します。

 

13. <L2TPv3 Xconnect2設定>
NXR_A(config)#l2tpv3 xconnect 2
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect2の説明としてNXR_B、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0 vid 20
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 2
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0.20インタフェースおよびリモートエンドIDを設定します。またTCP MSSの調整機能をオートに設定します。
(☞) 対向ルータ1台に対して複数のXconnectインタフェースを設定する場合、リモートエンドIDはL2TPv3セッション毎に異なる値を設定する必要があります。

 

14. <DNS 設定>
NXR_A(config)#dns
NXR_A(config-dns)#service enable

DNSサービスを有効にします。

 

15. <ファストフォワーディングの有効化>
NXR_A(config)#fast-forwarding enable
NXR_A(config)#l2tpv3 fast-forwarding enable

ファストフォワーディングおよびL2TPv3ファストフォワーディングを有効にします。
(☞) ファストフォワーディングおよびL2TPv3ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg240(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#vlan-database vid 1
NXR_B(config-if)#vlan-database vid 10
NXR_B(config-if)#vlan-database vid 20

スイッチポートで使用するVLAN IDを設定します。

NXR_B(config-if)#switchport 1 default-vlan-id 10
NXR_B(config-if)#switchport 1 vlan 10 untagged
NXR_B(config-if)#no switchport 1 vlan 1

スイッチポート1のPVIDおよびVLANID10をuntaggedに設定します。またVLANID1を削除します。

NXR_B(config-if)#switchport 2 default-vlan-id 10
NXR_B(config-if)#switchport 2 vlan 10 untagged
NXR_B(config-if)#no switchport 2 vlan 1

スイッチポート2のPVIDおよびVLANID10をuntaggedに設定します。またVLANID1を削除します。

NXR_B(config-if)#switchport 3 default-vlan-id 20
NXR_B(config-if)#switchport 3 vlan 20 untagged
NXR_B(config-if)#no switchport 3 vlan 1

スイッチポート3のPVIDおよびVLANID20をuntaggedに設定します。またVLANID1を削除します。

NXR_B(config-if)#switchport 4 default-vlan-id 20
NXR_B(config-if)#switchport 4 vlan 20 untagged
NXR_B(config-if)#no switchport 4 vlan 1

スイッチポート4のPVIDおよびVLANID20をuntaggedに設定します。またVLANID1を削除します。

NXR_B(config-if)#switchport router link trunk
NXR_B(config-if)#switchport router vlan 10 tagged
NXR_B(config-if)#switchport router vlan 20 tagged

ルータポートのリンクをトランクに設定します。またVLANID10,20をtaggedに設定します。

 

3. <LAN側(ethernet0.10)インタフェース設定>
NXR_B(config)#interface ethernet 0 vid 10
NXR_B(config-vlan)#ip address 192.168.10.2/24

ethernet0.10インタフェースのIPアドレスを設定します。

 

4. <LAN側(ethernet0.20)インタフェース設定>
NXR_B(config)#interface ethernet 0 vid 20
NXR_B(config-vlan)#ip address 192.168.20.2/24

ethernet0.20インタフェースのIPアドレスを設定します。

 

5. <スタティックルート設定>
NXR_B(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

6. <IPアクセスリスト設定>
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any 115

IPアクセスリスト名をppp0_inとし、送信元がルータNXR_AのWAN側IPアドレス10.10.10.1のL2TPパケット(プロトコル番号115)を許可します。
なおこのIPアクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

7. <PPPアカウント設定>
NXR_B(config)#ppp account username test2@example.jp password test2pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

8. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスが動的IPアドレスの場合は、negotiatedを設定します。

NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またIPアクセスリストppp0_inをinフィルタに適用します。そしてTCP MSSの調整機能をオートに設定します。

NXR_B(config-ppp)#ppp username test2@example.jp

ISP接続用ユーザIDを設定します。

 

9. <ethernet1インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

10. <L2TPv3設定>
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 172.20.20.1

L2TPv3のホスト名としてnxrbを設定します。またルータIDを設定します。

NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery enable

MACアドレス学習機能を有効にし、エージングタイムを設定します。またPath MTU Discoveryを有効にします。

 

11. <L2TPv3トンネル設定>
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address 10.10.10.1

L2TPv3トンネル1の説明としてNXR_A、リモートアドレスにルータNXR_AのWAN側IPアドレスを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf

ルータNXR_AのL2TPv3ホスト名およびルータIDを設定します。そしてベンダIDとしてietfを設定します。
(☞) ルータNXR_AのL2TPv3設定にあるホスト名,ルータIDと同一の値を設定します。

 

12. <L2TPv3 Xconnect1設定>
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_A、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0 vid 10
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0.10インタフェースおよびリモートエンドIDを設定します。またリトライインターバルを設定します。そしてTCP MSSの調整機能をオートに設定します。

 

13. <L2TPv3 Xconnect2設定>
NXR_B(config)#l2tpv3 xconnect 2
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect2の説明としてNXR_A、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0 vid 20
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 2
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0.20インタフェースおよびリモートエンドIDを設定します。またリトライインターバルを設定します。そしてTCP MSSの調整機能をオートに設定します。
(☞) 対向ルータ1台に対して複数のXconnectインタフェースを設定する場合、リモートエンドIDはL2TPv3セッション毎に異なる値を設定する必要があります。

 

14. <DNS設定>
NXR_B(config)#dns
NXR_B(config-dns)#service enable

DNSサービスを有効にします。

 

15. <ファストフォワーディングの有効化>
NXR_B(config)#fast-forwarding enable
NXR_B(config)#l2tpv3 fast-forwarding enable

ファストフォワーディングおよびL2TPv3ファストフォワーディングを有効にします。

 

【 端末の設定例 】

LAN_Aの端末 LAN_Bの端末 LAN_Cの端末 LAN_Dの端末
IPアドレス 192.168.10.100 192.168.20.100 192.168.10.101 192.168.20.101
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.20.1 192.168.10.2 192.168.20.2
DNSサーバ