FutureNet

NXR,WXRシリーズ

L2TPv3編

1. L2TPv3基本設定

1-3. PPPoEを利用したL2TPv3接続設定(センタ経由拠点間通信なし)

WAN回線にPPPoEを使用したハブ&スポーク構成のL2TPv3接続設定例です。この例ではスポーク拠点間の通信は行いません。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • NXR_AのL2TPv3 Xconnect設定でスプリットホライズンを有効に設定します。この設定を有効にすることによりNXR_A経由の拠点間通信をブロックします。
  • L2TPv3は通信の暗号化を行いませんので、インターネット上で利用する場合、IPsecと組み合わせて利用することを推奨致します。

 

【 設定例 】

〔NXR_Aの設定〕

nxr650#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr650(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24
NXR_A(config-if)#exit
NXR_A(config)#ip route 0.0.0.0/0 ppp 0
NXR_A(config)#ip access-list ppp0_in permit any 192.0.2.1 115
NXR_A(config)#ppp account username test1@example.jp password test1pass
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 192.0.2.1/32
NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test1@example.jp
NXR_A(config-ppp)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#exit
NXR_A(config)#l2tpv3 hostname nxra
NXR_A(config)#l2tpv3 router-id 192.168.10.1
NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery enable
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B
NXR_A(config-l2tpv3-tunnel)#tunnel address 192.0.2.2
NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.2
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A(config-l2tpv3-tunnel)#exit
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1
NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#retry-interval 30
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A(config-l2tpv3-xconnect)#split-horizon enable
NXR_A(config-l2tpv3-xconnect)#exit
NXR_A(config)#l2tpv3 tunnel 2
NXR_A(config-l2tpv3-tunnel)#description NXR_C
NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrc
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.3
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A(config-l2tpv3-tunnel)#exit
NXR_A(config)#l2tpv3 xconnect 2
NXR_A(config-l2tpv3-xconnect)#description NXR_C
NXR_A(config-l2tpv3-xconnect)#tunnel 2
NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A(config-l2tpv3-xconnect)#split-horizon enable
NXR_A(config-l2tpv3-xconnect)#exit
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#exit
NXR_A(config)#fast-forwarding enable
NXR_A(config)#l2tpv3 fast-forwarding enable
NXR_A(config)#exit
NXR_A#save config

 

〔NXR_Bの設定〕

nxrg240#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg240(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.2/24
NXR_B(config-if)#exit
NXR_B(config)#ip route 0.0.0.0/0 ppp 0
NXR_B(config)#ip access-list ppp0_in permit 192.0.2.1 192.0.2.2 115
NXR_B(config)#ppp account username test2@example.jp password test2pass
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address 192.0.2.2/32
NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ppp username test2@example.jp
NXR_B(config-ppp)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0
NXR_B(config-if)#exit
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 192.168.10.2
NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery enable
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address 192.0.2.1
NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_B(config-l2tpv3-tunnel)#exit
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 45
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#exit
NXR_B(config)#fast-forwarding enable
NXR_B(config)#l2tpv3 fast-forwarding enable
NXR_B(config)#exit
NXR_B#save config

 

〔NXR_Cの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_C
NXR_C(config)#interface ethernet 0
NXR_C(config-if)#ip address 192.168.10.3/24
NXR_C(config-if)#exit
NXR_C(config)#ip route 0.0.0.0/0 ppp 0
NXR_C(config)#ip access-list ppp0_in permit 192.0.2.1 any 115
NXR_C(config)#ppp account username test3@example.jp password test3pass
NXR_C(config)#interface ppp 0
NXR_C(config-ppp)#ip address negotiated
NXR_C(config-ppp)#ip masquerade
NXR_C(config-ppp)#ip spi-filter
NXR_C(config-ppp)#ip access-group in ppp0_in
NXR_C(config-ppp)#ip tcp adjust-mss auto
NXR_C(config-ppp)#ppp username test3@example.jp
NXR_C(config-ppp)#exit
NXR_C(config)#interface ethernet 1
NXR_C(config-if)#no ip address
NXR_C(config-if)#pppoe-client ppp 0
NXR_C(config-if)#exit
NXR_C(config)#l2tpv3 hostname nxrc
NXR_C(config)#l2tpv3 router-id 192.168.10.3
NXR_C(config)#l2tpv3 mac-learning
NXR_C(config)#l2tpv3 mac-aging 300
NXR_C(config)#l2tpv3 path-mtu-discovery enable
NXR_C(config)#l2tpv3 tunnel 1
NXR_C(config-l2tpv3-tunnel)#description NXR_A
NXR_C(config-l2tpv3-tunnel)#tunnel address 192.0.2.1
NXR_C(config-l2tpv3-tunnel)#tunnel hostname nxra
NXR_C(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.1
NXR_C(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_C(config-l2tpv3-tunnel)#exit
NXR_C(config)#l2tpv3 xconnect 1
NXR_C(config-l2tpv3-xconnect)#description NXR_A
NXR_C(config-l2tpv3-xconnect)#tunnel 1
NXR_C(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_C(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_C(config-l2tpv3-xconnect)#retry-interval 30
NXR_C(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_C(config-l2tpv3-xconnect)#exit
NXR_C(config)#dns
NXR_C(config-dns)#service enable
NXR_C(config-dns)#exit
NXR_C(config)#fast-forwarding enable
NXR_C(config)#l2tpv3 fast-forwarding enable
NXR_C(config)#exit
NXR_C#save config

 

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxr650(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_A(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_A(config)#ip access-list ppp0_in permit any 192.0.2.1 115

IPアクセスリストppp0_inを以下のルールで設定します。

  • 宛先IPアドレス192.0.2.1、プロトコル番号115(L2TP)を許可

(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

5. <PPPアカウント設定>
NXR_A(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 192.0.2.1/32

ppp0インタフェースのIPアドレスを設定します。

NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip spi-filter

IPマスカレード、ステートフルパケットインスペクションを有効にします。

NXR_A(config-ppp)#ip access-group in ppp0_in

IPアクセスグループのinフィルタにIPアクセスリストppp0_inを設定します。

NXR_A(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

NXR_A(config-ppp)#ppp username test1@example.jp

ISP接続用ユーザIDを設定します。

 

7. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0

PPPoEクライアントにppp0を設定します。

 

8. <L2TPv3設定>
NXR_A(config)#l2tpv3 hostname nxra

L2TPv3のホスト名を設定します。
(☞) 省略時はhostnameコマンドで設定した値が使用されます。

NXR_A(config)#l2tpv3 router-id 192.168.10.1

L2TPv3のルータIDを設定します。
(☞) ルータIDは必ずしも通信時に使用するアドレスと同じである必要はありません。

NXR_A(config)#l2tpv3 mac-learning

MACアドレス学習機能を有効にします。

NXR_A(config)#l2tpv3 mac-aging 300

MACアドレス学習機能のエージングタイムを設定します。

NXR_A(config)#l2tpv3 path-mtu-discovery enable

L2TPv3のPath MTU Discoveryを有効にします。

 

9. <L2TPv3トンネル1設定>
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B

L2TPv3トンネル1の説明文を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel address 192.0.2.2

トンネルアドレスにNXR_BのWAN側IPアドレスを設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb

NXR_BのL2TPv3のホスト名を設定します。
(☞) このホスト名はNXR_Bのl2tpv3 hostnameと同一の値を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.2

NXR_BのL2TPv3のルータIDを設定します。
(☞) このルータIDはNXR_Bのl2tpv3 router-idと同一の値を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf

ベンダIDをietfに設定します。
(☞) このベンダIDはNXR_Bのl2tpv3 tunnel1と同一の値を設定します。

 

10. <L2TPv3 Xconnect1設定>
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B

L2TPv3 Xconnect1の説明文を設定します。

NXR_A(config-l2tpv3-xconnect)#tunnel 1

このL2TPv3 Xconnectで使用するL2TPv3トンネルを設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0

Xconnectインタフェースを設定します。
(☞) この設定で指定したインタフェースがL2フレームを送受信するインタフェースになります。

NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1

リモートエンドIDを設定します。

NXR_A(config-l2tpv3-xconnect)#retry-interval 30

リトライインターバルを設定します。

NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

NXR_A(config-l2tpv3-xconnect)#split-horizon enable

スプリットホライズンを有効にします。
(☞) スプリットホライズンは、L2TPセッションより受信したフレームを別のL2TPセッションに転送しない機能です。

 

11. <L2TPv3トンネル2設定>
NXR_A(config)#l2tpv3 tunnel 2
NXR_A(config-l2tpv3-tunnel)#description NXR_C

L2TPv3トンネル2の説明文を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrc

NXR_CのL2TPv3のホスト名を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.3

NXR_CのL2TPv3のルータIDを設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf

ベンダIDをietfに設定します。

 

12. <L2TPv3 Xconnect2設定>
NXR_A(config)#l2tpv3 xconnect 2
NXR_A(config-l2tpv3-xconnect)#description NXR_C

L2TPv3 Xconnect2の説明文を設定します。

NXR_A(config-l2tpv3-xconnect)#tunnel 2

このL2TPv3 Xconnectで使用するL2TPv3トンネルを設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0

Xconnectインタフェースを設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1

リモートエンドIDを設定します。

NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

NXR_A(config-l2tpv3-xconnect)#split-horizon enable

スプリットホライズンを有効にします。

 

13. <DNS設定>
NXR_A(config)#dns
NXR_A(config-dns)#service enable

DNSサービスを有効にします。

 

14. <ファストフォワーディング設定>
NXR_A(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

NXR_A(config)#l2tpv3 fast-forwarding enable

L2TPv3ファストフォワーディングを有効にします。

 

15. <設定の保存>
NXR_A#save config

設定内容を保存します。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg240(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.2/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_B(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_B(config)#ip access-list ppp0_in permit 192.0.2.1 192.0.2.2 115

IPアクセスリストppp0_inを以下のルールで設定します。

  • 送信元IPアドレス192.0.2.1、宛先IPアドレス192.0.2.2、プロトコル番号115(L2TP)を許可

 

5. <PPPアカウント設定>
NXR_B(config)#ppp account username test2@example.jp password test2pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address 192.0.2.2/32

ppp0インタフェースのIPアドレスを設定します。

NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip spi-filter

IPマスカレード、ステートフルパケットインスペクションを有効にします。

NXR_B(config-ppp)#ip access-group in ppp0_in

IPアクセスグループのinフィルタにIPアクセスリストppp0_inを設定します。

NXR_B(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

NXR_B(config-ppp)#ppp username test2@example.jp

ISP接続用ユーザIDを設定します。

 

7. <ethernet1インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0

PPPoEクライアントにppp0を設定します。

 

8. <L2TPv3設定>
NXR_B(config)#l2tpv3 hostname nxrb

L2TPv3のホスト名を設定します。

NXR_B(config)#l2tpv3 router-id 192.168.10.2

L2TPv3のルータIDを設定します。

NXR_B(config)#l2tpv3 mac-learning

MACアドレス学習機能を有効にします。

NXR_B(config)#l2tpv3 mac-aging 300

MACアドレス学習機能のエージングタイムを設定します。

NXR_B(config)#l2tpv3 path-mtu-discovery enable

L2TPv3のPath MTU Discoveryを有効にします。

 

9. <L2TPv3トンネル設定>
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A

L2TPv3トンネル1の説明文を設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel address 192.0.2.1

トンネルアドレスにNXR_AのWAN側IPアドレスを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra

NXR_AのL2TPv3のホスト名を設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.1

NXR_AのL2TPv3のルータIDを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf

ベンダIDをietfに設定します。

 

10. <L2TPv3 Xconnect設定>
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A

L2TPv3 Xconnect1の説明文を設定します。

NXR_B(config-l2tpv3-xconnect)#tunnel 1

このL2TPv3 Xconnectで使用するL2TPv3トンネルを設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0

Xconnectインタフェースを設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1

リモートエンドIDを設定します。

NXR_B(config-l2tpv3-xconnect)#retry-interval 45

リトライインターバルを設定します。

NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

 

11. <DNS設定>
NXR_B(config)#dns
NXR_B(config-dns)#service enable

DNSサービスを有効にします。

 

12. <ファストフォワーディング設定>
NXR_B(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

NXR_B(config)#l2tpv3 fast-forwarding enable

L2TPv3ファストフォワーディングを有効にします。

 

13. <設定の保存>
NXR_B#save config

設定内容を保存します。

 

〔NXR_Cの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_C

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_C(config)#interface ethernet 0
NXR_C(config-if)#ip address 192.168.10.3/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_C(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_C(config)#ip access-list ppp0_in permit 192.0.2.1 any 115

IPアクセスリストppp0_inを以下のルールで設定します。

  • 送信元IPアドレス192.0.2.1、プロトコル番号115(L2TP)を許可

 

5. <PPPアカウント設定>
NXR_C(config)#ppp account username test3@example.jp password test3pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_C(config)#interface ppp 0
NXR_C(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスをnegotiatedに設定します。

NXR_C(config-ppp)#ip masquerade
NXR_C(config-ppp)#ip spi-filter

IPマスカレード、ステートフルパケットインスペクションを有効にします。

NXR_C(config-ppp)#ip access-group in ppp0_in

IPアクセスグループのinフィルタにIPアクセスリストppp0_inを設定します。

NXR_C(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

NXR_C(config-ppp)#ppp username test3@example.jp

ISP接続用ユーザIDを設定します。

 

7. <ethernet1インタフェース設定>
NXR_C(config)#interface ethernet 1
NXR_C(config-if)#no ip address
NXR_C(config-if)#pppoe-client ppp 0

PPPoEクライアントにppp0を設定します。

 

8. <L2TPv3設定>
NXR_C(config)#l2tpv3 hostname nxrc

L2TPv3のホスト名を設定します。

NXR_C(config)#l2tpv3 router-id 192.168.10.3

L2TPv3のルータIDを設定します。

NXR_C(config)#l2tpv3 mac-learning

MACアドレス学習機能を有効にします。

NXR_C(config)#l2tpv3 mac-aging 300

MACアドレス学習機能のエージングタイムを設定します。

NXR_C(config)#l2tpv3 path-mtu-discovery enable

L2TPv3のPath MTU Discoveryを有効にします。

 

9. <L2TPv3トンネル設定>
NXR_C(config)#l2tpv3 tunnel 1
NXR_C(config-l2tpv3-tunnel)#description NXR_A

L2TPv3トンネル1の説明文を設定します。

NXR_C(config-l2tpv3-tunnel)#tunnel address 192.0.2.1

トンネルアドレスにNXR_AのWAN側IPアドレスを設定します。

NXR_C(config-l2tpv3-tunnel)#tunnel hostname nxra

NXR_AのL2TPv3のホスト名を設定します。

NXR_C(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.1

NXR_AのL2TPv3のルータIDを設定します。

NXR_C(config-l2tpv3-tunnel)#tunnel vendor ietf

ベンダIDをietfに設定します。

 

10. <L2TPv3 Xconnect設定>
NXR_C(config)#l2tpv3 xconnect 1
NXR_C(config-l2tpv3-xconnect)#description NXR_A

L2TPv3 Xconnect1の説明文を設定します。

NXR_C(config-l2tpv3-xconnect)#tunnel 1

このL2TPv3 Xconnectで使用するL2TPv3トンネルを設定します。

NXR_C(config-l2tpv3-xconnect)#xconnect ethernet 0

Xconnectインタフェースを設定します。

NXR_C(config-l2tpv3-xconnect)#xconnect end-id 1

リモートエンドIDを設定します。

NXR_C(config-l2tpv3-xconnect)#retry-interval 30

リトライインターバルを設定します。

NXR_C(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

 

11. <DNS設定>
NXR_C(config)#dns
NXR_C(config-dns)#service enable

DNSサービスを有効にします。

 

12. <ファストフォワーディング設定>
NXR_C(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

NXR_C(config)#l2tpv3 fast-forwarding enable

L2TPv3ファストフォワーディングを有効にします。

 

13. <設定の保存>
NXR_C#save config

設定内容を保存します。

 

【 端末の設定例 】

NXR_A配下の端末 NXR_B配下の端末 NXR_C配下の端末
IPアドレス 192.168.10.101 192.168.10.102 192.168.10.103
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.10.2 192.168.10.3
DNSサーバアドレス

 

【 付録 】