FutureNet

NXR,WXRシリーズ

L2TPv3編

2. L2TPv3応用設定

2-4. FQDNでのL2TPv3接続設定

ダイナミックDNSを利用し動的IPアドレスのルータ同士でL2TPv3接続する設定例です。この例ではダイナミックDNSサービスに弊社が提供しているWarpLinkDDNSサービスを使用します。

 

【 構成図 】

  • WarpLink機能を設定し、WarpLinkDDNSサービスを動作させます。
    (☞) WarpLinkDDNSサービスは、弊社が提供している有償のDDNSサービスとなります。
    詳細は下記URLからご確認下さい。
    http://www.warplink.ne.jp/ddns/index.html
  • この例では両拠点ルータでWarpLinkDDNSサービスを利用することにより両拠点ルータからL2TPv3接続を開始できるようにします。
    (☞) 設定したFQDNの名前解決後にL2TPV3接続を開始します。よって名前解決ができない場合、L2TPv3接続を開始することができませんのでご注意ください。

 

【 設定データ 】

〔NXR_Aの設定〕

設定項目 設定内容
ホスト名 NXR_A
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
TCP MSS調整 オート
ISP接続用ユーザID test1@example.jp
ISP接続用パスワード test1pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in 動作 許可
送信元IPアドレス any
宛先IPアドレス any
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxra
ルータID 172.20.10.1
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 NXR_B
リモートトンネルアドレス nxrb.subdomain.warplink.ne.jp
リモートホスト名 nxrb
リモートルータID 172.20.20.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_B
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 30秒
TCP MSS調整 オート
WarpLink サービス 有効
ユーザID warplinksample1
パスワード warplinksample1pass
DNS サービス 有効
FastFowarding 有効
L2TPv3 FastFowarding 有効

〔NXR_Bの設定〕

設定項目 設定内容
ホスト名 NXR_B
LAN側インタフェース ethernet0のIPアドレス 192.168.10.2/24
WAN側インタフェース mobile1 ppp0
キャリア キャリア
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
TCP MSS調整 オート
PPP接続用ユーザID ユーザID
PPP接続用パスワード パスワード
APN APN
CID CID
PDPタイプ IP
発信用電話番号 *99***[CID]#
ダイアルタイムアウト 30秒
モバイルエラーリカバリー リセット
モバイルターミネーションリカバリー リセット
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in 動作 許可
送信元IPアドレス any
宛先IPアドレス any
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxrb
ルータID 172.20.20.1
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 NXR_A
リモートトンネルアドレス nxra.subdomain.warplink.ne.jp
リモートホスト名 nxra
リモートルータID 172.20.10.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_A
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 45秒
TCP MSS調整 オート
WarpLink サービス 有効
ユーザID warplinksample2
パスワード warplinksample2pass
DNS サービス 有効

 

【 設定例 】

〔NXR_Aの設定〕

nxrg240#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg240(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24
NXR_A(config-if)#exit
NXR_A(config)#ip route 0.0.0.0/0 ppp 0
NXR_A(config)#ip access-list ppp0_in permit any any 115
NXR_A(config)#ppp account username test1@example.jp password test1pass
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address negotiated
NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test1@example.jp
NXR_A(config-ppp)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#exit
NXR_A(config)#l2tpv3 hostname nxra
NXR_A(config)#l2tpv3 router-id 172.20.10.1
NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery enable
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B
NXR_A(config-l2tpv3-tunnel)#tunnel address nxrb.subdomain.warplink.ne.jp
NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A(config-l2tpv3-tunnel)#exit
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1
NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#retry-interval 30
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A(config-l2tpv3-xconnect)#exit
NXR_A(config)#warplink
NXR_A(config-warplink)#service enable
NXR_A(config-warplink)#account username warplinksample1 password warplinksample1pass
NXR_A(config-warplink)#exit
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#exit
NXR_A(config)#fast-forwarding enable
NXR_A(config)#l2tpv3 fast-forwarding enable
NXR_A(config)#exit
NXR_A#save config

〔NXR_Bの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.2/24
NXR_B(config-if)#exit
NXR_B(config)#ip route 0.0.0.0/0 ppp 0
NXR_B(config)#ip access-list ppp0_in permit any any 115
NXR_B(config)#ppp account username [ユーザID] password [パスワード]
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated
NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ppp username [ユーザID]
NXR_B(config-ppp)#mobile apn [APN] cid [CID] pdp-type ip
NXR_B(config-ppp)#dial-up string *99***[CID]#
NXR_B(config-ppp)#dial-up timeout 30
NXR_B(config-ppp)#exit
NXR_B(config)#mobile error-recovery-reset
NXR_B(config)#mobile termination-recovery reset
NXR_B(config)#mobile 1 ppp 0
% Please execute ‘clear mobile 1′ command to take affect.
NXR_B(config)#mobile 1 carrier [キャリア]
% Please execute ‘clear mobile 1′ command to take affect.
NXR_B(config)#exit
NXR_B#clear mobile 1
Reset mobile device 1 … Please wait.
NXR_B#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 172.20.20.1
NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery enable
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address nxra.subdomain.warplink.ne.jp
NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_B(config-l2tpv3-tunnel)#exit
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 45
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#warplink
NXR_B(config-warplink)#service enable
NXR_B(config-warplink)#account username warplinksample2 password warplinksample2pass
NXR_B(config-warplink)#exit
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#exit
NXR_B(config)#exit
NXR_B#save config

 

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxrg240(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_A(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_A(config)#ip access-list ppp0_in permit any any 115

IPアクセスリスト名をppp0_inとし、L2TPパケット(プロトコル番号115)を許可します。
なおこのIPアクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

5. <PPPアカウント設定>
NXR_A(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスが動的IPアドレスの場合は、negotiatedを設定します。

NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またIPアクセスリストppp0_inをinフィルタに適用します。そしてTCP MSSの調整機能をオートに設定します。

NXR_A(config-ppp)#ppp username test1@example.jp

ISP接続用ユーザIDを設定します。

 

7. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

8. <L2TPv3設定>
NXR_A(config)#l2tpv3 hostname nxra
NXR_A(config)#l2tpv3 router-id 172.20.10.1

L2TPv3のホスト名としてnxraを設定します。またルータIDを設定します。

NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery enable

MACアドレス学習機能を有効にし、エージングタイムを設定します。またPath MTU Discoveryを有効にします。

 

9. <L2TPv3トンネル設定>
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B

L2TPv3トンネル1の説明としてNXR_Bを設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel address nxrb.subdomain.warplink.ne.jp

ルータNXR_BのWAN側IPアドレスは動的IPアドレスですが、FQDNが指定可能なため、ルータNXR_BのFQDNを設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf

ルータNXR_BのL2TPv3ホスト名およびルータIDを設定します。そしてベンダIDとしてietfを設定します。
(☞) ルータNXR_BのL2TPv3設定にあるホスト名,ルータIDと同一の値を設定します。

 

10. <L2TPv3 Xconnect設定>
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_B、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#retry-interval 30
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。またリトライインターバルを設定します。そしてTCP MSSの調整機能をオートに設定します。

 

11. <WarpLink設定>
NXR_A(config)#warplink
NXR_A(config-warplink)#service enable

WarpLinkサービスを有効にします。

NXR_A(config-warplink)#account username warplinksample1 password warplinksample1pass

WarpLinkサービスで使用するユーザID,パスワードを設定します。

 

12. <DNS設定>
NXR_A(config)#dns
NXR_A(config-dns)#service enable

DNSサービスを有効にします。

 

13. <ファストフォワーディングの有効化>
NXR_A(config)#fast-forwarding enable
NXR_A(config)#l2tpv3 fast-forwarding enable

ファストフォワーディングおよびL2TPv3ファストフォワーディングを有効にします。
(☞) ファストフォワーディングおよびL2TPv3ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.2/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_B(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_B(config)#ip access-list ppp0_in permit any any 115

IPアクセスリスト名をppp0_inとし、L2TPパケット(プロトコル番号115)を許可します。
なおこのIPアクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

5. <PPPアカウント設定>
NXR_B(config)#ppp account username [ユーザID] password [パスワード]

モバイル接続で使用するユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスが動的IPアドレスの場合は、negotiatedを設定します。

NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またIPアクセスリストppp0_inをinフィルタに適用します。そしてTCP MSSの調整機能をオートに設定します。

NXR_B(config-ppp)#ppp username [ユーザID]
NXR_B(config-ppp)#mobile apn [APN] cid [CID] pdp-type ip

PPP接続用ユーザIDを設定します。またAPN,CID,PDPタイプを設定します。

NXR_B(config-ppp)#dial-up string *99***[CID]#
NXR_B(config-ppp)#dial-up timeout 30

発信用の電話番号およびダイアルタイムアウトを設定します。
(☞) ここで設定する電話番号はSIMカードの電話番号ではありません。

 

7. <モバイルエラーリカバリー設定>
NXR_B(config)#mobile error-recovery-reset

内蔵通信モジュールとの通信に重大な問題が発生する可能性が高いと判断した場合、内蔵通信モジュールのリセットを行うように設定します。

 

8. <モバイルターミネーションリカバリー設定>
NXR_B(config)#mobile termination-recovery reset

PPP接続時に網側から切断された場合、内蔵通信モジュールのリセットを行うように設定します。

 

9. <モバイル割り当て設定>
NXR_B(config)#mobile 1 ppp 0

mobile1として認識されている内蔵通信モジュールとppp0インタフェースの関連づけを行います。
内蔵通信モジュールをPPPインタフェースで使用する場合は、mobileコマンドによるPPPインタフェースへの関連付けが必要になります。
(☞) mobile1の情報はshow mobile 1コマンドで確認することができます。

 

10. <モバイルキャリア設定>
NXR_B(config)#mobile 1 carrier [キャリア]

mobile1として認識されている内蔵通信モジュールのキャリアを指定します。
(☞) キャリア設定は「clear mobile 1」コマンドによるモバイルリセットを行うことで反映されます。
(☞) モバイルキャリア設定はマルチキャリア対応機種NXR-G240/L,NXR-G260/L,NXR-G100/Lで設定することができます。

 

11. <L2TPv3設定>
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 172.20.20.1

L2TPv3のホスト名としてnxrbを設定します。またルータIDを設定します。

NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery enable

MACアドレス学習機能を有効にし、エージングタイムを設定します。またPath MTU Discoveryを有効にします。

 

12. <L2TPv3トンネル設定>
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A

L2TPv3トンネル1の説明としてNXR_Aを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel address nxra.subdomain.warplink.ne.jp

ルータNXR_AのWAN側IPアドレスは動的IPアドレスですが、FQDNが指定可能なため、ルータNXR_AのFQDNを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf

ルータNXR_AのL2TPv3ホスト名およびルータIDを設定します。そしてベンダIDとしてietfを設定します。
(☞) ルータNXR_AのL2TPv3設定にあるホスト名,ルータIDと同一の値を設定します。

 

13. <L2TPv3 Xconnect設定>
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_A、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 45
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。またリトライインターバルを設定します。そしてTCP MSSの調整機能をオートに設定します。

 

14. <WarpLink設定>
NXR_B(config)#warplink
NXR_B(config-warplink)#service enable
NXR_B(config-warplink)#account username warplinksample2 password warplinksample2pass

WarpLinkサービスを有効にし、ユーザID,パスワードを設定します。

 

15. <DNS設定>
NXR_B(config)#dns
NXR_B(config-dns)#service enable

DNSサービスを有効にします。

 

【 端末の設定例 】

LAN_Aの端末 LAN_Bの端末
IPアドレス 192.168.10.101 192.168.10.102
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.10.2
DNSサーバ