FutureNet

NXR,WXRシリーズ

L2TPv3編

1. L2TPv3基本設定

1-4. L2TPv3 over UDP設定

NAPTルータ配下にあるルータからL2TPv3 over UDPを使用してL2TPv3接続する設定例です。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • L2TPv3 over UDPを利用する場合、L2TPv3トンネル設定でプロトコルUDPを設定します。それにともないL2TPv3設定,L2TPv3トンネル設定で送信元,宛先のポート番号を設定します。
  • L2TPv3は通信の暗号化を行いませんので、インターネット上で利用する場合、IPsecと組み合わせて利用することを推奨致します。
  • NXR_Aのeth1で接続しているISPのDNSサーバアドレスを以下とします。
    プライマリDNSサーバ:203.0.113.253
    セカンダリDNSサーバ:203.0.113.254

 

【 設定例 】

〔NXR_Aの設定〕

nxr650#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr650(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24
NXR_A(config-if)#exit
NXR_A(config)#ip access-list eth1_in permit any 203.0.113.1 udp any 1701
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#ip address 203.0.113.1/30
NXR_A(config-if)#ip masquerade
NXR_A(config-if)#ip spi-filter
NXR_A(config-if)#ip access-group in eth1_in
NXR_A(config-if)#exit
NXR_A(config)#ip route 0.0.0.0/0 203.0.113.2
NXR_A(config)#l2tpv3 hostname nxra
NXR_A(config)#l2tpv3 router-id 192.168.10.1
NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 udp path-mtu-discovery enable
NXR_A(config)#l2tpv3 udp source-port 1701
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B
NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.2
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A(config-l2tpv3-tunnel)#tunnel protocol udp
NXR_A(config-l2tpv3-tunnel)#exit
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1
NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A(config-l2tpv3-xconnect)#exit
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#address 203.0.113.253
NXR_A(config-dns)#address 203.0.113.254
NXR_A(config-dns)#exit
NXR_A(config)#fast-forwarding enable
NXR_A(config)#l2tpv3 fast-forwarding enable
NXR_A(config)#exit
NXR_A#save config

 

〔NXR_Bの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.2/24
NXR_B(config-if)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#ip address dhcp
NXR_B(config-if)#exit
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 192.168.10.2
NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 udp path-mtu-discovery enable
NXR_B(config)#l2tpv3 udp source-port 1701
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address 203.0.113.1
NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_B(config-l2tpv3-tunnel)#tunnel protocol udp
NXR_B(config-l2tpv3-tunnel)#tunnel udp port 1701
NXR_B(config-l2tpv3-tunnel)#exit
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#exit
NXR_B(config)#fast-forwarding enable
NXR_B(config)#l2tpv3 fast-forwarding enable
NXR_B(config)#exit
NXR_B#save config

 

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxr650(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <IPアクセスリスト設定>
NXR_A(config)#ip access-list eth1_in permit any 203.0.113.1 udp any 1701

IPアクセスリストeth1_inを以下のルールで設定します。

  • 宛先IPアドレス203.0.113.1、宛先UDPポート1701番を許可

(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

4. <WAN側(ethernet1)インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#ip address 203.0.113.1/30

ethernet1インタフェースのIPアドレスを設定します。

NXR_A(config-if)#ip masquerade
NXR_A(config-if)#ip spi-filter

IPマスカレード、ステートフルパケットインスペクションを有効にします。

NXR_A(config-if)#ip access-group in eth1_in

IPアクセスグループのinフィルタにIPアクセスリストeth1_inを設定します。

 

5. <スタティックルート設定>
NXR_A(config)#ip route 0.0.0.0/0 203.0.113.2

デフォルトルートを設定します。

 

6. <L2TPv3設定>
NXR_A(config)#l2tpv3 hostname nxra

L2TPv3のホスト名を設定します。
(☞) 省略時はhostnameコマンドで設定した値が使用されます。

NXR_A(config)#l2tpv3 router-id 192.168.10.1

L2TPv3のルータIDを設定します。
(☞) ルータIDは必ずしも通信時に使用するアドレスと同じである必要はありません。

NXR_A(config)#l2tpv3 mac-learning

MACアドレス学習機能を有効にします。

NXR_A(config)#l2tpv3 mac-aging 300

MACアドレス学習機能のエージングタイムを設定します。

NXR_A(config)#l2tpv3 udp path-mtu-discovery enable

L2TPv3 over UDPでPath MTU Discoveryを有効にします。

NXR_A(config)#l2tpv3 udp source-port 1701

L2TPv3overUDP使用時の送信元ポート番号を設定します。

 

7. <L2TPv3トンネル設定>
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B

L2TPv3トンネル1の説明文を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb

NXR_BのL2TPv3のホスト名を設定します。
(☞) このホスト名はNXR_Bのl2tpv3 hostnameと同一の値を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.2

NXR_BのL2TPv3のルータIDを設定します。
(☞) このルータIDはNXR_Bのl2tpv3 router-idと同一の値を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf

ベンダIDをietfに設定します。
(☞) このベンダIDはNXR_Bのl2tpv3 tunnel1と同一の値を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel protocol udp

プロトコルをUDPに設定します。

 

8. <L2TPv3 Xconnect設定>
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B

L2TPv3 Xconnect1の説明文を設定します。

NXR_A(config-l2tpv3-xconnect)#tunnel 1

このL2TPv3 Xconnectで使用するL2TPv3トンネルを設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0

Xconnectインタフェースを設定します。
(☞) この設定で指定したインタフェースがL2フレームを送受信するインタフェースになります。

NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1

リモートエンドIDを設定します。
(☞) Xconnectインタフェースを識別する際に使用するIDのため、対向機器で設定するリモートエンドIDと同じIDを設定します。

NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

 

9. <DNS設定>
NXR_A(config)#dns
NXR_A(config-dns)#service enable

DNSサービスを有効にします。

NXR_A(config-dns)#address 203.0.113.253
NXR_A(config-dns)#address 203.0.113.254

DNSサーバアドレスを設定します。

 

10. <ファストフォワーディング設定>
NXR_A(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

NXR_A(config)#l2tpv3 fast-forwarding enable

L2TPv3ファストフォワーディングを有効にします。

 

11. <設定の保存>
NXR_A#save config

設定内容を保存します。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.2/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <WAN側(ethernet1)インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#ip address dhcp

ethernet1インタフェースのIPアドレスをdhcpに設定します。

 

4. <L2TPv3設定>
NXR_B(config)#l2tpv3 hostname nxrb

L2TPv3のホスト名を設定します。

NXR_B(config)#l2tpv3 router-id 192.168.10.2

L2TPv3のルータIDを設定します。

NXR_B(config)#l2tpv3 mac-learning

MACアドレス学習機能を有効にします。

NXR_B(config)#l2tpv3 mac-aging 300

MACアドレス学習機能のエージングタイムを設定します。

NXR_B(config)#l2tpv3 udp path-mtu-discovery enable

L2TPv3overUDP使用時のPath MTU Discoveryを有効にします。

NXR_B(config)#l2tpv3 udp source-port 1701

L2TPv3overUDP使用時の送信元ポート番号を設定します。

 

5. <L2TPv3トンネル設定>
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A

L2TPv3トンネル1の説明文を設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel address 203.0.113.1

トンネルアドレスにNXR_AのWAN側IPアドレスを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra

NXR_AのL2TPv3のホスト名を設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel router-id 192.168.10.1

NXR_AのL2TPv3のルータIDを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf

ベンダIDをietfに設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel protocol udp

プロトコルをUDPに設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel udp port 1701

L2TPv3overUDP使用時の宛先ポート番号を設定します。

 

6. <L2TPv3 Xconnect設定>
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A

L2TPv3 Xconnect1の説明文を設定します。

NXR_B(config-l2tpv3-xconnect)#tunnel 1

このL2TPv3 Xconnectで使用するL2TPv3トンネルを設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0

Xconnectインタフェースを設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1

リモートエンドIDを設定します。

NXR_B(config-l2tpv3-xconnect)#retry-interval 30

リトライインターバルを設定します。

NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

 

7. <DNS設定>
NXR_B(config)#dns
NXR_B(config-dns)#service enable

DNSサービスを有効にします。

 

8. <ファストフォワーディング設定>
NXR_B(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

NXR_B(config)#l2tpv3 fast-forwarding enable

L2TPv3ファストフォワーディングを有効にします。

 

9. <設定の保存>
NXR_B#save config

設定内容を保存します。

 

【 端末の設定例 】

NXR_A配下の端末 NXR_B配下の端末
IPアドレス 192.168.10.101 192.168.10.102
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.10.2
DNSサーバアドレス

 

【 付録 】