FutureNet

NXR,WXRシリーズ

IPv6編

5. IPv6 L2TPv3設定

5-4. IPv6 L2TPv3冗長化設定(IPv6 RA+IPv4 PPPoE)

メイン回線にIPv6 IPoE(RA方式)、バックアップ回線にIPv4 PPPoEを使用してL2TPv3の冗長化を実現します。なおIPv6 IPoE(RA方式)ではフレッツv6オプションの「ネーム」を利用します。「ネーム」を利用する場合は事前に登録が必要となります。

 

【 構成図 】

<正常時>

<障害時>

  • この設定例ではIPv6 IPoE(RA方式)で「ネーム」を利用しますので、L2TPv3のメイントンネルはルータNXR_A,Bともに対向ルータのFQDNの名前解決後、L2TPv3接続を開始します。よって名前解決ができない場合、L2TPv3接続を開始することができませんのでご注意ください。
  • IPv6アドレスが半固定の場合、プレフィックスが変更される可能性があるため、障害が発生していない場合でもL2TPv3トンネルがセカンダリに切り替わる可能性があります。
    (☞) プレフィックスが変更された場合は、必要に応じて「ネーム」を再設定して下さい。
  • 取得したドメインサーチリストを元に名前解決を行うよう設定します。
  • ルータNXR_BではL2TPv3グループ機能を設定します。これによりL2TPv3セッションの二重化が可能になります。なお、この設定例ではL2TPv3グループ機能のpreemptモードを有効に設定します。これによりセカンダリセッションがアクティブセッションとなっている状態で、プライマリセッションが確立した場合、プライマリセッションをアクティブセッションとして使用します。

 

【 設定データ 】

〔NXR_Aの設定〕

設定項目 設定内容
ホスト名 NXR_A
LAN側インタフェース ethernet0のIPv4アドレス 192.168.10.1/24
WAN側インタフェース ethernet1インタフェース
(IPv6側)
ethernet1のIPv4アドレス 無効
ethernet1のIPv6アドレス 自動設定
DHCPv6クライアント クライアント名 ipv6dhcpc
IPv6アクセスグループ in eth1_in
IPv6 SPIフィルタ 有効
PPPoEクライアント(ethernet1) ppp0
ppp0インタフェース
(IPv4側)
ppp0のIPv4アドレス 10.10.10.1/32
IPマスカレード 有効
IPv4アクセスグループ in ppp0_in
IPv4 SPIフィルタ 有効
IPv4 TCP MSS自動調整 オート
IPv4 ISP接続用ユーザID test1@example.jp
IPv4 ISP接続用パスワード test1pass
スタティックルート 宛先IPv4アドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPv4フィルタ ルール名 ppp0_in
ppp0_in 動作 許可
送信元IPアドレス any
宛先IPアドレス 10.10.10.1
プロトコル 115(L2TP)
IPv6フィルタ ルール名 eth1_in
eth1_in No.1 動作 許可
送信元IPv6アドレス any
宛先IPv6アドレス any
プロトコル ICMPv6
No.2 動作 許可
送信元IPv6アドレス any
宛先IPv6アドレス any
プロトコル UDP
送信元ポート any
宛先ポート 546
No.3 動作 許可
送信元IPv6アドレス any
宛先IPv6アドレス any
プロトコル 115(L2TP)
L2TPv3 MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 NXR_B
リモートトンネルアドレス(ipv6) △△△.aoi.flets-east.jp
リモートホスト名 nxrb1
リモートルータID 172.20.20.1
ローカルホスト名 nxra1
ローカルルータID 172.20.10.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_B
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 30秒
IPv4 TCP MSS自動調整 オート
L2TPv3トンネル2 名前 NXR_B
リモートホスト名 nxrb2
リモートルータID 172.20.20.2
ローカルホスト名 nxra2
ローカルルータID 172.20.10.2
リモートベンダーID ietf
L2TPv3 Xconnect2 名前 NXR_B
L2TPv3トンネルID 2
Xconnectインタフェース ethernet0
リモートエンドID 1
IPv4 TCP MSS自動調整 オート
DHCPv6クライアント 名前 ipv6dhcpc
information-only 有効
DNS サービス 有効
EDNS 有効
ドメインサーチ 有効
FastFowarding 有効
L2TPv3 FastFowarding 有効

 

〔NXR_Bの設定〕

設定項目 設定内容
ホスト名 NXR_B
LAN側インタフェース ethernet0のIPv4アドレス 192.168.10.2/24
WAN側インタフェース ethernet1インタフェース
(IPv6側)
ethernet1のIPv4アドレス 無効
ethernet1のIPv6アドレス 自動設定
DHCPv6クライアント クライアント名 ipv6dhcpc
IPv6アクセスグループ in eth1_in
IPv6 SPIフィルタ 有効
PPPoEクライアント(ethernet1) ppp0
ppp0インタフェース
(IPv4側)
ppp0のIPv4アドレス 動的IPアドレス
IPマスカレード 有効
IPv4アクセスグループ in ppp0_in
IPv4 SPIフィルタ 有効
IPv4 TCP MSS自動調整 オート
IPv4 ISP接続用ユーザID test2@example.jp
IPv4 ISP接続用パスワード test2pass
スタティックルート 宛先IPv4アドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPv4フィルタ ルール名 ppp0_in
ppp0_in 動作 許可
送信元IPアドレス 10.10.10.1
宛先IPアドレス any
プロトコル 115(L2TP)
IPv6フィルタ ルール名 eth1_in
eth1_in No.1 動作 許可
送信元IPv6アドレス any
宛先IPv6アドレス any
プロトコル ICMPv6
No.2 動作 許可
送信元IPv6アドレス any
宛先IPv6アドレス any
プロトコル UDP
送信元ポート any
宛先ポート 546
No.3 動作 許可
送信元IPv6アドレス any
宛先IPv6アドレス any
プロトコル 115(L2TP)
L2TPv3 MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 NXR_A
リモートトンネルアドレス(ipv6) ○○○.aoi.flets-east.jp
リモートホスト名 nxra1
リモートルータID 172.20.10.1
ローカルホスト名 nxrb1
ローカルルータID 172.20.20.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_A
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 45秒
IPv4 TCP MSS自動調整 オート
L2TPv3トンネル2 名前 NXR_A
リモートトンネルアドレス 10.10.10.1
リモートホスト名 nxra2
リモートルータID 172.20.10.2
ローカルホスト名 nxrb2
ローカルルータID 172.20.20.2
リモートベンダーID ietf
L2TPv3 Xconnect2 名前 NXR_A
L2TPv3トンネルID 2
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 30秒
IPv4 TCP MSS自動調整 オート
L2TPv3グループ1 Xconnect プライマリ 1
セカンダリ 2
プリエンプト 有効
アクティブホールド 有効
DHCPv6クライアント 名前 ipv6dhcpc
information-only 有効
DNS サービス 有効
EDNS 有効
ドメインサーチ 有効
FastFowarding 有効
L2TPv3 FastFowarding 有効

 

【 設定例 】

〔NXR_Aの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_A
NXR_A(config)#ipv6 dhcp-client ipv6dhcpc
NXR_A(config-dhcp6c)#information-only enable
NXR_A(config-dhcp6c)#exit
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24
NXR_A(config-if)#exit
NXR_A(config)#ip route 0.0.0.0/0 ppp 0
NXR_A(config)#ip access-list ppp0_in permit any 10.10.10.1 115
NXR_A(config)#ipv6 access-list eth1_in permit any any icmpv6
NXR_A(config)#ipv6 access-list eth1_in permit any any udp any 546
NXR_A(config)#ipv6 access-list eth1_in permit any any 115
NXR_A(config)#ppp account username test1@example.jp password test1pass
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 10.10.10.1/32
NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test1@example.jp
NXR_A(config-ppp)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#ipv6 address autoconfig
NXR_A(config-if)#ipv6 dhcp client ipv6dhcpc
NXR_A(config-if)#ipv6 access-group in eth1_in
NXR_A(config-if)#ipv6 spi-filter
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#exit
NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B
NXR_A(config-l2tpv3-tunnel)#tunnel address ipv6 △△△.aoi.flets-east.jp
NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb1
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
NXR_A(config-l2tpv3-tunnel)#tunnel local hostname nxra1
NXR_A(config-l2tpv3-tunnel)#tunnel local router-id 172.20.10.1
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A(config-l2tpv3-tunnel)#exit
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1
NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#retry-interval 30
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A(config-l2tpv3-xconnect)#exit
NXR_A(config)#l2tpv3 tunnel 2
NXR_A(config-l2tpv3-tunnel)#description NXR_B
NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb2
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.2
NXR_A(config-l2tpv3-tunnel)#tunnel local hostname nxra2
NXR_A(config-l2tpv3-tunnel)#tunnel local router-id 172.20.10.2
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A(config-l2tpv3-tunnel)#exit
NXR_A(config)#l2tpv3 xconnect 2
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 2
NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A(config-l2tpv3-xconnect)#exit
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#edns-query enable
NXR_A(config-dns)#domain-search enable
NXR_A(config-dns)#exit
NXR_A(config)#fast-forwarding enable
NXR_A(config)#l2tpv3 fast-forwarding enable
NXR_A(config)#exit
NXR_A#save config

〔NXR_Bの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_B
NXR_B(config)#ipv6 dhcp-client ipv6dhcpc
NXR_B(config-dhcp6c)#information-only enable
NXR_B(config-dhcp6c)#exit
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.2/24
NXR_B(config-if)#exit
NXR_B(config)#ip route 0.0.0.0/0 ppp 0
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any 115
NXR_B(config)#ipv6 access-list eth1_in permit any any icmpv6
NXR_B(config)#ipv6 access-list eth1_in permit any any udp any 546
NXR_B(config)#ipv6 access-list eth1_in permit any any 115
NXR_B(config)#ppp account username test2@example.jp password test2pass
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated
NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ppp username test2@example.jp
NXR_B(config-ppp)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#ipv6 address autoconfig
NXR_B(config-if)#ipv6 dhcp client ipv6dhcpc
NXR_B(config-if)#ipv6 access-group in eth1_in
NXR_B(config-if)#ipv6 spi-filter
NXR_B(config-if)#pppoe-client ppp 0
NXR_B(config-if)#exit
NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address ipv6 ○○○.aoi.flets-east.jp
NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra1
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel local hostname nxrb1
NXR_B(config-l2tpv3-tunnel)#tunnel local router-id 172.20.20.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_B(config-l2tpv3-tunnel)#exit
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 45
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#l2tpv3 tunnel 2
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address 10.10.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra2
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.2
NXR_B(config-l2tpv3-tunnel)#tunnel local hostname nxrb2
NXR_B(config-l2tpv3-tunnel)#tunnel local router-id 172.20.20.2
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_B(config-l2tpv3-tunnel)#exit
NXR_B(config)#l2tpv3 xconnect 2
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 2
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#l2tpv3 group 1
NXR_B(config-l2tpv3-group)#xconnect 1 2
NXR_B(config-l2tpv3-group)#preempt enable
NXR_B(config-l2tpv3-group)#active-hold enable
NXR_B(config-l2tpv3-group)#exit
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#edns-query enable
NXR_B(config-dns)#domain-search enable
NXR_B(config-dns)#exit
NXR_B(config)#fast-forwarding enable
NXR_B(config)#l2tpv3 fast-forwarding enable
NXR_B(config)#exit
NXR_B#save config

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_A

ホスト名を設定します。

 

2. <DHCPv6クライアント設定>
NXR_A(config)#ipv6 dhcp-client ipv6dhcpc
NXR_A(config-dhcp6c)#information-only enable

DHCPv6クライアント設定の名前を定義します。またinformation-only機能を有効に設定します。

 

3. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

 

4. <スタティックルート設定>
NXR_A(config)#ip route 0.0.0.0/0 ppp 0

IPv4デフォルトルートを設定します。

 

5. <IPv4アクセスリスト設定>
NXR_A(config)#ip access-list ppp0_in permit any 10.10.10.1 115

IPv4アクセスリスト名をppp0_inとし、NXR_AのWAN側IPv4アドレス10.10.10.1宛のL2TPパケット(プロトコル番号115)を許可します。
なお、このIPv4アクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPv4アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

6. <IPv6アクセスリスト設定>
NXR_A(config)#ipv6 access-list eth1_in permit any any icmpv6
NXR_A(config)#ipv6 access-list eth1_in permit any any udp any 546

IPv6アクセスリスト名をeth1_inとし、ICMPv6および宛先UDPポート546番(DHCPv6クライアント)を許可します。

NXR_A(config)#ipv6 access-list eth1_in permit any any 115

IPv6アクセスリスト名をeth1_inとし、L2TPパケット(プロトコル番号115)を許可します。
(☞) これらIPv6アクセスリスト設定はethernet1インタフェース設定で登録します。
(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

7. <PPPアカウント設定>
NXR_A(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するIPv4 ISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

8. <WAN側(ppp0)インタフェース設定>
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 10.10.10.1/32

ppp0インタフェースのIPアドレスを設定します。

NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またIPv4アクセスリストppp0_inをinフィルタに適用します。そしてIPv4 TCP MSSの調整機能をオートに設定します。

NXR_A(config-ppp)#ppp username test1@example.jp

IPv4 ISP接続用ユーザIDを設定します。

 

9. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#ipv6 address autoconfig

ethernet1インタフェースのIPv4アドレスを無効、IPv6アドレスを自動設定に設定します。

NXR_A(config-if)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

NXR_A(config-if)#ipv6 access-group in eth1_in
NXR_A(config-if)#ipv6 spi-filter

IPv6アクセスリストeth1_inをinフィルタに適用し、IPv6ステートフルパケットインスペクションを有効に設定します。

NXR_A(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

10. <L2TPv3設定>
NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery

MACアドレス学習機能を有効にし、エージングタイムを設定します。またPath MTU Discoveryを有効にします。

 

11. <L2TPv3トンネル1設定>
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B
NXR_A(config-l2tpv3-tunnel)#tunnel address ipv6 △△△.aoi.flets-east.jp

L2TPv3トンネル1の説明としてNXR_B、リモートアドレスにNXR_BのFQDNを設定します。
(☞) FQDN指定時、名前解決を行うプロトコルとしてIPv6のみ利用するよう設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb1
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1

NXR_Bのプライマリセッション用ホスト名およびルータIDを設定します。
(☞) NXR_BのL2TPv3トンネル1設定にあるローカルホスト名,ローカルルータIDと同一の値を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel local hostname nxra1
NXR_A(config-l2tpv3-tunnel)#tunnel local router-id 172.20.10.1
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf

NXR_Aのプライマリセッション用ホスト名およびルータIDを設定します。
そしてベンダIDとしてietfを設定します。
(☞) NXR_BのL2TPv3トンネル1設定にあるリモートホスト名,リモートルータIDと同一の値を設定します。

 

12. <L2TPv3 Xconnect1設定>
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_B、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#retry-interval 30
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。またリトライインターバルを設定します。そしてIPv4 TCP MSSの調整機能をオートに設定します。

 

13. <L2TPv3トンネル2設定>
NXR_A(config)#l2tpv3 tunnel 2
NXR_A(config-l2tpv3-tunnel)#description NXR_B

L2TPv3トンネル2の説明としてNXR_Bを設定します。なおNXR_BのWAN側IPv4アドレスが動的IPアドレスのため、リモートトンネルアドレスは設定しません。

NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb2
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.2

NXR_Bのセカンダリセッション用ホスト名およびルータIDを設定します。
(☞) NXR_BのL2TPv3トンネル2設定にあるローカルホスト名,ローカルルータIDと同一の値を設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel local hostname nxra2
NXR_A(config-l2tpv3-tunnel)#tunnel local router-id 172.20.10.2
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf

NXR_Aのセカンダリセッション用ホスト名およびルータIDを設定します。
そしてベンダIDとしてietfを設定します。
(☞) NXR_BのL2TPv3トンネル2設定にあるリモートホスト名,リモートルータIDと同一の値を設定します。

 

14. <L2TPv3 Xconnect2設定>
NXR_A(config)#l2tpv3 xconnect 2
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 2

L2TPv3 Xconnect2の説明としてNXR_B、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル2を設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。またIPv4 TCP MSSの調整機能をオートに設定します。

 

15. <DNS設定>
NXR_A(config)#dns
NXR_A(config-dns)#service enable

DNSサービスを有効にします。

NXR_A(config-dns)#edns-query enable

EDNSを有効にします。

NXR_A(config-dns)#domain-search enable

ドメインサーチを有効にします。
(☞) 有効にすることでドメインサーチリストで受信したドメインを含むアドレスを解決する際、取得したDNSサーバに対して名前解決を行うようになります。

 

16. <ファストフォワーディングの有効化>
NXR_A(config)#fast-forwarding enable
NXR_A(config)#l2tpv3 fast-forwarding enable

ファストフォワーディングおよびL2TPv3ファストフォワーディングを有効にします。
(☞) ファストフォワーディングおよびL2TPv3ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <DHCPv6クライアント設定>
NXR_B(config)#ipv6 dhcp-client ipv6dhcpc
NXR_B(config-dhcp6c)#information-only enable

DHCPv6クライアント設定の名前を定義します。またinformation-only機能を有効に設定します。

 

3. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.2/24

ethernet0インタフェースのIPv4アドレスを設定します。

 

4. <スタティックルート設定>
NXR_B(config)#ip route 0.0.0.0/0 ppp 0

IPv4デフォルトルートを設定します。

 

5. <IPv4アクセスリスト設定>
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any 115

IPv4アクセスリスト名をppp0_inとし、送信元がNXR_AのWAN側IPv4アドレス10.10.10.1のL2TPパケット(プロトコル番号115)を許可します。
なお、このIPv4アクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPv4アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

6. <IPv6アクセスリスト設定>
NXR_B(config)#ipv6 access-list eth1_in permit any any icmpv6
NXR_B(config)#ipv6 access-list eth1_in permit any any udp any 546

IPv6アクセスリスト名をeth1_inとし、ICMPv6および宛先UDPポート546番(DHCPv6クライアント)を許可します。

NXR_B(config)#ipv6 access-list eth1_in permit any any 115

IPv6アクセスリスト名をeth1_inとし、L2TPパケット(プロトコル番号115)を許可します。
(☞) これらIPv6アクセスリスト設定はethernet1インタフェース設定で登録します。
(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

7. <PPPアカウント設定>
NXR_B(config)#ppp account username test2@example.jp password test2pass

ppp0インタフェースで使用するIPv4 ISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

8. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated

ppp0インタフェースのIPv4アドレスが動的IPv4アドレスの場合は、negotiatedを設定します。

NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またIPアクセスリストppp0_inをinフィルタに適用します。そしてIPv4 TCP MSSの調整機能をオートに設定します。

NXR_B(config-ppp)#ppp username test2@example.jp

IPv4 ISP接続用ユーザIDを設定します。

 

9. <ethernet1インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#ipv6 address autoconfig

ethernet1インタフェースのIPv4アドレスを無効、IPv6アドレスを自動設定に設定します。

NXR_B(config-if)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

NXR_B(config-if)#ipv6 access-group in eth1_in
NXR_B(config-if)#ipv6 spi-filter

IPv6アクセスリストeth1_inをinフィルタに適用し、IPv6ステートフルパケットインスペクションを有効に設定します。

NXR_B(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

10. <L2TPv3設定>
NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery

MACアドレス学習機能を有効にし、エージングタイムを設定します。またPath MTU Discoveryを有効にします。

 

11. <L2TPv3トンネル1設定>
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address ipv6 ○○○.aoi.flets-east.jp

L2TPv3トンネル1の説明としてNXR_A、リモートアドレスにNXR_AのFQDNを設定します。
(☞) FQDN指定時、名前解決を行うプロトコルとしてIPv6のみ利用するよう設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra1
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1

NXR_Aのプライマリセッション用ホスト名およびルータIDを設定します。
(☞) NXR_AのL2TPv3トンネル1設定にあるローカルホスト名,ローカルルータIDと同一の値を設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel local hostname nxrb1
NXR_B(config-l2tpv3-tunnel)#tunnel local router-id 172.20.20.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf

NXR_Bのプライマリセッション用ホスト名およびルータIDを設定します。
そしてベンダIDとしてietfを設定します。
(☞) NXR_AのL2TPv3トンネル1設定にあるリモートホスト名,リモートルータIDと同一の値を設定します。

 

12. <L2TPv3 Xconnect1設定>
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_A、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 45
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。またリトライインターバルを設定します。そしてIPv4 TCP MSSの調整機能をオートに設定します。

 

13. <L2TPv3トンネル2設定>
NXR_B(config)#l2tpv3 tunnel 2
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address 10.10.10.1

L2TPv3トンネル2の説明としてNXR_A、リモートアドレスにNXR_AのWAN側IPv4アドレスを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra2
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.2

NXR_Aのセカンダリセッション用ホスト名およびルータIDを設定します。
(☞) NXR_AのL2TPv3トンネル2設定にあるローカルホスト名,ローカルルータIDと同一の値を設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel local hostname nxrb2
NXR_B(config-l2tpv3-tunnel)#tunnel local router-id 172.20.20.2
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf

NXR_Bのセカンダリセッション用ホスト名およびルータIDを設定します。
そしてベンダIDとしてietfを設定します。
(☞) NXR_AのL2TPv3トンネル2設定にあるリモートホスト名,リモートルータIDと同一の値を設定します。

 

14. <L2TPv3 Xconnect2設定>
NXR_B(config)#l2tpv3 xconnect 2
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 2

L2TPv3 Xconnect2の説明としてNXR_A、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル2を設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。またリトライインターバルを設定します。そしてIPv4 TCP MSSの調整機能をオートに設定します。

 

15. <L2TPv3グループ設定>
NXR_B(config)#l2tpv3 group 1

L2TPv3グループ1を設定します。

NXR_B(config-l2tpv3-group)#xconnect 1 2

使用するL2TPv3 Xconnect設定をプライマリ、セカンダリの順に指定します。

NXR_B(config-l2tpv3-group)#preempt enable

プリエンプトモードを有効に設定します。
(☞) これによりセカンダリセッションがアクティブセッションになっている状態でプライマリセッションが確立した場合、プライマリセッションをアクティブセッションとして使用します。

NXR_B(config-l2tpv3-group)#active-hold enable

アクティブホールドを有効に設定します。
(☞) 対向ルータでXconnectインタフェースのリンクダウンが発生してもセカンダリセッションへの切り替えは行わず、プライマリセッションをアクティブセッションとして維持します。

 

16. <DNS設定>
NXR_B(config)#dns
NXR_B(config-dns)#service enable

DNSサービスを有効にします。

NXR_B(config-dns)#edns-query enable

EDNSを有効にします。

NXR_B(config-dns)#domain-search enable

ドメインサーチを有効にします。

 

17. <ファストフォワーディングの有効化>
NXR_B(config)#fast-forwarding enable
NXR_B(config)#l2tpv3 fast-forwarding enable

ファストフォワーディングおよびL2TPv3ファストフォワーディングを有効にします。

 

【 端末の設定例 】

LAN_Aの端末 LAN_Bの端末
IPv4アドレス 192.168.10.101 192.168.10.102
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.10.2
DNSサーバ