FutureNet

NXR,WXRシリーズ

IPv6編

5. IPv6 L2TPv3設定

5-1. IPv6 PPPoE L2TPv3接続設定

NTT東日本/西日本が提供するフレッツ光ネクスト回線でIPv6 PPPoE接続を行います。そして、それを利用して拠点間でL2TPv3接続を行います。

 

【 構成図 】

  • ルータNXR_Aには固定でプレフィックス「2001:0db8:1:1::/56」が、ルータNXR_Bには固定でプレフィックス「2001:0db8:2:1::/56」が割り当てられるものとします。
  • この設定例ではルータ配下の端末からインターネットへアクセスすることはできません。

 

【 設定データ 】

〔NXR_Aの設定〕

設定項目 設定内容
ホスト名 NXR_A
LAN側インタフェース ethernet0のIPv4アドレス 192.168.10.1/24
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPv4アドレス 無効
ppp0のIPv6アドレス dhcpv6pd ::1/64
IPCP 無効
IPv6CP 有効
DHCPv6クライアント(PD) クライアント名 dhcpv6pd
IPv6アクセスグループ in ppp0_in
IPv6 SPIフィルタ 有効
IPv6 TCP MSS自動調整 オート
ISP接続用ユーザID test1@v6.example.jp
ISP接続用パスワード test1pass
スタティックルート 宛先IPv6アドレス ::/0
ゲートウェイ(インタフェース) ppp0
IPv6フィルタ ルール名 ppp0_in
ppp0_in No.1 動作 許可
送信元IPv6アドレス any
宛先IPv6アドレス any
プロトコル UDP
送信元ポート any
宛先ポート 546
No.2 動作 許可
送信元IPv6アドレス 2001:0db8:2:1::1
宛先IPv6アドレス 2001:0db8:1:1::1
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxra
ルータID 172.20.10.1
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 NXR_B
リモートトンネルアドレス 2001:0db8:2:1::1
リモートホスト名 nxrb
リモートルータID 172.20.20.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_B
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 30秒
IPv4 TCP MSS自動調整 オート

〔NXR_Bの設定〕

設定項目 設定内容
ホスト名 NXR_B
LAN側インタフェース ethernet0のIPv4アドレス 192.168.10.2/24
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPv4アドレス 無効
ppp0のIPv6アドレス dhcpv6pd ::1/64
IPCP 無効
IPv6CP 有効
DHCPv6クライアント(PD) クライアント名 dhcpv6pd
IPv6アクセスグループ in ppp0_in
IPv6 SPIフィルタ 有効
IPv6 TCP MSS自動調整 オート
ISP接続用ユーザID test2@v6.example.jp
ISP接続用パスワード test2pass
スタティックルート 宛先IPv6アドレス ::/0
ゲートウェイ(インタフェース) ppp0
IPv6フィルタ ルール名 ppp0_in
ppp0_in No.1 動作 許可
送信元IPv6アドレス any
宛先IPv6アドレス any
プロトコル UDP
送信元ポート any
宛先ポート 546
No.2 動作 許可
送信元IPv6アドレス 2001:0db8:1:1::1
宛先IPv6アドレス 2001:0db8:2:1::1
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxrb
ルータID 172.20.20.1
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 NXR_A
リモートトンネルアドレス 2001:0db8:1:1::1
リモートホスト名 nxra
リモートルータID 172.20.10.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_A
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 45秒
IPv4 TCP MSS自動調整 オート

【 設定例 】

〔NXR_Aの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24
NXR_A(config-if)#exit
NXR_A(config)#ipv6 route ::/0 ppp 0
NXR_A(config)#ipv6 access-list ppp0_in permit any any udp any 546
NXR_A(config)#ipv6 access-list ppp0_in permit 2001:0db8:2:1::1 2001:0db8:1:1::1 115
NXR_A(config)#ppp account username test1@v6.example.jp password test1pass
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#no ip address
NXR_A(config-ppp)#no ppp ipcp enable
NXR_A(config-ppp)#ppp ipv6cp enable
NXR_A(config-ppp)#ipv6 dhcp client pd dhcpv6pd
NXR_A(config-ppp)#ipv6 address dhcpv6pd ::1/64
NXR_A(config-ppp)#ipv6 access-group in ppp0_in
NXR_A(config-ppp)#ipv6 spi-filter
NXR_A(config-ppp)#ipv6 tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test1@v6.example.jp
NXR_A(config-ppp)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#exit
NXR_A(config)#l2tpv3 hostname nxra
NXR_A(config)#l2tpv3 router-id 172.20.10.1
NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B
NXR_A(config-l2tpv3-tunnel)#tunnel address 2001:0db8:2:1::1
NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A(config-l2tpv3-tunnel)#exit
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1
NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#retry-interval 30
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A(config-l2tpv3-xconnect)#exit
NXR_A(config)#exit
NXR_A#save config

〔NXR_Bの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.2/24
NXR_B(config-if)#exit
NXR_B(config)#ipv6 route ::/0 ppp 0
NXR_B(config)#ipv6 access-list ppp0_in permit any any udp any 546
NXR_B(config)#ipv6 access-list ppp0_in permit 2001:0db8:1:1::1 2001:0db8:2:1::1 115
NXR_B(config)#ppp account username test2@v6.example.jp password test2pass
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#no ip address
NXR_B(config-ppp)#no ppp ipcp enable
NXR_B(config-ppp)#ppp ipv6cp enable
NXR_B(config-ppp)#ipv6 dhcp client pd dhcpv6pd
NXR_B(config-ppp)#ipv6 address dhcpv6pd ::1/64
NXR_B(config-ppp)#ipv6 access-group in ppp0_in
NXR_B(config-ppp)#ipv6 spi-filter
NXR_B(config-ppp)#ipv6 tcp adjust-mss auto
NXR_B(config-ppp)#ppp username test2@v6.example.jp
NXR_B(config-ppp)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0
NXR_B(config-if)#exit
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 172.20.20.1
NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address 2001:0db8:1:1::1
NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_B(config-l2tpv3-tunnel)#exit
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 45
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#exit
NXR_B#save config

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

 

3. <スタティックルート設定>
NXR_A(config)#ipv6 route ::/0 ppp 0

IPv6デフォルトルートを設定します。

 

4. <IPv6アクセスリスト設定>
NXR_A(config)#ipv6 access-list ppp0_in permit any any udp any 546

IPv6アクセスリスト名をppp0_inとし、宛先UDPポート546番(DHCPv6クライアント)を許可します。

NXR_A(config)#ipv6 access-list ppp0_in permit 2001:0db8:2:1::1 2001:0db8:1:1::1 115

IPv6アクセスリスト名をppp0_inとし、送信元がNXR_BのWAN側IPv6アドレス2001:0db8:2:1::1、宛先がNXR_AのWAN側IPv6アドレス2001:0db8:1:1::1宛のL2TPパケット(プロトコル番号115)を許可します。
(☞) これらIPv6アクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

5. <PPPアカウント設定>
NXR_A(config)#ppp account username test1@v6.example.jp password test1pass

ppp0インタフェースで使用するIPv6 ISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#no ip address

ppp0インタフェースのIPv4アドレスを無効に設定します。

NXR_A(config-ppp)#no ppp ipcp enable
NXR_A(config-ppp)#ppp ipv6cp enable

IPCPを無効、IPv6CPを有効に設定します。

NXR_A(config-ppp)#ipv6 dhcp client pd dhcpv6pd

DHCPv6-PD名を指定し、DHCPv6-PDを有効にします。

NXR_A(config-ppp)#ipv6 address dhcpv6pd ::1/64

ppp0インタフェースのIPv6アドレスを設定します。
(☞) DHCPv6-PDで取得したIPv6プレフィックスを使用し、プレフィックス以降は::1/64とします。

NXR_A(config-ppp)#ipv6 access-group in ppp0_in

IPv6アクセスリストppp0_inをinフィルタに適用します。

NXR_A(config-ppp)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効に設定します。

NXR_A(config-ppp)#ipv6 tcp adjust-mss auto

IPv6 TCP MSSの調整機能をオートに設定します。

NXR_A(config-ppp)#ppp username test1@v6.example.jp

IPv6 ISP接続用ユーザIDを設定します。

 

7. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

8. <L2TPv3設定>
NXR_A(config)#l2tpv3 hostname nxra
NXR_A(config)#l2tpv3 router-id 172.20.10.1

L2TPv3のホスト名としてnxraを設定します。また、ルータIDを設定します。

NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery

MACアドレス学習機能を有効にし、エージングタイムを設定します。また、Path MTU Discoveryを有効にします。

 

9. <L2TPv3トンネル設定>
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description NXR_B
NXR_A(config-l2tpv3-tunnel)#tunnel address 2001:0db8:2:1::1

L2TPv3トンネル1の説明としてNXR_B、リモートアドレスにNXR_BのWAN側IPv6アドレスを設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf

NXR_BのL2TPv3ホスト名およびルータIDを設定します。そして、ベンダIDとしてietfを設定します。
(☞) L2TPv3のホスト名とルータIDはNXR_Bと同一の値を設定します。

 

10. <L2TPv3 Xconnect設定>
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description NXR_B
NXR_A(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_B、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#retry-interval 30
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。また、リトライインターバルを設定します。そして、IPv4 TCP MSSの調整機能をオートに設定します。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.2/24

ethernet0インタフェースのIPv4アドレスを設定します。

 

3. <スタティックルート設定>
NXR_B(config)#ipv6 route ::/0 ppp 0

IPv6デフォルトルートを設定します。

 

4. <IPv6アクセスリスト設定>
NXR_B(config)#ipv6 access-list ppp0_in permit any any udp any 546

IPv6アクセスリスト名をppp0_inとし、宛先UDPポート546番(DHCPv6クライアント)を許可します。

NXR_B(config)#ipv6 access-list ppp0_in permit 2001:0db8:1:1::1 2001:0db8:2:1::1 115

IPv6アクセスリスト名をppp0_inとし、送信元がNXR_AのWAN側IPv6アドレス2001:0db8:1:1::1、宛先がNXR_BのWAN側IPv6アドレス2001:0db8:2:1::1宛のL2TPパケット(プロトコル番号115)を許可します。
(☞) これらIPv6アクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

5. <PPPアカウント設定>
NXR_B(config)#ppp account username test2@v6.example.jp password test2pass

ppp0インタフェースで使用するIPv6 ISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#no ip address

ppp0インタフェースのIPv4アドレスを無効に設定します。

NXR_B(config-ppp)#no ppp ipcp enable
NXR_B(config-ppp)#ppp ipv6cp enable

IPCPを無効、IPv6CPを有効に設定します。

NXR_B(config-ppp)#ipv6 dhcp client pd dhcpv6pd

DHCPv6-PD名を指定し、DHCPv6-PDを有効にします。

NXR_B(config-ppp)#ipv6 address dhcpv6pd ::1/64

ppp0インタフェースのIPv6アドレスを設定します。
(☞) DHCPv6-PDで取得したIPv6プレフィックスを使用し、プレフィックス以降は::1/64とします。

NXR_B(config-ppp)#ipv6 access-group in ppp0_in
NXR_B(config-ppp)#ipv6 spi-filter

IPv6アクセスリストppp0_inをinフィルタに適用し、IPv6ステートフルパケットインスペクションを有効に設定します。

NXR_B(config-ppp)#ipv6 tcp adjust-mss auto

IPv6 TCP MSSの調整機能をオートに設定します。

NXR_B(config-ppp)#ppp username test2@v6.example.jp

IPv6 ISP接続用ユーザIDを設定します。

 

7. <ethernet1インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

8. <L2TPv3設定>
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 172.20.20.1

L2TPv3のホスト名としてnxrbを設定します。また、ルータIDを設定します。

NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery

MACアドレス学習機能を有効にし、エージングタイムを設定します。また、Path MTU Discoveryを有効にします。

 

9. <L2TPv3トンネル設定>
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A
NXR_B(config-l2tpv3-tunnel)#tunnel address 2001:0db8:1:1::1

L2TPv3トンネル1の説明としてNXR_A、リモートアドレスにNXR_AのWAN側IPv6アドレスを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf

NXR_AのL2TPv3ホスト名およびルータIDを設定します。そして、ベンダIDとしてietfを設定します。
(☞) L2TPv3のホスト名とルータIDはNXR_Aと同一の値を設定します。

 

10. <L2TPv3 Xconnect設定>
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A
NXR_B(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_A、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 45
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。また、リトライインターバルを設定します。そして、IPv4 TCP MSSの調整機能をオートに設定します。

 

【 端末の設定例 】

LAN_Aの端末 LAN_Bの端末
IPv4アドレス 192.168.10.101 192.168.10.102
サブネットマスク 255.255.255.0