FutureNet

NXR,WXRシリーズ

IPv6編

9. transix IPv4接続(DS-Lite)接続設定

9-4. transix IPv4接続(DS-Lite)+IPv4 PPPoE接続設定1

transix IPv4接続(DS-Lite)とIPv4 PPPoEを組み合わせた設定例です。この例では、IPv4 PPPoEを組み合わせることで、transix IPv4接続(DS-Lite)環境のみではできないIPv4アドレスを使った外部へのサーバ公開を行います。

 

【対象機種】NXR-1300シリーズ,NXR-650,NXR-530,NXR-G180/L-CA,NXR-G200シリーズ,NXR-G110シリーズ,NXR-G100シリーズ

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • この設定例は、フレッツ光ネクストでひかり電話契約なしの場合を想定しています。その場合、IPv6プレフィックスはRAで、IPv6DNSサーバアドレスはDHCPv6で取得します。
  • ルータ配下の端末にはIPv6プレフィックスはRAで、DNSサーバアドレスはDHCPv6で広告します。またIPv4アドレスはDHCPで配布します。(WWWサーバは除く)
  • IPv4アドレスでWWWサーバを外部へ公開するためにPPPoE接続を行います。またWWWサーバ用の経路をポリシーベースルーティングで設定します。

 

【 設定例 】

nxrg240#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg240(config)#ipv6 dhcp-client ipv6dhcpc
nxrg240(config-dhcp6c)#information-only enable
nxrg240(config-dhcp6c)#option-request dns-servers
nxrg240(config-dhcp6c)#exit
nxrg240(config)#ipv6 dhcp-server ipv6dhcps
nxrg240(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1
nxrg240(config-dhcp6s)#exit
nxrg240(config)#ip policy access-list ppp0_pbr_out 192.168.10.10 any
nxrg240(config)#route-map pbr permit 1
nxrg240(config-route-map)#match ip address ppp0_pbr_out
nxrg240(config-route-map)#set interface ppp 0
nxrg240(config-route-map)#exit
nxrg240(config)#ip route 0.0.0.0/0 tunnel 1
nxrg240(config)#ip dnat ppp0_dnat tcp any any 192.0.2.1 80 192.168.10.10
nxrg240(config)#ip access-list ppp0_forward-in permit any 192.168.10.10 tcp any 80
nxrg240(config)#ipv6 access-list eth1_in permit any any icmpv6
nxrg240(config)#ipv6 access-list eth1_in permit any any udp any 546
nxrg240(config)#ipv6 access-list eth1_in permit any any 4
nxrg240(config)#interface ethernet 0
nxrg240(config-if)#ip address 192.168.10.1/24
nxrg240(config-if)#ipv6 address autoconfig
nxrg240(config-if)#ipv6 nd send-ra
nxrg240(config-if)#ipv6 nd other-config-flag
nxrg240(config-if)#ipv6 dhcp server ipv6dhcps
nxrg240(config-if)#ip policy route-map pbr
nxrg240(config-if)#exit
nxrg240(config)#dhcp-server 1
nxrg240(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg240(config-dhcps)#gateway 192.168.10.1
nxrg240(config-dhcps)#dns-server 192.168.10.1
nxrg240(config-dhcps)#exit
nxrg240(config)#ppp account username test1@example.jp password test1pass
nxrg240(config)#interface ppp 0
nxrg240(config-ppp)#ip address 192.0.2.1/32
nxrg240(config-ppp)#ip dnat-group ppp0_dnat
nxrg240(config-ppp)#ip access-group forward-in ppp0_forward-in
nxrg240(config-ppp)#ip masquerade
nxrg240(config-ppp)#ip spi-filter
nxrg240(config-ppp)#ip tcp adjust-mss auto
nxrg240(config-ppp)#ppp username test1@example.jp
nxrg240(config-ppp)#exit
nxrg240(config)#interface ethernet 1
nxrg240(config-if)#no ip address
nxrg240(config-if)#ipv6 nd accept-ra proxy ethernet 0
nxrg240(config-if)#ipv6 dhcp client ipv6dhcpc
nxrg240(config-if)#ipv6 access-group in eth1_in
nxrg240(config-if)#ipv6 spi-filter
nxrg240(config-if)#pppoe-client ppp 0
nxrg240(config-if)#exit
nxrg240(config)#interface tunnel 1
nxrg240(config-tunnel)#tunnel mode ipipv6
nxrg240(config-tunnel)#tunnel source ethernet 0
nxrg240(config-tunnel)#tunnel destination [AFTRのFQDN]
nxrg240(config-tunnel)#ip spi-filter
nxrg240(config-tunnel)#ip tcp adjust-mss auto
nxrg240(config-tunnel)#no tunnel encap-limit
nxrg240(config-tunnel)#exit
nxrg240(config)#dns
nxrg240(config-dns)#service enable
nxrg240(config-dns)#edns-query enable
nxrg240(config-dns)#priority dhcpv6 1
nxrg240(config-dns)#priority ppp 0 2
nxrg240(config-dns)#timeout 5
nxrg240(config-dns)#exit
nxrg240(config)#fast-forwarding enable
nxrg240(config)#exit
nxrg240#save config

 

【 設定例解説 】

1. <DHCPv6クライアント設定>
nxrg240(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

nxrg240(config-dhcp6c)#information-only enable

information-only機能を有効にします。

nxrg240(config-dhcp6c)#option-request dns-servers

DHCPv6サーバに対してDNSサーバアドレスの通知を要求するように設定します。

 

2. <DHCPv6サーバ設定>
nxrg240(config)#ipv6 dhcp-server ipv6dhcps

DHCPv6サーバ設定の名前を定義します。

nxrg240(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1

DHCPv6 Reply送信時に、DNSサーバアドレスを通知するように設定します。
(☞) この設定例ではDHCPv6クライアントで取得したDNSサーバアドレスを広告します。

 

3. <IPポリシーアクセスリスト設定>
nxrg240(config)#ip policy access-list ppp0_pbr_out 192.168.10.10 any

IPポリシーアクセスリストppp0_pbr_outを以下のルールで設定します。

  • 送信元IPアドレス192.168.10.10

(☞) IPポリシーアクセスリストを設定しただけでは、ポリシーベースルーティングは機能しません。ルートマップ設定およびパケット受信インタフェースでルートマップの登録が必要になります。

 

4. <ルートマップ設定>
nxrg240(config)#route-map pbr permit 1

ルートマップ名をpbrとし、No.1のルールを作成します。

nxrg240(config-route-map)#match ip address ppp0_pbr_out

マッチ条件として、IPポリシーアクセスリストで設定したppp0_pbr_outを設定します。

nxrg240(config-route-map)#set interface ppp 0

該当条件にマッチした際のネクストホップとしてppp0を設定します。

 

5. <スタティックルート設定>
nxrg240(config)#ip route 0.0.0.0/0 tunnel 1

IPv4デフォルトルートを設定します。

 

6. <DNAT設定>
nxrg240(config)#ip dnat ppp0_dnat tcp any any 192.0.2.1 80 192.168.10.10

DNAT名ppp0_dnatを以下のルールで設定します。

  • 宛先IPアドレス192.0.2.1,宛先TCPポート番号80のパケットの宛先IPアドレスを192.168.10.10に変換

(☞) DNATを設定しただけでは、宛先IPアドレスの変換機能は有効になりません。宛先IPアドレスの変換を行うインタフェースでの登録が必要になります。

 

7. <IPv4アクセスリスト設定>
nxrg240(config)#ip access-list ppp0_forward-in permit any 192.168.10.10 tcp any 80

IPv4アクセスリストppp0_forward-inを以下のルールで設定します。

  • 宛先IPアドレス192.168.10.10,宛先TCPポート番号80を許可

(☞) IPv4アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

8. <IPv6アクセスリスト設定>
nxrg240(config)#ipv6 access-list eth1_in permit any any icmpv6
nxrg240(config)#ipv6 access-list eth1_in permit any any udp any 546
nxrg240(config)#ipv6 access-list eth1_in permit any any 4

IPv6アクセスリストeth1_inを以下のルールで設定します。

  • ICMPv6を許可
  • 宛先UDPポート546番(DHCPv6クライアント)を許可
  • IPIP(プロトコル番号4)を許可

(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

9. <LAN側(ethernet0)インタフェース設定>
nxrg240(config)#interface ethernet 0
nxrg240(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

nxrg240(config-if)#ipv6 address autoconfig

ethernet0インタフェースのIPv6アドレスを設定します。

nxrg240(config-if)#ipv6 nd send-ra

IPv6 RA(Router Advertisement)を送信するように設定します。

nxrg240(config-if)#ipv6 nd other-config-flag

RAパケットのOフラグ(other-config-flag)を設定します。

nxrg240(config-if)#ipv6 dhcp server ipv6dhcps

DHCPv6サーバ名を指定し、DHCPv6サーバを有効にします。

nxrg240(config-if)#ip policy route-map pbr

ポリシーベースルーティング用のルートマップを登録します。

 

10. <IPv4 DHCPサーバ設定>
nxrg240(config)#dhcp-server 1
nxrg240(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg240(config-dhcps)#gateway 192.168.10.1
nxrg240(config-dhcps)#dns-server 192.168.10.1

IPv4 DHCPサーバを設定します。

 

11. <PPPアカウント設定>
nxrg240(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。

 

12. <ppp0インタフェース設定>
nxrg240(config)#interface ppp 0
nxrg240(config-ppp)#ip address 192.0.2.1/32

ppp0インタフェースのIPアドレスを設定します。

nxrg240(config-ppp)#ip dnat-group ppp0_dnat

DNATグループにppp0_dnatを設定します。

nxrg240(config-ppp)#ip access-group forward-in ppp0_forward-in

IPv4アクセスグループのforward-inフィルタにIPv4アクセスリストppp0_forward-inを設定します。

nxrg240(config-ppp)#ip masquerade

IPマスカレードを有効にします。

nxrg240(config-ppp)#ip spi-filter

IPv4ステートフルパケットインスペクションを有効にします。

nxrg240(config-ppp)#ip tcp adjust-mss auto

IPv4 TCP MSSの調整機能をオートに設定します。

nxrg240(config-ppp)#ppp username test1@example.jp

ISP接続用ユーザIDを設定します。

 

13. <ethernet1インタフェース設定>
nxrg240(config)#interface ethernet 1
nxrg240(config-if)#no ip address

ethernet1インタフェースのIPv4アドレスを無効にします。

nxrg240(config-if)#ipv6 nd accept-ra proxy ethernet 0

RAプロキシを有効にします。

nxrg240(config-if)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

nxrg240(config-if)#ipv6 access-group in eth1_in

IPv6アクセスグループのinフィルタにIPv6アクセスリストeth1_inを設定します。

nxrg240(config-if)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

nxrg240(config-if)#pppoe-client ppp 0

PPPoEクライアントにppp0を設定します。

 

14. <トンネル1インタフェース設定>
nxrg240(config)#interface tunnel 1
nxrg240(config-tunnel)#tunnel mode ipipv6

トンネル1インタフェースのトンネルモードをipipv6に設定します。

nxrg240(config-tunnel)#tunnel source ethernet 0

トンネルの送信元にethernet0インタフェースを設定します。

nxrg240(config-tunnel)#tunnel destination [AFTRのFQDN]

トンネルの宛先にAFTR(Address Family Transition Router)のFQDNを設定します。
(☞) AFTRにはIPv6アドレスを設定することも可能です。

nxrg240(config-tunnel)#ip spi-filter

IPv4ステートフルパケットインスペクションを有効にします。

nxrg240(config-tunnel)#ip tcp adjust-mss auto

IPv4 TCP MSSの調整機能をオートに設定します。

nxrg240(config-tunnel)#no tunnel encap-limit

encap-limit設定を無効にします。

 

15. <DNS設定>
nxrg240(config)#dns
nxrg240(config-dns)#service enable

DNSサービスを有効にします。

nxrg240(config-dns)#edns-query enable

EDNSを有効にします。

nxrg240(config-dns)#priority dhcpv6 1
nxrg240(config-dns)#priority ppp 0 2

DNSサーバの優先度を変更します。DHCPv6で取得したDNSサーバアドレスを、ppp0で取得したDNSサーバアドレスよりも優先するように設定します。

nxrg240(config-dns)#timeout 5

タイムアウト時間を設定します。

 

16. <ファストフォワーディング設定>
nxrg240(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

 

17. <設定の保存>
nxrg240#save config

設定内容を保存します。

 

【 端末の設定例 】

IPv4 アドレス DHCPサーバから自動取得
サブネットマスク
デフォルトゲートウェイ
DNSサーバアドレス
IPv6 プレフィックス ルータからRAで取得
アドレス プレフィックス情報を元に自動生成
デフォルトゲートウェイ ルータからRAで取得
DNSサーバアドレス ルータからDHCPv6で取得

 

【 付録 】