FutureNet

NXR,WXRシリーズ

IPv6編

9. transix IPv4接続(DS-Lite)接続設定

9-2. transix IPv4接続(DS-Lite)接続設定2

IPv4 over IPv6を利用してIPv4通信を可能にするtransix IPv4接続(DS-Lite)の設定例です。この設定例では、フレッツ光ネクストでひかり電話契約ありの場合を想定しています。また、ルータはホームゲートウェイ(以下HGW)配下に接続します。

 

【対象機種】NXR-1300シリーズ,NXR-650,NXR-530,NXR-G180/L-CA,NXR-G200シリーズ,NXR-G110シリーズ,NXR-G100シリーズ

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

fnw_ipv6_dslite_2

 

  • フレッツ光ネクストでひかり電話契約があり、HGW配下にルータを接続する場合、IPv6プレフィックスはRA・DHCPv6で、DNSサーバアドレスはDHCPv6で取得します。
    ※この例は、RAプロキシを使用していません。一部機種・バージョンではHGW配下にルータを接続する構成でもRAプロキシが利用可能です。
  • ルータ配下の端末にはIPv6プレフィックスはRAで、DNSサーバアドレスはDHCPv6で広告します。またIPv4アドレスはDHCPで配布します。

 

【 設定例 】

nxrg240#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg240(config)#ipv6 dhcp-client ipv6dhcpc
nxrg240(config-dhcp6c)#ia-pd dhcpv6pd
nxrg240(config-dhcp6c)#option-request dns-servers
nxrg240(config-dhcp6c)#exit
nxrg240(config)#ipv6 dhcp-server ipv6dhcps
nxrg240(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1
nxrg240(config-dhcp6s)#exit
nxrg240(config)#ip route 0.0.0.0/0 tunnel 1
nxrg240(config)#ipv6 access-list eth1_in permit any any icmpv6
nxrg240(config)#ipv6 access-list eth1_in permit any any udp any 546
nxrg240(config)#ipv6 access-list eth1_in permit any any 4
nxrg240(config)#interface ethernet 0
nxrg240(config-if)#ip address 192.168.10.1/24
nxrg240(config-if)#ipv6 address dhcpv6pd ::/64 eui-64
nxrg240(config-if)#ipv6 nd send-ra
nxrg240(config-if)#ipv6 nd other-config-flag
nxrg240(config-if)#ipv6 dhcp server ipv6dhcps
nxrg240(config-if)#exit
nxrg240(config)#dhcp-server 1
nxrg240(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg240(config-dhcps)#gateway 192.168.10.1
nxrg240(config-dhcps)#dns-server 192.168.10.1
nxrg240(config-dhcps)#exit
nxrg240(config)#interface ethernet 1
nxrg240(config-if)#ip address dhcp
nxrg240(config-if)#ipv6 address autoconfig
nxrg240(config-if)#ipv6 dhcp client ipv6dhcpc
nxrg240(config-if)#ipv6 access-group in eth1_in
nxrg240(config-if)#ipv6 spi-filter
nxrg240(config-if)#exit
nxrg240(config)#interface tunnel 1
nxrg240(config-tunnel)#tunnel mode ipipv6
nxrg240(config-tunnel)#tunnel source ethernet 1
nxrg240(config-tunnel)#tunnel destination [AFTRのFQDN]
nxrg240(config-tunnel)#ip spi-filter
nxrg240(config-tunnel)#ip tcp adjust-mss auto
nxrg240(config-tunnel)#no tunnel encap-limit
nxrg240(config-tunnel)#exit
nxrg240(config)#dns
nxrg240(config-dns)#service enable
nxrg240(config-dns)#edns-query enable
nxrg240(config-dns)#exit
nxrg240(config)#fast-forwarding enable
nxrg240(config)#exit
nxrg240#save config

 

【 設定例解説 】

1. <DHCPv6クライアント設定>
nxrg240(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

nxrg240(config-dhcp6c)#ia-pd dhcpv6pd

Identity Association for Prefix Delegation(IAPD)を有効にし、IPv6プレフィックスの名前を定義します。

nxrg240(config-dhcp6c)#option-request dns-servers

DHCPv6サーバに対してDNSサーバアドレスの通知を要求するように設定します。

 

2. <DHCPv6サーバ設定>
nxrg240(config)#ipv6 dhcp-server ipv6dhcps

DHCPv6サーバ設定の名前を定義します。

nxrg240(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1

DHCPv6 Reply送信時に、DNSサーバアドレスを通知するように設定します。
(☞) この設定例ではDHCPv6クライアントで取得したDNSサーバアドレスを広告します。

 

3. <スタティックルート設定>
nxrg240(config)#ip route 0.0.0.0/0 tunnel 1

IPv4デフォルトルートを設定します。

 

4. <IPv6アクセスリスト設定>
nxrg240(config)#ipv6 access-list eth1_in permit any any icmpv6
nxrg240(config)#ipv6 access-list eth1_in permit any any udp any 546
nxrg240(config)#ipv6 access-list eth1_in permit any any 4

IPv6アクセスリストeth1_inを以下のルールで設定します。

  • ICMPv6を許可
  • 宛先UDPポート546番(DHCPv6クライアント)を許可
  • IPIP(プロトコル番号4)を許可

(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

5. <LAN側(ethernet0)インタフェース設定>
nxrg240(config)#interface ethernet 0
nxrg240(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

nxrg240(config-if)#ipv6 address dhcpv6pd ::/64 eui-64

ethernet0インタフェースのIPv6アドレスを設定します。
(☞) プレフィックスはDHCPv6クライアントで取得したIPv6プレフィックスを使用します。またインタフェースIDはEUI-64を使用して自動生成します。

nxrg240(config-if)#ipv6 nd send-ra

IPv6 RA(Router Advertisement)を送信するように設定します。

nxrg240(config-if)#ipv6 nd other-config-flag

RAパケットのOフラグ(other-config-flag)を設定します。

nxrg240(config-if)#ipv6 dhcp server ipv6dhcps

DHCPv6サーバ名を指定し、DHCPv6サーバを有効にします。

 

6. <IPv4 DHCPサーバ設定>
nxrg240(config)#dhcp-server 1
nxrg240(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg240(config-dhcps)#gateway 192.168.10.1
nxrg240(config-dhcps)#dns-server 192.168.10.1

IPv4 DHCPサーバを設定します。

 

7. <ethernet1インタフェース設定>
nxrg240(config)#interface ethernet 1
nxrg240(config-if)#ip address dhcp

ethernet1インタフェースのIPv4アドレスをDHCPで取得します。

nxrg240(config-if)#ipv6 address autoconfig

ethernet1インタフェースのIPv6アドレスを設定します。

nxrg240(config-if)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

nxrg240(config-if)#ipv6 access-group in eth1_in

IPv6アクセスグループのinフィルタにIPv6アクセスリストeth1_inを設定します。

nxrg240(config-if)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

 

8. <トンネル1インタフェース設定>
nxrg240(config)#interface tunnel 1
nxrg240(config-tunnel)#tunnel mode ipipv6

トンネル1インタフェースのトンネルモードをipipv6に設定します。

nxrg240(config-tunnel)#tunnel source ethernet 1

トンネルの送信元にethernet1インタフェースを設定します。

nxrg240(config-tunnel)#tunnel destination [AFTRのFQDN]

トンネルの宛先にAFTR(Address Family Transition Router)のFQDNを設定します。
(☞) AFTRにはIPv6アドレスを設定することも可能です。

nxrg240(config-tunnel)#ip spi-filter

IPv4ステートフルパケットインスペクションを有効にします。

nxrg240(config-tunnel)#ip tcp adjust-mss auto

IPv4 TCP MSSの調整機能をオートに設定します。

nxrg240(config-tunnel)#no tunnel encap-limit

encap-limit設定を無効にします。

 

9. <DNS設定>
nxrg240(config)#dns
nxrg240(config-dns)#service enable

DNSサービスを有効にします。

nxrg240(config-dns)#edns-query enable

EDNSを有効にします。

 

10. <ファストフォワーディング設定>
nxrg240(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

 

11. <設定の保存>
nxrg240#save config

設定内容を保存します。

 

【 端末の設定例 】

IPv4 アドレス DHCPサーバから自動取得
サブネットマスク
デフォルトゲートウェイ
DNSサーバアドレス
IPv6 プレフィックス ルータからRAで取得
アドレス プレフィックス情報を元に自動生成
デフォルトゲートウェイ ルータからRAで取得
DNSサーバアドレス ルータからDHCPv6で取得

 

【 付録 】