FutureNet

NXR,WXRシリーズ

WANインタフェース編

2. PPPoE設定

2-2. PPPoE LAN型接続設定

NTT東日本/西日本が提供するフレッツ光ネクスト,Bフレッツ,フレッツADSLなどの回線で、PPPoE接続を行う設定例です。この例はPPPoEによるLAN型接続となり、プロバイダ等からIPアドレスを複数割り当てられるサービスで利用できます。

 

コンテンツ
構成図 設定フロー 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • LAN型接続ではPPPインタフェースに固定IPアドレスを設定します。そしてPPPインタフェースに設定したIPアドレスと同じIPアドレスをLAN側インタフェースにも設定します。これでプロバイダ等から割り当てられたIPアドレスをLAN側で使用することができます。
  • この例ではLAN型接続の設定以外に以下を設定しています。
    – ppp0インタフェースでステートフルパケットインスペクションを有効
    – 宛先IPアドレス192.0.2.2,宛先TCPポート番号80(WWWサーバ)を許可

 

【 設定フロー 】

 

【 設定例 】

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.0.2.1/29
nxrg100(config-if)#exit
nxrg100(config)#ip route 0.0.0.0/0 ppp 0
nxrg100(config)#ip access-list ppp0_forward-in permit any 192.0.2.2 tcp any 80
nxrg100(config)#ppp account username test1@example.jp password test1pass
nxrg100(config)#interface ppp 0
nxrg100(config-ppp)#ip address 192.0.2.1/32
nxrg100(config-ppp)#ip access-group forward-in ppp0_forward-in
nxrg100(config-ppp)#ip spi-filter
nxrg100(config-ppp)#ip tcp adjust-mss auto
nxrg100(config-ppp)#ppp username test1@example.jp
nxrg100(config-ppp)#exit
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#no ip address
nxrg100(config-if)#pppoe-client ppp 0
nxrg100(config-if)#exit
nxrg100(config)#dns
nxrg100(config-dns)#service enable
nxrg100(config-dns)#exit
nxrg100(config)#fast-forwarding enable
nxrg100(config)#exit
nxrg100#save config

 

【 設定例解説 】

1. <LAN側(ethernet0)インタフェース設定>
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.0.2.1/29

ethernet0インタフェースのIPアドレスを設定します。

 

2. <スタティックルート設定>
nxrg100(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

3. <IPアクセスリスト設定>
nxrg100(config)#ip access-list ppp0_forward-in permit any 192.0.2.2 tcp any 80

IPアクセスリスト名をppp0_forward-inとします。そして宛先IPアドレス192.0.2.2,宛先TCPポート番号80のパケットを許可します。
(☞) IPアクセスリストを設定しただけでは、フィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

4. <PPPアカウント設定>
nxrg100(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で指定します。

 

5. <WAN側(ppp0)インタフェース設定>
nxrg100(config)#interface ppp 0
nxrg100(config-ppp)#ip address 192.0.2.1/32

ppp0インタフェースのIPアドレスを設定します。
(☞) プロバイダ等から割り当てられたIPアドレスとは異なるIPアドレスを設定した場合でも、ユーザID,パスワード等に問題がなければPPPoE接続は可能です。そのため、PPPoEは正常に接続できているが通信できないという事象が発生した場合、設定したIPアドレスがプロバイダ等から事前に割り当てられたIPアドレスと合っているか確認してください。

nxrg100(config-ppp)#ip access-group forward-in ppp0_forward-in

IPアクセスリストppp0_forward-inをforward-inフィルタに適用します。

nxrg100(config-ppp)#ip spi-filter
nxrg100(config-ppp)#ip tcp adjust-mss auto

ステートフルパケットインスペクションを有効にします。またTCP MSSの調整機能をオートに設定します。

nxrg100(config-ppp)#ppp username test1@example.jp

ISP接続用ユーザIDを設定します。
(☞) PPPアカウント設定で登録したアカウントを設定します。

 

6. <ethernet1インタフェース設定>
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#no ip address
nxrg100(config-if)#pppoe-client ppp 0

PPPoEクライアントを設定します。また使用するPPPインタフェースとしてppp0を指定します。

 

7. <DNS設定>
nxrg100(config)#dns
nxrg100(config-dns)#service enable

DNSサービスを有効にします。

 

8. <ファストフォワーディング設定>
nxrg100(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを有効にすることでパケット転送を高速に処理することができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 端末の設定例 】

IPアドレス 192.0.0.2
サブネットマスク 255.255.255.248
デフォルトゲートウェイ 192.0.0.1
DNSサーバアドレス

 

【 付録 】