FutureNet

NXR,WXRシリーズ

L2TPv3編

3. L2TPv3冗長化設定

3-1. L2TPv3グループ機能設定

センタ側(ルータ2台,WAN各1回線)、拠点側(ルータ1台,WAN1回線)という構成で冗長化する設定例です。メインのVPN回線や機器障害時は自動的にバックアップのVPN回線に切り替えて通信を継続できます。

 

【 構成図 】

<プライマリセッションアクティブ時>

<プライマリセッション障害、セカンダリセッションアクティブ時>

<プライマリセッション復旧、セカンダリセッションアクティブ時>

  • ルータNXR_A1,A2ではKnown Unicast送信機能を有効に設定します。これによりXconnectインタフェースより受信したユニキャストフレームの宛先MACアドレスが、L2TPv3ローカルMACテーブルに存在する場合でもセッション側へフレームを転送できるようになります。なおルータNXR_A1,A2はXconnectインタフェース側でLAN_Bから送信されたフレームを受信してしまう場合があります。よってこの設定を行わない場合、L2TPv3ローカルMAC テーブルに登録された該当MAC アドレスが削除される(エージングタイマが切れる)まで通信できない場合があります。
  • ルータNXR_BではL2TPv3グループ機能を設定します。これによりL2TPv3セッションの二重化が可能になります。なおこの設定例ではL2TPv3グループ機能のpreemptモードは無効に設定します。これによりセカンダリセッションがアクティブセッションとなっている状態でプライマリセッションが確立した場合、セカンダリセッションがアクティブな状態を維持し続けるようになります。
  • ルータNXR_BではL2TPv3 MAC Advertiseフレーム送信機能を有効にします。この機能はローカルテーブルに登録されているMACアドレス情報を元に疑似フレームを送信し、LAN_A側ルータ配下にあるスイッチのMACテーブルを更新します。この結果、設定前と比較してより早くLAN_A側にある端末から通信が可能になります。
  • この設定例ではLAN_A側からのインターネットアクセスの冗長化は考慮しておりません。

 

【 設定データ 】

〔NXR_A1の設定〕

設定項目 設定内容
ホスト名 NXR_A1
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 10.10.10.1/32
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
TCP MSS調整 オート
ISP接続用ユーザID test1@example.jp
ISP接続用パスワード test1pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in 動作 許可
送信元IPアドレス any
宛先IPアドレス 10.10.10.1
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxra1
ルータID 172.20.10.1
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
loop-detect 無効
send-known-unicast 有効
L2TPv3トンネル1 名前 NXR_B
リモートホスト名 nxrb
リモートルータID 172.20.20.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_B
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
TCP MSS調整 オート
send-known-unicast 有効
DNS サービス 有効
FastFowarding 有効
L2TPv3 FastFowarding 有効

〔NXR_A2の設定〕

設定項目 設定内容
ホスト名 NXR_A2
LAN側インタフェース ethernet0のIPアドレス 192.168.10.2/24
WAN側インタフェース ethernet1のIPアドレス 10.10.20.1/30
IPマスカレード 有効
IPアクセスグループ in eth1_in
SPIフィルタ 有効
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(IPアドレス) 10.10.20.2
IPフィルタ ルール名 eth1_in
eth1_in 動作 許可
送信元IPアドレス any
宛先IPアドレス 10.10.20.1
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxra2
ルータID 172.20.10.2
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
loop-detect 無効
send-known-unicast 有効
L2TPv3トンネル1 名前 NXR_B
リモートホスト名 nxrb
リモートルータID 172.20.20.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_B
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
TCP MSS調整 オート
send-known-unicast 有効
DNS サービス 有効
FastFowarding 有効
L2TPv3 FastFowarding 有効

〔NXR_Bの設定〕

設定項目 設定内容
ホスト名 NXR_B
LAN側インタフェース ethernet0のIPアドレス 192.168.10.3/24
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
TCP MSS調整 オート
ISP接続用ユーザID test3@example.jp
ISP接続用パスワード test3pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in No.1 動作 許可
送信元IPアドレス 10.10.10.1
宛先IPアドレス any
プロトコル 115(L2TP)
No.2 動作 許可
送信元IPアドレス 10.10.20.1
宛先IPアドレス any
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxrb
ルータID 172.20.20.1
MACアドレス学習機能 有効(always)
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 NXR_A1
リモートトンネルアドレス 10.10.10.1
リモートホスト名 nxra1
リモートルータID 172.20.10.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_A1
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 30秒
TCP MSS調整 オート
L2TPv3トンネル2 名前 NXR_A2
リモートトンネルアドレス 10.10.20.1
リモートホスト名 nxra2
リモートルータID 172.20.10.2
リモートベンダーID ietf
L2TPv3 Xconnect2 名前 NXR_A2
L2TPv3トンネルID 2
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 30秒
TCP MSS調整 オート
L2TPv3グループ1 Xconnect プライマリ 1
セカンダリ 2
プリエンプト 無効
MACアドバタイズ 有効
DNS サービス 有効
FastFowarding 有効
L2TPv3 FastFowarding 有効

 

【 設定例 】

〔NXR_A1の設定〕

nxr350#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr350(config)#hostname NXR_A1
NXR_A1(config)#interface ethernet 0
NXR_A1(config-if)#ip address 192.168.10.1/24
NXR_A1(config-if)#exit
NXR_A1(config)#ip route 0.0.0.0/0 ppp 0
NXR_A1(config)#ip access-list ppp0_in permit any 10.10.10.1 115
NXR_A1(config)#ppp account username test1@example.jp password test1pass
NXR_A1(config)#interface ppp 0
NXR_A1(config-ppp)#ip address 10.10.10.1/32
NXR_A1(config-ppp)#ip masquerade
NXR_A1(config-ppp)#ip access-group in ppp0_in
NXR_A1(config-ppp)#ip spi-filter
NXR_A1(config-ppp)#ip tcp adjust-mss auto
NXR_A1(config-ppp)#ppp username test1@example.jp
NXR_A1(config-ppp)#exit
NXR_A1(config)#interface ethernet 1
NXR_A1(config-if)#no ip address
NXR_A1(config-if)#pppoe-client ppp 0
NXR_A1(config-if)#exit
NXR_A1(config)#l2tpv3 hostname nxra1
NXR_A1(config)#l2tpv3 router-id 172.20.10.1
NXR_A1(config)#l2tpv3 mac-learning
NXR_A1(config)#l2tpv3 mac-aging 300
NXR_A1(config)#l2tpv3 path-mtu-discovery
NXR_A1(config)#no l2tpv3 loop-detect
NXR_A1(config)#l2tpv3 send-known-unicast
NXR_A1(config)#l2tpv3 tunnel 1
NXR_A1(config-l2tpv3-tunnel)#description NXR_B
NXR_A1(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A1(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
NXR_A1(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A1(config-l2tpv3-tunnel)#exit
NXR_A1(config)#l2tpv3 xconnect 1
NXR_A1(config-l2tpv3-xconnect)#description NXR_B
NXR_A1(config-l2tpv3-xconnect)#tunnel 1
NXR_A1(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A1(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A1(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A1(config-l2tpv3-xconnect)#send-known-unicast enable
NXR_A1(config-l2tpv3-xconnect)#exit
NXR_A1(config)#dns
NXR_A1(config-dns)#service enable
NXR_A1(config-dns)#exit
NXR_A1(config)#fast-forwarding enable
NXR_A1(config)#l2tpv3 fast-forwarding enable
NXR_A1(config)#exit
NXR_A1#save config

〔NXR_A2の設定〕

nxr350#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr350(config)#hostname NXR_A2
NXR_A2(config)#interface ethernet 0
NXR_A2(config-if)#ip address 192.168.10.2/24
NXR_A2(config-if)#exit
NXR_A2(config)#ip route 0.0.0.0/0 10.10.20.2
NXR_A2(config)#ip access-list eth1_in permit any 10.10.20.1 115
NXR_A2(config)#interface ethernet 1
NXR_A2(config-if)#ip address 10.10.20.1/30
NXR_A2(config-if)#ip masquerade
NXR_A2(config-if)#ip access-group in eth1_in
NXR_A2(config-if)#ip spi-filter
NXR_A2(config-if)#exit
NXR_A2(config)#l2tpv3 hostname nxra2
NXR_A2(config)#l2tpv3 router-id 172.20.10.2
NXR_A2(config)#l2tpv3 mac-learning
NXR_A2(config)#l2tpv3 mac-aging 300
NXR_A2(config)#l2tpv3 path-mtu-discovery
NXR_A2(config)#no l2tpv3 loop-detect
NXR_A2(config)#l2tpv3 send-known-unicast
NXR_A2(config)#l2tpv3 tunnel 1
NXR_A2(config-l2tpv3-tunnel)#description NXR_B
NXR_A2(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A2(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
NXR_A2(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A2(config-l2tpv3-tunnel)#exit
NXR_A2(config)#l2tpv3 xconnect 1
NXR_A2(config-l2tpv3-xconnect)#description NXR_B
NXR_A2(config-l2tpv3-xconnect)#tunnel 1
NXR_A2(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A2(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A2(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A2(config-l2tpv3-xconnect)#send-known-unicast enable
NXR_A2(config-l2tpv3-xconnect)#exit
NXR_A2(config)#dns
NXR_A2(config-dns)#service enable
NXR_A2(config-dns)#exit
NXR_A2(config)#fast-forwarding enable
NXR_A2(config)#l2tpv3 fast-forwarding enable
NXR_A2(config)#exit
NXR_A2#save config

〔NXR_Bの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.3/24
NXR_B(config-if)#exit
NXR_B(config)#ip route 0.0.0.0/0 ppp 0
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any 115
NXR_B(config)#ip access-list ppp0_in permit 10.10.20.1 any 115
NXR_B(config)#ppp account username test3@example.jp password test3pass
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated
NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ppp username test3@example.jp
NXR_B(config-ppp)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0
NXR_B(config-if)#exit
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 172.20.20.1
NXR_B(config)#l2tpv3 mac-learning always
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery enable
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A1
NXR_B(config-l2tpv3-tunnel)#tunnel address 10.10.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra1
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_B(config-l2tpv3-tunnel)#exit
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A1
NXR_B(config-l2tpv3-xconnect)#tunnel 1
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#l2tpv3 tunnel 2
NXR_B(config-l2tpv3-tunnel)#description NXR_A2
NXR_B(config-l2tpv3-tunnel)#tunnel address 10.10.20.1
NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra2
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.2
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_B(config-l2tpv3-tunnel)#exit
NXR_B(config)#l2tpv3 xconnect 2
NXR_B(config-l2tpv3-xconnect)#description NXR_A2
NXR_B(config-l2tpv3-xconnect)#tunnel 2
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#l2tpv3 group 1
NXR_B(config-l2tpv3-group)#xconnect 1 2
NXR_B(config-l2tpv3-group)#no preempt enable
NXR_B(config-l2tpv3-group)#mac-advertise enable
NXR_B(config-l2tpv3-group)#exit
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#exit
NXR_B(config)#fast-forwarding enable
NXR_B(config)#l2tpv3 fast-forwarding enable
NXR_B(config)#exit
NXR_B#save config

 

【 設定例解説 】

〔NXR_A1の設定〕

1. <ホスト名の設定>
nxr350(config)#hostname NXR_A1

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A1(config)#interface ethernet 0
NXR_A1(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_A1(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_A1(config)#ip access-list ppp0_in permit any 10.10.10.1 115

IPアクセスリスト名をppp0_inとし、ルータNXR_A1のWAN側IPアドレス10.10.10.1宛のL2TPパケット(プロトコル番号115)を許可します。
なおこのIPアクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

5. <PPPアカウント設定>
NXR_A1(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_A1(config)#interface ppp 0
NXR_A1(config-ppp)#ip address 10.10.10.1/32

ppp0インタフェースのIPアドレスを設定します。

NXR_A1(config-ppp)#ip masquerade
NXR_A1(config-ppp)#ip access-group in ppp0_in
NXR_A1(config-ppp)#ip spi-filter
NXR_A1(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またIPアクセスリストppp0_inをinフィルタに適用します。そしてTCP MSSの調整機能をオートに設定します。

NXR_A1(config-ppp)#ppp username test1@example.jp

ISP接続用ユーザIDを設定します。

 

7. <ethernet1インタフェース設定>
NXR_A1(config)#interface ethernet 1
NXR_A1(config-if)#no ip address
NXR_A1(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

8. <L2TPv3設定>
NXR_A1(config)#l2tpv3 hostname nxra1
NXR_A1(config)#l2tpv3 router-id 172.20.10.1

L2TPv3のホスト名としてnxra1を設定します。またルータIDを設定します。

NXR_A1(config)#l2tpv3 mac-learning
NXR_A1(config)#l2tpv3 mac-aging 300
NXR_A1(config)#l2tpv3 path-mtu-discovery

MACアドレス学習機能を有効にし、エージングタイムを設定します。またPath MTU Discoveryを有効にします。

NXR_A1(config)#no l2tpv3 loop-detect

LoopDetect機能を無効に設定します。(デフォルト値は無効です)

NXR_A1(config)#l2tpv3 send-known-unicast

Known Unicast送信機能を有効に設定します。
これにより、Xconnectインタフェースで受信したユニキャストフレームの宛先MACアドレスがL2TPv3ローカルMACテーブルに存在する場合でも、セッション側へフレームを転送します。
(☞) Known Unicast送信機能は、本設定とL2TPv3 Xconnect設定のsend-known-unicast enableの両方が設定された時に初めて有効となります。
(☞) Known Unicastフレームとは、MACアドレス学習済みのユニキャストフレームです。

 

9. <L2TPv3トンネル設定>
NXR_A1(config)#l2tpv3 tunnel 1
NXR_A1(config-l2tpv3-tunnel)#description NXR_B

L2TPv3トンネル1の説明としてNXR_Bを設定します。なおルータNXR_BのWAN側IPアドレスが動的IPアドレスのため、リモートトンネルアドレスは設定しません。

NXR_A1(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A1(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
NXR_A1(config-l2tpv3-tunnel)#tunnel vendor ietf

ルータNXR_BのL2TPv3ホスト名およびルータIDを設定します。そしてベンダIDとしてietfを設定します。
(☞) ルータNXR_BのL2TPv3設定にあるホスト名,ルータIDと同一の値を設定します。

 

10. <L2TPv3 Xconnect設定>
NXR_A1(config)#l2tpv3 xconnect 1
NXR_A1(config-l2tpv3-xconnect)#description NXR_B
NXR_A1(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_B、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_A1(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A1(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A1(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。またTCP MSSの調整機能をオートに設定します。

NXR_A1(config-l2tpv3-xconnect)#send-known-unicast enable

Known Unicast送信機能を有効に設定します。
(☞) この設定を有効にするには、L2TPv3設定のsend-known-unicastコマンドも設定する必要があります。

 

11. <DNS設定>
NXR_A1(config)#dns
NXR_A1(config-dns)#service enable

DNSサービスを有効にします。

 

12. <ファストフォワーディングの有効化>
NXR_A1(config)#fast-forwarding enable
NXR_A1(config)#l2tpv3 fast-forwarding enable

ファストフォワーディングおよびL2TPv3ファストフォワーディングを有効にします。
(☞) ファストフォワーディングおよびL2TPv3ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

〔NXR_A2の設定〕

1. <ホスト名の設定>
nxr350(config)#hostname NXR_A2

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A2(config)#interface ethernet 0
NXR_A2(config-if)#ip address 192.168.10.2/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_A2(config)#ip route 0.0.0.0/0 10.10.20.2

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_A2(config)#ip access-list eth1_in permit any 10.10.20.1 115

IPアクセスリスト名をeth1_inとし、ルータNXR_A2のWAN側IPアドレス10.10.20.1宛のL2TPパケット(プロトコル番号115)を許可します。
なおこのIPアクセスリスト設定はeth1インタフェース設定で登録します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

5. <WAN側(ethernet1)インタフェース設定>
NXR_A2(config)#interface ethernet 1
NXR_A2(config-if)#ip address 10.10.20.1/30

ethernet1インタフェースのIPアドレスを設定します。

NXR_A2(config-if)#ip masquerade
NXR_A2(config-if)#ip access-group in eth1_in
NXR_A2(config-if)#ip spi-filter

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またIPアクセスリストeth1_inをinフィルタに適用します。

 

6. <L2TPv3設定>
NXR_A2(config)#l2tpv3 hostname nxra2
NXR_A2(config)#l2tpv3 router-id 172.20.10.2

L2TPv3のホスト名としてnxra2を設定します。またルータIDを設定します。

NXR_A2(config)#l2tpv3 mac-learning
NXR_A2(config)#l2tpv3 mac-aging 300
NXR_A2(config)#l2tpv3 path-mtu-discovery

MACアドレス学習機能を有効にし、エージングタイムを設定します。またPath MTU Discoveryを有効にします。

NXR_A2(config)#no l2tpv3 loop-detect
NXR_A2(config)#l2tpv3 send-known-unicast

LoopDetect機能を無効に設定します。またKnown Unicast送信機能を有効に設定します。

 

7. <L2TPv3トンネル設定>
NXR_A2(config)#l2tpv3 tunnel 1
NXR_A2(config-l2tpv3-tunnel)#description NXR_B

L2TPv3トンネル1の説明としてNXR_Bを設定します。なおルータNXR_BのWAN側IPアドレスが動的IPアドレスのため、リモートトンネルアドレスは設定しません。

NXR_A2(config-l2tpv3-tunnel)#tunnel hostname nxrb
NXR_A2(config-l2tpv3-tunnel)#tunnel router-id 172.20.30.1
NXR_A2(config-l2tpv3-tunnel)#tunnel vendor ietf

ルータNXR_BのL2TPv3ホスト名およびルータIDを設定します。そしてベンダIDとしてietfを設定します。
(☞) ルータNXR_BのL2TPv3設定にあるホスト名,ルータIDと同一の値を設定します。

 

8. <L2TPv3 Xconnect設定>
NXR_A2(config)#l2tpv3 xconnect 1
NXR_A2(config-l2tpv3-xconnect)#description NXR_B
NXR_A2(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_B、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_A2(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A2(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A2(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A2(config-l2tpv3-xconnect)#send-known-unicast enable

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。またTCP MSSの調整機能をオートに設定します。そしてKnown Unicast送信機能を有効に設定します。

 

9. <DNS設定>
NXR_A2(config)#dns
NXR_A2(config-dns)#service enable

DNSサービスを有効にします。

 

10. <ファストフォワーディングの有効化>
NXR_A2(config)#fast-forwarding enable
NXR_A2(config)#l2tpv3 fast-forwarding enable

ファストフォワーディングおよびL2TPv3ファストフォワーディングを有効にします。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.3/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_B(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any 115
NXR_B(config)#ip access-list ppp0_in permit 10.10.20.1 any 115

IPアクセスリスト名をppp0_inとし、送信元がルータNXR_A1のWAN側IPアドレス10.10.10.1、ルータNXR_A2のWAN側IPアドレス10.10.20.1のL2TPパケット(プロトコル番号115)を許可します。
なおこのIPアクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

5. <PPPアカウント設定>
NXR_B(config)#ppp account username test3@example.jp password test3pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスが動的IPアドレスの場合は、negotiatedを設定します。

NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またIPアクセスリストppp0_inをinフィルタに適用します。そしてTCP MSSの調整機能をオートに設定します。

NXR_B(config-ppp)#ppp username test3@example.jp

ISP接続用ユーザIDを設定します。

 

7. <ethernet1インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

8. <L2TPv3設定>
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 172.20.20.1

L2TPv3のホスト名としてnxrbを設定します。またルータIDを設定します。

NXR_B(config)#l2tpv3 mac-learning always
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery enable

MACアドレス学習機能を有効(always)にし、エージングタイムを設定します。またPath MTU Discoveryを有効にします。
(☞) MACアドレス学習機能でalwaysを指定すると、L2TPセッションが1つも確立していない場合でも、ローカルテーブルでMACアドレスを学習するようになります。

 

9. <L2TPv3トンネル1設定>
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description NXR_A1
NXR_B(config-l2tpv3-tunnel)#tunnel address 10.10.10.1

L2TPv3トンネル1の説明としてNXR_A1、リモートアドレスにルータNXR_A1のWAN側IPアドレスを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra1
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf

ルータNXR_A1のL2TPv3ホスト名およびルータIDを設定します。そしてベンダIDとしてietfを設定します。
(☞) ルータNXR_A1のL2TPv3設定にあるホスト名,ルータIDと同一の値を設定します。

 

10. <L2TPv3 Xconnect1設定>
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description NXR_A1
NXR_B(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_A1、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。またリトライインターバルを設定します。そしてTCP MSSの調整機能をオートに設定します。

 

11. <L2TPv3トンネル2設定>
NXR_B(config)#l2tpv3 tunnel 2
NXR_B(config-l2tpv3-tunnel)#description NXR_A2
NXR_B(config-l2tpv3-tunnel)#tunnel address 10.10.20.1

L2TPv3トンネル2の説明としてNXR_A2、リモートアドレスにルータNXR_A2のWAN側IPアドレスを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel hostname nxra2
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.2
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf

ルータNXR_A2のL2TPv3ホスト名およびルータIDを設定します。そしてベンダIDとしてietfを設定します。
(☞) ルータNXR_A2のL2TPv3設定にあるホスト名,ルータIDと同一の値を設定します。

 

12. <L2TPv3 Xconnect2設定>
NXR_B(config)#l2tpv3 xconnect 2
NXR_B(config-l2tpv3-xconnect)#description NXR_A2
NXR_B(config-l2tpv3-xconnect)#tunnel 2

L2TPv3 Xconnect2の説明としてNXR_A2、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル2を設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。またリトライインターバルを設定します。そしてTCP MSSの調整機能をオートに設定します。

 

13. <L2TPv3グループ設定>
NXR_B(config)#l2tpv3 group 1

L2TPv3グループ1を設定します。

NXR_B(config-l2tpv3-group)#xconnect 1 2

使用するL2TPv3 Xconnect設定をプライマリ、セカンダリの順に指定します。

NXR_B(config-l2tpv3-group)#no preempt enable

preemptモードを設定します。
(☞) これによりセカンダリセッションがアクティブセッションになっている状態でプライマリセッションが確立した場合、セカンダリセッションがアクティブな状態を維持し続けるようになります。

NXR_B(config-l2tpv3-group)#mac-advertise enable

L2TPv3 MAC Advertise Frame送信機能を有効に設定します。
(☞) この機能は対向ルータ配下にあるスイッチのMACテーブルを更新するために、ローカルテーブルに登録されているMACアドレス情報を元にした疑似フレームを送信します。
(☞) この機能を使用する場合は、L2TPv3 MAC Address学習always機能を有効(l2tpv3 mac-learning always)に設定してください。なおこの機能を使用する場合は対向装置も同機能が実装されているファームウェアを使用することを推奨します。

 

14. <DNS設定>
NXR_B(config)#dns
NXR_B(config-dns)#service enable

DNSサービスを有効にします。

 

15. <ファストフォワーディングの有効化>
NXR_B(config)#fast-forwarding enable
NXR_B(config)#l2tpv3 fast-forwarding enable

ファストフォワーディングおよびL2TPv3ファストフォワーディングを有効にします。

 

【 端末の設定例 】

LAN_Aの端末 LAN_Bの端末
IPアドレス 192.168.10.101 192.168.10.102
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.10.3
DNSサーバ

←前のページ

次のページ→