FutureNet

NXR,WXRシリーズ

無線LAN編

2. 無線LAN設定(NXR-G260シリーズ)

2-1. 無線LAN設定1

有線LANおよび無線LANセグメントからインターネットアクセスする設定例です。なお無線LANの認証方式にはWPA2-PSKを利用します。また補足1ではWPS機能について記載しています。

 

【対象機種】NXR-G260,NXR-G260/L

 

コンテンツ
構成図 設定データ 設定例 設定例解説 端末の設定例 補足1 補足2 付録

 

【 構成図 】

  • 有線LANセグメントと無線LANセグメントを別ネットワークとします。
  • 無線LANセグメントではDHCPサーバ機能でアドレス配布を行います。
  • WPS機能を利用する場合はこちら

 

【 設定データ 】

設定項目 設定内容
有線LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
無線LAN側インタフェース wlan0のIPアドレス 192.168.11.1/24
SSID nxrgwlan0
認証方式 WPA2-PSK
暗号方式 AES
パスワード nxrgwlan0pass
ANY接続 拒否しない
SSID隠蔽 しない
プライバシープロテクション 無効
接続台数制限 32台
無線モジュール(wifi0) 無線方式 11ac
チャネル オート
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
SPIフィルタ 有効
TCP MSS調整 オート
ISP接続用ユーザID test1@example.jp
ISP接続用パスワード test1pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
DHCPサーバ IPアドレス払い出し範囲(始点) 192.168.11.200
IPアドレス払い出し範囲(終点) 192.168.11.210
ゲートウェイ 192.168.11.1
プライマリDNSサーバ 192.168.11.1
DNS サービス 有効
FastFowarding 有効

【 設定例 】

nxrg260#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg260(config)#interface ethernet 0
nxrg260(config-if)#ip address 192.168.10.1/24
nxrg260(config-if)#exit
nxrg260(config)#interface wlan 0
nxrg260(config-wlan)#ip address 192.168.11.1/24
nxrg260(config-wlan)#wlan ssid nxrgwlan0
nxrg260(config-wlan)#wlan wpa-psk password nxrgwlan0pass
nxrg260(config-wlan)#wlan authenticate wpa2-psk aes
nxrg260(config-wlan)#wlan guest-mode enable
nxrg260(config-wlan)#wlan access-point-bridge enable
nxrg260(config-wlan)#wlan max-associations 32
nxrg260(config-wlan)#exit
nxrg260(config)#wifi 0
nxrg260(config-wifi)#mode 11ac
nxrg260(config-wifi)#channel auto
nxrg260(config-wifi)#exit
% Executing setup, Please Wait.
nxrg260(config)#dhcp-server 1
nxrg260(config-dhcps)#network 192.168.11.0/24 range 192.168.11.200 192.168.11.210
nxrg260(config-dhcps)#gateway 192.168.11.1
nxrg260(config-dhcps)#dns-server 192.168.11.1
nxrg260(config-dhcps)#exit
nxrg260(config)#ip route 0.0.0.0/0 ppp 0
nxrg260(config)#ppp account username test1@example.jp password test1pass
nxrg260(config)#interface ppp 0
nxrg260(config-ppp)#ip address negotiated
nxrg260(config-ppp)#ip masquerade
nxrg260(config-ppp)#ip spi-filter
nxrg260(config-ppp)#ip tcp adjust-mss auto
nxrg260(config-ppp)#ppp username test1@example.jp
nxrg260(config-ppp)#exit
nxrg260(config)#interface ethernet 1
nxrg260(config-if)#no ip address
nxrg260(config-if)#pppoe-client ppp 0
nxrg260(config-if)#exit
nxrg260(config)#dns
nxrg260(config-dns)#service enable
nxrg260(config-dns)#exit
nxrg260(config)#fast-forwarding enable
nxrg260(config)#exit
nxrg260#save config

【 設定例解説 】

1. <有線LAN側(ethernet0)インタフェース設定>
nxrg260(config)#interface ethernet 0
nxrg260(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

2. <無線LAN側(wlan0)インタフェース設定>
nxrg260(config)#interface wlan 0
nxrg260(config-wlan)#ip address 192.168.11.1/24

wlan0インタフェースのIPアドレスを設定します。

nxrg260(config-wlan)#wlan ssid nxrgwlan0

SSIDを設定します。

nxrg260(config-wlan)#wlan wpa-psk password nxrgwlan0pass

WPA-PSK認証方式で使用するパスワードを設定します。
(☞) WPA-PSK認証方式で使用するパスワードはWPA-PSKの認証方式および暗号化方式よりも先に設定する必要があります。

nxrg260(config-wlan)#wlan authenticate wpa2-psk aes

認証方式と暗号化方式を設定します。

nxrg260(config-wlan)#wlan guest-mode enable

ゲストモードを有効に設定します。
(☞) ANY接続拒否機能,ステルス機能は連動して動作するためゲストモードでの一括設定となります。

nxrg260(config-wlan)#wlan access-point-bridge enable

アクセスポイントブリッジを有効に設定します。
(☞) アクセスポイントブリッジを有効に設定することでプライバシープロテクションが無効になります。

nxrg260(config-wlan)#wlan max-associations 32

接続台数制限を設定します。

 

3. <無線モジュール(wifi0)設定>
nxrg260(config)#wifi 0

無線モジュールwifi0の設定をします。

nxrg260(config-wifi)#mode 11ac

無線方式を設定します。

nxrg260(config-wifi)#channel auto

チャネルを設定します。
(☞) modeコマンドが未設定の場合は設定することができません。
(☞) 802.11acで無線LANの通信速度を向上させたい場合はこちら

 

4. <DHCPサーバ設定>
nxrg260(config)#dhcp-server 1
nxrg260(config-dhcps)#network 192.168.11.0/24 range 192.168.11.200 192.168.11.210
nxrg260(config-dhcps)#gateway 192.168.11.1
nxrg260(config-dhcps)#dns-server 192.168.11.1

DHCPサーバのサーバナンバを1とし、配布するIPアドレス情報を設定します。
(☞) このDHCPサーバはSSID「nxrgwlan0」用となります。またwlan0インタフェースで動作します。

 

5. <スタティックルート設定>
nxrg260(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

6. <PPPアカウント設定>
nxrg260(config)#ppp account username test1@example.jp password test1pass

PPPoE接続で使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

7. <WAN側(ppp0)インタフェース設定>
nxrg260(config)#interface ppp 0
nxrg260(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスが動的IPアドレスの場合はnegotiatedを設定します。

nxrg260(config-ppp)#ip masquerade
nxrg260(config-ppp)#ip spi-filter
nxrg260(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またTCP MSSの調整機能をオートに設定します。

nxrg260(config-ppp)#ppp username test1@example.jp

PPPアカウント設定で登録したISP接続用ユーザIDを設定します。

 

8. <ethernet1インタフェース設定>
nxrg260(config)#interface ethernet 1
nxrg260(config-if)#no ip address
nxrg260(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

9. <DNS設定>
nxrg260(config)#dns
nxrg260(config-dns)#service enable

DNSサービスを有効にします。

 

10. <ファストフォワーディングの有効化>
nxrg260(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 端末の設定例 】

有線端末 無線端末
IPアドレス 192.168.10.100 DHCPサーバから取得
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1
DNSサーバ

 

【 補足1 】

NXR-G260,NXR-G260/LではWPS機能に対応しています。WPS機能を利用するためにはwlanインタフェースでwlan wps information-element enableを設定する必要があります。

<WPS設定>
nxrg260(config)#interface wlan 0
nxrg260(config-wlan)#wlan wps information-element enable

wlan0インタフェースでWPS機能を利用できるように設定します。

(☞) WPS機能を利用するためには「wlan authenticate wpa2-psk aes」の設定が必要になります。また「no wlan guest-mode enable」が設定されている場合は接続できません。
(☞) WPS機能は1つのwlanインタフェースでのみ利用することができます。よって他のwlanインタフェースですでに設定済の場合は設定することができません。

 

<WPS起動>

WPS機能を起動する方法は以下の二通りになります。

  • CLIから起動する

CLIから起動する場合はWPS機能設定後、「wps-pbc start」コマンドを実行します。

nxrg260#wps-pbc start
  • WPSボタンから起動する

WPSボタンから起動する場合は製品本体背面にあるWPSボタンを約10秒間長押しします。

nxrg260l_wps

 

 

 

 

 

【 補足2 】

802.11acで無線LANの通信速度を向上させたい場合、以下の設定を有効にします。

<クワッドチャネル設定>
(config-wifi)#quad-channel enable

クワッドチャネル設定を有効にします。
(☞) クワッドチャネル設定を変更した場合は、guard-interval、channel、speed、txpower設定が削除されます(初期設定に戻ります)。

 

<A-MPDU設定>
(config-wifi)#a-mpdu enable

A-MPDU設定を有効にします。

 

<A-MSDU設定>
(config-wifi)#a-msdu enable

A-MSDU設定を有効にします。

 

<ガードインターバル設定>
(config-wifi)#guard-interval short

ガードインターバルをshortに設定します。

 

【 付録 】