FutureNet

NXR,WXRシリーズ

無線LAN編

1. 無線LAN設定(NXR-G100シリーズ,WXR-250)

1-4. 無線LAN設定4(MACアドレスフィルタリング)

無線LAN端末(ステーション)のMACアドレス情報を元に接続制限を行う設定例です。この機能はVAP毎に設定することができます。

 

【対象機種】NXR-G100/NLW,KLW,SLW、WXR-250

 

【 構成図 】

  • wlan1インタフェースでMACアドレスフィルタリングを設定し、指定したMACアドレスの無線端末のみ通信を許可するよう設定します。

 

【 設定データ 】

設定項目 設定内容
有線LAN側インタフェース ethernet0のIPアドレス 無効
無線LAN側インタフェース wlan0 wlan0のIPアドレス 無効
動作モード アクセスポイント
SSID wxrwlan0
認証方式 WPA2-PSK
暗号方式 AES
パスワード wxrwlan0pass
ANY接続 拒否しない
SSID隠蔽 しない
プライバシープロテクション 無効
接続台数制限 32台
wlan1 wlan1のIPアドレス 192.168.11.1/24
動作モード アクセスポイント
SSID wxrwlan1
認証方式 WPA2-PSK
暗号方式 AES
パスワード wxrwlan1pass
ANY接続 拒否しない
SSID隠蔽 しない
プライバシープロテクション 無効
接続台数制限 32台
MACアクセスリスト パーミッション 許可
アドレス XX:XX:XX:XX:XX:01
無線モジュール(wifi0) 無線方式 11ng
チャネル オート
ブリッジインタフェース bridge0のIPアドレス 192.168.10.1/24
ブリッジ対象インタフェース ethernet0
wlan0
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
SPIフィルタ 有効
TCP MSS自動調整 オート
ISP接続用ユーザID test1@example.jp
ISP接続用パスワード test1pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
DHCPサーバ No.1 IPアドレス払い出し範囲(始点) 192.168.10.200
IPアドレス払い出し範囲(終点) 192.168.10.210
ゲートウェイ 192.168.10.1
プライマリDNSサーバ 192.168.10.1
No.2 IPアドレス払い出し範囲(始点) 192.168.11.200
IPアドレス払い出し範囲(終点) 192.168.11.210
ゲートウェイ 192.168.11.1
プライマリDNSサーバ 192.168.11.1
DNS サービス 有効
FastFowarding 有効

【 設定例 】

wxr250#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
wxr250(config)#interface ethernet 0
wxr250(config-if)#no ip address
wxr250(config-if)#exit
wxr250(config)#interface wlan 0
wxr250(config-wlan)#no ip address
wxr250(config-wlan)#wlan mode access-point
wxr250(config-wlan)#wlan ssid wxrwlan0
wxr250(config-wlan)#wlan wpa-psk password wxrwlan0pass
wxr250(config-wlan)#wlan authenticate wpa2-psk aes
wxr250(config-wlan)#wlan guest-mode enable
wxr250(config-wlan)#wlan access-point-bridge enable
wxr250(config-wlan)#wlan max-associations 32
wxr250(config-wlan)#exit
wxr250(config)#interface wlan 1
wxr250(config-wlan)#ip address 192.168.11.1/24
wxr250(config-wlan)#wlan mode access-point
wxr250(config-wlan)#wlan ssid wxrwlan1
wxr250(config-wlan)#wlan wpa-psk password wxrwlan1pass
wxr250(config-wlan)#wlan authenticate wpa2-psk aes
wxr250(config-wlan)#wlan guest-mode enable
wxr250(config-wlan)#wlan access-point-bridge enable
wxr250(config-wlan)#wlan max-associations 32
wxr250(config-wlan)#wlan mac access-list permission permit
wxr250(config-wlan)#wlan mac access-list address XX:XX:XX:XX:XX:01
wxr250(config-wlan)#exit
wxr250(config)#wifi 0
wxr250(config-wifi)#mode 11ng
wxr250(config-wifi)#channel auto
wxr250(config-wifi)#exit
% Executing DFS/channel auto, Please Wait.
wxr250(config)#interface bridge 0
wxr250(config-bridge)#ip address 192.168.10.1/24
wxr250(config-bridge)#bridge port 1 ethernet 0
wxr250(config-bridge)#bridge port 2 wlan 0
wxr250(config-bridge)#exit
wxr250(config)#dhcp-server 1
wxr250(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
wxr250(config-dhcps)#gateway 192.168.10.1
wxr250(config-dhcps)#dns-server 192.168.10.1
wxr250(config-dhcps)#exit
wxr250(config)#dhcp-server 2
wxr250(config-dhcps)#network 192.168.11.0/24 range 192.168.11.200 192.168.11.210
wxr250(config-dhcps)#gateway 192.168.11.1
wxr250(config-dhcps)#dns-server 192.168.11.1
wxr250(config-dhcps)#exit
wxr250(config)#ip route 0.0.0.0/0 ppp 0
wxr250(config)#ppp account username test1@example.jp password test1pass
wxr250(config)#interface ppp 0
wxr250(config-ppp)#ip address negotiated
wxr250(config-ppp)#ip masquerade
wxr250(config-ppp)#ip spi-filter
wxr250(config-ppp)#ip tcp adjust-mss auto
wxr250(config-ppp)#ppp username test1@example.jp
wxr250(config-ppp)#exit
wxr250(config)#interface ethernet 1
wxr250(config-if)#no ip address
wxr250(config-if)#pppoe-client ppp 0
wxr250(config-if)#exit
wxr250(config)#dns
wxr250(config-dns)#service enable
wxr250(config-dns)#exit
wxr250(config)#fast-forwarding enable
wxr250(config)#exit
wxr250#save config

【 設定例解説 】

1. <有線LAN側(ethernet0)インタフェース設定>
wxr250(config)#interface ethernet 0
wxr250(config-if)#no ip address

ethernet0インタフェースのIPアドレスを無効にします。

 

2. <無線LAN側(wlan0)インタフェース設定>
wxr250(config)#interface wlan 0
wxr250(config-wlan)#no ip address

wlan0インタフェースのIPアドレスを無効にします。

wxr250(config-wlan)#wlan mode access-point
wxr250(config-wlan)#wlan ssid wxrwlan0
wxr250(config-wlan)#wlan wpa-psk password wxrwlan0pass
wxr250(config-wlan)#wlan authenticate wpa2-psk aes

動作モード、SSID、WPA-PSK認証方式で使用するパスワード、認証方式と暗号方式を設定します。
(☞) 動作モードはNXR-G100/NLW,KLW,SLWでは設定することができません。(アクセスポイントのみ)

wxr250(config-wlan)#wlan guest-mode enable
wxr250(config-wlan)#wlan access-point-bridge enable
wxr250(config-wlan)#wlan max-associations 32

ゲストモード、アクセスポイントブリッジ(プライバシープロテクション)を有効に設定します。また接続台数制限を設定します。
(☞) 接続台数制限はNXR-G100/NLW,KLW,SLWでは最大7台となります。(VAP2つの場合は最大6台)

 

3. <無線LAN側(wlan1)インタフェース設定>
wxr250(config)#interface wlan 1
wxr250(config-wlan)#ip address 192.168.11.1/24

wlan1インタフェースのIPアドレスを設定します。

wxr250(config-wlan)#wlan mode access-point
wxr250(config-wlan)#wlan ssid wxrwlan1
wxr250(config-wlan)#wlan wpa-psk password wxrwlan1pass
wxr250(config-wlan)#wlan authenticate wpa2-psk aes

動作モード、SSID、WPA-PSK認証方式で使用するパスワード、認証方式と暗号方式を設定します。
(☞) 動作モードはNXR-G100/NLW,KLW,SLWでは設定することができません。(アクセスポイントのみ)

wxr250(config-wlan)#wlan guest-mode enable
wxr250(config-wlan)#wlan access-point-bridge enable
wxr250(config-wlan)#wlan max-associations 32

ゲストモード、アクセスポイントブリッジ(プライバシープロテクション)を有効に設定します。また接続台数制限を設定します。
(☞) 接続台数制限はNXR-G100/NLW,KLW,SLWでは最大7台となります。(VAP2つの場合は最大6台)

wxr250(config-wlan)#wlan mac access-list permission permit

MACアクセスリストのパーミッションを設定します。
ここではMACアドレスリストに含まれるステーションのみ接続を許可します。

wxr250(config-wlan)#wlan mac access-list address XX:XX:XX:XX:XX:01

MACアクセスリストにMACアドレスを登録します。
(☞) MACアクセスリストのパーミッションで許可を設定していますので、ここで登録するMACアドレスは接続を許可するステーションのMACアドレスとなります。

 

4. <無線モジュール(wifi0)設定>
wxr250(config)#wifi 0
wxr250(config-wifi)#mode 11ng
wxr250(config-wifi)#channel auto

無線方式、チャネルを設定します。

 

5. <bridge0インタフェース設定>
wxr250(config)#interface bridge 0
wxr250(config-bridge)#ip address 192.168.10.1/24

bridge0インタフェースのIPアドレスを設定します。

wxr250(config-bridge)#bridge port 1 ethernet 0
wxr250(config-bridge)#bridge port 2 wlan 0

ブリッジインタフェースで利用するインタフェースを設定します。

 

6. <DHCPサーバ設定>
wxr250(config)#dhcp-server 1
wxr250(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
wxr250(config-dhcps)#gateway 192.168.10.1
wxr250(config-dhcps)#dns-server 192.168.10.1

DHCPサーバのサーバナンバを1とし、配布するIPアドレス情報を設定します。
(☞) このDHCPサーバは有線LANおよびSSID「wxrwlan0」用となります。またbridge0インタフェースで動作します。

wxr250(config)#dhcp-server 2
wxr250(config-dhcps)#network 192.168.11.0/24 range 192.168.11.200 192.168.11.210
wxr250(config-dhcps)#gateway 192.168.11.1
wxr250(config-dhcps)#dns-server 192.168.11.1

DHCPサーバのサーバナンバを2とし、配布するIPアドレス情報を設定します。
(☞) このDHCPサーバはSSID「wxrwlan1」用となります。またwlan1インタフェースで動作します。

 

7. <スタティックルート設定>
wxr250(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

8. <PPPアカウント設定>
wxr250(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

9. <WAN側(ppp0)インタフェース設定>
wxr250(config)#interface ppp 0
wxr250(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスが動的IPアドレスの場合はnegotiatedを設定します。

wxr250(config-ppp)#ip masquerade
wxr250(config-ppp)#ip spi-filter
wxr250(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またTCP MSSの調整機能をオートに設定します。

wxr250(config-ppp)#ppp username test1@example.jp

ISP接続用ユーザIDを設定します。

 

10. <ethernet1インタフェース設定>
wxr250(config)#interface ethernet 1
wxr250(config-if)#no ip address
wxr250(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

11. <DNS設定>
wxr250(config)#dns
wxr250(config-dns)#service enable

DNSサービスを有効にします。

 

12. <ファストフォワーディングの有効化>
wxr250(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 端末の設定例 】

192.168.10.0/24 192.168.11.0/24
有線端末 無線端末 無線端末
IPアドレス 192.168.10.100 DHCPサーバから取得 DHCPサーバから取得
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1
DNSサーバ