FutureNet

NXR,WXRシリーズ

QoS編

1. 帯域制御設定

1-8. 帯域制御の利用(LANインタフェースでの利用)

1-6. 帯域制御の利用(PPPインタフェースでの利用)ではWANインタフェースからの出力時に帯域制御を行いましたが、この設定例ではファイルのダウンロードなどWAN→LANへの通信に対して帯域制御を行います。

 

【 構成図 】

fnw_qos_bc_008

  • 出力インタフェース(Ethernet0インタフェース)の帯域幅を100Mbpsに設定します。
  • クラス10およびデフォルトクラスを作成し、それぞれの帯域幅を出力インタフェースの帯域幅の20%,80%に設定します。
    (☞) パーセンテージはインタフェースで設定する帯域幅に対する絶対比となります。
  • Ethernet0インタフェースから送信する宛先IPアドレス192.168.10.100のパケットをクラス10に割り当てます。またそれ以外のパケットはデフォルトクラスに割り当てます。

 

【 設定データ 】

設定項目 設定内容
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
classify output qos_routemap
QoS キューイング クラスポリシ
クラスポリシ名 eth0qos
帯域幅 100Mbps(100000kbps)
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
SPIフィルタ 有効
TCP MSS調整 オート
ISP接続用ユーザID test1@example.jp
ISP接続用パスワード test1pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
クラスアクセスリスト アクセスリスト名 class_acl
class_acl 送信元IPアドレス any
宛先IPアドレス 192.168.10.100
ルートマップ ルートマップ名 qos_routemap
qos_routemap No.1 マッチIPアドレス class_acl
セット(mark) 10
クラスフィルタ クラスナンバ 10
クラス10 マッチ条件 10(mark)
クラスポリシ ポリシ名 eth0qos
eth0qos No.1 クラス 10
帯域幅 20%
No.2 クラス デフォルト
帯域幅 80%
DNS サービス 有効
FastFowarding 有効

【 設定例 】

nxr230#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr230(config)#class access-list class_acl ip any 192.168.10.100
nxr230(config)#route-map qos_routemap permit 1
nxr230(config-route-map)#match ip address class_acl
nxr230(config-route-map)#set mark 10
nxr230(config-route-map)#exit
nxr230(config)#class filter 10
nxr230(config-class-filter)#match ip mark 10
nxr230(config-class-filter)#exit
nxr230(config)#class policy eth0qos
nxr230(config-class-policy)#class 10 bandwidth percent 20
nxr230(config-class-policy)#class default bandwidth percent 80
nxr230(config-class-policy)#exit
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24
nxr230(config-if)#classify output route-map qos_routemap
nxr230(config-if)#queue policy eth0qos bandwidth 100000
nxr230(config-if)#exit
nxr230(config)#ppp account username test1@example.jp password test1pass
nxr230(config)#interface ppp 0
nxr230(config-ppp)#ip address negotiated
nxr230(config-ppp)#ip masquerade
nxr230(config-ppp)#ip spi-filter
nxr230(config-ppp)#ip tcp adjust-mss auto
nxr230(config-ppp)#ppp username test1@example.jp
nxr230(config-ppp)#exit
nxr230(config)#interface ethernet 1
nxr230(config-if)#no ip address
nxr230(config-if)#pppoe-client ppp 0
nxr230(config-if)#exit
nxr230(config)#ip route 0.0.0.0/0 ppp 0
nxr230(config)#dns
nxr230(config-dns)#service enable
nxr230(config-dns)#exit
nxr230(config)#fast-forwarding enable
nxr230(config)#exit
nxr230#save config

【 設定例解説 】

1. <クラスアクセスリスト設定>
nxr230(config)#class access-list class_acl ip any 192.168.10.100

クラスアクセスリスト名をclass_aclとし、宛先IPアドレス192.168.10.100のパケット全てが対象となるように設定します。

 

2. <ルートマップ設定>
nxr230(config)#route-map qos_routemap permit 1

ルートマップ名をqos_routemapとし、No.1のルールを作成します。

nxr230(config-route-map)#match ip address class_acl

マッチ条件としてクラスアクセスリストで設定したclass_aclを設定します。

nxr230(config-route-map)#set mark 10

該当条件にマッチした場合、マーク値10を設定します。
(☞) markはルータ内でのみ利用可能なマーキング値です。

 

3. <クラスフィルタ設定>
nxr230(config)#class filter 10
nxr230(config-class-filter)#match ip mark 10

マーク値10のパケットをクラス10に割り当てるように設定します。

 

4. <クラスポリシ設定>
nxr230(config)#class policy eth0qos

クラスポリシ名としてeth0qosを設定します。

nxr230(config-class-policy)#class 10 bandwidth percent 20

クラス10の帯域幅を設定します。
(☞) パーセンテージはインタフェースで設定する帯域幅に対する絶対比となります。

nxr230(config-class-policy)#class default bandwidth percent 80

デフォルトクラスの帯域幅を設定します。

 

5. <LAN側(ethernet0)インタフェース設定>
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

nxr230(config-if)#classify output route-map qos_routemap

パケット送信時にルートマップによるパケット分類を行うように設定します。

nxr230(config-if)#queue policy eth0qos bandwidth 100000

出力インタフェースのキューイング方式としてクラスポリシを指定し、クラスポリシ名および帯域幅を設定します。
(☞) 帯域幅の単位はkbpsになります。

 

6. <PPPアカウント設定>
nxr230(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

7. <WAN側(ppp0)インタフェース設定>
nxr230(config)#interface ppp 0
nxr230(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスを設定します。

nxr230(config-ppp)#ip masquerade
nxr230(config-ppp)#ip spi-filter
nxr230(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またTCP MSSの調整機能をオートに設定します。

nxr230(config-ppp)#ppp username test1@example.jp

ISP接続用ユーザIDを設定します。

 

8. <ethernet1インタフェース設定>
nxr230(config)#interface ethernet 1
nxr230(config-if)#no ip address
nxr230(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

9. <スタティックルート設定>
nxr230(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

10. <DNS設定>
nxr230(config)#dns
nxr230(config-dns)#service enable

DNSサービスを有効にします。

 

11. <ファストフォワーディングの有効化>
nxr230(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 端末の設定例 】

IPアドレス 192.168.10.100
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1
DNSサーバ