FutureNet

NXR,WXRシリーズ

QoS編

2. 優先制御設定

2-1. 優先制御の利用

この設定例ではQoSの優先制御機能を利用して優先度の高いパケットを出力するように設定します。

 

【 構成図 】

  • 出力インタフェース(Ethernet1インタフェース)の通信速度を契約帯域に合わせて10Mbpsに設定します。
  • Ethernet0インタフェースで受信する全てのUDPパケットにマーク値10を設定します。
  • 優先制御ではHigh,Middle,Normal,Lowの4つのクラスがあります。
  • マーク値10のパケットはHighクラスに、それ以外のパケットはNormalクラスに格納します。

 

【 設定データ 】

設定項目 設定内容
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
classify input qos_routemap
WAN側インタフェース ethernet1のIPアドレス 10.10.10.1/30
通信速度,通信モード 10M,Full
QoS キューイング プライオリティ キューイング
プライオリティマップナンバ 1
スタティックルート 宛先IPアドレス 0.0.0.0
ゲートウェイ(IPアドレス) 10.10.10.2
クラスアクセスリスト アクセスリスト名 class_acl
class_acl 送信元IPアドレス any
宛先IPアドレス any
プロトコル UDP
ルートマップ ルートマップ名 qos_routemap
qos_routemap マッチIPアドレス class_acl
セット(mark) 10
プライオリティマップ ナンバ 1
プライオリティマップ1 クラス High
マッチ条件 10(mark)
FastFowarding 有効

【 設定例 】

nxr230#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr230(config)#class access-list class_acl ip any any udp
nxr230(config)#route-map qos_routemap permit 1
nxr230(config-route-map)#match ip address class_acl
nxr230(config-route-map)#set mark 10
nxr230(config-route-map)#exit
nxr230(config)#priority-map 1 high ip mark 10
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24
nxr230(config-if)#classify input route-map qos_routemap
nxr230(config-if)#exit
nxr230(config)#interface ethernet 1
nxr230(config-if)#ip address 10.10.10.1/30
nxr230(config-if)#speed 10M-full
nxr230(config-if)#queue priority-group 1
nxr230(config-if)#exit
nxr230(config)#ip route 0.0.0.0/0 10.10.10.2
nxr230(config)#fast-forwarding enable
nxr230(config)#exit
nxr230#save config

【 設定例解説 】

1. <クラスアクセスリスト設定>
nxr230(config)#class access-list class_acl ip any any udp

クラスアクセスリスト名をclass_aclとし、UDPパケット全てが対象となるように設定します。

 

2. <ルートマップ設定>
nxr230(config)#route-map qos_routemap permit 1

ルートマップ名をqos_routemapとし、No.1のルールを作成します。

nxr230(config-route-map)#match ip address class_acl

マッチ条件としてクラスアクセスリストで設定したclass_aclを設定します。

nxr230(config-route-map)#set mark 10

該当条件にマッチした場合、マーク値10を設定します。
(☞) markはルータ内でのみ利用可能なマーキング値です。
(☞) ルートマップ設定を設定しただけではパケット分類は適切に機能しません。パケット分類を行うインタフェースでルートマップの登録が必要になります。

 

3. <プライオリティマップ設定>
nxr230(config)#priority-map 1 high ip mark 10

プライオリティマップ1を作成し、マーク値10のパケットをHighクラスに格納するように設定します。

 

4. <LAN側(ethernet0)インタフェース設定>
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

nxr230(config-if)#classify input route-map qos_routemap

パケット受信時にルートマップによるパケット分類を行うように設定します。

 

5. <WAN側(ethernet1)インタフェース設定>
nxr230(config)#interface ethernet 1
nxr230(config-if)#ip address 10.10.10.1/30

ethernet1インタフェースのIPアドレスを設定します。

nxr230(config-if)#speed 10M-full

契約帯域に合わせて通信速度を10M、通信モードをFullに設定します。

nxr230(config-if)#queue priority-group 1

出力インタフェースのキューイング方式としてPQを利用するため、プライオリティグループを設定します。
(☞) priority-groupの後ろの数字はプライオリティマップナンバを設定します。

 

6. <スタティックルート設定>
nxr230(config)#ip route 0.0.0.0/0 10.10.10.2

デフォルトルートを設定します。

 

7. <ファストフォワーディングの有効化>
nxr230(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 端末の設定例 】

IPアドレス 192.168.10.100
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1