FutureNet

NXR,WXRシリーズ

QoS編

1. 帯域制御設定

1-4. 帯域制御の利用(未使用帯域の活用)

この設定例では帯域制御機能で帯域幅を2つに分け、かつ他のクラスが帯域を使用していない場合、その帯域を借りるように設定します。これにより未使用帯域がある場合は設定したレートより高いレートで通信することができます。

 

【 構成図 】

  • 出力インタフェース(Ethernet1インタフェース)の帯域幅を契約帯域に合わせて20Mbpsに設定します。
  • クラスをクラス10とデフォルトクラスの2つに分け、それぞれの帯域幅を出力インタフェースの帯域幅の25%と75%に設定します。
  • 他のクラスが帯域を使用していない場合、その帯域を借りるように設定します。
  • Ethernet0インタフェースで受信する全てのUDPパケットをクラス10に割り当てます。またそれ以外のパケットはデフォルトクラスに割り当てます。

 

【 設定データ 】

設定項目 設定内容
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
classify input qos_routemap
WAN側インタフェース ethernet1のIPアドレス 10.10.10.1/30
QoS キューイング クラスポリシ
クラスポリシ名 eth1qos
帯域幅 20Mbps(20000kbps)
ifg-pa-fcs 有効
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(IPアドレス) 10.10.10.2
クラスアクセスリスト アクセスリスト名 class_acl
class_acl 送信元IPアドレス any
宛先IPアドレス any
プロトコル UDP
ルートマップ ルートマップ名 qos_routemap
qos_routemap マッチIPアドレス class_acl
セット(mark) 10
クラスフィルタ クラスナンバ 10
クラス10 マッチ条件 10(mark)
クラスポリシ ポリシ名 eth1qos
eth1qos No.1 クラス 10
帯域幅 25%
ceil 100%
No.2 クラス デフォルト
帯域幅 75%
ceil 100%
FastFowarding 有効

【 設定例 】

nxr230#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr230(config)#class access-list class_acl ip any any udp
nxr230(config)#route-map qos_routemap permit 1
nxr230(config-route-map)#match ip address class_acl
nxr230(config-route-map)#set mark 10
nxr230(config-route-map)#exit
nxr230(config)#class filter 10
nxr230(config-class-filter)#match ip mark 10
nxr230(config-class-filter)#exit
nxr230(config)#class policy eth1qos
nxr230(config-class-policy)#class 10 bandwidth percent 25 ceil 100
nxr230(config-class-policy)#class default bandwidth percent 75 ceil 100
nxr230(config-class-policy)#exit
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24
nxr230(config-if)#classify input route-map qos_routemap
nxr230(config-if)#exit
nxr230(config)#interface ethernet 1
nxr230(config-if)#ip address 10.10.10.1/30
nxr230(config-if)#queue policy eth1qos bandwidth 20000 ifg-pa-fcs
nxr230(config-if)#exit
nxr230(config)#ip route 0.0.0.0/0 10.10.10.2
nxr230(config)#fast-forwarding enable
nxr230(config)#exit
nxr230#save config

【 設定例解説 】

1. <クラスアクセスリスト設定>
nxr230(config)#class access-list class_acl ip any any udp

クラスアクセスリスト名をclass_aclとし、UDPパケット全てが対象となるように設定します。

 

2. <ルートマップ設定>
nxr230(config)#route-map qos_routemap permit 1

ルートマップ名をqos_routemapとし、No.1のルールを作成します。

nxr230(config-route-map)#match ip address class_acl

マッチ条件としてクラスアクセスリストで設定したclass_aclを設定します。

nxr230(config-route-map)#set mark 10

該当条件にマッチした場合、マーク値10を設定します。
(☞) markはルータ内でのみ利用可能なマーキング値です。
(☞) ルートマップ設定を設定しただけではパケット分類は適切に機能しません。パケット分類を行うインタフェースでルートマップの登録が必要になります。

 

3. <クラスフィルタ設定>
nxr230(config)#class filter 10
nxr230(config-class-filter)#match ip mark 10

マーク値10のパケットをクラス10に割り当てるように設定します。

 

4. <クラスポリシ設定>
nxr230(config)#class policy eth1qos

クラスポリシ名としてeth1qosを設定します。

nxr230(config-class-policy)#class 10 bandwidth percent 25 ceil 100

クラス10の帯域幅を設定します。また未使用帯域を使用するようにし、その帯域幅を設定します。
(☞) パーセンテージはインタフェースで設定する帯域幅に対する絶対比となります。

nxr230(config-class-policy)#class default bandwidth percent 75 ceil 100

デフォルトクラスの帯域幅を設定します。また未使用帯域を使用するようにし、その帯域幅を設定します。

 

5. <LAN側(ethernet0)インタフェース設定>
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

nxr230(config-if)#classify input route-map qos_routemap

パケット受信時にルートマップによるパケット分類を行うように設定します。

 

6. <WAN側(ethernet1)インタフェース設定>
nxr230(config)#interface ethernet 1
nxr230(config-if)#ip address 10.10.10.1/30

ethernet1インタフェースのIPアドレスを設定します。

nxr230(config-if)#queue policy eth1qos bandwidth 20000 ifg-pa-fcs

出力インタフェースのキューイング方式としてクラスポリシを指定し、クラスポリシ名および帯域幅を設定します。またシェーピングレートの計算時にIFG,プリアンブル,FCSをフレームサイズに加えるように設定します。
(☞) 帯域幅の単位はkbpsになります。

 

7. <スタティックルート設定>
nxr230(config)#ip route 0.0.0.0/0 10.10.10.2

デフォルトルートを設定します。

 

8. <ファストフォワーディングの有効化>
nxr230(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 端末の設定例 】

IPアドレス 192.168.10.100
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1