FutureNet

NXR,WXRシリーズ

ルーティング編

4. BGP4設定

4-7. ローカルプリファレンス設定

LOCAL_PREF属性は上りのトラフィック制御に用いられ、どのパスを優先させるかを決める際に利用されます。またLOCAL_PREF値は大きい方の経路が優先されます。なおLOCAL_PREF属性はIBGPでのみ利用できます。

 

【 構成図 】

  • ルータ1から受信した経路情報「192.168.30.0/24」にLOCAL_PREF値150を設定します。
    (☞) デフォルト値は100になります。

 

【 設定データ 】

設定項目 設定内容
ethernet0インタフェースのIPアドレス 192.168.10.1/24
ethernet1インタフェースのIPアドレス 192.168.20.1/24
BGP4 自AS番号 65000
ネットワーク 192.168.10.0/24
ネイバー 192.168.20.2 リモートAS番号 65000
ルートマップ ルートマップ名 LOCAL-PREF150
適用方向 in
ネイバー 192.168.20.3 リモートAS番号 65000
IPルートアクセスリスト ACL名 local-pref
local-pref 動作 許可
プレフィックス 192.168.30.0/24
ルートマップ ルートマップ名 LOCAL-PREF150
LOCAL-PREF150 マッチIPアドレス local-pref
セットローカルプリファレンス 150
FastFowarding 有効

【 設定例 】

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24
nxrg100(config-if)#exit
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#ip address 192.168.20.1/24
nxrg100(config-if)#exit
nxrg100(config)#ip route access-list local-pref permit 192.168.30.0/24
nxrg100(config)#route-map LOCAL-PREF150 permit 1
nxrg100(config-route-map)#match ip address local-pref
nxrg100(config-route-map)#set local-preference 150
nxrg100(config-route-map)#exit
nxrg100(config)#router bgp 65000
nxrg100(config-router)#network 192.168.10.0/24
nxrg100(config-router)#neighbor 192.168.20.2 remote-as 65000
nxrg100(config-router)#neighbor 192.168.20.2 route-map LOCAL-PREF150 in
nxrg100(config-router)#neighbor 192.168.20.3 remote-as 65000
nxrg100(config-router)#exit
nxrg100(config)#fast-forwarding enable
nxrg100(config)#exit
nxrg100#save config

【 設定例解説 】

1. <ethernet0インタフェース設定>
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

2. <ethernet1インタフェース設定>
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#ip address 192.168.20.1/24

ethernet1インタフェースのIPアドレスを設定します。

 

3. <IPルートアクセスリスト設定>
nxrg100(config)#ip route access-list local-pref permit 192.168.30.0/24

IPルートアクセスリスト名をlocal-prefとし、IPアドレス192.168.30.0/24を登録します。
(☞) この設定はルートマップ設定のマッチ条件で使用します。

 

4. <ルートマップ設定>
nxrg100(config)#route-map LOCAL-PREF150 permit 1

ルートマップ名をLOCAL-PREF150とし、No.1のルールを作成します。

nxrg100(config-route-map)#match ip address local-pref

マッチ条件として、IPルートアクセスリストで設定したlocal-prefを設定します。

nxrg100(config-route-map)#set local-preference 150

該当条件にマッチした場合、ローカルプリファレンス値に150を設定します。

 

5. <BGP4設定>
nxrg100(config)#router bgp 65000

BGP4を有効にし、自AS番号を65000に設定します。

nxrg100(config-router)#network 192.168.10.0/24

BGPでアドバタイズするネットワークアドレスを設定します。

nxrg100(config-router)#neighbor 192.168.20.2 remote-as 65000

BGPピア(ルータ1)のIPアドレスおよびAS番号を設定します。

nxrg100(config-router)#neighbor 192.168.20.2 route-map LOCAL-PREF150 in

BGPピア(ルータ1)に作成したルートマップLOCAL-PREF150を適用します。また受信する経路情報に適用するためinを指定します。

nxrg100(config-router)#neighbor 192.168.20.3 remote-as 65000

BGPピア(ルータ2)のIPアドレスおよびAS番号を設定します。

 

6. <ファストフォワーディングの有効化>
nxrg100(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR ,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 端末の設定例 】

IP アドレス 192.168.10.100
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1