FutureNet

NXR,WXRシリーズ

IPv6編

2. IPv6 PPPoE設定

2-2. IPv4+IPv6 PPPoE接続設定

NTT東日本/西日本が提供するフレッツ光ネクスト回線でIPv4およびIPv6のPPPoEを同時に接続する設定例です。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • IPv6プレフィックスおよびIPv6DNSサーバアドレスはDHCPv6で取得します。
  • ルータ配下の端末に対してIPv4アドレスはDHCPで配布します。またIPv6プレフィックスはRAで広告します。
    (☞) この設定例ではIPv6DNSサーバアドレスを広告しません。
  • IPv6インターネット接続とNGN網内のIPv6サービスを同時に利用することはできません。

 

【 設定例 】

nxrg240#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg240(config)#ipv6 dhcp-client ipv6dhcpc
nxrg240(config-dhcp6c)#ia-pd dhcpv6pd
nxrg240(config-dhcp6c)#option-request dns-servers
nxrg240(config-dhcp6c)#exit
nxrg240(config)#ipv6 route ::/0 ppp 0
nxrg240(config)#ip route 0.0.0.0/0 ppp 1
nxrg240(config)#ipv6 access-list ppp0_in permit any any udp any 546
nxrg240(config)#interface ethernet 0
nxrg240(config-if)#ip address 192.168.10.1/24
nxrg240(config-if)#ipv6 address dhcpv6pd ::/64 eui-64
nxrg240(config-if)#ipv6 nd send-ra
nxrg240(config-if)#exit
nxrg240(config)#dhcp-server 1
nxrg240(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg240(config-dhcps)#gateway 192.168.10.1
nxrg240(config-dhcps)#dns-server 192.168.10.1
nxrg240(config-dhcps)#exit
nxrg240(config)#ppp account username test1@v6.example.jp password test1pass
nxrg240(config)#ppp account username test1@example.jp password test1pass
nxrg240(config)#interface ppp 0
nxrg240(config-ppp)#no ip address
nxrg240(config-ppp)#no ppp ipcp enable
nxrg240(config-ppp)#ppp ipv6cp enable
nxrg240(config-ppp)#ipv6 dhcp client ipv6dhcpc
nxrg240(config-ppp)#ipv6 access-group in ppp0_in
nxrg240(config-ppp)#ipv6 spi-filter
nxrg240(config-ppp)#ipv6 tcp adjust-mss auto
nxrg240(config-ppp)#ppp username test1@v6.example.jp
nxrg240(config-ppp)#exit
nxrg240(config)#interface ppp 1
nxrg240(config-ppp)#ip address negotiated
nxrg240(config-ppp)#ip masquerade
nxrg240(config-ppp)#ip spi-filter
nxrg240(config-ppp)#ip tcp adjust-mss auto
nxrg240(config-ppp)#ppp username test1@example.jp
nxrg240(config-ppp)#exit
nxrg240(config)#interface ethernet 1
nxrg240(config-if)#no ip address
nxrg240(config-if)#pppoe-client ppp 0
nxrg240(config-if)#pppoe-client ppp 1
nxrg240(config-if)#exit
nxrg240(config)#dns
nxrg240(config-dns)#service enable
nxrg240(config-dns)#edns-query enable
nxrg240(config-dns)#timeout 5
nxrg240(config-dns)#exit
nxrg240(config)#fast-forwarding enable
nxrg240(config)#exit
nxrg240#save config

 

【 設定例解説 】

1. <DHCPv6クライアント設定>
nxrg240(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

nxrg240(config-dhcp6c)#ia-pd dhcpv6pd

Identity Association for Prefix Delegation(IAPD)を有効にし、IPv6プレフィックスの名前を定義します。

nxrg240(config-dhcp6c)#option-request dns-servers

DNSサーバアドレスの通知を要求するように設定します。

 

2. <IPv6スタティックルート設定>
nxrg240(config)#ipv6 route ::/0 ppp 0

デフォルトルートを設定します。

 

3. <IPv4スタティックルート設定>
nxrg240(config)#ip route 0.0.0.0/0 ppp 1

デフォルトルートを設定します。

 

4. <IPv6アクセスリスト設定>
nxrg240(config)#ipv6 access-list ppp0_in permit any any udp any 546

IPv6アクセスリストppp0_inを以下のルールで設定します。

  • 宛先UDPポート546番(DHCPv6クライアント)を許可

(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

5. <LAN側(ethernet0)インタフェース設定>
nxrg240(config)#interface ethernet 0
nxrg240(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

nxrg240(config-if)#ipv6 address dhcpv6pd ::/64 eui-64

ethernet0インタフェースのIPv6アドレスを設定します。
(☞) プレフィックスはDHCPv6クライアントで取得したIPv6プレフィックスを使用します。またインタフェースIDはEUI-64を使用して自動生成します。

nxrg240(config-if)#ipv6 nd send-ra

IPv6 RA(Router Advertisement)を送信するように設定します。

 

6. <IPv4 DHCPサーバ設定>
nxrg240(config)#dhcp-server 1
nxrg240(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg240(config-dhcps)#gateway 192.168.10.1
nxrg240(config-dhcps)#dns-server 192.168.10.1

DHCPサーバを設定します。

 

7. <PPPアカウント設定>
nxrg240(config)#ppp account username test1@v6.example.jp password test1pass

ppp0インタフェースで使用するIPv6 ISP接続用ユーザID,パスワードを設定します。

nxrg240(config)#ppp account username test1@example.jp password test1pass

ppp1インタフェースで使用するIPv4 ISP接続用ユーザID,パスワードを設定します。

 

8. <WAN側(ppp0)インタフェース設定>
nxrg240(config)#interface ppp 0
nxrg240(config-ppp)#no ip address

ppp0インタフェースのIPv4アドレスを無効にします。

nxrg240(config-ppp)#no ppp ipcp enable

IPCPを無効にします。

nxrg240(config-ppp)#ppp ipv6cp enable

IPv6CPを有効にします。

nxrg240(config-ppp)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

nxrg240(config-ppp)#ipv6 access-group in ppp0_in

IPv6アクセスグループのinフィルタにIPv6アクセスリストppp0_inを設定します。

nxrg240(config-ppp)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

nxrg240(config-ppp)#ipv6 tcp adjust-mss auto

IPv6 TCP MSSの調整機能をオートに設定します。

nxrg240(config-ppp)#ppp username test1@v6.example.jp

IPv6 ISP接続用ユーザIDを設定します。

 

9. <WAN側(ppp1)インタフェース設定>
nxrg240(config)#interface ppp 1
nxrg240(config-ppp)#ip address negotiated

ppp1インタフェースのIPv4アドレスをnegotiatedに設定します。

nxrg240(config-ppp)#ip masquerade
nxrg240(config-ppp)#ip spi-filter

IPマスカレード、IPv4ステートフルパケットインスペクションを有効にします。

nxrg240(config-ppp)#ip tcp adjust-mss auto

IPv4 TCP MSSの調整機能をオートに設定します。

nxrg240(config-ppp)#ppp username test1@example.jp

IPv4 ISP接続用ユーザIDを設定します。

 

10. <ethernet1インタフェース設定>
nxrg240(config)#interface ethernet 1
nxrg240(config-if)#no ip address

ethernet1インタフェースのIPv4アドレスを無効にします。

nxrg240(config-if)#pppoe-client ppp 0
nxrg240(config-if)#pppoe-client ppp 1

PPPoEクライアントにppp0、ppp1を設定します。

 

11. <DNS設定>
nxrg240(config)#dns
nxrg240(config-dns)#service enable

DNSサービスを有効にします。

nxrg240(config-dns)#edns-query enable

EDNSを有効にします。

nxrg240(config-dns)#timeout 5

タイムアウト時間を設定します。

 

12. <ファストフォワーディング設定>
nxrg240(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

 

13. <設定の保存>
nxrg240#save config

設定内容を保存します。

 

【 端末の設定例 】

IPv4 アドレス DHCPサーバから取得
サブネットマスク
デフォルトゲートウェイ
DNSサーバアドレス
IPv6 プレフィックス ルータからRAで取得
アドレス プレフィックス情報を元に自動生成
デフォルトゲートウェイ ルータからRAで取得

 

【 付録 】