FutureNet
NXR,VXRシリーズ
IPv6編
1. IPv6ブリッジ設定
1-1. IPv4 PPPoE+IPv6ブリッジ設定
NTT東日本/西日本が提供するフレッツ光ネクスト回線を利用してPPPoEによるインターネット接続(IPv4)とIPv6ブリッジによるサービス情報サイト(IPv6)への接続を行う設定例です。
コンテンツ | ||||
構成図 | 設定例 | 設定例解説 | 端末の設定例 | 付録 |
【 構成図 】
- IPv6でサービス情報サイトにアクセスできるようにするため、IPv6ブリッジを有効にします。これによりルータ配下の端末はNGN網から広告されるプレフィックス情報を元にIPv6アドレスを自動生成することができます。
【 設定例 】
nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24
nxrg100(config-if)#exit
nxrg100(config)#dhcp-server 1
nxrg100(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg100(config-dhcps)#gateway 192.168.10.1
nxrg100(config-dhcps)#dns-server 192.168.10.1
nxrg100(config-dhcps)#exit
nxrg100(config)#ipv6 bridge ethernet 0 ethernet 1
nxrg100(config)#ip route 0.0.0.0/0 ppp 0
nxrg100(config)#ppp account username test1@example.jp password test1pass
nxrg100(config)#interface ppp 0
nxrg100(config-ppp)#ip address negotiated
nxrg100(config-ppp)#ip masquerade
nxrg100(config-ppp)#ip spi-filter
nxrg100(config-ppp)#ip tcp adjust-mss auto
nxrg100(config-ppp)#ppp username test1@example.jp
nxrg100(config-ppp)#exit
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#no ip address
nxrg100(config-if)#pppoe-client ppp 0
nxrg100(config-if)#exit
nxrg100(config)#dns
nxrg100(config-dns)#service enable
nxrg100(config-dns)#exit
nxrg100(config)#fast-forwarding enable
nxrg100(config)#exit
nxrg100#save config
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24
nxrg100(config-if)#exit
nxrg100(config)#dhcp-server 1
nxrg100(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg100(config-dhcps)#gateway 192.168.10.1
nxrg100(config-dhcps)#dns-server 192.168.10.1
nxrg100(config-dhcps)#exit
nxrg100(config)#ipv6 bridge ethernet 0 ethernet 1
nxrg100(config)#ip route 0.0.0.0/0 ppp 0
nxrg100(config)#ppp account username test1@example.jp password test1pass
nxrg100(config)#interface ppp 0
nxrg100(config-ppp)#ip address negotiated
nxrg100(config-ppp)#ip masquerade
nxrg100(config-ppp)#ip spi-filter
nxrg100(config-ppp)#ip tcp adjust-mss auto
nxrg100(config-ppp)#ppp username test1@example.jp
nxrg100(config-ppp)#exit
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#no ip address
nxrg100(config-if)#pppoe-client ppp 0
nxrg100(config-if)#exit
nxrg100(config)#dns
nxrg100(config-dns)#service enable
nxrg100(config-dns)#exit
nxrg100(config)#fast-forwarding enable
nxrg100(config)#exit
nxrg100#save config
【 設定例解説 】
1. <LAN側(ethernet0)インタフェース設定>
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24
nxrg100(config-if)#ip address 192.168.10.1/24
ethernet0インタフェースのIPv4アドレスを設定します。
2. <IPv4 DHCPサーバ設定>
nxrg100(config)#dhcp-server 1
nxrg100(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg100(config-dhcps)#gateway 192.168.10.1
nxrg100(config-dhcps)#dns-server 192.168.10.1
nxrg100(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg100(config-dhcps)#gateway 192.168.10.1
nxrg100(config-dhcps)#dns-server 192.168.10.1
DHCPサーバのサーバナンバを1とし、配布するアドレス情報を設定します。
3. <IPv6ブリッジ設定>
nxrg100(config)#ipv6 bridge ethernet 0 ethernet 1
IPv6ブリッジするインタフェースを設定します。
4. <IPv4スタティックルート設定>
nxrg100(config)#ip route 0.0.0.0/0 ppp 0
デフォルトルートを設定します。
5. <PPPアカウント設定>
nxrg100(config)#ppp account username test1@example.jp password test1pass
ppp0インタフェースで使用するIPv4 ISP接続用ユーザID,パスワードを設定します。
6. <WAN側(ppp0)インタフェース設定>
nxrg100(config)#interface ppp 0
nxrg100(config-ppp)#ip address negotiated
nxrg100(config-ppp)#ip address negotiated
ppp0インタフェースのIPv4アドレスをnegotiatedに設定します。
nxrg100(config-ppp)#ip masquerade
nxrg100(config-ppp)#ip spi-filter
nxrg100(config-ppp)#ip spi-filter
IPマスカレード、IPv4ステートフルパケットインスペクションを有効にします。
nxrg100(config-ppp)#ip tcp adjust-mss auto
IPv4 TCP MSSの調整機能をオートに設定します。
nxrg100(config-ppp)#ppp username test1@example.jp
IPv4 ISP接続用ユーザIDを設定します。
7. <ethernet1インタフェース設定>
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#no ip address
nxrg100(config-if)#no ip address
ethernet1インタフェースのIPv4アドレスを無効にします。
nxrg100(config-if)#pppoe-client ppp 0
PPPoEクライアントにppp0を設定します。
8. <DNS設定>
nxrg100(config)#dns
nxrg100(config-dns)#service enable
nxrg100(config-dns)#service enable
DNSサービスを有効にします。
9. <ファストフォワーディング設定>
nxrg100(config)#fast-forwarding enable
ファストフォワーディングを有効にします。
10. <設定の保存>
nxrg100#save config
設定内容を保存します。
【 端末の設定例 】
IPv4 | アドレス | DHCPサーバから取得 |
サブネットマスク | ||
デフォルトゲートウェイ | ||
DNSサーバ | ||
IPv6 | プレフィックス | NGN網から取得 |
アドレス | プレフィックス情報を元に自動生成 | |
デフォルトゲートウェイ | NGN網から取得 | |
DNSサーバ |
【 付録 】
目次
- 1. IPv6ブリッジ設定
- 2. IPv6 PPPoE設定
- 3. IPv6 IPoE設定
- 4. IPv6 IPsec設定
- 5. IPv6 L2TPv3設定
- 6.「v6プラス」(固定IP)サービス接続設定
- 7.「v6プラス」接続設定
- 8.「OCNバーチャルコネクト」接続設定
- 9. transix IPv4接続(DS-Lite)接続設定
- 10. transix IPv4接続(固定IP)接続設定
- 11. IPv6 モバイル設定
- 12.「v6 コネクト」IPv4 over IPv6 接続(IPIP)設定
- 13. BIGLOBE IPv6 サービス ( IPIP ) 接続設定
- 14. クロスパス(Xpass)可変IP接続設定
- 15. クロスパス(Xpass)固定IP接続設定
更新情報
→ 一覧へ- 2024.10.01NXR,VXR
ネットイベント編
3-19. DDNSクライアントの有効/無効化設定 - 2024.10.01NXR,VXR
運用管理編
11-3. センチュリー・テクニカルサポート情報の取得と転送 - 2024.09.18NXR,VXR
REST-API編
2-18. センチュリー・テクニカルサポート情報の取得(maint/century-tech-support) - 2024.09.18NXR,VXR
REST-API編
2-17. デバッグタイマの実行(maint/debug) - 2024.09.18NXR,VXR
REST-API編
12-10. SSHクライアント設定(ssh-client)
カテゴリ
タグ
- CRG
- DDNS
- DHCP
- DNAT
- DNSインターセプト
- Ethernet
- IIJモバイル
- IKE Modeconfig
- IKEv2 Configuration Payload
- IPinIP
- IPoE
- IPv6
- KDDI
- L2TPv3
- MAP-E
- NGN
- NTTドコモ
- PBR
- Policy Based IPsec
- PPP
- PPPoE
- QoS
- RADIUS連携
- RAシリーズ
- Route Based IPsec
- SMS
- SNAT
- SoftBank
- UPnP
- URL転送
- VLAN
- VRRP
- Web認証
- WiMAX
- コンフィグロールバック
- ネットイベント
- フィルタ
- ブリッジ
- モニタログ
- ワイモバイル
- 仮想スイッチ
- 冗長化
- 無線LAN