FutureNet

NXR,WXRシリーズ

IPv6編

3. IPv6 IPoE設定

3-4. IPv4 PPPoE+IPv6 IPoE(DHCPv6-PD)接続設定

NTT東日本/西日本が提供するフレッツ光ネクスト回線でIPv4はPPPoE、IPv6はIPoEを同時に接続する設定例です。なおこの例ではひかり電話契約ありの場合を想定しています。またルータはホームゲートウェイ(以下HGW)と置き換えて接続します。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • ひかり電話契約があり、ルータをHGWと置き換えて接続する場合、IPv6プレフィックスおよびDNSサーバアドレスはDHCPv6で取得します。
  • ルータ配下の端末に対してIPv4アドレスはDHCPで配布します。またIPv6プレフィックスはRAで広告します。
    (☞) この設定例ではIPv6DNSサーバアドレスを広告しません。

 

【 設定例 】

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#ipv6 dhcp-client ipv6dhcpc
nxrg100(config-dhcp6c)#ia-pd dhcpv6pd
nxrg100(config-dhcp6c)#option-request dns-servers
nxrg100(config-dhcp6c)#exit
nxrg100(config)#ip route 0.0.0.0/0 ppp 0
nxrg100(config)#ipv6 access-list eth1_in permit any any icmpv6
nxrg100(config)#ipv6 access-list eth1_in permit any any udp any 546
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24
nxrg100(config-if)#ipv6 address dhcpv6pd ::/64 eui-64
nxrg100(config-if)#ipv6 nd send-ra
nxrg100(config-if)#exit
nxrg100(config)#dhcp-server 1
nxrg100(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg100(config-dhcps)#gateway 192.168.10.1
nxrg100(config-dhcps)#dns-server 192.168.10.1
nxrg100(config-dhcps)#exit
nxrg100(config)#ppp account username test1@example.jp password test1pass
nxrg100(config)#interface ppp 0
nxrg100(config-ppp)#ip address negotiated
nxrg100(config-ppp)#ip masquerade
nxrg100(config-ppp)#ip spi-filter
nxrg100(config-ppp)#ip tcp adjust-mss auto
nxrg100(config-ppp)#ppp username test1@example.jp
nxrg100(config-ppp)#exit
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#no ip address
nxrg100(config-if)#ipv6 nd accept-ra
nxrg100(config-if)#ipv6 dhcp client ipv6dhcpc
nxrg100(config-if)#ipv6 access-group in eth1_in
nxrg100(config-if)#ipv6 spi-filter
nxrg100(config-if)#pppoe-client ppp 0
nxrg100(config-if)#exit
nxrg100(config)#dns
nxrg100(config-dns)#service enable
nxrg100(config-dns)#edns-query enable
nxrg100(config-dns)#timeout 5
nxrg100(config-dns)#exit
nxrg100(config)#fast-forwarding enable
nxrg100(config)#exit
nxrg100#save config

 

【 設定例解説 】

1. <DHCPv6クライアント設定>
nxrg100(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

nxrg100(config-dhcp6c)#ia-pd dhcpv6pd

Identity Association for Prefix Delegation(IAPD)を有効にし、IPv6プレフィックスの名前を定義します。

nxrg100(config-dhcp6c)#option-request dns-servers 

DNSサーバアドレスの通知を要求するように設定します。

 

2. <IPv4スタティックルート設定>
nxrg100(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

3. <IPv6アクセスリスト設定>
nxrg100(config)#ipv6 access-list eth1_in permit any any icmpv6
nxrg100(config)#ipv6 access-list eth1_in permit any any udp any 546

IPv6アクセスリストeth1_inを以下のルールで設定します。

  • ICMPv6を許可
  • 宛先UDPポート546番(DHCPv6クライアント)を許可

(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

4. <LAN側(ethernet0)インタフェース設定>
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

nxrg100(config-if)#ipv6 address dhcpv6pd ::/64 eui-64

ethernet0インタフェースのIPv6アドレスを設定します。
(☞) プレフィックスはDHCPv6クライアントで取得したIPv6プレフィックスを使用します。またインタフェースIDはEUI-64を使用して自動生成します。

nxrg100(config-if)#ipv6 nd send-ra

IPv6 RA(Router Advertisement)を送信するように設定します。

 

5. <IPv4 DHCPサーバ設定>
nxrg100(config)#dhcp-server 1
nxrg100(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg100(config-dhcps)#gateway 192.168.10.1
nxrg100(config-dhcps)#dns-server 192.168.10.1

DHCPサーバを設定します。

 

6. <PPPアカウント設定>
nxrg100(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するIPv4 ISP接続用ユーザID,パスワードを設定します。

 

7. <WAN側(ppp0)インタフェース設定>
nxrg100(config)#interface ppp 0
nxrg100(config-ppp)#ip address negotiated

ppp0インタフェースのIPv4アドレスをnegotiatedに設定します。

nxrg100(config-ppp)#ip masquerade
nxrg100(config-ppp)#ip spi-filter

IPマスカレード、IPv4ステートフルパケットインスペクションを有効にします。

nxrg100(config-ppp)#ip tcp adjust-mss auto

IPv4 TCP MSSの調整機能をオートに設定します。

nxrg100(config-ppp)#ppp username test1@example.jp

IPv4 ISP接続用ユーザIDを設定します。

 

8. <WAN側(ethernet1)インタフェース設定>
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#no ip address

ethernet1インタフェースのIPv4アドレスを無効にします。

nxrg100(config-if)#ipv6 nd accept-ra

RAを受信するように設定します。

nxrg100(config-if)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

nxrg100(config-if)#ipv6 access-group in eth1_in

IPv6アクセスグループのinフィルタにIPv6アクセスリストeth1_inを設定します。

nxrg100(config-if)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

nxrg100(config-if)#pppoe-client ppp 0

PPPoEクライアントにppp0を設定します。

 

9. <DNS設定>
nxrg100(config)#dns
nxrg100(config-dns)#service enable

DNSサービスを有効にします。

nxrg100(config-dns)#edns-query enable

EDNSを有効にします。

nxrg100(config-dns)#timeout 5

タイムアウト時間を設定します。

 

10. <ファストフォワーディング設定>
nxrg100(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

 

11. <設定の保存>
nxrg100#save config

設定内容を保存します。

 

【 端末の設定例 】

IPv4 アドレス DHCPサーバから取得
サブネットマスク
デフォルトゲートウェイ
DNSサーバアドレス
IPv6 プレフィックス ルータからRAで取得
アドレス プレフィックス情報を元に自動生成
デフォルトゲートウェイ ルータからRAで取得

 

【 付録 】