FutureNet

NXR,VXRシリーズ

無線LAN編

4. 無線LAN設定(NXR-G050/LW)

4-3. 無線LAN設定(MACアドレスフィルタリング)

無線LAN端末(ステーション)のMACアドレス情報を元に接続制限を行う設定例です。

 

【 対象機種 】NXR-G050/LW(2022/5現在)
最新の対応状況は、各製品の更新履歴やユーザーズガイドをご確認ください。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • 有線LANインタフェースと無線LANインタフェースをブリッジします。
  • ブリッジインタフェースでDHCPサーバを動作させることで、無線LAN端末,有線LAN端末それぞれにIPアドレスを配布します。
  • TELNETとHTTPのforbidden-access-wanが有効になっている場合、それらを使用してbridgeインタフェースのIPアドレスにアクセスすることはできません。そのため、この設定例ではbridge0インタフェースでTELNETとHTTPアクセスを許可するフィルタを設定します。

 

【 設定例 】

nxrg050#configure terminal
nxrg050(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.1 tcp any 23
nxrg050(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.1 tcp any 880
nxrg050(config)#interface bridge 0
nxrg050(config-bridge)#ip address 192.168.10.1/24
nxrg050(config-bridge)#ip access-group in br0_in
nxrg050(config-bridge)#exit
nxrg050(config)#interface ethernet 0
nxrg050(config-if)#no ip address
nxrg050(config-if)#bridge-group 0 port 1
nxrg050(config-if)#exit
nxrg050(config)#interface wlan 0
nxrg050(config-wlan)#no ip address
nxrg050(config-wlan)#bridge-group 0 port 2
nxrg050(config-wlan)#wlan ssid nxrg050wlan0
nxrg050(config-wlan)#wlan wpa-psk password nxrg050wlan0pass
nxrg050(config-wlan)#wlan authenticate wpa2-psk aes
nxrg050(config-wlan)#wlan guest-mode enable
nxrg050(config-wlan)#wlan access-point-bridge enable
nxrg050(config-wlan)#wlan max-associations 16
nxrg050(config-wlan)#wlan mac access-list permission permit
nxrg050(config-wlan)#wlan mac access-list address 00:00:5E:00:53:01
nxrg050(config-wlan)#exit
nxrg050(config)#wifi 0
nxrg050(config-wifi)#mode 11na
nxrg050(config-wifi)#channel auto
nxrg050(config-wifi)#exit
nxrg050(config)#dhcp-server 1
nxrg050(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg050(config-dhcps)#gateway 192.168.10.1
nxrg050(config-dhcps)#dns-server 192.168.10.1
nxrg050(config-dhcps)#exit
nxrg050(config)#ip route 0.0.0.0/0 ppp 0
nxrg050(config)#ppp account username [PPP接続用ユーザID] password [PPP接続用パスワード]
nxrg050(config)#interface ppp 0
nxrg050(config-ppp)#ip address negotiated
nxrg050(config-ppp)#ip masquerade
nxrg050(config-ppp)#ip spi-filter
nxrg050(config-ppp)#ip tcp adjust-mss auto
nxrg050(config-ppp)#ppp username [PPP接続用ユーザID]
nxrg050(config-ppp)#mobile apn [APN] cid 1 pdp-type ip
nxrg050(config-ppp)#dial-up string *99***1#
nxrg050(config-ppp)#dial-up timeout 30
nxrg050(config-ppp)#exit
nxrg050(config)#mobile error-recovery-reset
nxrg050(config)#mobile termination-recovery reset
nxrg050(config)#mobile 2 ppp 0
nxrg050(config)#mobile 2 carrier [キャリア]
nxrg050(config)#exit
nxrg050#clear mobile 2
nxrg050#configure terminal
nxrg050(config)#dns
nxrg050(config-dns)#service enable
nxrg050(config-dns)#exit
nxrg050(config)#exit
nxrg050#save config

 

【 設定例解説 】

1. <IPアクセスリスト設定>
nxrg050(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.1 tcp any 23
nxrg050(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.1 tcp any 880

IPアクセスリストbr0_inを以下のルールで設定します。

  • 送信元IPアドレス192.168.10.0/24、宛先IPアドレス192.168.10.1、宛先TCPポート23番を許可
  • 送信元IPアドレス192.168.10.0/24、宛先IPアドレス192.168.10.1、宛先TCPポート880番を許可

(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

2. <bridge0インタフェース設定>
nxrg050(config)#interface bridge 0
nxrg050(config-bridge)#ip address 192.168.10.1/24

bridge0インタフェースのIPアドレスを設定します。

nxrg050(config-bridge)#ip access-group in br0_in

IPアクセスグループのinフィルタにIPアクセスリストbr0_inを設定します。

 

3. <ethernet0インタフェース設定>
nxrg050(config)#interface ethernet 0
nxrg050(config-if)#no ip address

ethernet0インタフェースのIPアドレスを無効にします。

nxrg050(config-if)#bridge-group 0 port 1

ブリッジグループを設定します。
(☞) ブリッジグループの番号はbridgeインタフェースの番号と同一のものを設定します。またポートはブリッジグループ内でユニークなものを設定する必要があります。

 

4. <wlan0インタフェース設定>
nxrg050(config)#interface wlan 0
nxrg050(config-wlan)#no ip address

wlan0インタフェースのIPアドレスを無効にします。

nxrg050(config-wlan)#bridge-group 0 port 2

ブリッジグループを設定します。

nxrg050(config-wlan)#wlan ssid nxrg050wlan0

SSIDを設定します。

nxrg050(config-wlan)#wlan wpa-psk password nxrg050wlan0pass

WPA-PSK認証方式で使用するパスワードを設定します。
(☞) WPA-PSK認証方式で使用するパスワードは、WPA-PSKの認証方式および暗号化方式よりも先に設定する必要があります。

nxrg050(config-wlan)#wlan authenticate wpa2-psk aes

認証方式と暗号化方式を設定します。

nxrg050(config-wlan)#wlan guest-mode enable

ゲストモードを有効に設定します。
(☞) ANY接続拒否機能,ステルス機能は連動して動作するためゲストモードでの一括設定となります。

nxrg050(config-wlan)#wlan access-point-bridge enable

アクセスポイントブリッジを有効に設定します。
(☞) アクセスポイントブリッジを有効に設定することでプライバシープロテクションが無効になります。

nxrg050(config-wlan)#wlan max-associations 16

接続台数制限を設定します。

nxrg050(config-wlan)#wlan mac access-list permission permit

MACアクセスリストのパーミッションを許可に設定します。
(☞) MACアクセスリストに含まれるステーションのみ接続を許可します。

nxrg050(config-wlan)#wlan mac access-list address 00:00:5E:00:53:01

MACアクセスリストにMACアドレスを登録します。
(☞) MACアクセスリストのパーミッションで許可を設定していますので、ここで登録するMACアドレスは接続を許可するステーションのMACアドレスになります。

 

5. <wifi0設定>
nxrg050(config)#wifi 0
nxrg050(config-wifi)#mode 11na

無線方式を設定します。

nxrg050(config-wifi)#channel auto

チャネルを設定します。
(☞) modeコマンドが未設定の場合、設定することはできません。

 

6. <DHCPサーバ設定>
nxrg050(config)#dhcp-server 1
nxrg050(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg050(config-dhcps)#gateway 192.168.10.1
nxrg050(config-dhcps)#dns-server 192.168.10.1

DHCPサーバを設定します。

 

7. <スタティックルート設定>
nxrg050(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

8. <PPPアカウント設定>
nxrg050(config)#ppp account username [PPP接続用ユーザID] password [PPP接続用パスワード]

PPP接続用ユーザID,パスワードを設定します。

 

9. <ppp0インタフェース設定>
nxrg050(config)#interface ppp 0
nxrg050(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスをnegotiatedに設定します。

nxrg050(config-ppp)#ip masquerade
nxrg050(config-ppp)#ip spi-filter

IPマスカレード、ステートフルパケットインスペクションを有効にします。

nxrg050(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

nxrg050(config-ppp)#ppp username [PPP接続用ユーザID]

PPP接続用ユーザIDを設定します。

nxrg050(config-ppp)#mobile apn [APN] cid 1 pdp-type ip

APN,CID,PDPタイプを設定します。

nxrg050(config-ppp)#dial-up string *99***1#

発信用の電話番号を設定します。
(☞) 電話番号の#の前の数字はCIDを表しています。

nxrg050(config-ppp)#dial-up timeout 30

ダイアルタイムアウトを設定します。

 

10. <モバイルエラーリカバリー設定>
nxrg050(config)#mobile error-recovery-reset

内蔵通信モジュールとの通信に重大な問題が発生する可能性が高いと判断した場合、内蔵通信モジュールのリセットを行うように設定します。

 

11. <モバイルターミネーションリカバリー設定>
nxrg050(config)#mobile termination-recovery reset

PPP接続時に網側から切断された場合、内蔵通信モジュールのリセットを行うように設定します。

 

12. <モバイル割り当て設定>
nxrg050(config)#mobile 2 ppp 0

mobile2として認識されている内蔵通信モジュールとppp0インタフェースの関連づけを行います。
内蔵通信モジュールをPPPインタフェースで使用する場合は、mobileコマンドによるPPPインタフェースへの関連付けが必要になります。
(☞) mobile2の情報はshow mobile 2コマンドで確認することができます。

 

13. <モバイルキャリア設定>
nxrg050(config)#mobile 2 carrier [キャリア]

mobile2のキャリアを設定します。
(☞) キャリア設定は「clear mobile 2」コマンドによるモバイルリセットを行うことで反映されます。

 

14. <DNS設定>
nxrg050(config)#dns
nxrg050(config-dns)#service enable

DNSサービスを有効にします。

 

15. <設定の保存>
nxrg050#save config

設定内容を保存します。

 

【 端末の設定例 】

有線端末 無線端末
IPアドレス DHCPサーバから取得
サブネットマスク
デフォルトゲートウェイ
DNSサーバ

 

【 付録 】