FutureNet

NXR,WXRシリーズ

NAT・フィルタ編

3. NAT/フィルタ応用設定

3-3. NATでのサーバ公開3(複数IP+Ethernet)設定

複数のグローバルIPアドレスが割り当てられている環境でLAN内のサーバにそれぞれ異なるグローバルIPアドレスでアクセスする設定例です。この例ではWAN回線にEthernetを利用します。

 

コンテンツ
構成図 設定フロー 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • この設定例では、接続しているISPのDNSサーバアドレスを以下とします。
    プライマリDNSサーバ:203.0.113.253
    セカンダリDNSサーバ:203.0.113.254

 

【 設定フロー 】

 

【 設定例 】

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24
nxrg100(config-if)#exit
nxrg100(config)#ip route 0.0.0.0/0 203.0.113.6
nxrg100(config)#ip dnat eth1_dnat tcp any any 203.0.113.1 80 192.168.10.10
nxrg100(config)#ip dnat eth1_dnat tcp any any 203.0.113.2 80 192.168.10.20
nxrg100(config)#ip access-list eth1_forward-in permit any 192.168.10.10 tcp any 80
nxrg100(config)#ip access-list eth1_forward-in permit any 192.168.10.20 tcp any 80
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#ip address 203.0.113.1/29
nxrg100(config-if)#ip address 203.0.113.2/29 secondary
nxrg100(config-if)#ip dnat-group eth1_dnat
nxrg100(config-if)#ip access-group forward-in eth1_forward-in
nxrg100(config-if)#ip masquerade
nxrg100(config-if)#ip spi-filter
nxrg100(config-if)#ip tcp adjust-mss auto
nxrg100(config-if)#exit
nxrg100(config)#dns
nxrg100(config-dns)#service enable
nxrg100(config-dns)#address 203.0.113.253
nxrg100(config-dns)#address 203.0.113.254
nxrg100(config-dns)#exit
nxrg100(config)#fast-forwarding enable
nxrg100(config)#exit
nxrg100#save config

 

【 設定例解説 】

1. <LAN側(ethernet0)インタフェース設定>
nxrg100(config)#interface ethernet 0
nxrg100(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

2. <スタティックルート設定>
nxrg100(config)#ip route 0.0.0.0/0 203.0.113.6

デフォルトルートを設定します。

 

3. <DNAT設定>
nxrg100(config)#ip dnat eth1_dnat tcp any any 203.0.113.1 80 192.168.10.10
nxrg100(config)#ip dnat eth1_dnat tcp any any 203.0.113.2 80 192.168.10.20

DNAT名をeth1_dnatとします。そして宛先IPアドレス203.0.113.1,宛先TCPポート番号80のパケットの宛先IPアドレスを192.168.10.10に、宛先IPアドレス203.0.113.2,宛先TCPポート番号80のパケットの宛先IPアドレスを192.168.10.20に変換します。
(☞) DNATを設定しただけでは宛先IPアドレスの変換機能は有効になりません。宛先IPアドレスの変換を行うインタフェースでの登録が必要になります。

 

4. <IPアクセスリスト設定>
nxrg100(config)#ip access-list eth1_forward-in permit any 192.168.10.10 tcp any 80
nxrg100(config)#ip access-list eth1_forward-in permit any 192.168.10.20 tcp any 80

IPアクセスリスト名をeth1_forward-inとします。そして宛先IPアドレス192.168.10.10,宛先TCPポート番号80、宛先IPアドレス192.168.10.20,宛先TCPポート番号80のパケットを許可します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

5. <WAN側(ethernet1)インタフェース設定>
nxrg100(config)#interface ethernet 1
nxrg100(config-if)#ip address 203.0.113.1/29
nxrg100(config-if)#ip address 203.0.113.2/29 secondary

ethernet1インタフェースのIPアドレスおよびセカンダリIPアドレスを設定します。

nxrg100(config-if)#ip dnat-group eth1_dnat
nxrg100(config-if)#ip access-group forward-in eth1_forward-in
nxrg100(config-if)#ip masquerade
nxrg100(config-if)#ip spi-filter
nxrg100(config-if)#ip tcp adjust-mss auto

eth1_dnatをDNATグループに、IPアクセスリストeth1_forward-inをforward-inフィルタに適用します。またIPマスカレード、ステートフルパケットインスペクションを有効に設定します。そしてTCP MSSの調整機能をオートに設定します。

 

6. <DNS設定>
nxrg100(config)#dns
nxrg100(config-dns)#service enable
nxrg100(config-dns)#address 203.0.113.253
nxrg100(config-dns)#address 203.0.113.254

DNSサービスを有効にします。またプロバイダから指定されたプライマリ,セカンダリのDNSサーバアドレスを設定します。

 

7. <ファストフォワーディング設定>
nxrg100(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを有効にすることでパケット転送を高速に処理することができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 端末の設定例 】

WWWサーバ1 WWWサーバ2
IPアドレス 192.168.10.10 192.168.10.20
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1
DNSサーバ 192.168.10.1

 

【 付録 】