FutureNet

NXR,WXRシリーズ

GRE・IPinIP編

2. GRE・IPinIP応用設定

2-1. GRE(IPinIP)経由でのインターネット接続設定

通常閉域網にのみ接続しているルータからインターネットアクセスすることはできませんが、この設定例ではGRE(IPinIP)を利用することで拠点間通信だけでなく、センタ経由でのインターネットアクセスも可能にします。

 

【 構成図 】

  • ルータNXR_Aではppp0インタフェースでインターネット接続,ppp1インタフェースでフレッツVPNワイドなどの閉域網に接続します。
  • ルータNXR_B,Cではppp0インタフェースでフレッツVPNワイドなどの閉域網に接続します。

 

【 設定データ 】

〔NXR_Aの設定〕

設定項目 設定内容
ホスト名 NXR_A
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
ip access-linkdown 有効
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0インタフェース
(インターネット側)
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
SPIフィルタ 有効
TCP MSS自動調整 オート
ISP接続用ユーザID test@example.jp
ISP接続用パスワード testpass
PPPoEクライアント(ethernet1) ppp1
ppp1インタフェース
(閉域網側)
ppp1のIPアドレス 10.10.10.1/32
TCP MSS自動調整 オート
ip send-source 有効
閉域網接続用ユーザID test1@example.jp
閉域網接続用パスワード test1pass
スタティックルート No.1 宛先IPアドレス 192.168.20.0/24
ゲートウェイ(インタフェース) tunnel1
ディスタンス 1
No.2 宛先IPアドレス 192.168.20.0/24
ゲートウェイ(インタフェース) null
ディスタンス 254
No.3 宛先IPアドレス 192.168.30.0/24
ゲートウェイ(インタフェース) tunnel2
ディスタンス 1
No.4 宛先IPアドレス 192.168.30.0/24
ゲートウェイ(インタフェース) null
ディスタンス 254
No.5 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
トンネル1インタフェース トンネルモード gre
名前 NXR_B
送信元IPアドレス 10.10.10.1
宛先IPアドレス 10.10.20.1
MTU 1430
TCP MSS自動調整 オート
TTL 255
トンネル2インタフェース トンネルモード gre
名前 NXR_C
送信元IPアドレス 10.10.10.1
宛先IPアドレス 10.10.30.1
MTU 1430
TCP MSS自動調整 オート
TTL 255
DNS サービス 有効
FastFowarding 有効

 〔NXR_Bの設定〕

設定項目 設定内容
ホスト名 NXR_B
LAN側インタフェース ethernet0のIPアドレス 192.168.20.1/24
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 10.10.20.1/32
TCP MSS自動調整 オート
ip send-source 有効
閉域網接続用ユーザID test2@example.jp
閉域網接続用パスワード test2pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) tunnel1
トンネル1インタフェース トンネルモード gre
名前 NXR_A
送信元IPアドレス 10.10.20.1
宛先IPアドレス 10.10.10.1
MTU 1430
TCP MSS自動調整 オート
TTL 255

 〔NXR_Cの設定〕

設定項目 設定内容
ホスト名 NXR_C
LAN側インタフェース ethernet0のIPアドレス 192.168.30.1/24
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 10.10.30.1/32
TCP MSS自動調整 オート
ip send-source 有効
閉域網接続用ユーザID test3@example.jp
閉域網接続用パスワード test3pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) tunnel1
トンネル1インタフェース トンネルモード gre
名前 NXR_A
送信元IPアドレス 10.10.30.1
宛先IPアドレス 10.10.10.1
MTU 1430
TCP MSS自動調整 オート
TTL 255

 

【 設定例 】

〔NXR_Aの設定〕

nxr230#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr230(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24
NXR_A(config-if)#ip access-linkdown
NXR_A(config-if)#exit
NXR_A(config)#ip route 192.168.20.0/24 tunnel 1 1
NXR_A(config)#ip route 192.168.20.0/24 null 254
NXR_A(config)#ip route 192.168.30.0/24 tunnel 2 1
NXR_A(config)#ip route 192.168.30.0/24 null 254
NXR_A(config)#ip route 0.0.0.0/0 ppp 0
NXR_A(config)#ppp account username test@example.jp password testpass
NXR_A(config)#ppp account username test1@example.jp password test1pass
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address negotiated
NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test@example.jp
NXR_A(config-ppp)#exit
NXR_A(config)#interface ppp 1
NXR_A(config-ppp)#ip address 10.10.10.1/32
NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ip send-source
NXR_A(config-ppp)#ppp username test1@example.jp
NXR_A(config-ppp)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#pppoe-client ppp 1
NXR_A(config-if)#exit
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode gre
NXR_A(config-tunnel)#description NXR_B
NXR_A(config-tunnel)#tunnel source 10.10.10.1
NXR_A(config-tunnel)#tunnel destination 10.10.20.1
NXR_A(config-tunnel)#mtu 1430
NXR_A(config-tunnel)#ip tcp adjust-mss auto
NXR_A(config-tunnel)#tunnel ttl 255
NXR_A(config-tunnel)#exit
NXR_A(config)#interface tunnel 2
NXR_A(config-tunnel)#tunnel mode gre
NXR_A(config-tunnel)#description NXR_C
NXR_A(config-tunnel)#tunnel source 10.10.10.1
NXR_A(config-tunnel)#tunnel destination 10.10.30.1
NXR_A(config-tunnel)#mtu 1430
NXR_A(config-tunnel)#ip tcp adjust-mss auto
NXR_A(config-tunnel)#tunnel ttl 255
NXR_A(config-tunnel)#exit
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#exit
NXR_A(config)#fast-forwarding enable
NXR_A(config)#exit
NXR_A#save config

〔NXR_Bの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.20.1/24
NXR_B(config-if)#exit
NXR_B(config)#ip route 0.0.0.0/0 tunnel 1
NXR_B(config)#ppp account username test2@example.jp password test2pass
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address 10.10.20.1/32
NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ip send-source
NXR_B(config-ppp)#ppp username test2@example.jp
NXR_B(config-ppp)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0
NXR_B(config-if)#exit
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode gre
NXR_B(config-tunnel)#description NXR_A
NXR_B(config-tunnel)#tunnel source 10.10.20.1
NXR_B(config-tunnel)#tunnel destination 10.10.10.1
NXR_B(config-tunnel)#mtu 1430
NXR_B(config-tunnel)#ip tcp adjust-mss auto
NXR_B(config-tunnel)#tunnel ttl 255
NXR_B(config-tunnel)#exit
NXR_B(config)#exit
NXR_B#save config

 〔NXR_Cの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_C
NXR_C(config)#interface ethernet 0
NXR_C(config-if)#ip address 192.168.30.1/24
NXR_C(config-if)#exit
NXR_C(config)#ip route 0.0.0.0/0 tunnel 1
NXR_C(config)#ppp account username test3@example.jp password test3pass
NXR_C(config)#interface ppp 0
NXR_C(config-ppp)#ip address 10.10.30.1/32
NXR_C(config-ppp)#ip tcp adjust-mss auto
NXR_C(config-ppp)#ip send-source
NXR_C(config-ppp)#ppp username test3@example.jp
NXR_C(config-ppp)#exit
NXR_C(config)#interface ethernet 1
NXR_C(config-if)#no ip address
NXR_C(config-if)#pppoe-client ppp 0
NXR_C(config-if)#exit
NXR_C(config)#interface tunnel 1
NXR_C(config-tunnel)#tunnel mode gre
NXR_C(config-tunnel)#description NXR_A
NXR_C(config-tunnel)#tunnel source 10.10.30.1
NXR_C(config-tunnel)#tunnel destination 10.10.10.1
NXR_C(config-tunnel)#mtu 1430
NXR_C(config-tunnel)#ip tcp adjust-mss auto
NXR_C(config-tunnel)#tunnel ttl 255
NXR_C(config-tunnel)#exit
NXR_C(config)#exit
NXR_C#save config

 

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxr230(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

NXR_A(config-if)#ip access-linkdown

リンクダウン状態でもLAN側(ethernet0)インタフェースのIPアドレスに対して通信できるように設定します。

 

3. <スタティックルート設定>
NXR_A(config)#ip route 192.168.20.0/24 tunnel 1
NXR_A(config)#ip route 192.168.20.0/24 null 254

LAN_B向けのルートを設定します。なおトンネルインタフェース無効時はnullインタフェースのルートを利用するように設定します。
(☞) nullインタフェースが出力インタフェースとして有効な場合、パケットが出力されることはありません(ドロップされます)。

NXR_A(config)#ip route 192.168.30.0/24 tunnel 2
NXR_A(config)#ip route 192.168.30.0/24 null 254

LAN_C向けのルートを設定します。なおトンネルインタフェース無効時はnullインタフェースのルートを利用するように設定します。

NXR_A(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <PPPアカウント設定>
NXR_A(config)#ppp account username test@example.jp password testpass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

NXR_A(config)#ppp account username test1@example.jp password test1pass

ppp1インタフェースで使用する閉域網接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp1インタフェースの設定で利用します。

 

5. <WAN側(ppp0)インタフェース設定>
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスが動的IPアドレスのためnegotiatedを設定します。

NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またTCP MSSの調整機能をオートに設定します。

NXR_A(config-ppp)#ppp username test@example.jp

ISP接続用ユーザIDを設定します。

 

6. <WAN側(ppp1)インタフェース設定>
NXR_A(config)#interface ppp 1
NXR_A(config-ppp)#ip address 10.10.10.1/32

ppp1インタフェースのIPアドレスを設定します。

NXR_A(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

NXR_A(config-ppp)#ip send-source

ip send-sourceを有効に設定します。
(☞) ip send-source機能はPPPインタフェースに設定されているIPアドレスを送信元IPアドレスとするパケットを送信する際、必ずIPアドレスの所有者であるPPPインタフェースから出力する機能です。

NXR_A(config-ppp)#ppp username test1@example.jp

閉域網接続用ユーザIDを設定します。

 

7. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#pppoe-client ppp 1

PPPoEクライアントとしてppp0,ppp1インタフェースを使用できるように設定します。

 

8. <トンネル1インタフェース設定>
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode gre
NXR_A(config-tunnel)#description NXR_B

トンネル1インタフェースで使用するトンネルモードを設定します。
またトンネルインタフェースの説明としてNXR_Bを設定します。

NXR_A(config-tunnel)#tunnel source 10.10.10.1
NXR_A(config-tunnel)#tunnel destination 10.10.20.1

トンネルの送信元,宛先IPアドレスを設定します。

NXR_A(config-tunnel)#mtu 1430

トンネルインタフェースのMTU値に1430を設定します。
(☞) この設定例ではPPPoE接続時のWAN側インタフェースのMTU値として1454を想定しています。またGREのオプションは使用していないものとします。

NXR_A(config-tunnel)#ip tcp adjust-mss auto
NXR_A(config-tunnel)#tunnel ttl 255

TCP MSSの調整機能をオートに設定します。またTTL値を設定します。

 

9. <トンネル2インタフェース設定>
NXR_A(config)#interface tunnel 2
NXR_A(config-tunnel)#tunnel mode gre
NXR_A(config-tunnel)#description NXR_C

トンネル2インタフェースで使用するトンネルモードを設定します。
またトンネルインタフェースの説明としてNXR_Cを設定します。

NXR_A(config-tunnel)#tunnel source 10.10.10.1
NXR_A(config-tunnel)#tunnel destination 10.10.30.1

トンネルの送信元,宛先IPアドレスを設定します。

NXR_A(config-tunnel)#mtu 1430

トンネルインタフェースのMTU値に1430を設定します。

NXR_A(config-tunnel)#ip tcp adjust-mss auto
NXR_A(config-tunnel)#tunnel ttl 255

TCP MSSの調整機能をオートに設定します。またTTL値を設定します。

 

10. <DNS設定>
NXR_A(config)#dns
NXR_A(config-dns)#service enable

DNSサービスを有効にします。

 

11. <ファストフォワーディングの有効化>
NXR_A(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.20.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_B(config)#ip route 0.0.0.0/0 tunnel 1

デフォルトルートを設定します。
(☞) 拠点間通信だけでなくインターネット向けのパケットもGRE(IPinIP)トンネルを経由するように設定します。

 

4. <PPPアカウント設定>
NXR_B(config)#ppp account username test2@example.jp password test2pass

ppp0インタフェースで使用する閉域網接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

5. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address 10.10.20.1/32

ppp0インタフェースのIPアドレスを設定します。

NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ip send-source
NXR_B(config-ppp)#ppp username test2@example.jp

TCP MSSの調整機能をオート、ip send-sourceを有効に設定します。また閉域網接続用ユーザIDを設定します。

 

6. <ethernet1インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

7. <トンネル1インタフェース設定>
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode gre
NXR_B(config-tunnel)#description NXR_A

トンネル1インタフェースで使用するトンネルモードを設定します。
またトンネルインタフェースの説明としてNXR_Aを設定します。

NXR_B(config-tunnel)#tunnel source 10.10.20.1
NXR_B(config-tunnel)#tunnel destination 10.10.10.1

トンネルの送信元,宛先IPアドレスを設定します。

NXR_B(config-tunnel)#mtu 1430

トンネルインタフェースのMTU値に1430を設定します。
(☞) この設定例ではPPPoE接続時のWAN側インタフェースのMTU値として1454を想定しています。またGREのオプションは使用していないものとします。

NXR_B(config-tunnel)#ip tcp adjust-mss auto
NXR_B(config-tunnel)#tunnel ttl 255

TCP MSSの調整機能をオートに設定します。またTTL値を設定します。

 

〔NXR_Cの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_C

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_C(config)#interface ethernet 0
NXR_C(config-if)#ip address 192.168.30.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_C(config)#ip route 0.0.0.0/0 tunnel 1

デフォルトルートを設定します。

 

4. <PPPアカウント設定>
NXR_C(config)#ppp account username test3@example.jp password test3pass

ppp0インタフェースで使用する閉域網接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

5. <WAN側(ppp0)インタフェース設定>
NXR_C(config)#interface ppp 0
NXR_C(config-ppp)#ip address 10.10.30.1/32

ppp0インタフェースのIPアドレスを設定します。

NXR_C(config-ppp)#ip tcp adjust-mss auto
NXR_C(config-ppp)#ip send-source
NXR_C(config-ppp)#ppp username test3@example.jp

TCP MSSの調整機能をオート、ip send-sourceを有効に設定します。また閉域網接続用ユーザIDを設定します。

 

6. <ethernet1インタフェース設定>
NXR_C(config)#interface ethernet 1
NXR_C(config-if)#no ip address
NXR_C(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

7. <トンネル1インタフェース設定>
NXR_C(config)#interface tunnel 1
NXR_C(config-tunnel)#tunnel mode gre
NXR_C(config-tunnel)#description NXR_A

トンネル1インタフェースで使用するトンネルモードを設定します。またトンネルインタフェースの説明としてNXR_Aを設定します。

NXR_C(config-tunnel)#tunnel source 10.10.30.1
NXR_C(config-tunnel)#tunnel destination 10.10.10.1

トンネルの送信元,宛先IPアドレスを設定します。

NXR_C(config-tunnel)#mtu 1430

トンネルインタフェースのMTU値に1430を設定します。
(☞) この設定例ではPPPoE接続時のWAN側インタフェースのMTU値として1454を想定しています。またGREのオプションは使用していないものとします。

NXR_C(config-tunnel)#ip tcp adjust-mss auto
NXR_C(config-tunnel)#tunnel ttl 255

TCP MSSの調整機能をオートに設定します。またTTL値を設定します。

 

【 補足 】

IPinIPを利用する場合はトンネルインタフェース設定のtunnel modeでipipを設定します。

<IPinIP設定>
(config)#interface tunnel [インタフェースナンバ]
(config-tunnel)#tunnel mode ipip

トンネルインタフェースで使用するトンネルモードをipipに設定します。