FutureNet

NXR,WXRシリーズ

無線LAN編

1. 無線LAN設定(NXR-G100シリーズ,WXR-250)

1-7. 無線LAN設定7(RADIUS連携)

この設定例ではWXRシリーズが対応しているWPA-EAP/WPA2-EAPを利用し、RADIUSサーバと連携することでIEEE802.1X認証を行います。

 

【対象機種】WXR-250

 

【 構成図 】

 

【 設定データ 】

設定項目 設定内容
有線LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
無線LAN側インタフェース wlan0のIPアドレス 192.168.11.1/24
動作モード アクセスポイント
SSID wxrwlan0
認証方式 WPA2-EAP
暗号方式 AES
RADIUS サーバのIPアドレス 192.168.10.254
パスワード wxrpass
ポート番号 1812
NAS-IP-Address 192.168.11.1
NAS-Identifier wxrw0
ANY接続 拒否しない
SSID隠蔽 しない
プライバシープロテクション 無効
接続台数制限 32台
無線モジュール(wifi0) 無線方式 11ng
チャネル オート
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
SPIフィルタ 有効
TCP MSS自動調整 オート
ISP接続用ユーザID test1@example.jp
ISP接続用パスワード test1pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
DHCPサーバ No.1 IPアドレス払い出し範囲(始点) 192.168.11.200
IPアドレス払い出し範囲(終点) 192.168.11.210
ゲートウェイ 192.168.11.1
プライマリDNSサーバ 192.168.11.1
DNS サービス 有効

【 設定例 】

wxr250#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
wxr250(config)#interface ethernet 0
wxr250(config-if)#ip address 192.168.10.1/24
wxr250(config-if)#exit
wxr250(config)#interface wlan 0
wxr250(config-wlan)#ip address 192.168.11.1/24
wxr250(config-wlan)#wlan mode access-point
wxr250(config-wlan)#wlan ssid wxrwlan0
wxr250(config-wlan)#wlan radius authentication 192.168.10.254 password wxrpass port 1812
wxr250(config-wlan)#wlan radius attribute nas-ip-address 192.168.11.1
wxr250(config-wlan)#wlan radius attribute nas-identifier wxrw0
wxr250(config-wlan)#wlan authenticate wpa2-eap aes
wxr250(config-wlan)#wlan guest-mode enable
wxr250(config-wlan)#wlan access-point-bridge enable
wxr250(config-wlan)#wlan max-associations 32
wxr250(config-wlan)#exit
wxr250(config)#wifi 0
wxr250(config-wifi)#mode 11ng
wxr250(config-wifi)#channel auto
wxr250(config-wifi)#exit
% Executing DFS/channel auto, Please Wait.
wxr250(config)#dhcp-server 1
wxr250(config-dhcps)#network 192.168.11.0/24 range 192.168.11.200 192.168.11.210
wxr250(config-dhcps)#gateway 192.168.11.1
wxr250(config-dhcps)#dns-server 192.168.11.1
wxr250(config-dhcps)#exit
wxr250(config)#ip route 0.0.0.0/0 ppp 0
wxr250(config)#ppp account username test1@example.jp password test1pass
wxr250(config)#interface ppp 0
wxr250(config-ppp)#ip address negotiated
wxr250(config-ppp)#ip masquerade
wxr250(config-ppp)#ip spi-filter
wxr250(config-ppp)#ip tcp adjust-mss auto
wxr250(config-ppp)#ppp username test1@example.jp
wxr250(config-ppp)#exit
wxr250(config)#interface ethernet 1
wxr250(config-if)#no ip address
wxr250(config-if)#pppoe-client ppp 0
wxr250(config-if)#exit
wxr250(config)#dns
wxr250(config-dns)#service enable
wxr250(config-dns)#exit
wxr250(config)#exit
wxr250#save config

【 設定例解説 】

1. <有線LAN側(ethernet0)インタフェース設定>
wxr250(config)#interface ethernet 0
wxr250(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

2. <無線LAN側(wlan0)インタフェース設定>
wxr250(config)#interface wlan 0
wxr250(config-wlan)#ip address 192.168.11.1/24

wlan0インタフェースのIPアドレスを設定します。

wxr250(config-wlan)#wlan mode access-point
wxr250(config-wlan)#wlan ssid wxrwlan0

動作モード、SSIDを設定します。

wxr250(config-wlan)#wlan radius authentication 192.168.10.254 password wxrpass port 1812

RADIUSサーバのIPアドレス,パスワード,ポート番号を設定します。

wxr250(config-wlan)#wlan radius attribute nas-ip-address 192.168.11.1

RADIUSサーバに通知するアトリビュートとしてNAS-IP-Addressを設定します。

wxr250(config-wlan)#wlan radius attribute nas-identifier wxrw0

RADIUSサーバに通知するアトリビュートとしてNAS-Identifierを設定します。

wxr250(config-wlan)#wlan authenticate wpa2-eap aes

認証方式と暗号方式を設定します。

wxr250(config-wlan)#wlan guest-mode enable
wxr250(config-wlan)#wlan access-point-bridge enable
wxr250(config-wlan)#wlan max-associations 32

ゲストモード、アクセスポイントブリッジ(プライバシープロテクション)を有効に設定します。また接続台数制限を設定します。

 

3. <無線モジュール(wifi0)設定>
wxr250(config)#wifi 0
wxr250(config-wifi)#mode 11ng
wxr250(config-wifi)#channel auto

無線方式、チャネルを設定します。

 

4. <DHCPサーバ設定>
wxr250(config)#dhcp-server 1
wxr250(config-dhcps)#network 192.168.11.0/24 range 192.168.11.200 192.168.11.210
wxr250(config-dhcps)#gateway 192.168.11.1
wxr250(config-dhcps)#dns-server 192.168.11.1

DHCPサーバのサーバナンバを1とし、配布するIPアドレス情報を設定します。
(☞) このDHCPサーバはSSID「wxrwlan0」用となります。またwlan0インタフェースで動作します。

 

5. <スタティックルート設定>
wxr250(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

6. <PPPアカウント設定>
wxr250(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

7. <WAN側(ppp0)インタフェース設定>
wxr250(config)#interface ppp 0
wxr250(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスが動的IPアドレスの場合はnegotiatedを設定します。

wxr250(config-ppp)#ip masquerade
wxr250(config-ppp)#ip spi-filter
wxr250(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またTCP MSSの調整機能をオートに設定します。

wxr250(config-ppp)#ppp username test1@example.jp

ISP接続用ユーザIDを設定します。

 

8. <ethernet1インタフェース設定>
wxr250(config)#interface ethernet 1
wxr250(config-if)#no ip address
wxr250(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

9. <DNS設定>
wxr250(config)#dns
wxr250(config-dns)#service enable

DNSサービスを有効にします。

 

【 端末の設定例 】

192.168.10.0/24 192.168.11.0/24
RADIUSサーバ 無線端末
IPアドレス 192.168.10.100 DHCPサーバから取得
サブネットマスク 255.255.255.0
デフォルトゲートウェイ
DNSサーバ