FutureNet

NXR,WXRシリーズ

VXRシリーズ編

5. VXR-x64(AWS)IPsec接続設定

5-2. VXR-x64(AWS)IPsec接続設定(IPv6)

Amazon Web Services(以下AWS)上でセットアップしたVXR-x64とNXRシリーズでIPv4 over IPv6のIPsec接続を行う設定例です。

※Amazon Web Services、“Powered by Amazon Web Services”ロゴ、およびかかる資料で使用されるその他のAWS商標は、米国その他の諸国における、Amazon.com, Inc.またはその関連会社の商標です。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 補足 付録

 

【 構成図 】

  • AWS側のセキュリティグループで、IPsec用に以下のインバウンドルールを追加します。
    ※VXR-x64へのSSHアクセス用ルール等はすでに作成済みとします。

    タイプ プロトコル ポート範囲 ソース
    カスタムUDPルール UDP 500 ::/0
    ESP (50) ESP (50) すべて ::/0

 

【 設定例 】

〔VXRの設定〕

vxr-x64#configure terminal
vxr-x64(config)#hostname VXR
VXR(config)#ipv6 dhcp-client ipv6dhcpc
VXR(config-dhcp6c)#ia-na enable
VXR(config-dhcp6c)#exit
VXR(config)#interface ethernet 1
VXR(config-if)#ip address 10.0.1.254/24
VXR(config-if)#exit
VXR(config)#ip route 192.168.10.0/24 tunnel 1 1
VXR(config)#ip route 192.168.10.0/24 null 254
VXR(config)#ipv6 route ::/0 dhcp ethernet 0
VXR(config)#ipsec access-list ipsec_acl ip any any
VXR(config)#ipsec local policy 1
VXR(config-ipsec-local)#address ipv6
VXR(config-ipsec-local)#self-identity fqdn vxr
VXR(config-ipsec-local)#exit
VXR(config)#ipsec isakmp policy 1
VXR(config-ipsec-isakmp)#description NXR
VXR(config-ipsec-isakmp)#authentication pre-share ipseckey
VXR(config-ipsec-isakmp)#hash sha256
VXR(config-ipsec-isakmp)#encryption aes128
VXR(config-ipsec-isakmp)#group 5
VXR(config-ipsec-isakmp)#lifetime 86400
VXR(config-ipsec-isakmp)#isakmp-mode aggressive
VXR(config-ipsec-isakmp)#remote address ipv6 [NXRのFQDN]
VXR(config-ipsec-isakmp)#remote identity fqdn nxr
VXR(config-ipsec-isakmp)#keepalive 30 3 periodic restart
VXR(config-ipsec-isakmp)#local policy 1
VXR(config-ipsec-isakmp)#exit
VXR(config)#interface tunnel 1
VXR(config-tunnel)#tunnel mode ipsec ipv6
VXR(config-tunnel)#tunnel protection ipsec policy 1
VXR(config-tunnel)#ip tcp adjust-mss auto
VXR(config-tunnel)#exit
VXR(config)#ipsec tunnel policy 1
VXR(config-ipsec-tunnel)#description NXR
VXR(config-ipsec-tunnel)#negotiation-mode auto
VXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha256-hmac
VXR(config-ipsec-tunnel)#set pfs group5
VXR(config-ipsec-tunnel)#set sa lifetime 28800
VXR(config-ipsec-tunnel)#set key-exchange isakmp 1
VXR(config-ipsec-tunnel)#match address ipsec_acl
VXR(config-ipsec-tunnel)#exit
VXR(config)#interface ethernet 0
VXR(config-if)#ipv6 address dhcp ipv6dhcpc
VXR(config-if)#ipsec policy 1
VXR(config-if)#exit
VXR(config)#ddns
VXR(config-ddns)#service enable
VXR(config-ddns)#ddns-provider http-client
VXR(config-ddns)#account username [VXRのDDNSユーザID] password [VXRのDDNSパスワード]
VXR(config-ddns)#bind-interface ethernet 0
VXR(config-ddns)#url ipv6 [DDNSのURL]
VXR(config-ddns)#query [DDNSのクエリ]
VXR(config-ddns)#forced-update-interval 1
VXR(config-ddns)#exit
VXR(config)#dns
VXR(config-dns)#service enable
VXR(config-dns)#edns-query enable
VXR(config-dns)#exit
VXR(config)#fast-forwarding enable
VXR(config)#exit
VXR#save config

 

〔NXRの設定〕

nxrg110#configure terminal
nxrg110(config)#hostname NXR
NXR(config)#ipv6 dhcp-client ipv6dhcpc
NXR(config-dhcp6c)#information-only enable
NXR(config-dhcp6c)#option-request dns-servers
NXR(config-dhcp6c)#exit
NXR(config)#interface ethernet 0
NXR(config-if)#ip address 192.168.10.1/24
NXR(config-if)#exit
NXR(config)#ip route 10.0.1.0/24 tunnel 1 1
NXR(config)#ip route 10.0.1.0/24 null 254
NXR(config)#ipv6 access-list ppp0_in permit any any icmpv6
NXR(config)#ipv6 access-list ppp0_in permit any any udp any 546
NXR(config)#ipv6 access-list ppp0_in permit any any udp any 500
NXR(config)#ipv6 access-list ppp0_in permit any any 50
NXR(config)#ipsec access-list ipsec_acl ip any any
NXR(config)#ipsec local policy 1
NXR(config-ipsec-local)#address ipv6
NXR(config-ipsec-local)#self-identity fqdn nxr
NXR(config-ipsec-local)#exit
NXR(config)#ipsec isakmp policy 1
NXR(config-ipsec-isakmp)#description VXR
NXR(config-ipsec-isakmp)#authentication pre-share ipseckey
NXR(config-ipsec-isakmp)#hash sha256
NXR(config-ipsec-isakmp)#encryption aes128
NXR(config-ipsec-isakmp)#group 5
NXR(config-ipsec-isakmp)#lifetime 86400
NXR(config-ipsec-isakmp)#isakmp-mode aggressive
NXR(config-ipsec-isakmp)#remote address ipv6 [VXRのFQDN]
NXR(config-ipsec-isakmp)#remote identity fqdn vxr
NXR(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR(config-ipsec-isakmp)#local policy 1
NXR(config-ipsec-isakmp)#exit
NXR(config)#interface tunnel 1
NXR(config-tunnel)#tunnel mode ipsec ipv6
NXR(config-tunnel)#tunnel protection ipsec policy 1
NXR(config-tunnel)#ip tcp adjust-mss auto
NXR(config-tunnel)#exit
NXR(config)#ipsec tunnel policy 1
NXR(config-ipsec-tunnel)#description VXR
NXR(config-ipsec-tunnel)#negotiation-mode auto
NXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha256-hmac
NXR(config-ipsec-tunnel)#set pfs group5
NXR(config-ipsec-tunnel)#set sa lifetime 28800
NXR(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR(config-ipsec-tunnel)#match address ipsec_acl
NXR(config-ipsec-tunnel)#exit
NXR(config)#ppp account username [PPP接続用ユーザID] password [PPP接続用パスワード]
NXR(config)#interface ppp 0
NXR(config-ppp)#no ip address
NXR(config-ppp)#no ppp ipcp enable
NXR(config-ppp)#ppp ipv6cp enable
NXR(config-ppp)#ipv6 address autoconfig
NXR(config-ppp)#ipv6 dhcp client ipv6dhcpc
NXR(config-ppp)#ipv6 access-group in ppp0_in
NXR(config-ppp)#ipv6 spi-filter
NXR(config-ppp)#ipv6 tcp adjust-mss auto
NXR(config-ppp)#ppp username [PPP接続用ユーザID]
NXR(config-ppp)#mobile apn [APN] cid 1 pdp-type ipv6
NXR(config-ppp)#dial-up string *99***1#
NXR(config-ppp)#dial-up timeout 30
NXR(config-ppp)#ipsec policy 1
NXR(config-ppp)#exit
NXR(config)#mobile error-recovery-reset
NXR(config)#mobile termination-recovery reset
NXR(config)#mobile 1 ppp 0
NXR(config)#mobile 1 carrier [キャリア]
NXR(config)#exit
NXR#clear mobile 1
NXR#configure terminal
NXR(config)#ddns
NXR(config-ddns)#service enable
NXR(config-ddns)#ddns-provider http-client
NXR(config-ddns)#account username [NXRのDDNSユーザID] password [NXRのDDNSパスワード]
NXR(config-ddns)#bind-interface ppp 0
NXR(config-ddns)#url ipv6 [DDNSのURL]
NXR(config-ddns)#query [DDNSのクエリ]
NXR(config-ddns)#forced-update-interval 1
NXR(config-ddns)#exit
NXR(config)#dns
NXR(config-dns)#service enable
NXR(config-dns)#edns-query enable
NXR(config-dns)#exit
NXR(config)#exit
NXR#save config

 

【 設定例解説 】

〔VXRの設定〕

1. <ホスト名の設定>
vxr-x64(config)#hostname VXR

ホスト名を設定します。

 

2. <DHCPv6クライアント設定>
VXR(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

VXR(config-dhcp6c)#ia-na enable

Identity Association for Non-temporary Addresses(IANA)を有効にします。

 

3. <LAN側(ethernet1)インタフェース設定>
VXR(config)#interface ethernet 1
VXR(config-if)#ip address 10.0.1.254/24

ethernet1インタフェースのIPアドレスを設定します。

 

4. <IPv4スタティックルート設定>
VXR(config)#ip route 192.168.10.0/24 tunnel 1 1
VXR(config)#ip route 192.168.10.0/24 null 254

192.168.10.0/24向けのルートを設定します。
(☞) IPsec SA確立時はトンネル1インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。

 

5. <IPv6スタティックルート設定>
VXR(config)#ipv6 route ::/0 dhcp ethernet 0

IPv6デフォルトルートを設定します。

 

6. <IPsecアクセスリスト設定>
VXR(config)#ipsec access-list ipsec_acl ip any any

送信元IPアドレス,宛先IPアドレスともにanyのIPsecアクセスリストipsec_aclを設定します。

 

7. <IPsecローカルポリシー設定>
VXR(config)#ipsec local policy 1
VXR(config-ipsec-local)#address ipv6

IPsecトンネルの送信元IPアドレスにipv6を設定します。

VXR(config-ipsec-local)#self-identity fqdn vxr

セルフID(FQDN方式)を設定します。
(☞) NXRのIPsec ISAKMPポリシー1のリモートIDと同じIDを設定します。

 

8. <IPsec ISAKMPポリシー設定>
VXR(config)#ipsec isakmp policy 1
VXR(config-ipsec-isakmp)#description NXR

ISAKMPポリシー1の説明文を設定します。

VXR(config-ipsec-isakmp)#authentication pre-share ipseckey

認証方式としてpre-share(事前共有鍵)を選択し、事前共有鍵を設定します。
(☞) 事前共有鍵はNXRのipsec isakmp policy 1と共通の値を設定します。

VXR(config-ipsec-isakmp)#hash sha256

認証アルゴリズムをsha256に設定します。

VXR(config-ipsec-isakmp)#encryption aes128

暗号化アルゴリズムをaes128に設定します。

VXR(config-ipsec-isakmp)#group 5

DH(Diffie-Hellman)グループをgroup 5に設定します。

VXR(config-ipsec-isakmp)#lifetime 86400

ISAKMP SAのライフタイムを設定します。

VXR(config-ipsec-isakmp)#isakmp-mode aggressive

フェーズ1のネゴシエーションモードをアグレッシブモードに設定します。

VXR(config-ipsec-isakmp)#remote address ipv6 [NXRのFQDN]

リモートアドレスにNXRのFQDNを設定します。

VXR(config-ipsec-isakmp)#remote identity fqdn nxr

リモートID(FQDN方式)を設定します。
(☞) NXRのセルフIDと同じIDを設定します。

VXR(config-ipsec-isakmp)#keepalive 30 3 periodic restart

IKE KeepAlive(DPD)を監視間隔30秒、リトライ回数3回、keepalive失敗時にSAを削除しIKEのネゴシエーションを開始するように設定します。

VXR(config-ipsec-isakmp)#local policy 1

このIPsec ISAKMPポリシーで使用するIPsecローカルポリシーを設定します。

 

9. <トンネル1インタフェース設定>
VXR(config)#interface tunnel 1
VXR(config-tunnel)#tunnel mode ipsec ipv6

トンネル1インタフェースのトンネルモードをipsec ipv6に設定します。

VXR(config-tunnel)#tunnel protection ipsec policy 1

このトンネルインタフェースで使用するIPsecトンネルポリシーを設定します。

VXR(config-tunnel)#ip tcp adjust-mss auto

IPv4 TCP MSSの調整機能をオートに設定します。

 

10. <IPsec トンネルポリシー設定>
VXR(config)#ipsec tunnel policy 1
VXR(config-ipsec-tunnel)#description NXR

IPsecトンネルポリシー1の説明文を設定します。

VXR(config-ipsec-tunnel)#negotiation-mode auto

ネゴシエーションモードをautoに設定します。

VXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha256-hmac

暗号化アルゴリズムをaes128、認証アルゴリズムをsha256に設定します。

VXR(config-ipsec-tunnel)#set pfs group5

PFSを有効、DHグループをgroup5に設定します。

VXR(config-ipsec-tunnel)#set sa lifetime 28800

IPsec SAのライフタイムを設定します。

VXR(config-ipsec-tunnel)#set key-exchange isakmp 1

このIPsecトンネルポリシーで使用するIPsec ISAKMPポリシーを設定します。

VXR(config-ipsec-tunnel)#match address ipsec_acl

IPsecアクセスリストを設定します。

 

11. <WAN側(ethernet0)インタフェース設定>
VXR(config)#interface ethernet 0
VXR(config-if)#ipv6 address dhcp ipv6dhcpc

ethernet0インタフェースのIPv6アドレスを設定します。
(☞) DHCPv6クライアント名を設定し、DHCPv6クライアントを有効にします。

VXR(config-if)#ipsec policy 1

このインタフェースで使用するIPsecローカルポリシーを設定します。

 

12. <DDNS設定>

※ここでは一般的なDDNSの設定例を掲載しています。DDNSの設定例についてはこちらもご参照ください。

VXR(config)#ddns
VXR(config-ddns)#service enable

DDNSサービスを有効にします。

VXR(config-ddns)#ddns-provider http-client

接続するDDNSプロバイダにhttp-client(汎用プロバイダ)を設定します。

VXR(config-ddns)#account username [VXRのDDNSユーザID] password [VXRのDDNSパスワード]

VXRのDDNSユーザID,パスワードを設定します。

VXR(config-ddns)#bind-interface ethernet 0

接続回線のインタフェースを設定します。

VXR(config-ddns)#url ipv6 [DDNSのURL]

DDNS接続用URLを設定します。

VXR(config-ddns)#query [DDNSのクエリ]

HTTPクエリを設定します。

VXR(config-ddns)#forced-update-interval 1

IPアドレス変更通知を1時間毎に送信するように設定します。
(☞) IPアドレス変更の有無に関わらず送信する間隔を設定します。

 

13. <DNS設定>
VXR(config)#dns
VXR(config-dns)#service enable

DNSサービスを有効にします。

VXR(config-dns)#edns-query enable

EDNSを有効にします。

 

14. <ファストフォワーディング設定>
VXR(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

 

15. <設定の保存>
VXR#save config

設定内容を保存します。

 

〔NXRの設定〕

1. <ホスト名の設定>
nxrg110(config)#hostname NXR

ホスト名を設定します。

 

2. <DHCPv6クライアント設定>
NXR(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

NXR(config-dhcp6c)#information-only enable

information-only機能を有効にします。

NXR(config-dhcp6c)#option-request dns-servers

DHCPv6サーバに対してDNSサーバアドレスの通知を要求するように設定します。

 

3. <LAN側(ethernet0)インタフェース設定>
NXR(config)#interface ethernet 0
NXR(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

4. <IPv4スタティックルート設定>
NXR(config)#ip route 10.0.1.0/24 tunnel 1 1
NXR(config)#ip route 10.0.1.0/24 null 254

10.0.1.0/24向けのルートを設定します。

 

5. <IPv6アクセスリスト設定>
NXR(config)#ipv6 access-list ppp0_in permit any any icmpv6
NXR(config)#ipv6 access-list ppp0_in permit any any udp any 546
NXR(config)#ipv6 access-list ppp0_in permit any any udp any 500
NXR(config)#ipv6 access-list ppp0_in permit any any 50

IPv6アクセスリストppp0_inを以下のルールで設定します。

  • ICMPv6を許可
  • 宛先UDPポート546番(DHCPv6クライアント)を許可
  • 宛先UDPポート500番を許可
  • ESP(プロトコル番号50)を許可

(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

6. <IPsecアクセスリスト設定>
NXR(config)#ipsec access-list ipsec_acl ip any any

送信元,宛先IPアドレスともにanyのIPsecアクセスリストipsec_aclを設定します。

 

7. <IPsecローカルポリシー設定>
NXR(config)#ipsec local policy 1
NXR(config-ipsec-local)#address ipv6

IPsecトンネルの送信元IPアドレスにip(IPv6)を設定します。

NXR(config-ipsec-local)#self-identity fqdn nxr

セルフID(FQDN方式)を設定します。
(☞) VXRのIPsec ISAKMPポリシー1のリモートIDと同じIDを設定します。

 

8. <IPsec ISAKMPポリシー設定>
NXR(config)#ipsec isakmp policy 1
NXR(config-ipsec-isakmp)#description VXR

ISAKMPポリシー1の説明文を設定します。

NXR(config-ipsec-isakmp)#authentication pre-share ipseckey

認証方式にpre-share(事前共有鍵)を選択し、事前共有鍵を設定します。
(☞) 事前共有鍵はVXRのipsec isakmp policy 1と共通の値を設定します。

NXR(config-ipsec-isakmp)#hash sha256

認証アルゴリズムをsha256に設定します。

NXR(config-ipsec-isakmp)#encryption aes128

暗号化アルゴリズムをaes128に設定します。

NXR(config-ipsec-isakmp)#group 5

DHグループをgroup 5に設定します。

NXR(config-ipsec-isakmp)#lifetime 86400

ISAKMP SAのライフタイムを設定します。

NXR(config-ipsec-isakmp)#isakmp-mode aggressive

フェーズ1のネゴシエーションモードをアグレッシブモードに設定します。

NXR(config-ipsec-isakmp)#remote address ipv6 [VXRのFQDN]

リモートアドレスにVXRのFQDNを設定します。

NXR(config-ipsec-isakmp)#remote identity fqdn vxr

リモートID(FQDN方式)を設定します。
(☞) VXRのセルフIDと同じIDを設定します。

NXR(config-ipsec-isakmp)#keepalive 30 3 periodic restart

IKE KeepAlive(DPD)を監視間隔30秒、リトライ回数3回、keepalive失敗時にSAを削除しIKEのネゴシエーションを開始するように設定します。

NXR(config-ipsec-isakmp)#local policy 1

このIPsec ISAKMPポリシーで使用するIPsecローカルポリシーを設定します。

 

9. <トンネル1インタフェース設定>
NXR(config)#interface tunnel 1
NXR(config-tunnel)#tunnel mode ipsec ipv6

トンネル1インタフェースのトンネルモードをipsec ipv6に設定します。

NXR(config-tunnel)#tunnel protection ipsec policy 1

このトンネルインタフェースで使用するIPsecトンネルポリシーを設定します。

NXR(config-tunnel)#ip tcp adjust-mss auto

IPv4 TCP MSSの調整機能をオートに設定します。

 

10. <IPsec トンネルポリシー設定>
NXR(config)#ipsec tunnel policy 1
NXR(config-ipsec-tunnel)#description VXR

IPsecトンネルポリシー1の説明文を設定します。

NXR(config-ipsec-tunnel)#negotiation-mode auto

ネゴシエーションモードをautoに設定します。

NXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha256-hmac

暗号化アルゴリズムをaes128、認証アルゴリズムをsha256に設定します。

NXR(config-ipsec-tunnel)#set pfs group5

PFSを有効、DHグループをgroup5に設定します。

NXR(config-ipsec-tunnel)#set sa lifetime 28800

IPsec SAのライフタイムを設定します。

NXR(config-ipsec-tunnel)#set key-exchange isakmp 1

このIPsecトンネルポリシーで使用するIPsec ISAKMPポリシーを設定します。

NXR(config-ipsec-tunnel)#match address ipsec_acl

IPsecアクセスリストを設定します。

 

11. <PPPアカウント設定>
NXR(config)#ppp account username [PPP接続用ユーザID] password [PPP接続用パスワード]

PPP接続用ユーザID,パスワードを設定します。

 

12. <WAN側(ppp0)インタフェース設定>
NXR(config)#interface ppp 0
NXR(config-ppp)#no ip address

ppp0インタフェースのIPv4アドレスを無効にします。

NXR(config-ppp)#no ppp ipcp enable

IPCPを無効にします。

NXR(config-ppp)#ppp ipv6cp enable

IPv6CPを有効にします。

NXR(config-ppp)#ipv6 address autoconfig

ppp0インタフェースのIPv6アドレスを設定します。

NXR(config-ppp)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

NXR(config-ppp)#ipv6 access-group in ppp0_in

IPv6アクセスグループのinフィルタにIPv6アクセスリストppp0_inを設定します。

NXR(config-ppp)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

NXR(config-ppp)#ipv6 tcp adjust-mss auto

IPv6 TCP MSSの調整機能をオートに設定します。

NXR(config-ppp)#ppp username [PPP接続用ユーザID]

PPP続用ユーザIDを設定します。

NXR(config-ppp)#mobile apn [APN] cid 1 pdp-type ipv6

APN,CID,pdp-typeを設定します。
(☞) モバイルキャリア設定でKDDI(KDDI MVNO含む)を選択する場合、KDDI MNO SIMを使用する場合はCIDを「2」に、KDDI MVNO SIMを使用する場合はCIDを「1」に設定します。

NXR(config-ppp)#dial-up string *99***1#

発信用の電話番号を設定します。
(☞) 電話番号の#の前の数字はCIDを表しています。

NXR(config-ppp)#dial-up timeout 30

ダイアルタイムアウトを設定します。

NXR(config-ppp)#ipsec policy 1

このインタフェースで使用するIPsecローカルポリシーを設定します。

 

13. <モバイルエラーリカバリー設定>
NXR(config)#mobile error-recovery-reset

通信モジュールとの通信に重大な問題が発生する可能性が高いと判断した場合、通信モジュールのリセットを行うように設定します。

 

14. <モバイルターミネーションリカバリー設定>
NXR(config)#mobile termination-recovery reset

PPP接続時に網側から切断された場合、内蔵通信モジュールのリセットを行うように設定します。

 

15. <モバイル割り当て設定>
NXR(config)#mobile 1 ppp 0

mobile1として認識されている内蔵通信モジュールとppp0インタフェースの関連づけを行います。
内蔵通信モジュールをPPPインタフェースで使用する場合は、mobileコマンドによるPPPインタフェースへの関連付けが必要になります。
(☞) mobile1の情報はshow mobile 1コマンドで確認することができます。

 

16. <モバイルキャリア設定>
NXR(config)#mobile 1 carrier [キャリア]

mobile1(内蔵通信モジュール)のキャリアを設定します。
(☞) キャリア設定は「clear mobile 1」コマンドによるモバイルリセットを行うことで反映されます。

 

17. <DDNS設定>

※ここでは一般的なDDNSの設定例を掲載しています。DDNSの設定例についてはこちらもご参照ください。

NXR(config)#ddns
NXR(config-ddns)#service enable

DDNSサービスを有効にします。

NXR(config-ddns)#ddns-provider http-client

接続するDDNSプロバイダにhttp-client(汎用プロバイダ)を設定します。

NXR(config-ddns)#account username [NXRのDDNSユーザID] password [NXRのDDNSパスワード]

NXRのDDNSユーザID,パスワードを設定します。

NXR(config-ddns)#bind-interface ppp 0

接続回線のインタフェースを設定します。

NXR(config-ddns)#url ipv6 [DDNSのURL]

DDNS接続用URLを設定します。

NXR(config-ddns)#query [DDNSのクエリ]

HTTPクエリを設定します。

NXR(config-ddns)#forced-update-interval 1

IPアドレス変更通知を1時間毎に送信するように設定します。
(☞) IPアドレス変更の有無に関わらず送信する間隔を設定します。

 

18. <DNS設定>
NXR(config)#dns
NXR(config-dns)#service enable

DNSサービスを有効にします。

NXR(config-dns)#edns-query enable

EDNSを有効にします。

 

19. <設定の保存>
NXR#save config

設定内容を保存します。

 

【 端末の設定例 】

192.168.10.0/24
IPアドレス 192.168.10.100
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1
DNSサーバアドレス

 

【 補足 】

forbidden-access-wan機能が有効になっている場合、Route Based IPsec経由でルータにアクセスすることはできません。アクセスするためにはトンネルインタフェースでアクセスを許可するフィルタを設定します。

ここではNXRのTELNETサーバ,HTTPサーバへのアクセスを許可する設定例を紹介します。

(☞) 工場出荷状態では、ethernet0インタフェース以外からのTELNETサーバ,HTTPサーバへのアクセス禁止が有効になっています。

<IPv4アクセスリスト設定>
(config)#ip access-list tunnel1_in permit 10.0.1.0/24 192.168.10.1 tcp any 23
(config)#ip access-list tunnel1_in permit 10.0.1.0/24 192.168.10.1 tcp any 880

IPv4アクセスリストtunnel1_inを以下のルールで設定します。

  • 送信元IPアドレス10.0.1.0/24、宛先IPアドレス192.168.10.1、宛先TCPポート23番を許可
  • 送信元IPアドレス10.0.1.0/24、宛先IPアドレス192.168.10.1、宛先TCPポート880番を許可

(☞) IPv4アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

<トンネル1インタフェース設定>
(config)#interface tunnel1
(config-tunnel)#ip access-group in tunnel1_in

IPv4アクセスグループのinフィルタにIPv4アクセスリストtunnel1_inを設定します。

 

【 付録 】

←前のページ

次のページ→