FutureNet

NXR,WXRシリーズ

EtherIP編

1. EtherIP設定

1-2. PPPoEを利用したEtherIP接続設定

WAN回線にPPPoEを使用したハブ&スポーク構成のEtherIP(Ethernet over IP)接続設定例です。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • EtherIPは通信の暗号化を行いませんので、インターネット上で利用する場合、IPsecと組み合わせて利用することを推奨致します。
  • TELNETとHTTPのforbidden-access-wanが有効になっている場合、それらを使用してbridgeインタフェースにアクセスすることはできません。そのため、この設定例ではbridgeインタフェースへのTELNETとHTTPアクセスを許可するフィルタを設定しています。

 

【 設定例 】

〔NXR_Aの設定〕

nxrg240#configure terminal
nxrg240(config)#hostname NXR_A
NXR_A(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.1 tcp any 23
NXR_A(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.1 tcp any 880
NXR_A(config)#interface bridge 0
NXR_A(config-bridge)#ip address 192.168.10.1/24
NXR_A(config-bridge)#ip access-group in br0_in
NXR_A(config-bridge)#exit
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#no ip address
NXR_A(config-if)#bridge-group 0 port 1
NXR_A(config-if)#exit
NXR_A(config)#ip route 0.0.0.0/0 ppp 0
NXR_A(config)#ppp account username test1@example.jp password test1pass
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 192.0.2.1/32
NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test1@example.jp
NXR_A(config-ppp)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#exit
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode ethernet ip
NXR_A(config-tunnel)#mtu 1500
NXR_A(config-tunnel)#bridge-group 0 port 2
NXR_A(config-tunnel)#tunnel source ppp 0
NXR_A(config-tunnel)#tunnel destination 192.0.2.2
NXR_A(config-tunnel)#exit
NXR_A(config)#interface tunnel 2
NXR_A(config-tunnel)#tunnel mode ethernet ip
NXR_A(config-tunnel)#mtu 1500
NXR_A(config-tunnel)#bridge-group 0 port 3
NXR_A(config-tunnel)#tunnel source ppp 0
NXR_A(config-tunnel)#tunnel destination 192.0.2.3
NXR_A(config-tunnel)#exit
NXR_A(config)#exit
NXR_A#save config

 

〔NXR_Bの設定〕

nxrg240#configure terminal
nxrg240(config)#hostname NXR_B
NXR_B(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.2 tcp any 23
NXR_B(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.2 tcp any 880
NXR_B(config)#interface bridge 0
NXR_B(config-bridge)#ip address 192.168.10.2/24
NXR_B(config-bridge)#ip access-group in br0_in
NXR_B(config-bridge)#exit
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#no ip address
NXR_B(config-if)#bridge-group 0 port 1
NXR_B(config-if)#exit
NXR_B(config)#ip route 0.0.0.0/0 ppp 0
NXR_B(config)#ppp account username test2@example.jp password test2pass
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address 192.0.2.2/32
NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ppp username test2@example.jp
NXR_B(config-ppp)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0
NXR_B(config-if)#exit
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode ethernet ip
NXR_B(config-tunnel)#mtu 1500
NXR_B(config-tunnel)#bridge-group 0 port 2
NXR_B(config-tunnel)#tunnel source ppp 0
NXR_B(config-tunnel)#tunnel destination 192.0.2.1
NXR_B(config-tunnel)#exit
NXR_B(config)#exit
NXR_B#save config

 

〔NXR_Cの設定〕

nxrg240#configure terminal
nxrg240(config)#hostname NXR_C
NXR_C(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.3 tcp any 23
NXR_C(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.3 tcp any 880
NXR_C(config)#interface bridge 0
NXR_C(config-bridge)#ip address 192.168.10.3/24
NXR_C(config-bridge)#ip access-group in br0_in
NXR_C(config-bridge)#exit
NXR_C(config)#interface ethernet 0
NXR_C(config-if)#no ip address
NXR_C(config-if)#bridge-group 0 port 1
NXR_C(config-if)#exit
NXR_C(config)#ip route 0.0.0.0/0 ppp 0
NXR_C(config)#ppp account username test3@example.jp password test3pass
NXR_C(config)#interface ppp 0
NXR_C(config-ppp)#ip address 192.0.2.3/32
NXR_C(config-ppp)#ip tcp adjust-mss auto
NXR_C(config-ppp)#ppp username test3@example.jp
NXR_C(config-ppp)#exit
NXR_C(config)#interface ethernet 1
NXR_C(config-if)#no ip address
NXR_C(config-if)#pppoe-client ppp 0
NXR_C(config-if)#exit
NXR_C(config)#interface tunnel 1
NXR_C(config-tunnel)#tunnel mode ethernet ip
NXR_C(config-tunnel)#mtu 1500
NXR_C(config-tunnel)#bridge-group 0 port 2
NXR_C(config-tunnel)#tunnel source ppp 0
NXR_C(config-tunnel)#tunnel destination 192.0.2.1
NXR_C(config-tunnel)#exit
NXR_C(config)#exit
NXR_C#save config

 

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxrg240(config)#hostname NXR_A

ホスト名を設定します。

 

2. <IPアクセスリスト設定>
NXR_A(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.1 tcp any 23
NXR_A(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.1 tcp any 880

IPアクセスリストbr0_inを以下のルールで設定します。

  • 送信元IPアドレス192.168.10.0/24、宛先IPアドレス192.168.10.1、宛先TCPポート23番を許可
  • 送信元IPアドレス192.168.10.0/24、宛先IPアドレス192.168.10.1、宛先TCPポート880番を許可

(☞) TELNETとHTTPのforbidden-access-wanが有効になっている場合、それらを使用してbridgeインタフェースにアクセスすることはできません。そのため、この設定例ではbridgeインタフェースへのTELNETとHTTPアクセスを許可するフィルタを設定しています。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングを行うインタフェースでの登録が必要になります。

 

3. <LAN側(bridge0)インタフェース設定>
NXR_A(config)#interface bridge 0
NXR_A(config-bridge)#ip address 192.168.10.1/24

bridge0インタフェースのIPアドレスを設定します。

NXR_A(config-bridge)#ip access-group in br0_in

bridge0インタフェースでIPアクセスグループのinフィルタにIPアクセスリストbr0_inを設定します。

 

4. <ethernet0インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#no ip address

ethernet0インタフェースのIPアドレスを無効にします。

NXR_A(config-if)#bridge-group 0 port 1

ブリッジグループを設定します。
(☞) ブリッジグループの番号はbridgeインタフェースの番号と同一のものを設定します。またポートはブリッジグループ内でユニークなものを設定する必要があります。

 

5. <スタティックルート設定>
NXR_A(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

6. <PPPアカウント設定>
NXR_A(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するPPPoE接続用ユーザID,パスワードを設定します。

 

7. <WAN側(ppp0)インタフェース設定>
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 192.0.2.1/32

ppp0インタフェースのIPアドレスを設定します。

NXR_A(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

NXR_A(config-ppp)#ppp username test1@example.jp

PPPoE接続用ユーザIDを設定します。

 

8. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address

ethernet1インタフェースのIPアドレスを無効にします。

NXR_A(config-if)#pppoe-client ppp 0

PPPoEクライアントにppp0を設定します。

 

9. <トンネル1インタフェース設定>
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode ethernet ip

トンネル1インタフェースのトンネルモードをethernet ipに設定します。

NXR_A(config-tunnel)#mtu 1500

トンネルインタフェースのMTU値を設定します。
(☞) この例では1500に設定します。

NXR_A(config-tunnel)#bridge-group 0 port 2

ブリッジグループを設定します。

NXR_A(config-tunnel)#tunnel source ppp 0

トンネルの送信元インタフェースを設定します。
(☞) 送信元IPアドレスを指定することも可能です。

NXR_A(config-tunnel)#tunnel destination 192.0.2.2

トンネルの宛先IPアドレスを設定します。

 

10. <トンネル2インタフェース設定>
NXR_A(config)#interface tunnel 2
NXR_A(config-tunnel)#tunnel mode ethernet ip

トンネル2インタフェースのトンネルモードをethernet ipに設定します。

NXR_A(config-tunnel)#mtu 1500

トンネルインタフェースのMTU値を設定します。

NXR_A(config-tunnel)#bridge-group 0 port 3

ブリッジグループを設定します。

NXR_A(config-tunnel)#tunnel source ppp 0

トンネルの送信元インタフェースを設定します。

NXR_A(config-tunnel)#tunnel destination 192.0.2.3

トンネルの宛先IPアドレスを設定します。

 

11. <設定の保存>
NXR_A#save config

設定内容を保存します。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg240(config)#hostname NXR_B

ホスト名を設定します。

 

2. <IPアクセスリスト設定>
NXR_B(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.2 tcp any 23
NXR_B(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.2 tcp any 880

IPアクセスリストbr0_inを以下のルールで設定します。

  • 送信元IPアドレス192.168.10.0/24、宛先IPアドレス192.168.10.2、宛先TCPポート23番を許可
  • 送信元IPアドレス192.168.10.0/24、宛先IPアドレス192.168.10.2、宛先TCPポート880番を許可

 

3. <LAN側(bridge0)インタフェース設定>
NXR_B(config)#interface bridge 0
NXR_B(config-bridge)#ip address 192.168.10.2/24

bridge0インタフェースのIPアドレスを設定します。

NXR_B(config-bridge)#ip access-group in br0_in

bridge0インタフェースでIPアクセスグループのinフィルタにIPアクセスリストbr0_inを設定します。

 

4. <ethernet0インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#no ip address

ethernet0インタフェースのIPアドレスを無効にします。

NXR_B(config-if)#bridge-group 0 port 1

ブリッジグループを設定します。

 

5. <スタティックルート設定>
NXR_B(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

6. <PPPアカウント設定>
NXR_B(config)#ppp account username test2@example.jp password test2pass

ppp0インタフェースで使用するPPPoE接続用ユーザID,パスワードを設定します。

 

7. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address 192.0.2.2/32

ppp0インタフェースのIPアドレスを設定します。

NXR_B(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

NXR_B(config-ppp)#ppp username test2@example.jp

PPPoE接続用ユーザIDを設定します。

 

8. <ethernet1インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address

ethernet1インタフェースのIPアドレスを無効にします。

NXR_B(config-if)#pppoe-client ppp 0

PPPoEクライアントにppp0を設定します。

 

9. <トンネル1インタフェース設定>
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode ethernet ip

トンネル1インタフェースのトンネルモードをethernet ipに設定します。

NXR_B(config-tunnel)#mtu 1500

トンネルインタフェースのMTU値を設定します。
(☞) この例では1500に設定します。

NXR_B(config-tunnel)#bridge-group 0 port 2

ブリッジグループを設定します。

NXR_B(config-tunnel)#tunnel source ppp 0

トンネルの送信元インタフェースを設定します。

NXR_B(config-tunnel)#tunnel destination 192.0.2.1

トンネルの宛先IPアドレスを設定します。

 

10. <設定の保存>
NXR_B#save config

設定内容を保存します。

 

〔NXR_Cの設定〕

1. <ホスト名の設定>
nxrg240(config)#hostname NXR_C

ホスト名を設定します。

 

2. <IPアクセスリスト設定>
NXR_C(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.3 tcp any 23
NXR_C(config)#ip access-list br0_in permit 192.168.10.0/24 192.168.10.3 tcp any 880

IPアクセスリストbr0_inを以下のルールで設定します。

  • 送信元IPアドレス192.168.10.0/24、宛先IPアドレス192.168.10.3、宛先TCPポート23番を許可
  • 送信元IPアドレス192.168.10.0/24、宛先IPアドレス192.168.10.3、宛先TCPポート880番を許可

 

3. <LAN側(bridge0)インタフェース設定>
NXR_C(config)#interface bridge 0
NXR_C(config-bridge)#ip address 192.168.10.3/24

bridge0インタフェースのIPアドレスを設定します。

NXR_C(config-bridge)#ip access-group in br0_in

bridge0インタフェースでIPアクセスグループのinフィルタにIPアクセスリストbr0_inを設定します。

 

4. <ethernet0インタフェース設定>
NXR_C(config)#interface ethernet 0
NXR_C(config-if)#no ip address

ethernet0インタフェースのIPアドレスを無効にします。

NXR_C(config-if)#bridge-group 0 port 1

ブリッジグループを設定します。

 

5. <スタティックルート設定>
NXR_C(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

6. <PPPアカウント設定>
NXR_C(config)#ppp account username test3@example.jp password test3pass

ppp0インタフェースで使用するPPPoE接続用ユーザID,パスワードを設定します。

 

7. <WAN側(ppp0)インタフェース設定>
NXR_C(config)#interface ppp 0
NXR_C(config-ppp)#ip address 192.0.2.3/32

ppp0インタフェースのIPアドレスを設定します。

NXR_C(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

NXR_C(config-ppp)#ppp username test3@example.jp

PPPoE接続用ユーザIDを設定します。

 

8. <ethernet1インタフェース設定>
NXR_C(config)#interface ethernet 1
NXR_C(config-if)#no ip address

ethernet1インタフェースのIPアドレスを無効にします。

NXR_C(config-if)#pppoe-client ppp 0

PPPoEクライアントにppp0を設定します。

 

9. <トンネル1インタフェース設定>
NXR_C(config)#interface tunnel 1
NXR_C(config-tunnel)#tunnel mode ethernet ip

トンネル1インタフェースのトンネルモードをethernet ipに設定します。

NXR_C(config-tunnel)#mtu 1500

トンネルインタフェースのMTU値を設定します。
(☞) この例では1500に設定します。

NXR_C(config-tunnel)#bridge-group 0 port 2

ブリッジグループを設定します。

NXR_C(config-tunnel)#tunnel source ppp 0

トンネルの送信元インタフェースを設定します。

NXR_C(config-tunnel)#tunnel destination 192.0.2.1

トンネルの宛先IPアドレスを設定します。

 

10. <設定の保存>
NXR_C#save config

設定内容を保存します。

 

【 端末の設定例 】

NXR_A配下の端末 NXR_B配下の端末 NXR_C配下の端末
IPアドレス 192.168.10.101 192.168.10.102 192.168.10.103
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.10.2 192.168.10.3

 

【 付録 】