FutureNet

NXR,WXRシリーズ

GRE・IPinIP編

1. GRE・IPinIP基本設定

1-1. GRE(IPinIP)でのLAN間接続設定

この設定例ではルータNXR_AとルータNXR_B間でGREトンネルを利用してLAN間通信を行います。なおGRE(IPinIP)を使用するルータのWAN側IPアドレスはともに固定IPアドレスが必要になります。
※設定例はGREになりますが、IPinIPは補足にて記載しています。

 

【 構成図 】

  • GRE(IPinIP)ではトンネルインタフェースを使用します。

 

【 設定データ 】

〔NXR_Aの設定〕

設定項目 設定内容
ホスト名 NXR_A
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
WAN側インタフェース ethernet1のIPアドレス 10.10.10.1/24
スタティックルート No.1 宛先IPアドレス 192.168.20.0/24
ゲートウェイ(インタフェース) tunnel1
No.2 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(IPアドレス) 10.10.10.254
トンネル1インタフェース トンネルモード gre
送信元IPアドレス 10.10.10.1
宛先IPアドレス 10.10.20.1
TCP MSS自動調整 オート
TTL 255

 〔NXR_Bの設定〕

設定項目 設定内容
ホスト名 NXR_B
LAN側インタフェース ethernet0のIPアドレス 192.168.20.1/24
WAN側インタフェース ethernet1のIPアドレス 10.10.20.1/24
スタティックルート No.1 宛先IPアドレス 192.168.10.0/24
ゲートウェイ(インタフェース) tunnel1
No.2 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(IPアドレス) 10.10.20.254
トンネル1インタフェース トンネルモード gre
送信元IPアドレス 10.10.20.1
宛先IPアドレス 10.10.10.1
TCP MSS自動調整 オート
TTL 255

 

【 設定例 】

〔NXR_Aの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24
NXR_A(config-if)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#ip address 10.10.10.1/24
NXR_A(config-if)#exit
NXR_A(config)#ip route 192.168.20.0/24 tunnel 1
NXR_A(config)#ip route 0.0.0.0/0 10.10.10.254
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode gre
NXR_A(config-tunnel)#tunnel source 10.10.10.1
NXR_A(config-tunnel)#tunnel destination 10.10.20.1
NXR_A(config-tunnel)#ip tcp adjust-mss auto
NXR_A(config-tunnel)#tunnel ttl 255
NXR_A(config-tunnel)#exit
NXR_A(config)#exit
NXR_A#save config

〔NXR_Bの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.20.1/24
NXR_B(config-if)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#ip address 10.10.20.1/24
NXR_B(config-if)#exit
NXR_B(config)#ip route 192.168.10.0/24 tunnel 1
NXR_B(config)#ip route 0.0.0.0/0 10.10.20.254
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode gre
NXR_B(config-tunnel)#tunnel source 10.10.20.1
NXR_B(config-tunnel)#tunnel destination 10.10.10.1
NXR_B(config-tunnel)#ip tcp adjust-mss auto
NXR_B(config-tunnel)#tunnel ttl 255
NXR_B(config-tunnel)#exit
NXR_B(config)#exit
NXR_B#save config

 

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <WAN側(ethernet1)インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#ip address 10.10.10.1/24

ethernet1インタフェースのIPアドレスを設定します。

 

4. <スタティックルート設定>
NXR_A(config)#ip route 192.168.20.0/24 tunnel 1

LAN_B向けのルートを設定します。ゲートウェイインタフェースはtunnel 1を設定します。
(☞) これはGREで使用するスタティックルートであり、ここで設定した宛先IPアドレスにマッチしたパケットがGREのカプセル化対象となります。なおゲートウェイアドレスはGREで使用するトンネルインタフェースを設定します。

NXR_A(config)#ip route 0.0.0.0/0 10.10.10.254

デフォルトルートを設定します。

 

5. <トンネル1インタフェース設定>
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode gre

トンネル1インタフェースで使用するトンネルモードを設定します。
(☞) トンネルインタフェースをGREで使用する場合はgreを設定します。

NXR_A(config-tunnel)#tunnel source 10.10.10.1

トンネルの送信元IPアドレスを設定します。

NXR_A(config-tunnel)#tunnel destination 10.10.20.1

トンネルの宛先IPアドレスを設定します。

NXR_A(config-tunnel)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。
TCP MSSの調整機能はTCPのネゴシエーション時にMSS値を調整することで、サイズの大きいTCPパケットを転送する際にフラグメントによるスループットの低下を抑制する場合に利用します。

NXR_A(config-tunnel)#tunnel ttl 255

TTL値を設定します。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.20.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <WAN側(ethernet1)インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#ip address 10.10.20.1/24

ethernet1インタフェースのIPアドレスを設定します。

 

4. <スタティックルート設定>
NXR_B(config)#ip route 192.168.10.0/24 tunnel 1

LAN_A向けのルートを設定します。

NXR_B(config)#ip route 0.0.0.0/0 10.10.20.254

デフォルトルートを設定します。

 

5. <トンネル1インタフェース設定>
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode gre

トンネル1インタフェースで使用するトンネルモードをgreに設定します。

NXR_B(config-tunnel)#tunnel source 10.10.20.1
NXR_B(config-tunnel)#tunnel destination 10.10.10.1

トンネルの送信元,宛先IPアドレスを設定します。

NXR_B(config-tunnel)#ip tcp adjust-mss auto
NXR_B(config-tunnel)#tunnel ttl 255

TCP MSSの調整機能をオートに設定します。またTTL値を設定します。

 

【 端末の設定例 】

LAN_Aの端末 LAN_Bの端末
IPアドレス 192.168.10.100 192.168.20.100
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.20.1

【 補足 】

IPinIPを利用する場合はトンネルインタフェース設定のtunnel modeでipipを設定します。

<IPinIP設定>
(config)#interface tunnel [インタフェースナンバ]
(config-tunnel)#tunnel mode ipip

トンネルインタフェースで使用するトンネルモードをipipに設定します。