FutureNet

NXR,WXRシリーズ

相互接続編

2. NEC製IXルータとの接続

2-2. NEC製IXルータとのIPinIP接続設定(IPv4)

WAN回線にPPPoEを使用したハブ&スポーク構成のIPinIP接続設定例です。この例ではハブ拠点にNEC製ルータのIXシリーズを利用します。
この設定例は弊社独自の検証結果を元に作成しております。よってNEC製IXルータとの接続を保証するものではありません。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • 動作確認時に利用したNEC製IXルータ
    – IX2207(Ver.9.5.11)
    (☞) ご利用頂くNEC製IXルータやファームウェアバージョンによって設定等異なる場合もありますので、詳しくはご利用製品のドキュメント等をご参照下さい。

 

【 設定例 】

〔NEC製IXルータの設定〕

NEC製IXルータの設定方法についてはご利用製品のドキュメント等をご参照下さい。

hostname IX
!
ip ufs-cache enable
ip route default GigaEthernet0.1
ip route 192.168.20.0/24 Tunnel0.0
ip route 192.168.30.0/24 Tunnel1.0
!
ppp profile pppprof
authentication myname test1@example.jp
authentication password test1@example.jp test1pass
!
interface GigaEthernet2.0
ip address 192.168.10.1/24
no shutdown
!
interface GigaEthernet0.1
encapsulation pppoe
auto-connect
ppp binding pppprof
ip address 10.0.0.1/32
ip tcp adjust-mss auto
no shutdown
!
interface Tunnel0.0
tunnel mode 4-over-4
tunnel destination 10.0.0.2
tunnel source 10.0.0.1
ip unnumbered GigaEthernet2.0
ip tcp adjust-mss auto
no shutdown
!
interface Tunnel1.0
tunnel mode 4-over-4
tunnel destination 10.0.0.3
tunnel source 10.0.0.1
ip unnumbered GigaEthernet2.0
ip tcp adjust-mss auto
no shutdown

 

〔NXR_Aの設定〕

nxrg100#configure terminal
nxrg100(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.20.1/24
NXR_A(config-if)#exit
NXR_A(config)#ip route 192.168.10.0/24 tunnel 1
NXR_A(config)#ip route 0.0.0.0/0 ppp 0
NXR_A(config)#ppp account username test2@example.jp password test2pass
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 10.0.0.2/32
NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test2@example.jp
NXR_A(config-ppp)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#exit
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode ipip
NXR_A(config-tunnel)#description NEC_IX
NXR_A(config-tunnel)#tunnel source 10.0.0.2
NXR_A(config-tunnel)#tunnel destination 10.0.0.1
NXR_A(config-tunnel)#mtu 1434
NXR_A(config-tunnel)#ip tcp adjust-mss auto
NXR_A(config-tunnel)#tunnel ttl 255
NXR_A(config-tunnel)#exit
NXR_A(config)#exit
NXR_A#save config

 

〔NXR_Bの設定〕

nxrg100#configure terminal
nxrg100(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.30.1/24
NXR_B(config-if)#exit
NXR_B(config)#ip route 192.168.10.0/24 tunnel 1
NXR_B(config)#ip route 0.0.0.0/0 ppp 0
NXR_B(config)#ppp account username test3@example.jp password test3pass
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address 10.0.0.3/32
NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ppp username test3@example.jp
NXR_B(config-ppp)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0
NXR_B(config-if)#exit
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode ipip
NXR_B(config-tunnel)#description NEC_IX
NXR_B(config-tunnel)#tunnel source 10.0.0.3
NXR_B(config-tunnel)#tunnel destination 10.0.0.1
NXR_B(config-tunnel)#mtu 1434
NXR_B(config-tunnel)#ip tcp adjust-mss auto
NXR_B(config-tunnel)#tunnel ttl 255
NXR_B(config-tunnel)#exit
NXR_B(config)#exit
NXR_B#save config

 

【 設定例解説 】

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.20.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_A(config)#ip route 192.168.10.0/24 tunnel 1

LAN_A向けのルートを設定します。

NXR_A(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <PPPアカウント設定>
NXR_A(config)#ppp account username test2@example.jp password test2pass

ppp0インタフェースで使用する閉域網接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

5. <WAN側(ppp0)インタフェース設定>
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 10.0.0.2/32

ppp0インタフェースのIPアドレスを設定します。

NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test2@example.jp

TCP MSSの調整機能をオートに設定します。また閉域網接続用ユーザIDを設定します。

 

6. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

7. <トンネル1インタフェース設定>
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode ipip
NXR_A(config-tunnel)#description NEC_IX

トンネル1インタフェースで使用するトンネルモードをipipに設定します。またトンネルインタフェースの説明としてNEC_IXを設定します。

NXR_A(config-tunnel)#tunnel source 10.0.0.2
NXR_A(config-tunnel)#tunnel destination 10.0.0.1

トンネルの送信元,宛先IPアドレスを設定します。

NXR_A(config-tunnel)#mtu 1434

トンネルインタフェースのMTU値に1434を設定します。
(☞) この設定例ではPPPoE接続時のWAN側インタフェースのMTU値として1454を想定しています。

NXR_A(config-tunnel)#ip tcp adjust-mss auto
NXR_A(config-tunnel)#tunnel ttl 255

TCP MSSの調整機能をオートに設定します。またTTL値を設定します。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.30.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_B(config)#ip route 192.168.10.0/24 tunnel 1

LAN_A向けのルートを設定します。

NXR_B(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <PPPアカウント設定>
NXR_B(config)#ppp account username test3@example.jp password test3pass

ppp0インタフェースで使用する閉域網接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

5. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address 10.0.0.3/32

ppp0インタフェースのIPアドレスを設定します。

NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ppp username test3@example.jp

TCP MSSの調整機能をオートに設定します。また閉域網接続用ユーザIDを設定します。

 

6. <ethernet1インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#no ip address
NXR_B(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

7. <トンネル1インタフェース設定>
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode ipip
NXR_B(config-tunnel)#description NEC_IX

トンネル1インタフェースで使用するトンネルモードをipipに設定します。またトンネルインタフェースの説明としてNEC_IXを設定します。

NXR_B(config-tunnel)#tunnel source 10.0.0.3
NXR_B(config-tunnel)#tunnel destination 10.0.0.1

トンネルの送信元,宛先IPアドレスを設定します。

NXR_B(config-tunnel)#mtu 1434

トンネルインタフェースのMTU値に1434を設定します。
(☞) この設定例ではPPPoE接続時のWAN側インタフェースのMTU値として1454を想定しています。

NXR_B(config-tunnel)#ip tcp adjust-mss auto
NXR_B(config-tunnel)#tunnel ttl 255

TCP MSSの調整機能をオートに設定します。またTTL値を設定します。

 

【 端末の設定例 】

LAN_Aの端末 LAN_Bの端末 LAN_Cの端末
IPアドレス 192.168.10.100 192.168.20.100 192.168.30.100
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.20.1 192.168.30.1

 

【 付録 】