FutureNet

NXR,WXRシリーズ

無線LAN編

3. 無線LAN設定(NXR-160/LW)

3-1. 無線LAN設定(wlanの利用)

有線LANおよび無線LANセグメントからインターネットアクセスする設定例です。なお無線LANの認証方式にはWPA2-PSKを利用します。

 

【対象機種】NXR-160/LW(2020/12現在)
最新の対応状況は、各製品の更新履歴やユーザーズガイドをご確認ください。

 

コンテンツ
構成図 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • 有線LANセグメントと無線LANセグメントを別ネットワークとします。
  • 無線LANセグメントにはDHCPサーバ機能でアドレス配布を行います。

 

【 設定例 】

nxr160#configure terminal
nxr160(config)#interface ethernet 0
nxr160(config-if)#ip address 192.168.10.1/24
nxr160(config-if)#exit
nxr160(config)#interface wlan 0
nxr160(config-wlan)#ip address 192.168.11.1/24
nxr160(config-wlan)#wlan ssid nxr160wlan0
nxr160(config-wlan)#wlan wpa-psk password nxr160wlan0pass
nxr160(config-wlan)#wlan authenticate wpa2-psk aes
nxr160(config-wlan)#wlan guest-mode enable
nxr160(config-wlan)#wlan access-point-bridge enable
nxr160(config-wlan)#wlan max-associations 16
nxr160(config-wlan)#exit
nxr160(config)#wifi 0
nxr160(config-wifi)#mode 11na
nxr160(config-wifi)#channel auto
nxr160(config-wifi)#exit
nxr160(config)#dhcp-server 1
nxr160(config-dhcps)#network 192.168.11.0/24 range 192.168.11.200 192.168.11.210
nxr160(config-dhcps)#gateway 192.168.11.1
nxr160(config-dhcps)#dns-server 192.168.11.1
nxr160(config-dhcps)#exit
nxr160(config)#ip route 0.0.0.0/0 ppp 0
nxr160(config)#ppp account username [ユーザID] password [パスワード]
nxr160(config)#interface ppp 0
nxr160(config-ppp)#ip address negotiated
nxr160(config-ppp)#ip masquerade
nxr160(config-ppp)#ip spi-filter
nxr160(config-ppp)#ip tcp adjust-mss auto
nxr160(config-ppp)#ppp username [ユーザID]
nxr160(config-ppp)#mobile apn [APN] cid 1 pdp-type ip
nxr160(config-ppp)#dial-up string *99***1#
nxr160(config-ppp)#dial-up timeout 30
nxr160(config-ppp)#exit
nxr160(config)#mobile error-recovery-reset
nxr160(config)#mobile termination-recovery reset
nxr160(config)#mobile 1 ppp 0
nxr160(config)#mobile 1 carrier [キャリア]
nxr160(config)#exit
nxr160#clear mobile 1
nxr160#configure terminal
nxr160(config)#dns
nxr160(config-dns)#service enable
nxr160(config-dns)#exit
nxr160(config)#exit
nxr160#save config

 

【 設定例解説 】

1. <有線LAN側(ethernet0)インタフェース設定>
nxr160(config)#interface ethernet 0
nxr160(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

2. <無線LAN側(wlan0)インタフェース設定>
nxr160(config)#interface wlan 0
nxr160(config-wlan)#ip address 192.168.11.1/24

wlan0インタフェースのIPアドレスを設定します。

nxr160(config-wlan)#wlan ssid nxr160wlan0

SSIDを設定します。

nxr160(config-wlan)#wlan wpa-psk password nxr160wlan0pass

WPA-PSK認証方式で使用するパスワードを設定します。
(☞) WPA-PSK認証方式で使用するパスワードは、WPA-PSKの認証方式および暗号化方式よりも先に設定する必要があります。

nxr160(config-wlan)#wlan authenticate wpa2-psk aes

認証方式と暗号化方式を設定します。

nxr160(config-wlan)#wlan guest-mode enable

ゲストモードを有効に設定します。
(☞) ANY接続拒否機能,ステルス機能は連動して動作するためゲストモードでの一括設定となります。

nxr160(config-wlan)#wlan access-point-bridge enable

アクセスポイントブリッジを有効に設定します。
(☞) アクセスポイントブリッジを有効に設定することでプライバシープロテクションが無効になります。

nxr160(config-wlan)#wlan max-associations 16

接続台数制限を設定します。

 

3. <無線モジュール(wifi0)設定>
nxr160(config)#wifi 0
nxr160(config-wifi)#mode 11na

無線方式を設定します。

nxr160(config-wifi)#channel auto

チャネルを設定します。
(☞) modeコマンドが未設定の場合、設定することはできません。

 

4. <DHCPサーバ設定>
nxr160(config)#dhcp-server 1
nxr160(config-dhcps)#network 192.168.11.0/24 range 192.168.11.200 192.168.11.210
nxr160(config-dhcps)#gateway 192.168.11.1
nxr160(config-dhcps)#dns-server 192.168.11.1

DHCPサーバを設定します。

 

5. <スタティックルート設定>
nxr160(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

6. <PPPアカウント設定>
nxr160(config)#ppp account username [ユーザID] password [パスワード]

PPP接続で使用するユーザID,パスワードを設定します。

 

7. <WAN側(ppp0)インタフェース設定>
nxr160(config)#interface ppp 0
nxr160(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスをnegotiatedに設定します。

nxr160(config-ppp)#ip masquerade
nxr160(config-ppp)#ip spi-filter

IPマスカレード、ステートフルパケットインスペクションを有効にします。

nxr160(config-ppp)#ip tcp adjust-mss auto

TCP MSSの調整機能をオートに設定します。

nxr160(config-ppp)#ppp username [ユーザID]

PPP接続用ユーザIDを設定します。

nxr160(config-ppp)#mobile apn [APN] cid 1 pdp-type ip

APN,CID,PDPタイプを設定します。
(☞) モバイルキャリア設定でKDDI(KDDI MVNO含む)を選択する場合、KDDI MNO SIMを使用する場合はCIDを「2」に、KDDI MVNO SIMを使用する場合はCIDを「1」に設定します。

nxr160(config-ppp)#dial-up string *99***1#

発信用の電話番号を設定します。
(☞) 電話番号の#の前の数字はCIDを表しています。

nxr160(config-ppp)#dial-up timeout 30

ダイアルタイムアウトを設定します。

 

8. <モバイルエラーリカバリー設定>
nxr160(config)#mobile error-recovery-reset

通信モジュールとの通信に重大な問題が発生する可能性が高いと判断した場合、通信モジュールのリセットを行うように設定します。

 

9. <モバイルターミネーションリカバリー設定>
nxr160(config)#mobile termination-recovery reset

PPP接続時に網側から切断された場合、通信モジュールのリセットを行うように設定します。

 

10. <モバイル割り当て設定>
nxr160(config)#mobile 1 ppp 0

mobile1として認識されている内蔵通信モジュールとppp0インタフェースの関連づけを行います。
内蔵通信モジュールをPPPインタフェースで使用する場合は、mobileコマンドによるPPPインタフェースへの関連付けが必要になります。
(☞) mobile1の情報はshow mobile 1コマンドで確認することができます。

 

11. <モバイルキャリア設定>
nxr160(config)#mobile 1 carrier [キャリア]

mobile1(内蔵通信モジュール)のキャリアを設定します。
(☞) キャリア設定は「clear mobile 1」コマンドによるモバイルリセットを行うことで反映されます。

 

12. <DNS設定>
nxr160(config)#dns
nxr160(config-dns)#service enable

DNSサービスを有効にします。

 

13. <設定の保存>
nxr160#save config

設定内容を保存します。

 

【 端末の設定例 】

有線端末 無線端末
IPアドレス 192.168.10.100 DHCPサーバから取得
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1
DNSサーバ

 

【 付録 】