FutureNet

NXR,WXRシリーズ

VXRシリーズ編

3. Cloudn Compute(VPCタイプOpenNW) VPN接続設定

3-5. L2TPv3接続設定(VPCタイプOpenNW,VXR経由拠点間通信あり)

「Cloudn Compute(VPCタイプOpenNW)」(以下Cloudn)はNTTコミュニケーションズ社が提供するクラウド上に論理的なプライベートネットワーク(Virtual Private Cloud)を構築し、その中にCloudnの仮想サーバを設置するサービスです。この環境にVXR-x86をインストールし、NXRとL2TPv3接続します。なおCloudn側のVRでNATを行いますので、VXR-x86のWAN側インタフェースのIPアドレスはプライベートIPアドレスとなります。またVXR経由での拠点間通信を行います。

 

【 構成図 】

fnw_vxr_l2tpv3_301

  • この設定例ではモバイルルータとしてNXR-G100/NLを使用します。また通信プランはXiデータプランでの利用を想定しています。
    (☞) 他のモバイル機能を持ったNXRシリーズを利用することも可能です。

 

【 設定データ 】

〔VXRの設定〕

設定項目 設定内容
ホスト名 VXR
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
WAN側インタフェース ethernet1のIPアドレス 192.168.11.1/24
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(IPアドレス) 192.168.11.254
L2TPv3 ホスト名 vxr
ルータID 172.20.10.1
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 NXR_A
リモートトンネルアドレス 10.10.20.1
リモートホスト名 nxra
リモートルータID 172.20.20.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 NXR_A
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 30秒
MSS自動調整 オート
L2TPv3トンネル2 名前 NXR_B
リモートホスト名 nxrb
リモートルータID 172.20.30.1
リモートベンダーID ietf
L2TPv3 Xconnect2 名前 NXR_B
L2TPv3トンネルID 2
Xconnectインタフェース ethernet0
リモートエンドID 1
MSS自動調整 オート
SSHサーバ 有効
DNS サービス 有効
DNSサーバ プライマリ 192.168.11.254
FastFowarding 有効
L2TPv3 FastFowarding 有効

〔NXR_Aの設定〕

設定項目 設定内容
ホスト名 NXR_A
LAN側インタフェース ethernet0のIPアドレス 192.168.10.2/24
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 10.10.20.1/32
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
MSS自動調整 オート
ISP接続用ユーザID test2@example.jp
ISP接続用パスワード test2pass
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in 動作 許可
送信元IPアドレス 10.10.10.1
宛先IPアドレス 10.10.20.1
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxra
ルータID 172.20.20.1
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 VXR
リモートトンネルアドレス 10.10.10.1
リモートホスト名 vxr
リモートルータID 172.20.10.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 VXR
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 45秒
MSS自動調整 オート
DNS サービス 有効
FastFowarding 有効
L2TPv3 FastFowarding 有効

〔NXR_Bの設定〕

設定項目 設定内容
ホスト名 NXR_B
LAN側インタフェース ethernet0のIPアドレス 192.168.10.3/24
WAN側インタフェース mobile1 ppp0
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
MSS自動調整 オート
PPP接続用ユーザID lte
PPP接続用パスワード lte
APN mopera.net
CID 1
PDPタイプ IP
発信用電話番号 *99***1#
ダイアルタイムアウト 30秒
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in 動作 許可
送信元IPアドレス 10.10.10.1
宛先IPアドレス any
プロトコル 115(L2TP)
L2TPv3 ホスト名 nxrb
ルータID 172.20.30.1
MACアドレス学習機能 有効
MACアドレス保持時間 300秒
Path MTU Discovery 有効
L2TPv3トンネル1 名前 VXR
リモートトンネルアドレス 10.10.10.1
リモートホスト名 vxr
リモートルータID 172.20.10.1
リモートベンダーID ietf
L2TPv3 Xconnect1 名前 VXR
L2TPv3トンネルID 1
Xconnectインタフェース ethernet0
リモートエンドID 1
再送間隔 30秒
MSS自動調整 オート
DNS サービス 有効
モバイルエラーリカバリー リセット
モバイルターミネーションリカバリー リセット

 

【 設定例 】

〔VXRの設定〕

vxr-x86#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
vxr-x86(config)#hostname VXR
VXR(config)#interface ethernet 0
VXR(config-if)#ip address 192.168.10.1/24
VXR(config-if)#exit
VXR(config)#interface ethernet 1
VXR(config-if)#ip address 192.168.11.1/24
VXR(config-if)#exit
VXR(config)#ip route 0.0.0.0/0 192.168.11.254
VXR(config)#l2tpv3 hostname vxr
VXR(config)#l2tpv3 router-id 172.20.10.1
VXR(config)#l2tpv3 mac-learning
VXR(config)#l2tpv3 mac-aging 300
VXR(config)#l2tpv3 path-mtu-discovery
VXR(config)#l2tpv3 tunnel 1
VXR(config-l2tpv3-tunnel)#description NXR_A
VXR(config-l2tpv3-tunnel)#tunnel address 10.10.20.1
VXR(config-l2tpv3-tunnel)#tunnel hostname nxra
VXR(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
VXR(config-l2tpv3-tunnel)#tunnel vendor ietf
VXR(config-l2tpv3-tunnel)#exit
VXR(config)#l2tpv3 xconnect 1
VXR(config-l2tpv3-xconnect)#description NXR_A
VXR(config-l2tpv3-xconnect)#tunnel 1
VXR(config-l2tpv3-xconnect)#xconnect ethernet 0
VXR(config-l2tpv3-xconnect)#xconnect end-id 1
VXR(config-l2tpv3-xconnect)#retry-interval 30
VXR(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
VXR(config-l2tpv3-xconnect)#exit
VXR(config)#l2tpv3 tunnel 2
VXR(config-l2tpv3-tunnel)#description NXR_B
VXR(config-l2tpv3-tunnel)#tunnel hostname nxrb
VXR(config-l2tpv3-tunnel)#tunnel router-id 172.20.30.1
VXR(config-l2tpv3-tunnel)#tunnel vendor ietf
VXR(config-l2tpv3-tunnel)#exit
VXR(config)#l2tpv3 xconnect 2
VXR(config-l2tpv3-xconnect)#description NXR_B
VXR(config-l2tpv3-xconnect)#tunnel 2
VXR(config-l2tpv3-xconnect)#xconnect ethernet 0
VXR(config-l2tpv3-xconnect)#xconnect end-id 1
VXR(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
VXR(config-l2tpv3-xconnect)#exit
VXR(config)#ssh-server enable
VXR(config)#dns
VXR(config-dns)#service enable
VXR(config-dns)#address 192.168.11.254
VXR(config-dns)#exit
VXR(config)#fast-forwarding enable
VXR(config)#l2tpv3 fast-forwarding enable
VXR(config)#exit
VXR#save config

〔NXR_Aの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.2/24
NXR_A(config-if)#exit
NXR_A(config)#ip route 0.0.0.0/0 ppp 0
NXR_A(config)#ip access-list ppp0_in permit 10.10.10.1 10.10.20.1 115
NXR_A(config)#ppp account username test2@example.jp password test2pass
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 10.10.20.1/32
NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test2@example.jp
NXR_A(config-ppp)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#exit
NXR_A(config)#l2tpv3 hostname nxra
NXR_A(config)#l2tpv3 router-id 172.20.20.1
NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description VXR
NXR_A(config-l2tpv3-tunnel)#tunnel address 10.10.10.1
NXR_A(config-l2tpv3-tunnel)#tunnel hostname vxr
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_A(config-l2tpv3-tunnel)#exit
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description VXR
NXR_A(config-l2tpv3-xconnect)#tunnel 1
NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#retry-interval 45
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_A(config-l2tpv3-xconnect)#exit
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#exit
NXR_A(config)#fast-forwarding enable
NXR_A(config)#l2tpv3 fast-forwarding enable
NXR_A(config)#exit
NXR_A#save config

〔NXR_Bの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.3/24
NXR_B(config-if)#exit
NXR_B(config)#ip route 0.0.0.0/0 ppp 0
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any 115
NXR_B(config)#ppp account username lte password lte
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated
NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ppp username lte
NXR_B(config-ppp)#mobile apn mopera.net cid 1 pdp-type ip
NXR_B(config-ppp)#dial-up string *99***1#
NXR_B(config-ppp)#dial-up timeout 30
NXR_B(config-ppp)#exit
NXR_B(config)#mobile error-recovery-reset
NXR_B(config)#mobile termination-recovery reset
NXR_B(config)#mobile 1 ppp 0
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 172.20.30.1
NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description VXR
NXR_B(config-l2tpv3-tunnel)#tunnel address 10.10.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel hostname vxr
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf
NXR_B(config-l2tpv3-tunnel)#exit
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description VXR
NXR_B(config-l2tpv3-xconnect)#tunnel 1
NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto
NXR_B(config-l2tpv3-xconnect)#exit
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#exit
NXR_B(config)#exit
NXR_B#save config

 

【 設定例解説 】

〔VXRの設定〕

1. <ホスト名の設定>
vxr-x86(config)#hostname VXR

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
VXR(config)#interface ethernet 0
VXR(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <WAN側(ethernet1)インタフェース設定>
VXR(config)#interface ethernet 1
VXR(config-if)#ip address 192.168.11.1/24

ethernet1インタフェースのIPアドレスを設定します。

 

4. <スタティックルート設定>
VXR(config)#ip route 0.0.0.0/0 192.168.11.254

デフォルトルートを設定します。

 

5. <L2TPv3設定>
VXR(config)#l2tpv3 hostname vxr
VXR(config)#l2tpv3 router-id 172.20.10.1

L2TPv3のホスト名としてvxrを設定します。また、ルータIDを設定します。

VXR(config)#l2tpv3 mac-learning
VXR(config)#l2tpv3 mac-aging 300
VXR(config)#l2tpv3 path-mtu-discovery

MACアドレス学習機能を有効にし、エージングタイムを設定します。また、Path MTU Discoveryを有効にします。

 

6. <L2TPv3トンネル1設定>
VXR(config)#l2tpv3 tunnel 1
VXR(config-l2tpv3-tunnel)#description NXR_A
VXR(config-l2tpv3-tunnel)#tunnel address 10.10.20.1

L2TPv3トンネル1の説明としてNXR_A、リモートアドレスにNXR_AのWAN側IPアドレスを設定します。

VXR(config-l2tpv3-tunnel)#tunnel hostname nxra
VXR(config-l2tpv3-tunnel)#tunnel router-id 172.20.20.1
VXR(config-l2tpv3-tunnel)#tunnel vendor ietf

NXR_AのL2TPv3ホスト名およびルータIDを設定します。そして、ベンダIDとしてietfを設定します。
(☞) L2TPv3のホスト名とルータIDはNXR_Aと同一の値を設定します。

 

7. <L2TPv3 Xconnect1設定>
VXR(config)#l2tpv3 xconnect 1
VXR(config-l2tpv3-xconnect)#description NXR_A
VXR(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてNXR_A、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

VXR(config-l2tpv3-xconnect)#xconnect ethernet 0
VXR(config-l2tpv3-xconnect)#xconnect end-id 1
VXR(config-l2tpv3-xconnect)#retry-interval 30
VXR(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。また、リトライインターバルを設定します。そして、TCP MSSの調整機能をオートに設定します。

 

8. <L2TPv3トンネル2設定>
VXR(config)#l2tpv3 tunnel 2
VXR(config-l2tpv3-tunnel)#description NXR_B

L2TPv3トンネル2の説明としてNXR_Bを設定します。なお、NXR_BのWAN側IPアドレスが動的IPアドレスのため、リモートトンネルアドレスは設定しません。

VXR(config-l2tpv3-tunnel)#tunnel hostname nxrb
VXR(config-l2tpv3-tunnel)#tunnel router-id 172.20.30.1
VXR(config-l2tpv3-tunnel)#tunnel vendor ietf

NXR_BのL2TPv3ホスト名およびルータIDを設定します。そして、ベンダIDとしてietfを設定します。
(☞) L2TPv3のホスト名とルータIDはNXR_Bと同一の値を設定します。

 

9. <L2TPv3 Xconnect2設定>
VXR(config)#l2tpv3 xconnect 2
VXR(config-l2tpv3-xconnect)#description NXR_B
VXR(config-l2tpv3-xconnect)#tunnel 2

L2TPv3 Xconnect2の説明としてNXR_B、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル2を設定します。

VXR(config-l2tpv3-xconnect)#xconnect ethernet 0
VXR(config-l2tpv3-xconnect)#xconnect end-id 1
VXR(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。また、TCP MSSの調整機能をオートに設定します。

 

10. <SSHサーバ設定>
VXR(config)#ssh-server enable

SSHサーバを有効にします。
(☞) この設定例ではコンソール以外からのアクセス方法としてSSHサーバを設定しています。

 

11. <DNS設定>
VXR(config)#dns
VXR(config-dns)#service enable
VXR(config-dns)#address 192.168.11.254

DNSサービスを有効にします。また、VRをプライマリDNSサーバとして設定します。

 

12. <ファストフォワーディングの有効化>
VXR(config)#fast-forwarding enable
VXR(config)#l2tpv3 fast-forwarding enable

ファストフォワーディングおよびL2TPv3ファストフォワーディングを有効にします。
(☞) ファストフォワーディングおよびL2TPv3ファストフォワーディングの詳細および利用時の制約については、VXR-x86のユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.10.2/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_A(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_A(config)#ip access-list ppp0_in permit 10.10.10.1 10.10.20.1 115

IPアクセスリスト名をppp0_inとし、送信元がVRのWAN側IPアドレス10.10.10.1、宛先IPアドレスが10.10.20.1のL2TPパケット(プロトコル番号115)を許可します。
なお、このIPアクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

5. <PPPアカウント設定>
NXR_A(config)#ppp account username test2@example.jp password test2pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 10.10.20.1/32

ppp0インタフェースのIPアドレスを設定します。

NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。また、IPアクセスリストppp0_inをinフィルタに適用します。そして、TCP MSSの調整機能をオートに設定します。

NXR_A(config-ppp)#ppp username test2@example.jp

ISP接続用ユーザIDを設定します。

 

7. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

8. <L2TPv3設定>
NXR_A(config)#l2tpv3 hostname nxra
NXR_A(config)#l2tpv3 router-id 172.20.20.1

L2TPv3のホスト名としてnxraを設定します。また、ルータIDを設定します。

NXR_A(config)#l2tpv3 mac-learning
NXR_A(config)#l2tpv3 mac-aging 300
NXR_A(config)#l2tpv3 path-mtu-discovery

MACアドレス学習機能を有効にし、エージングタイムを設定します。また、Path MTU Discoveryを有効にします。

 

9. <L2TPv3トンネル設定>
NXR_A(config)#l2tpv3 tunnel 1
NXR_A(config-l2tpv3-tunnel)#description VXR
NXR_A(config-l2tpv3-tunnel)#tunnel address 10.10.10.1

L2TPv3トンネル1の説明としてVXR、リモートアドレスにVRのWAN側IPアドレスを設定します。

NXR_A(config-l2tpv3-tunnel)#tunnel hostname vxr
NXR_A(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_A(config-l2tpv3-tunnel)#tunnel vendor ietf

VXRのL2TPv3ホスト名およびルータIDを設定します。そして、ベンダIDとしてietfを設定します。
(☞) L2TPv3のホスト名とルータIDはVXRと同一の値を設定します。

 

10. <L2TPv3 Xconnect設定>
NXR_A(config)#l2tpv3 xconnect 1
NXR_A(config-l2tpv3-xconnect)#description VXR
NXR_A(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてVXR、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_A(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_A(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_A(config-l2tpv3-xconnect)#retry-interval 45
NXR_A(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。また、リトライインターバルを設定します。そして、TCP MSSの調整機能をオートに設定します。

 

11. <DNS設定>
NXR_A(config)#dns
NXR_A(config-dns)#service enable

DNSサービスを有効にします。

 

12. <ファストフォワーディングの有効化>
NXR_A(config)#fast-forwarding enable
NXR_A(config)#l2tpv3 fast-forwarding enable

ファストフォワーディングおよびL2TPv3ファストフォワーディングを有効にします。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.10.3/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_B(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any 115

IPアクセスリスト名をppp0_inとし、送信元がVRのWAN側IPアドレス10.10.10.1のL2TPパケット(プロトコル番号115)を許可します。
なお、このIPアクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

5. <PPPアカウント設定>
NXR_B(config)#ppp account username lte password lte

ppp0インタフェースで使用するPPP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

6. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスを設定します。

NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。また、IPアクセスリストppp0_inをinフィルタに適用します。そして、TCP MSSの調整機能をオートに設定します。

NXR_B(config-ppp)#ppp username lte

PPP接続用ユーザIDを設定します。

NXR_B(config-ppp)#mobile apn mopera.net cid 1 pdp-type ip

APN,CID,pdp-typeを設定します。

NXR_B(config-ppp)#dial-up string *99***1#
NXR_B(config-ppp)#dial-up timeout 30

発信用の電話番号およびダイアルタイムアウトを設定します。

 

7. <モバイルエラーリカバリー設定>
NXR_B(config)#mobile error-recovery-reset

通信モジュールとの通信に重大な問題が発生する可能性が高いと判断した場合、通信モジュールのリセットを行うように設定します。

 

8. <モバイルターミネーションリカバリー設定>
NXR_B(config)#mobile termination-recovery reset

PPP接続時に網側から切断された場合、通信モジュールのリセットを行うように設定します。

 

9. <モバイル割り当て設定>
NXR_B(config)#mobile 1 ppp 0

mobile1と認識されている通信モジュールとppp0インタフェースの関連づけを行います。
通信モジュールをPPPインタフェースで使用する場合は、mobileコマンドによるPPPインタフェースへの関連付けが必要になります。
(☞) mobile1に割り当てられている通信モジュールはshow mobile 1コマンドで確認することができます。

 

10. <L2TPv3設定>
NXR_B(config)#l2tpv3 hostname nxrb
NXR_B(config)#l2tpv3 router-id 172.20.30.1

L2TPv3のホスト名としてnxrbを設定します。また、ルータIDを設定します。

NXR_B(config)#l2tpv3 mac-learning
NXR_B(config)#l2tpv3 mac-aging 300
NXR_B(config)#l2tpv3 path-mtu-discovery

MACアドレス学習機能を有効にし、エージングタイムを設定します。また、Path MTU Discoveryを有効にします。

 

11. <L2TPv3トンネル設定>
NXR_B(config)#l2tpv3 tunnel 1
NXR_B(config-l2tpv3-tunnel)#description VXR
NXR_B(config-l2tpv3-tunnel)#tunnel address 10.10.10.1

L2TPv3トンネル1の説明としてVXR、リモートアドレスにVRのWAN側IPアドレスを設定します。

NXR_B(config-l2tpv3-tunnel)#tunnel hostname vxr
NXR_B(config-l2tpv3-tunnel)#tunnel router-id 172.20.10.1
NXR_B(config-l2tpv3-tunnel)#tunnel vendor ietf

VXRのL2TPv3ホスト名およびルータIDを設定します。そして、ベンダIDとしてietfを設定します。
(☞) L2TPv3のホスト名とルータIDはVXRと同一の値を設定します。

 

12. <L2TPv3 Xconnect設定>
NXR_B(config)#l2tpv3 xconnect 1
NXR_B(config-l2tpv3-xconnect)#description VXR
NXR_B(config-l2tpv3-xconnect)#tunnel 1

L2TPv3 Xconnect1の説明としてVXR、関連づけを行うL2TPv3トンネルとしてL2TPv3トンネル1を設定します。

NXR_B(config-l2tpv3-xconnect)#xconnect ethernet 0
NXR_B(config-l2tpv3-xconnect)#xconnect end-id 1
NXR_B(config-l2tpv3-xconnect)#retry-interval 30
NXR_B(config-l2tpv3-xconnect)#ip tcp adjust-mss auto

Xconnectインタフェースとしてethernet0インタフェースおよびリモートエンドIDを設定します。また、リトライインターバルを設定します。そして、TCP MSSの調整機能をオートに設定します。

 

13. <DNS設定>
NXR_B(config)#dns
NXR_B(config-dns)#service enable

DNSサービスを有効にします。

 

【 端末の設定例 】

仮想サーバ LAN_Aの端末 LAN_Bの端末
IPアドレス 192.168.10.101 192.168.10.102 192.168.10.103
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.10.2 192.168.10.3
DNSサーバ 192.168.11.254