FutureNet

NXR,WXRシリーズ

VXRシリーズ編

3. Cloudn Compute(VPCタイプOpenNW) VPN接続設定

3-3. VXR経由拠点間IPsec NAT-T通信設定(VPCタイプOpenNW)

2-2. VXR経由拠点間IPsec通信設定(VPCタイプOpenNW)の構成をベースに、拠点側ルータがNAT配下にあるためIPsec NATトラバーサルで接続します。

 

【 構成図 】

  • Cloudn側のVRでNATを行いますので、VXR-x86のWAN側インタフェースのIPアドレスはプライベートIPアドレスとなります。

 

【 設定データ 】

〔VXRの設定〕

設定項目 設定内容
ホスト名 VXR
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
WAN側インタフェース ethernet1のIPアドレス 192.168.11.1/24
IPsecローカルポリシー 1
スタティックルート No.1 宛先IPアドレス 192.168.20.0/24
ゲートウェイ(インタフェース) tunnel1
ディスタンス 1
No.2 宛先IPアドレス 192.168.20.0/24
ゲートウェイ(インタフェース) null
ディスタンス 254
No.3 宛先IPアドレス 192.168.30.0/24
ゲートウェイ(インタフェース) tunnel2
ディスタンス 1
No.4 宛先IPアドレス 192.168.30.0/24
ゲートウェイ(インタフェース) null
ディスタンス 254
No.5 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(IPアドレス) 192.168.11.254
IPsec IPsecアクセスリスト リスト名 ipsec_acl
送信元IPアドレス any
宛先IPアドレス any
NATトラバーサル 有効
IPsec priority-ignore 有効
IPsecローカルポリシー1 address ip
セルフID(FQDN) vxr
IPsec ISAKMPポリシー1 名前 NXR_A
認証方式 pre-share
認証鍵 ipseckey1
認証アルゴリズム sha1
暗号化アルゴリズム aes128
DHグループ 5
ライフタイム 10800秒
ISAKMPモード アグレッシブモード
リモートアドレス any
リモートID(FQDN) nxra
DPD 再送間隔 30秒
リトライ回数 3回
動作 clear
ローカルポリシー 1
 IPsecトンネルポリシー1 名前 NXR_A
ネゴシエーションモード レスポンダ
認証アルゴリズム sha1
暗号化アルゴリズム aes128
PFS 有効(グループ5)
ライフタイム 3600秒
ISAKMPポリシー 1
IPsecアクセスリスト ipsec_acl
IPsec ISAKMPポリシー2 名前 NXR_B
認証方式 pre-share
認証鍵 ipseckey2
認証アルゴリズム sha1
暗号化アルゴリズム aes128
DHグループ 5
ライフタイム 10800秒
ISAKMPモード アグレッシブモード
リモートアドレス any
リモートID(FQDN) nxrb
DPD 再送間隔 30秒
リトライ回数 3回
動作 clear
ローカルポリシー 1
 IPsecトンネルポリシー2 名前 NXR_B
ネゴシエーションモード レスポンダ
認証アルゴリズム sha1
暗号化アルゴリズム aes128
PFS 有効(グループ5)
ライフタイム 3600秒
ISAKMPポリシー 2
IPsecアクセスリスト ipsec_acl
トンネル1インタフェース トンネルモード IPsec(IPv4)
トンネルプロテクション ipsec policy 1
MSS自動調整 オート
トンネル2インタフェース トンネルモード IPsec(IPv4)
トンネルプロテクション ipsec policy 2
MSS自動調整 オート
SSHサーバ 有効
DNS サービス 有効
DNSサーバ プライマリ 192.168.11.254

〔NXR_Aの設定〕

設定項目 設定内容
ホスト名 NXR_A
LAN側インタフェース ethernet0のIPアドレス 192.168.20.1/24
WAN側インタフェース ethernet1のIPアドレス 192.168.21.1/24
IPsecローカルポリシー 1
スタティックルート No.1 宛先IPアドレス 192.168.0.0/16
ゲートウェイ(インタフェース) tunnel1
ディスタンス 1
No.2 宛先IPアドレス 192.168.0.0/16
ゲートウェイ(インタフェース) null
ディスタンス 254
No.3 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(IPアドレス) 192.168.21.254
IPsec IPsecアクセスリスト リスト名 ipsec_acl
送信元IPアドレス any
宛先IPアドレス any
NATトラバーサル 有効
IPsecローカルポリシー1 address ip
セルフID(FQDN) nxra
IPsec ISAKMPポリシー1 名前 VXR
認証方式 pre-share
認証鍵 ipseckey1
認証アルゴリズム sha1
暗号化アルゴリズム aes128
DHグループ 5
ライフタイム 10800秒
ISAKMPモード アグレッシブモード
リモートアドレス 10.10.10.1
リモートID(FQDN) vxr
DPD 再送間隔 30秒
リトライ回数 3回
動作 restart
ローカルポリシー 1
 IPsecトンネルポリシー1 名前 VXR
ネゴシエーションモード オート
認証アルゴリズム sha1
暗号化アルゴリズム aes128
PFS 有効(グループ5)
ライフタイム 3600秒
ISAKMPポリシー 1
IPsecアクセスリスト ipsec_acl
トンネル1インタフェース トンネルモード IPsec(IPv4)
トンネルプロテクション ipsec policy 1
MSS自動調整 オート
DNS サービス 有効
DNSサーバ プライマリ 192.168.21.254
FastFowarding 有効

〔NXR_Bの設定〕

設定項目 設定内容
ホスト名 NXR_B
LAN側インタフェース ethernet0のIPアドレス 192.168.30.1/24
WAN側インタフェース ethernet1のIPアドレス 192.168.31.1/24
IPsecローカルポリシー 1
スタティックルート No.1 宛先IPアドレス 192.168.0.0/16
ゲートウェイ(インタフェース) tunnel1
ディスタンス 1
No.2 宛先IPアドレス 192.168.0.0/16
ゲートウェイ(インタフェース) null
ディスタンス 254
No.3 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(IPアドレス) 192.168.31.254
IPsec IPsecアクセスリスト リスト名 ipsec_acl
送信元IPアドレス any
宛先IPアドレス any
NATトラバーサル 有効
IPsecローカルポリシー1 address ip
セルフID(FQDN) nxrb
IPsec ISAKMPポリシー1 名前 VXR
認証方式 pre-share
認証鍵 ipseckey2
認証アルゴリズム sha1
暗号化アルゴリズム aes128
DHグループ 5
ライフタイム 10800秒
ISAKMPモード アグレッシブモード
リモートアドレス 10.10.10.1
リモートID(FQDN) vxr
DPD 再送間隔 30秒
リトライ回数 3回
動作 restart
ローカルポリシー 1
 IPsecトンネルポリシー1 名前 VXR
ネゴシエーションモード オート
認証アルゴリズム sha1
暗号化アルゴリズム aes128
PFS 有効(グループ5)
ライフタイム 3600秒
ISAKMPポリシー 1
IPsecアクセスリスト ipsec_acl
トンネル1インタフェース トンネルモード IPsec(IPv4)
トンネルプロテクション ipsec policy 1
MSS自動調整 オート
DNS サービス 有効
DNSサーバ プライマリ 192.168.31.254
FastFowarding 有効

 

【 設定例 】

〔VXRの設定〕

vxr-x86#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
vxr-x86(config)#hostname VXR
VXR(config)#interface ethernet 0
VXR(config-if)#ip address 192.168.10.1/24
VXR(config-if)#exit
VXR(config)#ip route 192.168.20.0/24 tunnel 1 1
VXR(config)#ip route 192.168.20.0/24 null 254
VXR(config)#ip route 192.168.30.0/24 tunnel 2 1
VXR(config)#ip route 192.168.30.0/24 null 254
VXR(config)#ip route 0.0.0.0/0 192.168.11.254
VXR(config)#ipsec access-list ipsec_acl ip any any
VXR(config)#ipsec nat-traversal enable
% restart ipsec service to take affect.
VXR(config)#ipsec priority-ignore enable
% restart ipsec service to take affect.
VXR(config)#ipsec local policy 1
VXR(config-ipsec-local)#address ip
VXR(config-ipsec-local)#self-identity fqdn vxr
VXR(config-ipsec-local)#exit
VXR(config)#ipsec isakmp policy 1
VXR(config-ipsec-isakmp)#description NXR_A
VXR(config-ipsec-isakmp)#authentication pre-share ipseckey1
VXR(config-ipsec-isakmp)#hash sha1
VXR(config-ipsec-isakmp)#encryption aes128
VXR(config-ipsec-isakmp)#group 5
VXR(config-ipsec-isakmp)#lifetime 10800
VXR(config-ipsec-isakmp)#isakmp-mode aggressive
VXR(config-ipsec-isakmp)#remote address ip any
VXR(config-ipsec-isakmp)#remote identity fqdn nxra
VXR(config-ipsec-isakmp)#keepalive 30 3 periodic clear
VXR(config-ipsec-isakmp)#local policy 1
VXR(config-ipsec-isakmp)#exit
VXR(config)#ipsec tunnel policy 1
VXR(config-ipsec-tunnel)#description NXR_A
VXR(config-ipsec-tunnel)#negotiation-mode responder
VXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
VXR(config-ipsec-tunnel)#set pfs group5
VXR(config-ipsec-tunnel)#set sa lifetime 3600
VXR(config-ipsec-tunnel)#set key-exchange isakmp 1
VXR(config-ipsec-tunnel)#match address ipsec_acl
VXR(config-ipsec-tunnel)#exit
VXR(config)#interface tunnel 1
VXR(config-tunnel)#tunnel mode ipsec ipv4
VXR(config-tunnel)#tunnel protection ipsec policy 1
VXR(config-tunnel)#ip tcp adjust-mss auto
VXR(config-tunnel)#exit
VXR(config)#ipsec isakmp policy 2
VXR(config-ipsec-isakmp)#description NXR_B
VXR(config-ipsec-isakmp)#authentication pre-share ipseckey2
VXR(config-ipsec-isakmp)#hash sha1
VXR(config-ipsec-isakmp)#encryption aes128
VXR(config-ipsec-isakmp)#group 5
VXR(config-ipsec-isakmp)#lifetime 10800
VXR(config-ipsec-isakmp)#isakmp-mode aggressive
VXR(config-ipsec-isakmp)#remote address ip any
VXR(config-ipsec-isakmp)#remote identity fqdn nxrb
VXR(config-ipsec-isakmp)#keepalive 30 3 periodic clear
VXR(config-ipsec-isakmp)#local policy 1
VXR(config-ipsec-isakmp)#exit
VXR(config)#ipsec tunnel policy 2
VXR(config-ipsec-tunnel)#description NXR_B
VXR(config-ipsec-tunnel)#negotiation-mode responder
VXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
VXR(config-ipsec-tunnel)#set pfs group5
VXR(config-ipsec-tunnel)#set sa lifetime 3600
VXR(config-ipsec-tunnel)#set key-exchange isakmp 2
VXR(config-ipsec-tunnel)#match address ipsec_acl
VXR(config-ipsec-tunnel)#exit
VXR(config)#interface tunnel 2
VXR(config-tunnel)#tunnel mode ipsec ipv4
VXR(config-tunnel)#tunnel protection ipsec policy 2
VXR(config-tunnel)#ip tcp adjust-mss auto
VXR(config-tunnel)#exit
VXR(config)#interface ethernet 1
VXR(config-if)#ip address 192.168.11.1/24
VXR(config-if)#ipsec policy 1
VXR(config-if)#exit
VXR(config)#ssh-server enable
VXR(config)#dns
VXR(config-dns)#service enable
VXR(config-dns)#address 192.168.11.254
VXR(config-dns)#exit
VXR(config)#fast-forwarding enable
VXR(config)#exit
VXR#save config

〔NXR_Aの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.20.1/24
NXR_A(config-if)#exit
NXR_A(config)#ip route 192.168.0.0/16 tunnel 1 1
NXR_A(config)#ip route 192.168.0.0/16 null 254
NXR_A(config)#ip route 0.0.0.0/0 192.168.21.254
NXR_A(config)#ipsec access-list ipsec_acl ip any any
NXR_A(config)#ipsec nat-traversal enable
% restart ipsec service to take affect.
NXR_A(config)#ipsec local policy 1
NXR_A(config-ipsec-local)#address ip
NXR_A(config-ipsec-local)#self-identity fqdn nxra
NXR_A(config-ipsec-local)#exit
NXR_A(config)#ipsec isakmp policy 1
NXR_A(config-ipsec-isakmp)#description VXR
NXR_A(config-ipsec-isakmp)#authentication pre-share ipseckey1
NXR_A(config-ipsec-isakmp)#hash sha1
NXR_A(config-ipsec-isakmp)#encryption aes128
NXR_A(config-ipsec-isakmp)#group 5
NXR_A(config-ipsec-isakmp)#lifetime 10800
NXR_A(config-ipsec-isakmp)#isakmp-mode aggressive
NXR_A(config-ipsec-isakmp)#remote address ip 10.10.10.1
NXR_A(config-ipsec-isakmp)#remote identity fqdn vxr
NXR_A(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR_A(config-ipsec-isakmp)#local policy 1
NXR_A(config-ipsec-isakmp)#exit
NXR_A(config)#ipsec tunnel policy 1
NXR_A(config-ipsec-tunnel)#description VXR
NXR_A(config-ipsec-tunnel)#negotiation-mode auto
NXR_A(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
NXR_A(config-ipsec-tunnel)#set pfs group5
NXR_A(config-ipsec-tunnel)#set sa lifetime 3600
NXR_A(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_A(config-ipsec-tunnel)#match address ipsec_acl
NXR_A(config-ipsec-tunnel)#exit
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode ipsec ipv4
NXR_A(config-tunnel)#tunnel protection ipsec policy 1
NXR_A(config-tunnel)#ip tcp adjust-mss auto
NXR_A(config-tunnel)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#ip address 192.168.21.1/24
NXR_A(config-if)#ipsec policy 1
NXR_A(config-if)#exit
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#address 192.168.21.254
NXR_A(config-dns)#exit
NXR_A(config)#fast-forwarding enable
NXR_A(config)#exit
NXR_A#save config

〔NXR_Bの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.30.1/24
NXR_B(config-if)#exit
NXR_B(config)#ip route 192.168.0.0/16 tunnel 1 1
NXR_B(config)#ip route 192.168.0.0/16 null 254
NXR_B(config)#ip route 0.0.0.0/0 192.168.31.254
NXR_B(config)#ipsec access-list ipsec_acl ip any any
NXR_B(config)#ipsec nat-traversal enable
% restart ipsec service to take affect.
NXR_B(config)#ipsec local policy 1
NXR_B(config-ipsec-local)#address ip
NXR_B(config-ipsec-local)#self-identity fqdn nxrb
NXR_B(config-ipsec-local)#exit
NXR_B(config)#ipsec isakmp policy 1
NXR_B(config-ipsec-isakmp)#description VXR
NXR_B(config-ipsec-isakmp)#authentication pre-share ipseckey2
NXR_B(config-ipsec-isakmp)#hash sha1
NXR_B(config-ipsec-isakmp)#encryption aes128
NXR_B(config-ipsec-isakmp)#group 5
NXR_B(config-ipsec-isakmp)#lifetime 10800
NXR_B(config-ipsec-isakmp)#isakmp-mode aggressive
NXR_B(config-ipsec-isakmp)#remote address ip 10.10.10.1
NXR_B(config-ipsec-isakmp)#remote identity fqdn vxr
NXR_B(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR_B(config-ipsec-isakmp)#local policy 1
NXR_B(config-ipsec-isakmp)#exit
NXR_B(config)#ipsec tunnel policy 1
NXR_B(config-ipsec-tunnel)#description VXR
NXR_B(config-ipsec-tunnel)#negotiation-mode auto
NXR_B(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
NXR_B(config-ipsec-tunnel)#set pfs group5
NXR_B(config-ipsec-tunnel)#set sa lifetime 3600
NXR_B(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_B(config-ipsec-tunnel)#match address ipsec_acl
NXR_B(config-ipsec-tunnel)#exit
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode ipsec ipv4
NXR_B(config-tunnel)#tunnel protection ipsec policy 1
NXR_B(config-tunnel)#ip tcp adjust-mss auto
NXR_B(config-tunnel)#exit
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#ip address 192.168.31.1/24
NXR_B(config-if)#ipsec policy 1
NXR_B(config-if)#exit
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#address 192.168.31.254
NXR_B(config-dns)#exit
NXR_B(config)#fast-forwarding enable
NXR_B(config)#exit
NXR_B#save config

 

【 設定例解説 】

〔VXRの設定〕

1. <ホスト名の設定>
vxr-x86(config)#hostname VXR

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
VXR(config)#interface ethernet 0
VXR(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
VXR(config)#ip route 192.168.20.0/24 tunnel 1 1
VXR(config)#ip route 192.168.20.0/24 null 254

LAN_A向けのルートを設定します。なお、IPsec SA確立時はトンネル1インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。
(☞) nullインタフェースを出力インタフェースとして設定した場合、パケットが出力されることはありません(ドロップされます)。

VXR(config)#ip route 192.168.30.0/24 tunnel 2 1
VXR(config)#ip route 192.168.30.0/24 null 254

LAN_B向けのルートを設定します。なお、IPsec SA確立時はトンネル2インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。

VXR(config)#ip route 0.0.0.0/0 192.168.11.254

デフォルトルートを設定します。

 

4. <IPsecアクセスリスト設定>
VXR(config)#ipsec access-list ipsec_acl ip any any

ipsec_aclという名前のIPsecアクセスリストを設定します。なお、送信元IPアドレス,宛先IPアドレスともにanyとします。
(☞) Route Based IPsecでESP化するか否かはIPsecアクセスリストではなく、トンネルインタフェースをゲートウェイとするルート設定の有無で決まります。よって、Policy Based IPsecではIPsecアクセスリストで設定したルールに基づきIPsecでESP化するかどうかが決定されましたが、Route Based IPsecではIPsecアクセスリストをIKEフェーズ2のIDとしてのみ使用します。

 

5. <IPsec NATトラバーサル設定>
VXR(config)#ipsec nat-traversal enable

NATトラバーサルを有効にします。

 

6. <IPsec priority-ignore設定>
VXR(config)#ipsec priority-ignore enable

ipsec priority-ignoreを有効に設定します。
これはプライオリティによるIPsec SAの優先度を無効にする設定です。
Route based IPsecではフェーズ2のIDをIPsec SAを確立するためのIDとしてのみ使用します。そのためプライオリティによる冗長化設定などを利用しない場合は、本設定を有効にすることによって同じフェーズ2のIDを持つIPsec SAを複数個同時に確立することができます。
(☞) この機能に対応していない場合は、同じフェーズ2のIDを持つIPsec SAを同時に複数個確立することができません。そのため設定例のように同一のIPsecアクセスリストを複数のIPsecトンネルポリシーに適用した場合IPsec SAを複数同時に確立することができませんので、各IPsecトンネルポリシー毎に異なるルールのIPsecアクセスリストを設定する必要があります。

 

7. <IPsecローカルポリシー設定>
VXR(config)#ipsec local policy 1
VXR(config-ipsec-local)#address ip
VXR(config-ipsec-local)#self-identity fqdn vxr

IPsecトンネルの送信元IPアドレスをip(IPv4)と設定します。また、セルフIDをFQDN方式でvxrとし、NXR_A,BのリモートIDと同じIDを設定します。

 

8. <IPsec ISAKMPポリシー1設定>
VXR(config)#ipsec isakmp policy 1
VXR(config-ipsec-isakmp)#description NXR_A
VXR(config-ipsec-isakmp)#authentication pre-share ipseckey1

ISAKMPポリシーの説明としてNXR_A、認証方式としてpre-share(事前共有鍵)を選択し事前共有鍵ipseckey1を設定します。なお、事前共有鍵はNXR_Aと共通の値を設定します。

VXR(config-ipsec-isakmp)#hash sha1
VXR(config-ipsec-isakmp)#encryption aes128
VXR(config-ipsec-isakmp)#group 5
VXR(config-ipsec-isakmp)#lifetime 10800
VXR(config-ipsec-isakmp)#isakmp-mode aggressive

認証アルゴリズムとしてsha1、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして10800秒、フェーズ1のネゴシエーションモードとしてアグレッシブモードを設定します。

VXR(config-ipsec-isakmp)#remote address ip any
VXR(config-ipsec-isakmp)#remote identity fqdn nxra
VXR(config-ipsec-isakmp)#keepalive 30 3 periodic clear
VXR(config-ipsec-isakmp)#local policy 1

NXR_AがNAPTルータ配下にあるため、リモートアドレスをanyとします。また、リモートIDをFQDN方式でnxraとし、NXR_AのセルフIDと同じIDを設定します。そして、IKE KeepAlive(DPD)を監視間隔30秒,リトライ回数3回としkeepalive失敗時にSAを削除するよう設定します。さらに、IPsecローカルポリシー1と関連づけを行います。

 

9. <IPsec トンネルポリシー1設定>
VXR(config)#ipsec tunnel policy 1
VXR(config-ipsec-tunnel)#description NXR_A
VXR(config-ipsec-tunnel)#negotiation-mode responder

IPsecトンネルポリシーの説明としてNXR_A、ネゴシエーションモードとしてresponderを設定します。

VXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
VXR(config-ipsec-tunnel)#set pfs group5
VXR(config-ipsec-tunnel)#set sa lifetime 3600

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha1、PFSを有効にし、かつDHグループとしてgroup5、IPsec SAのライフタイムとして3600秒を設定します。

VXR(config-ipsec-tunnel)#set key-exchange isakmp 1
VXR(config-ipsec-tunnel)#match address ipsec_acl

ISAKMPポリシー1と関連づけを行い、IPsecアクセスリストipsec_aclを設定します。

 

10. <トンネル1インタフェース設定>
VXR(config)#interface tunnel 1
VXR(config-tunnel)#tunnel mode ipsec ipv4
VXR(config-tunnel)#tunnel protection ipsec policy 1
VXR(config-tunnel)#ip tcp adjust-mss auto

トンネル1インタフェースでトンネルモードをipsec ipv4、使用するトンネルポリシーとして1を設定します。また、TCPMSS値をオートに設定します。

 

11. <IPsec ISAKMPポリシー2設定>
VXR(config)#ipsec isakmp policy 2
VXR(config-ipsec-isakmp)#description NXR_B
VXR(config-ipsec-isakmp)#authentication pre-share ipseckey2

ISAKMPポリシーの説明としてNXR_B、認証方式としてpre-share(事前共有鍵)を選択し事前共有鍵ipseckey2を設定します。なお、事前共有鍵はNXR_Bと共通の値を設定します。

VXR(config-ipsec-isakmp)#hash sha1
VXR(config-ipsec-isakmp)#encryption aes128
VXR(config-ipsec-isakmp)#group 5
VXR(config-ipsec-isakmp)#lifetime 10800
VXR(config-ipsec-isakmp)#isakmp-mode aggressive

認証アルゴリズムとしてsha1、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして10800秒、フェーズ1のネゴシエーションモードとしてアグレッシブモードを設定します。

VXR(config-ipsec-isakmp)#remote address ip any
VXR(config-ipsec-isakmp)#remote identity fqdn nxrb
VXR(config-ipsec-isakmp)#keepalive 30 3 periodic clear
VXR(config-ipsec-isakmp)#local policy 1

NXR_BがNAPTルータ配下にあるため、リモートアドレスをanyとします。また、リモートIDをFQDN方式でnxrbとし、NXR_BのセルフIDと同じIDを設定します。そして、IKE KeepAlive(DPD)を監視間隔30秒,リトライ回数3回としkeepalive失敗時にSAを削除するよう設定します。さらに、IPsecローカルポリシー1と関連づけを行います。

 

12. <IPsec トンネルポリシー2設定>
VXR(config)#ipsec tunnel policy 2
VXR(config-ipsec-tunnel)#description NXR_B
VXR(config-ipsec-tunnel)#negotiation-mode responder

IPsecトンネルポリシーの説明としてNXR_B、ネゴシエーションモードとしてresponderを設定します。

VXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
VXR(config-ipsec-tunnel)#set pfs group5
VXR(config-ipsec-tunnel)#set sa lifetime 3600

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha1、PFSを有効にし、かつDHグループとしてgroup5、IPsec SAのライフタイムとして3600秒を設定します。

VXR(config-ipsec-tunnel)#set key-exchange isakmp 2
VXR(config-ipsec-tunnel)#match address ipsec_acl

ISAKMPポリシー2と関連づけを行い、IPsecアクセスリストipsec_aclを設定します。

 

13. <トンネル2インタフェース設定>
VXR(config)#interface tunnel 2
VXR(config-tunnel)#tunnel mode ipsec ipv4
VXR(config-tunnel)#tunnel protection ipsec policy 2
VXR(config-tunnel)#ip tcp adjust-mss auto

トンネル2インタフェースでトンネルモードをipsec ipv4、使用するトンネルポリシーとして2を設定します。また、TCPMSS値をオートに設定します。

 

14. <WAN側(ethernet1)インタフェース設定>
VXR(config)#interface ethernet 1
VXR(config-if)#ip address 192.168.11.1/24
VXR(config-if)#ipsec policy 1

ethernet1インタフェースのIPアドレスを設定します。また、IPsecトンネルのエンドポイントとなるためIPsecローカルポリシー1を設定します。

 

15. <SSHサーバ設定>
VXR(config)#ssh-server enable

SSHサーバを有効にします。
(☞) この設定例ではコンソール以外からのアクセス方法としてSSHサーバを設定しています。

 

16. <DNS設定>
VXR(config)#dns
VXR(config-dns)#service enable
VXR(config-dns)#address 192.168.11.254

DNSサービスを有効にします。また、VRをプライマリDNSサーバとして設定します。

 

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.20.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_A(config)#ip route 192.168.0.0/16 tunnel 1 1
NXR_A(config)#ip route 192.168.0.0/16 null 254

仮想サーバおよびLAN_B向けのルートを設定します。なお、IPsec SA確立時はトンネル1インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。
(☞) nullインタフェースを出力インタフェースとして設定した場合、パケットが出力されることはありません(ドロップされます)。

NXR_A(config)#ip route 0.0.0.0/0 192.168.21.254

デフォルトルートを設定します。

 

4. <IPsecアクセスリスト設定>
NXR_A(config)#ipsec access-list ipsec_acl ip any any

ipsec_aclという名前のIPsecアクセスリストを設定します。なお、送信元IPアドレス,宛先IPアドレスともにanyとします。

 

5. <IPsec NATトラバーサル設定>
NXR_A(config)#ipsec nat-traversal enable

NATトラバーサルを有効にします。

 

6. <IPsecローカルポリシー設定>
NXR_A(config)#ipsec local policy 1
NXR_A(config-ipsec-local)#address ip
NXR_A(config-ipsec-local)#self-identity fqdn nxra

IPsecトンネルの送信元IPアドレスをip(IPv4)と設定します。また、セルフIDをFQDN方式でnxraとし、VXRのリモートIDと同じIDを設定します。

 

7. <IPsec ISAKMPポリシー設定>
NXR_A(config)#ipsec isakmp policy 1
NXR_A(config-ipsec-isakmp)#description VXR
NXR_A(config-ipsec-isakmp)#authentication pre-share ipseckey1

ISAKMPポリシーの説明としてVXR、認証方式としてpre-share(事前共有鍵)を選択し、事前共有鍵ipseckey1を設定します。なお、事前共有鍵はVXRと共通の値を設定します。

NXR_A(config-ipsec-isakmp)#hash sha1
NXR_A(config-ipsec-isakmp)#encryption aes128
NXR_A(config-ipsec-isakmp)#group 5
NXR_A(config-ipsec-isakmp)#lifetime 10800
NXR_A(config-ipsec-isakmp)#isakmp-mode aggressive

認証アルゴリズムとしてsha1、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして10800秒、フェーズ1のネゴシエーションモードとしてアグレッシブモードを設定します。

NXR_A(config-ipsec-isakmp)#remote address ip 10.10.10.1
NXR_A(config-ipsec-isakmp)#remote identity fqdn vxr
NXR_A(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR_A(config-ipsec-isakmp)#local policy 1

リモートアドレスにVRのWAN側IPアドレスを設定します。また、リモートIDをFQDN方式でvxrとし、VXRのセルフIDと同じIDを設定します。そして、IKE KeepAlive(DPD)を監視間隔30秒,リトライ回数3回としkeepalive失敗時にSAを削除しIKEのネゴシエーションを開始するよう設定します。さらに、IPsecローカルポリシー1と関連づけを行います。

 

8. <IPsec トンネルポリシー設定>
NXR_A(config)#ipsec tunnel policy 1
NXR_A(config-ipsec-tunnel)#description VXR
NXR_A(config-ipsec-tunnel)#negotiation-mode auto

IPsecトンネルポリシーの説明としてVXR、ネゴシエーションモードとしてautoを設定します。

NXR_A(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
NXR_A(config-ipsec-tunnel)#set pfs group5
NXR_A(config-ipsec-tunnel)#set sa lifetime 3600

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha1、PFSを有効にし、かつDHグループとしてgroup5、IPsec SAのライフタイムとして3600秒を設定します。

NXR_A(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_A(config-ipsec-tunnel)#match address ipsec_acl

ISAKMPポリシー1と関連づけを行い、IPsecアクセスリストipsec_aclを設定します。

 

9. <トンネルインタフェース設定>
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode ipsec ipv4
NXR_A(config-tunnel)#tunnel protection ipsec policy 1
NXR_A(config-tunnel)#ip tcp adjust-mss auto

トンネル1インタフェースでトンネルモードをipsec ipv4、使用するトンネルポリシーとして1を設定します。また、TCPMSS値をオートに設定します。

 

10. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#ip address 192.168.21.1/24
NXR_A(config-if)#ipsec policy 1

ethernet1インタフェースのIPアドレスを設定します。また、IPsecトンネルのエンドポイントとなるためIPsecローカルポリシー1を設定します。

 

11. <DNS設定>
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#address 192.168.21.254

DNSサービスを有効にします。また、DNSサーバアドレスとして上位のNAPTルータを設定します。

 

12. <ファストフォワーディングの有効化>
NXR_A(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.30.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_B(config)#ip route 192.168.0.0/16 tunnel 1 1
NXR_B(config)#ip route 192.168.0.0/16 null 254

仮想サーバおよびLAN_A向けのルートを設定します。なお、IPsec SA確立時はトンネル1インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。

NXR_B(config)#ip route 0.0.0.0/0 192.168.31.254

デフォルトルートを設定します。

 

4. <IPsecアクセスリスト設定>
NXR_B(config)#ipsec access-list ipsec_acl ip any any

ipsec_aclという名前のIPsecアクセスリストを設定します。
なお、送信元IPアドレス,宛先IPアドレスともにanyとします。

 

5. <IPsec NATトラバーサルの有効化>
NXR_B(config)#ipsec nat-traversal enable

NATトラバーサルを有効にします。

 

6. <IPsecローカルポリシー設定>
NXR_B(config)#ipsec local policy 1
NXR_B(config-ipsec-local)#address ip
NXR_B(config-ipsec-local)#self-identity fqdn nxrb

IPsecトンネルの送信元IPアドレスをip(IPv4)と設定します。また、セルフIDをFQDN方式でnxrbとし、VXRのリモートIDと同じIDを設定します。

 

7. <IPsec ISAKMPポリシー設定>
NXR_B(config)#ipsec isakmp policy 1
NXR_B(config-ipsec-isakmp)#description VXR
NXR_B(config-ipsec-isakmp)#authentication pre-share ipseckey2

ISAKMPポリシーの説明としてVXR、認証方式としてpre-share(事前共有鍵)を選択し、事前共有鍵ipseckey2を設定します。なお、事前共有鍵はVXRと共通の値を設定します。

NXR_B(config-ipsec-isakmp)#hash sha1
NXR_B(config-ipsec-isakmp)#encryption aes128
NXR_B(config-ipsec-isakmp)#group 5
NXR_B(config-ipsec-isakmp)#lifetime 10800
NXR_B(config-ipsec-isakmp)#isakmp-mode aggressive

認証アルゴリズムとしてsha1、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして10800秒、フェーズ1のネゴシエーションモードとしてアグレッシブモードを設定します。

NXR_B(config-ipsec-isakmp)#remote address ip 10.10.10.1
NXR_B(config-ipsec-isakmp)#remote identity fqdn vxr
NXR_B(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR_B(config-ipsec-isakmp)#local policy 1

リモートアドレスにVRのWAN側IPアドレスを設定します。また、リモートIDをFQDN方式でvxrとし、VXRのセルフIDと同じIDを設定します。そして、IKE KeepAlive(DPD)を監視間隔30秒,リトライ回数3回としkeepalive失敗時にSAを削除しIKEのネゴシエーションを開始するよう設定します。さらに、IPsecローカルポリシー1と関連づけを行います。

 

8. <IPsec トンネルポリシー設定>
NXR_B(config)#ipsec tunnel policy 1
NXR_B(config-ipsec-tunnel)#description VXR
NXR_B(config-ipsec-tunnel)#negotiation-mode auto

IPsecトンネルポリシーの説明としてVXR、ネゴシエーションモードとしてautoを設定します。

NXR_B(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
NXR_B(config-ipsec-tunnel)#set pfs group5
NXR_B(config-ipsec-tunnel)#set sa lifetime 3600

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha1、PFSを有効にし、かつDHグループとしてgroup5、IPsec SAのライフタイムとして3600秒を設定します。

NXR_B(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_B(config-ipsec-tunnel)#match address ipsec_acl

ISAKMPポリシー1と関連づけを行い、IPsecアクセスリストipsec_aclを設定します。

 

9. <トンネルインタフェース設定>
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode ipsec ipv4
NXR_B(config-tunnel)#tunnel protection ipsec policy 1
NXR_B(config-tunnel)#ip tcp adjust-mss auto

トンネル1インタフェースでトンネルモードをipsec ipv4、使用するトンネルポリシーとして1を設定します。また、TCPMSS値をオートに設定します。

 

10. <WAN側(ethernet1)インタフェース設定>
NXR_B(config)#interface ethernet 1
NXR_B(config-if)#ip address 192.168.31.1/24
NXR_B(config-if)#ipsec policy 1

ethernet1インタフェースのIPアドレスを設定します。また、IPsecトンネルのエンドポイントとなるためIPsecローカルポリシー1を設定します。

 

11. <DNS設定>
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#address 192.168.31.254

DNSサービスを有効にします。また、DNSサーバアドレスとして上位のNAPTルータを設定します。

 

12. <ファストフォワーディングの有効化>
NXR_B(config)#fast-forwarding enable

ファストフォワーディングを有効にします。

 

【 端末の設定例 】

仮想サーバ LAN_Aの端末 LAN_Bの端末
IPアドレス 192.168.10.100 192.168.20.100 192.168.30.100
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.20.1 192.168.30.1
DNSサーバ 192.168.11.254