FutureNet

NXR,WXRシリーズ

VXRシリーズ編

3. Cloudn Compute(VPCタイプOpenNW) VPN接続設定

3-1. IPsec接続設定(VPCタイプOpenNW)

「Cloudn Compute(VPCタイプOpenNW)」(以下Cloudn)はNTTコミュニケーションズ社が提供するクラウド上に論理的なプライベートネットワーク(Virtual Private Cloud)を構築し、その中にCloudnの仮想サーバを設置するサービスです。この環境にVXR-x86をインストールし、NXRとIPsec接続します。なおCloudn側のVRでNATを行いますので、VXR-x86のWAN側インタフェースのIPアドレスはプライベートIPアドレスとなります。

 

【 構成図 】

  • この設定例ではモバイルルータとしてNXR-G100/NLを使用します。また通信プランはXiデータプランでの利用を想定しています。
    (☞) 他のモバイル機能を持ったNXRシリーズを利用することも可能です。

 

【 設定データ 】

〔VXRの設定〕

設定項目 設定内容
ホスト名 VXR
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
WAN側インタフェース ethernet1のIPアドレス 192.168.11.1/24
IPsecローカルポリシー 1
スタティックルート No.1 宛先IPアドレス 192.168.20.0/24
ゲートウェイ(インタフェース) tunnel1
ディスタンス 1
No.2 宛先IPアドレス 192.168.20.0/24
ゲートウェイ(インタフェース) null
ディスタンス 254
No.3 宛先IPアドレス 192.168.30.0/24
ゲートウェイ(インタフェース) tunnel2
ディスタンス 1
No.4 宛先IPアドレス 192.168.30.0/24
ゲートウェイ(インタフェース) null
ディスタンス 254
No.5 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(IPアドレス) 192.168.11.254
IPsec IPsecアクセスリスト リスト名 ipsec_acl
送信元IPアドレス any
宛先IPアドレス any
IPsec priority-ignore 有効
IPsecローカルポリシー1 address ip
セルフID(FQDN) vxr
IPsec ISAKMPポリシー1 名前 NXR_A
認証方式 pre-share
認証鍵 ipseckey1
認証アルゴリズム sha1
暗号化アルゴリズム aes128
DHグループ 5
ライフタイム 10800秒
ISAKMPモード メインモード
リモートアドレス 10.10.20.1
リモートID(FQDN) nxra
DPD 再送間隔 30秒
リトライ回数 3回
動作 restart
ローカルポリシー 1
 IPsecトンネルポリシー1 名前 NXR_A
ネゴシエーションモード オート
認証アルゴリズム sha1
暗号化アルゴリズム aes128
PFS 有効(グループ5)
ライフタイム 3600秒
ISAKMPポリシー 1
IPsecアクセスリスト ipsec_acl
IPsec ISAKMPポリシー2 名前 NXR_B
認証方式 pre-share
認証鍵 ipseckey2
認証アルゴリズム sha1
暗号化アルゴリズム aes128
DHグループ 5
ライフタイム 10800秒
ISAKMPモード アグレッシブモード
リモートアドレス any
リモートID(FQDN) nxrb
DPD 再送間隔 30秒
リトライ回数 3回
動作 clear
ローカルポリシー 1
 IPsecトンネルポリシー2 名前 NXR_B
ネゴシエーションモード レスポンダ
認証アルゴリズム sha1
暗号化アルゴリズム aes128
PFS 有効(グループ5)
ライフタイム 3600秒
ISAKMPポリシー 2
IPsecアクセスリスト ipsec_acl
トンネル1インタフェース トンネルモード IPsec(IPv4)
トンネルプロテクション ipsec policy 1
MSS自動調整 オート
トンネル2インタフェース トンネルモード IPsec(IPv4)
トンネルプロテクション ipsec policy 2
MSS自動調整 オート
SSHサーバ 有効
DNS サービス 有効
DNSサーバ プライマリ 192.168.11.254

〔NXR_Aの設定〕

設定項目 設定内容
ホスト名 NXR_A
LAN側インタフェース ethernet0のIPアドレス 192.168.20.1/24
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 10.10.20.1/32
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
MSS自動調整 オート
ISP接続用ユーザID test2@example.jp
ISP接続用パスワード test2pass
IPsecローカルポリシー 1
スタティックルート No.1 宛先IPアドレス 192.168.10.0/24
ゲートウェイ(インタフェース) tunnel1
ディスタンス 1
No.2 宛先IPアドレス 192.168.10.0/24
ゲートウェイ(インタフェース) null
ディスタンス 254
No.3 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in No.1 動作 許可
送信元IPアドレス 10.10.10.1
宛先IPアドレス 10.10.20.1
プロトコル UDP
送信元ポート 500
宛先ポート 500
No.2 動作 許可
送信元IPアドレス 10.10.10.1
宛先IPアドレス 10.10.20.1
プロトコル 50(ESP)
IPsec IPsecアクセスリスト リスト名 ipsec_acl
送信元IPアドレス any
宛先IPアドレス any
IPsecローカルポリシー1 address ip
セルフID(FQDN) nxra
IPsec ISAKMPポリシー1 名前 VXR
認証方式 pre-share
認証鍵 ipseckey1
認証アルゴリズム sha1
暗号化アルゴリズム aes128
DHグループ 5
ライフタイム 10800秒
ISAKMPモード メインモード
リモートアドレス 10.10.10.1
リモートID(FQDN) vxr
DPD 再送間隔 30秒
リトライ回数 3回
動作 restart
ローカルポリシー 1
 IPsecトンネルポリシー1 名前 VXR
ネゴシエーションモード オート
認証アルゴリズム sha1
暗号化アルゴリズム aes128
PFS 有効(グループ5)
ライフタイム 3600秒
ISAKMPポリシー 1
IPsecアクセスリスト ipsec_acl
トンネル1インタフェース トンネルモード IPsec(IPv4)
トンネルプロテクション ipsec policy 1
MSS自動調整 オート
DNS サービス 有効
FastFowarding 有効

〔NXR_Bの設定〕

設定項目 設定内容
ホスト名 NXR_B
LAN側インタフェース ethernet0のIPアドレス 192.168.30.1/24
WAN側インタフェース mobile1 ppp0
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
MSS自動調整 オート
PPP接続用ユーザID lte
PPP接続用パスワード lte
APN mopera.net
CID 1
PDPタイプ IP
発信用電話番号 *99***1#
ダイアルタイムアウト 30秒
IPsecローカルポリシー 1
スタティックルート No.1 宛先IPアドレス 192.168.10.0/24
ゲートウェイ(インタフェース) tunnel1
ディスタンス 1
No.2 宛先IPアドレス 192.168.10.0/24
ゲートウェイ(インタフェース) null
ディスタンス 254
No.3 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in No.1 動作 許可
送信元IPアドレス 10.10.10.1
宛先IPアドレス any
プロトコル UDP
送信元ポート 500
宛先ポート 500
No.2 動作 許可
送信元IPアドレス 10.10.10.1
宛先IPアドレス any
プロトコル 50(ESP)
IPsec IPsecアクセスリスト リスト名 ipsec_acl
送信元IPアドレス any
宛先IPアドレス any
IPsecローカルポリシー1 address ip
セルフID(FQDN) nxrb
IPsec ISAKMPポリシー1 名前 VXR
認証方式 pre-share
認証鍵 ipseckey2
認証アルゴリズム sha1
暗号化アルゴリズム aes128
DHグループ 5
ライフタイム 10800秒
ISAKMPモード アグレッシブモード
リモートアドレス 10.10.10.1
リモートID(FQDN) vxr
DPD 再送間隔 30秒
リトライ回数 3回
動作 restart
ローカルポリシー 1
 IPsecトンネルポリシー1 名前 VXR
ネゴシエーションモード オート
認証アルゴリズム sha1
暗号化アルゴリズム aes128
PFS 有効(グループ5)
ライフタイム 3600秒
ISAKMPポリシー 1
IPsecアクセスリスト ipsec_acl
トンネル1インタフェース トンネルモード IPsec(IPv4)
トンネルプロテクション ipsec policy 1
MSS自動調整 オート
モバイルエラーリカバリー リセット
モバイルターミネーションリカバリー リセット
DNS サービス 有効

 

【 設定例 】

〔VXRの設定〕

vxr-x86#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
vxr-x86(config)#hostname VXR
VXR(config)#interface ethernet 0
VXR(config-if)#ip address 192.168.10.1/24
VXR(config-if)#exit
VXR(config)#ip route 192.168.20.0/24 tunnel 1 1
VXR(config)#ip route 192.168.20.0/24 null 254
VXR(config)#ip route 192.168.30.0/24 tunnel 2 1
VXR(config)#ip route 192.168.30.0/24 null 254
VXR(config)#ip route 0.0.0.0/0 192.168.11.254
VXR(config)#ipsec access-list ipsec_acl ip any any
VXR(config)#ipsec priority-ignore enable
% restart ipsec service to take affect.
VXR(config)#ipsec local policy 1
VXR(config-ipsec-local)#address ip
VXR(config-ipsec-local)#self-identity fqdn vxr
VXR(config-ipsec-local)#exit
VXR(config)#ipsec isakmp policy 1
VXR(config-ipsec-isakmp)#description NXR_A
VXR(config-ipsec-isakmp)#authentication pre-share ipseckey1
VXR(config-ipsec-isakmp)#hash sha1
VXR(config-ipsec-isakmp)#encryption aes128
VXR(config-ipsec-isakmp)#group 5
VXR(config-ipsec-isakmp)#lifetime 10800
VXR(config-ipsec-isakmp)#isakmp-mode main
VXR(config-ipsec-isakmp)#remote address ip 10.10.20.1
VXR(config-ipsec-isakmp)#remote identity fqdn nxra
VXR(config-ipsec-isakmp)#keepalive 30 3 periodic restart
VXR(config-ipsec-isakmp)#local policy 1
VXR(config-ipsec-isakmp)#exit
VXR(config)#ipsec tunnel policy 1
VXR(config-ipsec-tunnel)#description NXR_A
VXR(config-ipsec-tunnel)#negotiation-mode auto
VXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
VXR(config-ipsec-tunnel)#set pfs group5
VXR(config-ipsec-tunnel)#set sa lifetime 3600
VXR(config-ipsec-tunnel)#set key-exchange isakmp 1
VXR(config-ipsec-tunnel)#match address ipsec_acl
VXR(config-ipsec-tunnel)#exit
VXR(config)#interface tunnel 1
VXR(config-tunnel)#tunnel mode ipsec ipv4
VXR(config-tunnel)#tunnel protection ipsec policy 1
VXR(config-tunnel)#ip tcp adjust-mss auto
VXR(config-tunnel)#exit
VXR(config)#ipsec isakmp policy 2
VXR(config-ipsec-isakmp)#description NXR_B
VXR(config-ipsec-isakmp)#authentication pre-share ipseckey2
VXR(config-ipsec-isakmp)#hash sha1
VXR(config-ipsec-isakmp)#encryption aes128
VXR(config-ipsec-isakmp)#group 5
VXR(config-ipsec-isakmp)#lifetime 10800
VXR(config-ipsec-isakmp)#isakmp-mode aggressive
VXR(config-ipsec-isakmp)#remote address ip any
VXR(config-ipsec-isakmp)#remote identity fqdn nxrb
VXR(config-ipsec-isakmp)#keepalive 30 3 periodic clear
VXR(config-ipsec-isakmp)#local policy 1
VXR(config-ipsec-isakmp)#exit
VXR(config)#ipsec tunnel policy 2
VXR(config-ipsec-tunnel)#description NXR_B
VXR(config-ipsec-tunnel)#negotiation-mode responder
VXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
VXR(config-ipsec-tunnel)#set pfs group5
VXR(config-ipsec-tunnel)#set sa lifetime 3600
VXR(config-ipsec-tunnel)#set key-exchange isakmp 2
VXR(config-ipsec-tunnel)#match address ipsec_acl
VXR(config-ipsec-tunnel)#exit
VXR(config)#interface tunnel 2
VXR(config-tunnel)#tunnel mode ipsec ipv4
VXR(config-tunnel)#tunnel protection ipsec policy 2
VXR(config-tunnel)#ip tcp adjust-mss auto
VXR(config-tunnel)#exit
VXR(config)#interface ethernet 1
VXR(config-if)#ip address 192.168.11.1/24
VXR(config-if)#ipsec policy 1
VXR(config-if)#exit
VXR(config)#ssh-server enable
VXR(config)#dns
VXR(config-dns)#service enable
VXR(config-dns)#address 192.168.11.254
VXR(config-dns)#exit
VXR(config)#exit
VXR#save config

〔NXR_Aの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_A
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.20.1/24
NXR_A(config-if)#exit
NXR_A(config)#ip route 192.168.10.0/24 tunnel 1 1
NXR_A(config)#ip route 192.168.10.0/24 null 254
NXR_A(config)#ip route 0.0.0.0/0 ppp 0
NXR_A(config)#ip access-list ppp0_in permit 10.10.10.1 10.10.20.1 udp 500 500
NXR_A(config)#ip access-list ppp0_in permit 10.10.10.1 10.10.20.1 50
NXR_A(config)#ipsec access-list ipsec_acl ip any any
NXR_A(config)#ipsec local policy 1
NXR_A(config-ipsec-local)#address ip
NXR_A(config-ipsec-local)#self-identity fqdn nxra
NXR_A(config-ipsec-local)#exit
NXR_A(config)#ipsec isakmp policy 1
NXR_A(config-ipsec-isakmp)#description VXR
NXR_A(config-ipsec-isakmp)#authentication pre-share ipseckey1
NXR_A(config-ipsec-isakmp)#hash sha1
NXR_A(config-ipsec-isakmp)#encryption aes128
NXR_A(config-ipsec-isakmp)#group 5
NXR_A(config-ipsec-isakmp)#lifetime 10800
NXR_A(config-ipsec-isakmp)#isakmp-mode main
NXR_A(config-ipsec-isakmp)#remote address ip 10.10.10.1
NXR_A(config-ipsec-isakmp)#remote identity fqdn vxr
NXR_A(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR_A(config-ipsec-isakmp)#local policy 1
NXR_A(config-ipsec-isakmp)#exit
NXR_A(config)#ipsec tunnel policy 1
NXR_A(config-ipsec-tunnel)#description VXR
NXR_A(config-ipsec-tunnel)#negotiation-mode auto
NXR_A(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
NXR_A(config-ipsec-tunnel)#set pfs group5
NXR_A(config-ipsec-tunnel)#set sa lifetime 3600
NXR_A(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_A(config-ipsec-tunnel)#match address ipsec_acl
NXR_A(config-ipsec-tunnel)#exit
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode ipsec ipv4
NXR_A(config-tunnel)#tunnel protection ipsec policy 1
NXR_A(config-tunnel)#ip tcp adjust-mss auto
NXR_A(config-tunnel)#exit
NXR_A(config)#ppp account username test2@example.jp password test2pass
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 10.10.20.1/32
NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto
NXR_A(config-ppp)#ppp username test2@example.jp
NXR_A(config-ppp)#ipsec policy 1
NXR_A(config-ppp)#exit
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0
NXR_A(config-if)#exit
NXR_A(config)#dns
NXR_A(config-dns)#service enable
NXR_A(config-dns)#exit
NXR_A(config)#fast-forwarding enable
NXR_A(config)#exit
NXR_A#save config

〔NXR_Bの設定〕

nxrg100#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg100(config)#hostname NXR_B
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.30.1/24
NXR_B(config-if)#exit
NXR_B(config)#ip route 192.168.10.0/24 tunnel 1 1
NXR_B(config)#ip route 192.168.10.0/24 null 254
NXR_B(config)#ip route 0.0.0.0/0 ppp 0
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any udp 500 500
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any 50
NXR_B(config)#ipsec access-list ipsec_acl ip any any
NXR_B(config)#ipsec local policy 1
NXR_B(config-ipsec-local)#address ip
NXR_B(config-ipsec-local)#self-identity fqdn nxrb
NXR_B(config-ipsec-local)#exit
NXR_B(config)#ipsec isakmp policy 1
NXR_B(config-ipsec-isakmp)#description VXR
NXR_B(config-ipsec-isakmp)#authentication pre-share ipseckey2
NXR_B(config-ipsec-isakmp)#hash sha1
NXR_B(config-ipsec-isakmp)#encryption aes128
NXR_B(config-ipsec-isakmp)#group 5
NXR_B(config-ipsec-isakmp)#lifetime 10800
NXR_B(config-ipsec-isakmp)#isakmp-mode aggressive
NXR_B(config-ipsec-isakmp)#remote address ip 10.10.10.1
NXR_B(config-ipsec-isakmp)#remote identity fqdn vxr
NXR_B(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR_B(config-ipsec-isakmp)#local policy 1
NXR_B(config-ipsec-isakmp)#exit
NXR_B(config)#ipsec tunnel policy 1
NXR_B(config-ipsec-tunnel)#description VXR
NXR_B(config-ipsec-tunnel)#negotiation-mode auto
NXR_B(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
NXR_B(config-ipsec-tunnel)#set pfs group5
NXR_B(config-ipsec-tunnel)#set sa lifetime 3600
NXR_B(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_B(config-ipsec-tunnel)#match address ipsec_acl
NXR_B(config-ipsec-tunnel)#exit
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode ipsec ipv4
NXR_B(config-tunnel)#tunnel protection ipsec policy 1
NXR_B(config-tunnel)#ip tcp adjust-mss auto
NXR_B(config-tunnel)#exit
NXR_B(config)#ppp account username lte password lte
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated
NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto
NXR_B(config-ppp)#ppp username lte
NXR_B(config-ppp)#mobile apn mopera.net cid 1 pdp-type ip
NXR_B(config-ppp)#dial-up string *99***1#
NXR_B(config-ppp)#dial-up timeout 30
NXR_B(config-ppp)#ipsec policy 1
NXR_B(config-ppp)#exit
NXR_B(config)#mobile error-recovery-reset
NXR_B(config)#mobile termination-recovery reset
NXR_B(config)#mobile 1 ppp 0
NXR_B(config)#dns
NXR_B(config-dns)#service enable
NXR_B(config-dns)#exit
NXR_B(config)#exit
NXR_B#save config

 

【 設定例解説 】

〔VXRの設定〕

1. <ホスト名の設定>
vxr-x86(config)#hostname VXR

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
VXR(config)#interface ethernet 0
VXR(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
VXR(config)#ip route 192.168.20.0/24 tunnel 1 1
VXR(config)#ip route 192.168.20.0/24 null 254

LAN_A向けのルートを設定します。なお、IPsec SA確立時はトンネル1インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。
(☞) nullインタフェースを出力インタフェースとして設定した場合、パケットが出力されることはありません(ドロップされます)。

VXR(config)#ip route 192.168.30.0/24 tunnel 2 1
VXR(config)#ip route 192.168.30.0/24 null 254

LAN_B向けのルートを設定します。なお、IPsec SA確立時はトンネル2インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。

VXR(config)#ip route 0.0.0.0/0 192.168.11.254

デフォルトルートを設定します。

 

4. <IPsecアクセスリスト設定>
VXR(config)#ipsec access-list ipsec_acl ip any any

ipsec_aclという名前のIPsecアクセスリストを設定します。なお、送信元IPアドレス,宛先IPアドレスともにanyとします。
(☞) Route Based IPsecでESP化するか否かはIPsecアクセスリストではなく、トンネルインタフェースをゲートウェイとするルート設定の有無で決まります。よって、Policy Based IPsecではIPsecアクセスリストで設定したルールに基づきIPsecでESP化するかどうかが決定されましたが、Route Based IPsecではIPsecアクセスリストをIKEフェーズ2のIDとしてのみ使用します。

 

5. <IPsec priority-ignore設定>
VXR(config)#ipsec priority-ignore enable

ipsec priority-ignoreを有効に設定します。
これはプライオリティによるIPsec SAの優先度を無効にする設定です。
Route based IPsecではフェーズ2のIDをIPsec SAを確立するためのIDとしてのみ使用します。そのためプライオリティによる冗長化設定などを利用しない場合は、本設定を有効にすることによって同じフェーズ2のIDを持つIPsec SAを複数個同時に確立することができます。
(☞) この機能に対応していない場合は、同じフェーズ2のIDを持つIPsec SAを同時に複数個確立することができません。そのため設定例のように同一のIPsecアクセスリストを複数のIPsecトンネルポリシーに適用した場合IPsec SAを複数同時に確立することができませんので、各IPsecトンネルポリシー毎に異なるルールのIPsecアクセスリストを設定する必要があります。

 

6. <IPsecローカルポリシー設定>
VXR(config)#ipsec local policy 1
VXR(config-ipsec-local)#address ip
VXR(config-ipsec-local)#self-identity fqdn vxr

IPsecトンネルの送信元IPアドレスをip(IPv4)と設定します。また、セルフIDをFQDN方式でvxrとし、NXR_A,BのリモートIDと同じIDを設定します。

 

7. <IPsec ISAKMPポリシー1設定>
VXR(config)#ipsec isakmp policy 1
VXR(config-ipsec-isakmp)#description NXR_A
VXR(config-ipsec-isakmp)#authentication pre-share ipseckey1

ISAKMPポリシーの説明としてNXR_A、認証方式としてpre-share(事前共有鍵)を選択し事前共有鍵ipseckey1を設定します。なお、事前共有鍵はNXR_Aと共通の値を設定します。

VXR(config-ipsec-isakmp)#hash sha1
VXR(config-ipsec-isakmp)#encryption aes128
VXR(config-ipsec-isakmp)#group 5
VXR(config-ipsec-isakmp)#lifetime 10800
VXR(config-ipsec-isakmp)#isakmp-mode main

認証アルゴリズムとしてsha1、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして10800秒、フェーズ1のネゴシエーションモードとしてメインモードを設定します。

VXR(config-ipsec-isakmp)#remote address ip 10.10.20.1
VXR(config-ipsec-isakmp)#remote identity fqdn nxra
VXR(config-ipsec-isakmp)#keepalive 30 3 periodic restart
VXR(config-ipsec-isakmp)#local policy 1

リモートアドレスにNXR_AのWAN側IPアドレスを設定します。また、リモートIDをFQDN方式でnxraとし、NXR_AのセルフIDと同じIDを設定します。そして、IKE KeepAlive(DPD)を監視間隔30秒,リトライ回数3回としkeepalive失敗時にSAを削除しIKEのネゴシエーションを開始するよう設定します。さらに、IPsecローカルポリシー1と関連づけを行います。

 

8. <IPsec トンネルポリシー1設定>
VXR(config)#ipsec tunnel policy 1
VXR(config-ipsec-tunnel)#description NXR_A
VXR(config-ipsec-tunnel)#negotiation-mode auto

IPsecトンネルポリシーの説明としてNXR_A、ネゴシエーションモードとしてautoを設定します。

VXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
VXR(config-ipsec-tunnel)#set pfs group5
VXR(config-ipsec-tunnel)#set sa lifetime 3600

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha1、PFSを有効にし、かつDHグループとしてgroup5、IPsec SAのライフタイムとして3600秒を設定します。

VXR(config-ipsec-tunnel)#set key-exchange isakmp 1
VXR(config-ipsec-tunnel)#match address ipsec_acl

ISAKMPポリシー1と関連づけを行い、IPsecアクセスリストipsec_aclを設定します。

 

9. <トンネル1インタフェース設定>
VXR(config)#interface tunnel 1
VXR(config-tunnel)#tunnel mode ipsec ipv4
VXR(config-tunnel)#tunnel protection ipsec policy 1
VXR(config-tunnel)#ip tcp adjust-mss auto

トンネル1インタフェースでトンネルモードをipsec ipv4、使用するトンネルポリシーとして1を設定します。また、TCPMSS値をオートに設定します。

 

10. <IPsec ISAKMPポリシー2設定>
VXR(config)#ipsec isakmp policy 2
VXR(config-ipsec-isakmp)#description NXR_B
VXR(config-ipsec-isakmp)#authentication pre-share ipseckey2

ISAKMPポリシーの説明としてNXR_B、認証方式としてpre-share(事前共有鍵)を選択し事前共有鍵ipseckey2を設定します。なお、事前共有鍵はNXR_Bと共通の値を設定します。

VXR(config-ipsec-isakmp)#hash sha1
VXR(config-ipsec-isakmp)#encryption aes128
VXR(config-ipsec-isakmp)#group 5
VXR(config-ipsec-isakmp)#lifetime 10800
VXR(config-ipsec-isakmp)#isakmp-mode aggressive

認証アルゴリズムとしてsha1、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして10800秒、フェーズ1のネゴシエーションモードとしてアグレッシブモードを設定します。

VXR(config-ipsec-isakmp)#remote address ip any
VXR(config-ipsec-isakmp)#remote identity fqdn nxrb
VXR(config-ipsec-isakmp)#keepalive 30 3 periodic clear
VXR(config-ipsec-isakmp)#local policy 1

NXR_BのWAN側IPアドレスが動的IPアドレスのため、リモートアドレスをanyとします。また、リモートIDをFQDN方式でnxrbとし、NXR_BのセルフIDと同じIDを設定します。そして、IKE KeepAlive(DPD)を監視間隔30秒,リトライ回数3回としkeepalive失敗時にSAを削除するよう設定します。さらに、IPsecローカルポリシー1と関連づけを行います。

 

11. <IPsec トンネルポリシー2設定>
VXR(config)#ipsec tunnel policy 2
VXR(config-ipsec-tunnel)#description NXR_B
VXR(config-ipsec-tunnel)#negotiation-mode responder

IPsecトンネルポリシーの説明としてNXR_B、ネゴシエーションモードとしてresponderを設定します。

VXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
VXR(config-ipsec-tunnel)#set pfs group5
VXR(config-ipsec-tunnel)#set sa lifetime 3600

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha1、PFSを有効にし、かつDHグループとしてgroup5、IPsec SAのライフタイムとして3600秒を設定します。

VXR(config-ipsec-tunnel)#set key-exchange isakmp 2
VXR(config-ipsec-tunnel)#match address ipsec_acl

ISAKMPポリシー2と関連づけを行い、IPsecアクセスリストipsec_aclを設定します。

 

12. <トンネル2インタフェース設定>
VXR(config)#interface tunnel 2
VXR(config-tunnel)#tunnel mode ipsec ipv4
VXR(config-tunnel)#tunnel protection ipsec policy 2
VXR(config-tunnel)#ip tcp adjust-mss auto

トンネル2インタフェースでトンネルモードをipsec ipv4、使用するトンネルポリシーとして2を設定します。また、TCPMSS値をオートに設定します。

 

13. <WAN側(ethernet1)インタフェース設定>
VXR(config)#interface ethernet 1
VXR(config-if)#ip address 192.168.11.1/24
VXR(config-if)#ipsec policy 1

ethernet1インタフェースのIPアドレスを設定します。また、IPsecトンネルのエンドポイントとなるためIPsecローカルポリシー1を設定します。

 

14. <SSHサーバ設定>
VXR(config)#ssh-server enable

SSHサーバを有効にします。
(☞) この設定例ではコンソール以外からのアクセス方法としてSSHサーバを設定しています。

 

15. <DNS設定>
VXR(config)#dns
VXR(config-dns)#service enable
VXR(config-dns)#address 192.168.11.254

DNSサービスを有効にします。また、VRをプライマリDNSサーバとして設定します。

 

〔NXR_Aの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_A

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_A(config)#interface ethernet 0
NXR_A(config-if)#ip address 192.168.20.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_A(config)#ip route 192.168.10.0/24 tunnel 1 1
NXR_A(config)#ip route 192.168.10.0/24 null 254

仮想サーバ向けのルートを設定します。なお、IPsec SA確立時はトンネル1インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。
(☞) nullインタフェースを出力インタフェースとして設定した場合、パケットが出力されることはありません(ドロップされます)。

NXR_A(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_A(config)#ip access-list ppp0_in permit 10.10.10.1 10.10.20.1 udp 500 500
NXR_A(config)#ip access-list ppp0_in permit 10.10.10.1 10.10.20.1 50

IPアクセスリスト名をppp0_inとし、送信元がVRのWAN側IPアドレス10.10.10.1、宛先IPアドレスが10.10.20.1のIKEパケット(UDPポート500番)、ESPパケット(プロトコル番号50)を許可します。なお、このIPアクセスリスト設定はppp0インタフェース設定で登録します。

 

5. <IPsecアクセスリスト設定>
NXR_A(config)#ipsec access-list ipsec_acl ip any any

ipsec_aclという名前のIPsecアクセスリストを設定します。なお、送信元IPアドレス,宛先IPアドレスともにanyとします。

 

6. <IPsecローカルポリシー設定>
NXR_A(config)#ipsec local policy 1
NXR_A(config-ipsec-local)#address ip
NXR_A(config-ipsec-local)#self-identity fqdn nxra

IPsecトンネルの送信元IPアドレスをip(IPv4)と設定します。また、セルフIDをFQDN方式でnxraとし、VXRのリモートIDと同じIDを設定します。

 

7. <IPsec ISAKMPポリシー設定>
NXR_A(config)#ipsec isakmp policy 1
NXR_A(config-ipsec-isakmp)#description VXR
NXR_A(config-ipsec-isakmp)#authentication pre-share ipseckey1

ISAKMPポリシーの説明としてVXR、認証方式としてpre-share(事前共有鍵)を選択し、事前共有鍵ipseckey1を設定します。なお、事前共有鍵はVXRと共通の値を設定します。

NXR_A(config-ipsec-isakmp)#hash sha1
NXR_A(config-ipsec-isakmp)#encryption aes128
NXR_A(config-ipsec-isakmp)#group 5
NXR_A(config-ipsec-isakmp)#lifetime 10800
NXR_A(config-ipsec-isakmp)#isakmp-mode main

認証アルゴリズムとしてsha1、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして10800秒、フェーズ1のネゴシエーションモードとしてメインモードを設定します。

NXR_A(config-ipsec-isakmp)#remote address ip 10.10.10.1
NXR_A(config-ipsec-isakmp)#remote identity fqdn vxr
NXR_A(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR_A(config-ipsec-isakmp)#local policy 1

リモートアドレスにVRのWAN側IPアドレスを設定します。また、リモートIDをFQDN方式でvxrとし、VXRのセルフIDと同じIDを設定します。そして、IKE KeepAlive(DPD)を監視間隔30秒,リトライ回数3回としkeepalive失敗時にSAを削除しIKEのネゴシエーションを開始するよう設定します。さらに、IPsecローカルポリシー1と関連づけを行います。

 

8. <IPsec トンネルポリシー設定>
NXR_A(config)#ipsec tunnel policy 1
NXR_A(config-ipsec-tunnel)#description VXR
NXR_A(config-ipsec-tunnel)#negotiation-mode auto

IPsecトンネルポリシーの説明としてVXR、ネゴシエーションモードとしてautoを設定します。

NXR_A(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
NXR_A(config-ipsec-tunnel)#set pfs group5
NXR_A(config-ipsec-tunnel)#set sa lifetime 3600

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha1、PFSを有効にし、かつDHグループとしてgroup5、IPsec SAのライフタイムとして3600秒を設定します。

NXR_A(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_A(config-ipsec-tunnel)#match address ipsec_acl

ISAKMPポリシー1と関連づけを行い、IPsecアクセスリストipsec_aclを設定します。

 

9. <トンネルインタフェース設定>
NXR_A(config)#interface tunnel 1
NXR_A(config-tunnel)#tunnel mode ipsec ipv4
NXR_A(config-tunnel)#tunnel protection ipsec policy 1
NXR_A(config-tunnel)#ip tcp adjust-mss auto

トンネル1インタフェースでトンネルモードをipsec ipv4、使用するトンネルポリシーとして1を設定します。また、TCPMSS値をオートに設定します。

 

10. <PPPアカウント設定>
NXR_A(config)#ppp account username test2@example.jp password test2pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

11. <WAN側(ppp0)インタフェース設定>
NXR_A(config)#interface ppp 0
NXR_A(config-ppp)#ip address 10.10.20.1/32

ppp0インタフェースのIPアドレスを設定します。

NXR_A(config-ppp)#ip masquerade
NXR_A(config-ppp)#ip access-group in ppp0_in
NXR_A(config-ppp)#ip spi-filter
NXR_A(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。また、IPアクセスリストppp0_inをinフィルタに適用します。そして、TCP MSSの調整機能をオートに設定します。

NXR_A(config-ppp)#ppp username test2@example.jp
NXR_A(config-ppp)#ipsec policy 1

ISP接続用ユーザIDを設定します。また、IPsecトンネルのエンドポイントとなるためIPsecローカルポリシー1を設定します。

 

12. <ethernet1インタフェース設定>
NXR_A(config)#interface ethernet 1
NXR_A(config-if)#no ip address
NXR_A(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

13. <DNS設定>
NXR_A(config)#dns
NXR_A(config-dns)#service enable

DNSサービスを有効にします。

 

14. <ファストフォワーディングの有効化>
NXR_A(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。

 

〔NXR_Bの設定〕

1. <ホスト名の設定>
nxrg100(config)#hostname NXR_B

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR_B(config)#interface ethernet 0
NXR_B(config-if)#ip address 192.168.30.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR_B(config)#ip route 192.168.10.0/24 tunnel 1 1
NXR_B(config)#ip route 192.168.10.0/24 null 254

仮想サーバ向けのルートを設定します。なお、IPsec SA確立時はトンネル1インタフェースを、未確立時はnullインタフェースのルートを利用するように設定します。

NXR_B(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any udp 500 500
NXR_B(config)#ip access-list ppp0_in permit 10.10.10.1 any 50

IPアクセスリスト名をppp0_inとし、送信元がVRのWAN側IPアドレス10.10.10.1のIKEパケット(UDPポート500番)、ESPパケット(プロトコル番号50)を許可します。
なお、このIPアクセスリスト設定はppp0インタフェース設定で登録します。

 

5. <IPsecアクセスリスト設定>
NXR_B(config)#ipsec access-list ipsec_acl ip any any

ipsec_aclという名前のIPsecアクセスリストを設定します。
なお、送信元IPアドレス,宛先IPアドレスともにanyとします。

 

6. <IPsecローカルポリシー設定>
NXR_B(config)#ipsec local policy 1
NXR_B(config-ipsec-local)#address ip
NXR_B(config-ipsec-local)#self-identity fqdn nxrb

IPsecトンネルの送信元IPアドレスをip(IPv4)と設定します。また、セルフIDをFQDN方式でnxrbとし、VXRのリモートIDと同じIDを設定します。

 

7. <IPsec ISAKMPポリシー設定>
NXR_B(config)#ipsec isakmp policy 1
NXR_B(config-ipsec-isakmp)#description VXR
NXR_B(config-ipsec-isakmp)#authentication pre-share ipseckey2

ISAKMPポリシーの説明としてVXR、認証方式としてpre-share(事前共有鍵)を選択し、事前共有鍵ipseckey2を設定します。なお、事前共有鍵はVXRと共通の値を設定します。

NXR_B(config-ipsec-isakmp)#hash sha1
NXR_B(config-ipsec-isakmp)#encryption aes128
NXR_B(config-ipsec-isakmp)#group 5
NXR_B(config-ipsec-isakmp)#lifetime 10800
NXR_B(config-ipsec-isakmp)#isakmp-mode aggressive

認証アルゴリズムとしてsha1、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして10800秒、フェーズ1のネゴシエーションモードとしてアグレッシブモードを設定します。

NXR_B(config-ipsec-isakmp)#remote address ip 10.10.10.1
NXR_B(config-ipsec-isakmp)#remote identity fqdn vxr
NXR_B(config-ipsec-isakmp)#keepalive 30 3 periodic restart
NXR_B(config-ipsec-isakmp)#local policy 1

リモートアドレスにVRのWAN側IPアドレスを設定します。また、リモートIDをFQDN方式でvxrとし、VXRのセルフIDと同じIDを設定します。そして、IKE KeepAlive(DPD)を監視間隔30秒,リトライ回数3回としkeepalive失敗時にSAを削除しIKEのネゴシエーションを開始するよう設定します。さらに、IPsecローカルポリシー1と関連づけを行います。

 

8. <IPsec トンネルポリシー設定>
NXR_B(config)#ipsec tunnel policy 1
NXR_B(config-ipsec-tunnel)#description VXR
NXR_B(config-ipsec-tunnel)#negotiation-mode auto

IPsecトンネルポリシーの説明としてVXR、ネゴシエーションモードとしてautoを設定します。

NXR_B(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
NXR_B(config-ipsec-tunnel)#set pfs group5
NXR_B(config-ipsec-tunnel)#set sa lifetime 3600

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha1、PFSを有効にし、かつDHグループとしてgroup5、IPsec SAのライフタイムとして3600秒を設定します。

NXR_B(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR_B(config-ipsec-tunnel)#match address ipsec_acl

ISAKMPポリシー1と関連づけを行い、IPsecアクセスリストipsec_aclを設定します。

 

9. <トンネルインタフェース設定>
NXR_B(config)#interface tunnel 1
NXR_B(config-tunnel)#tunnel mode ipsec ipv4
NXR_B(config-tunnel)#tunnel protection ipsec policy 1
NXR_B(config-tunnel)#ip tcp adjust-mss auto

トンネル1インタフェースでトンネルモードをipsec ipv4、使用するトンネルポリシーとして1を設定します。また、TCPMSS値をオートに設定します。

 

10. <PPPアカウント設定>
NXR_B(config)#ppp account username lte password lte

ppp0インタフェースで使用するPPP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

11. <WAN側(ppp0)インタフェース設定>
NXR_B(config)#interface ppp 0
NXR_B(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスが動的IPアドレスの場合は、negotiatedを設定します。

NXR_B(config-ppp)#ip masquerade
NXR_B(config-ppp)#ip access-group in ppp0_in
NXR_B(config-ppp)#ip spi-filter
NXR_B(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。また、IPアクセスリストppp0_inをinフィルタに適用します。そして、TCP MSSの調整機能をオートに設定します。

NXR_B(config-ppp)#ppp username lte

PPP接続用ユーザIDを設定します。

NXR_B(config-ppp)#mobile apn mopera.net cid 1 pdp-type ip

APN,CID,pdp-typeを設定します。

NXR_B(config-ppp)#dial-up string *99***1#
NXR_B(config-ppp)#dial-up timeout 30

発信用の電話番号およびダイアルタイムアウトを設定します。

NXR_B(config-ppp)#ipsec policy 1

IPsecトンネルのエンドポイントとなるためIPsecローカルポリシー1を設定します。

 

12. <モバイルエラーリカバリー設定>
NXR_B(config)#mobile error-recovery-reset

通信モジュールとの通信に重大な問題が発生する可能性が高いと判断した場合、通信モジュールのリセットを行うように設定します。

 

13. <モバイルターミネーションリカバリー設定>
NXR_B(config)#mobile termination-recovery reset

PPP接続時に網側から切断された場合、通信モジュールのリセットを行うように設定します。

 

14. <モバイル割り当て設定>
NXR_B(config)#mobile 1 ppp 0

mobile1と認識されている通信モジュールとppp0インタフェースの関連づけを行います。
通信モジュールをPPPインタフェースで使用する場合は、mobileコマンドによるPPPインタフェースへの関連付けが必要になります。
(☞) mobile1に割り当てられている通信モジュールはshow mobile 1コマンドで確認することができます。

 

15. <DNS設定>
NXR_B(config)#dns
NXR_B(config-dns)#service enable

DNSサービスを有効にします。

 

【 端末の設定例 】

仮想サーバ LAN_Aの端末 LAN_Bの端末
IPアドレス 192.168.10.100 192.168.20.100 192.168.30.100
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1 192.168.20.1 192.168.30.1
DNSサーバ 192.168.11.254