FutureNet

NXR,WXRシリーズ

IPsec編

3. リモートアクセスVPN設定

3-3. スマートデバイスとのL2TP/IPsec NATトラバーサル接続設定

AndroidやiOSのスマートデバイスがNAT環境下にある構成で、L2TP/IPsec接続する設定例です。グローバルIPアドレスが割り当てられないようなケース(キャリアグレードNATなど)では、この設定例のようにNATトラバーサルを設定する必要があります。なおこの設定例ではIPsecで事前共有鍵を利用します。
なおこの設定例は弊社独自の検証結果を元に作成しております。よってAndroidやiOSのスマートデバイスとの接続を保証するものではありません。

 

【 構成図 】

fnw_ip_remote_03

  • 接続してきたスマートデバイスにはIPアドレスプールよりIPアドレスを割り当てます。この設定例では2台分のIPアドレスを設定します。また接続してきた端末のユーザIDに対してIPアドレスプールの範囲内から動的にIPアドレスを割り当てます。
  • IPアドレスプールの範囲はNXRのLAN側ネットワーク内のアドレスとするため、virtual-template0インタフェースでプロキシARPを有効にします。

 

【 設定データ 】

設定項目 設定内容
ホスト名 NXR
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
PPPアカウント No.1 ユーザID android01
パスワード android01pass
No.2 ユーザID ios01
パスワード ios01pass
No.3 ユーザID test1@example.jp
パスワード test1pass
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0のIPアドレス 10.10.10.1/32
IPマスカレード 有効
IPアクセスグループ in ppp0_in
SPIフィルタ 有効
MSS自動調整 オート
IPリダイレクト 無効
ISP接続用ユーザID test1@example.jp
IPsecローカルポリシー 1
スタティックルート 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
IPフィルタ ルール名 ppp0_in
ppp0_in No.1 動作 許可
送信元IPアドレス any
宛先IPアドレス 10.10.10.1
プロトコル UDP
送信元ポート any
宛先ポート 500
No.2 動作 許可
送信元IPアドレス any
宛先IPアドレス 10.10.10.1
プロトコル UDP
送信元ポート any
宛先ポート 4500
IPsec NATトラバーサル 有効
IPsecローカルポリシー1 address ip
IPsec ISAKMPポリシー1 名前 smartphone
認証方式 pre-share
認証鍵 ipseckey
認証アルゴリズム sha1
暗号化アルゴリズム aes128
DHグループ 5
ライフタイム 86400秒
ISAKMPモード メインモード
リモートアドレス any
ローカルポリシー 1
 IPsecトンネルポリシー1 名前 smartphone
認証アルゴリズム sha1
暗号化アルゴリズム aes128
PFS 無効
ライフタイム 28800秒
ISAKMPポリシー 1
match protocol l2tp-smartphone(nat-traversal)
ip local pool プール名 smartphoneip
IPアドレス払い出し範囲(始点) 192.168.10.10
IPアドレス払い出し範囲(終点) 192.168.10.11
virtual-template0
インタフェース
IPアドレス 192.168.10.1/32
MSS自動調整 オート
IPリダイレクト 無効
IPリバウンド 無効
peer ip pool smartphoneip
プロキシARP 有効
L2TP UDP送信元ポート 1701
L2TP 接続先 any(IPsec)
トンネルモード lns
使用するvirtual-template 0
DNS サービス 有効
FastFowarding 有効

【 設定例 】

nxr120#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr120(config)#hostname NXR
NXR(config)#interface ethernet 0
NXR(config-if)#ip address 192.168.10.1/24
NXR(config-if)#exit
NXR(config)#ip route 0.0.0.0/0 ppp 0
NXR(config)#ip access-list ppp0_in permit any 10.10.10.1 udp any 500
NXR(config)#ip access-list ppp0_in permit any 10.10.10.1 udp any 4500
NXR(config)#ipsec nat-traversal enable
% restart ipsec service to take affect.
NXR(config)#ipsec local policy 1
NXR(config-ipsec-local)#address ip
NXR(config-ipsec-local)#exit
NXR(config)#ipsec isakmp policy 1
NXR(config-ipsec-isakmp)#description smartphone
NXR(config-ipsec-isakmp)#authentication pre-share ipseckey
NXR(config-ipsec-isakmp)#hash sha1
NXR(config-ipsec-isakmp)#encryption aes128
NXR(config-ipsec-isakmp)#group 5
NXR(config-ipsec-isakmp)#lifetime 86400
NXR(config-ipsec-isakmp)#isakmp-mode main
NXR(config-ipsec-isakmp)#remote address ip any
NXR(config-ipsec-isakmp)#local policy 1
NXR(config-ipsec-isakmp)#exit
NXR(config)#ipsec tunnel policy 1
NXR(config-ipsec-tunnel)#description smartphone
NXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
NXR(config-ipsec-tunnel)#no set pfs
NXR(config-ipsec-tunnel)#set sa lifetime 28800
NXR(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR(config-ipsec-tunnel)#match protocol l2tp-smartphone nat-traversal
NXR(config-ipsec-tunnel)#exit
NXR(config)#ppp account username android01 password android01pass
NXR(config)#ppp account username ios01 password ios01pass
NXR(config)#ppp account username test1@example.jp password test1pass
NXR(config)#ip local pool smartphoneip address 192.168.10.10 192.168.10.11
NXR(config)#interface virtual-template 0
NXR(config-if-vt)#ip address 192.168.10.1/32
NXR(config-if-vt)#ip tcp adjust-mss auto
NXR(config-if-vt)#no ip redirects
NXR(config-if-vt)#no ip rebound
NXR(config-if-vt)#peer ip pool smartphoneip
NXR(config-if-vt)#peer ip proxy-arp
NXR(config-if-vt)#exit
NXR(config)#l2tp udp source-port 1701
NXR(config)#l2tp 1
NXR(config-l2tp)#tunnel address any ipsec
NXR(config-l2tp)#tunnel mode lns
NXR(config-l2tp)#tunnel virtual-template 0
NXR(config-l2tp)#exit
% Restarting l2tp service. Please wait…..
NXR(config)#interface ppp 0
NXR(config-ppp)#ip address 10.10.10.1/32
NXR(config-ppp)#ip masquerade
NXR(config-ppp)#ip access-group in ppp0_in
NXR(config-ppp)#ip spi-filter
NXR(config-ppp)#ip tcp adjust-mss auto
NXR(config-ppp)#no ip redirects
NXR(config-ppp)#ppp username test1@example.jp
NXR(config-ppp)#ipsec policy 1
NXR(config-ppp)#exit
NXR(config)#interface ethernet 1
NXR(config-if)#no ip address
NXR(config-if)#pppoe-client ppp 0
NXR(config-if)#exit
NXR(config)#dns
NXR(config-dns)#service enable
NXR(config-dns)#exit
NXR(config)#fast-forwarding enable
NXR(config)#exit
NXR#save config

【 設定例解説 】

1. <ホスト名の設定>
nxr120(config)#hostname NXR

ホスト名を設定します。

 

2. <LAN側(ethernet0)インタフェース設定>
NXR(config)#interface ethernet 0
NXR(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

 

3. <スタティックルート設定>
NXR(config)#ip route 0.0.0.0/0 ppp 0

デフォルトルートを設定します。

 

4. <IPアクセスリスト設定>
NXR(config)#ip access-list ppp0_in permit any 10.10.10.1 udp any 500
NXR(config)#ip access-list ppp0_in permit any 10.10.10.1 udp any 4500

IPアクセスリスト名をppp0_inとし、NXRのWAN側IPアドレス10.10.10.1宛のUDPポート番号500、4500のパケットを許可します。
なおこのIPアクセスリスト設定はppp0インタフェース設定で登録します。
(☞) IPアクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。
(☞) NATトラバーサルでは、UDPポート番号500および4500をIPsecのネゴシエーションおよび通信で使用します。

 

5. <IPsec NATトラバーサル設定>
NXR(config)#ipsec nat-traversal enable

NATトラバーサルを有効にします。

 

6. <IPsecローカルポリシー設定>
NXR(config)#ipsec local policy 1
NXR(config-ipsec-local)#address ip

IPsecトンネルの送信元IPアドレスをip(IPv4)と設定します。

 

7. <IPsec ISAKMPポリシー設定>
NXR(config)#ipsec isakmp policy 1
NXR(config-ipsec-isakmp)#description smartphone
NXR(config-ipsec-isakmp)#authentication pre-share ipseckey

ISAKMPポリシーの説明としてsmartphone、認証方式としてpre-share(事前共有鍵)を選択し事前共有鍵ipseckeyを設定します。なお事前共有鍵はスマートデバイスと共通の値を設定します。

NXR(config-ipsec-isakmp)#hash sha1
NXR(config-ipsec-isakmp)#encryption aes128
NXR(config-ipsec-isakmp)#group 5
NXR(config-ipsec-isakmp)#lifetime 86400
NXR(config-ipsec-isakmp)#isakmp-mode main

認証アルゴリズムとしてsha1、暗号化アルゴリズムとしてaes128,Diffie-Hellman(DH)グループとしてgroup 5、ISAKMP SAのライフタイムとして86400秒、フェーズ1のネゴシエーションモードとしてメインモードを設定します。

NXR(config-ipsec-isakmp)#remote address ip any
NXR(config-ipsec-isakmp)#local policy 1

リモートアドレスにanyを設定します。またIPsecローカルポリシー1と関連づけを行います。

 

8. <IPsec トンネルポリシー設定>
NXR(config)#ipsec tunnel policy 1
NXR(config-ipsec-tunnel)#description smartphone

IPsecトンネルポリシーの説明としてsmartphoneを設定します。

NXR(config-ipsec-tunnel)#set transform esp-aes128 esp-sha1-hmac
NXR(config-ipsec-tunnel)#no set pfs
NXR(config-ipsec-tunnel)#set sa lifetime 28800

暗号化アルゴリズムとしてaes128、認証アルゴリズムとしてsha1、PFSを無効、IPsec SAのライフタイムとして28800秒を設定します。

NXR(config-ipsec-tunnel)#set key-exchange isakmp 1
NXR(config-ipsec-tunnel)#match protocol l2tp-smartphone nat-traversal

ISAKMPポリシー1と関連づけを行います。またmatch protocol l2tp-smartphone nat-traversalを設定します。この設定を行うことで、IPsec接続を行う際に下記項目が自動的に設定されます。
・protocol-mode → transport
・negotiation-mode → responder
・IPsecセレクタ → 以下のように自動設定されます。またNATトラバーサル有効時はNAT配下のどのアドレスからの接続も受け付けます。

IDペイロード NXR側 スマートデバイス側
IPv4アドレス host host
プロトコル UDP UDP
ポート番号 1701 any(どのポートでも受け付ける)
9. <PPPアカウント設定>
NXR(config)#ppp account username android01 password android01pass
NXR(config)#ppp account username ios01 password ios01pass

L2TPv2のLNS機能による着信時のユーザID,パスワードを設定します。

NXR(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するユーザ名,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

 

10. <IPアドレスプール設定>
NXR(config)#ip local pool smartphoneip address 192.168.10.10 192.168.10.11

IPアドレスプール名をsmartphoneipとし、スマートデバイスに割り当てるIPアドレスを設定します。

 

11. <virtual-template0インタフェース設定>
NXR(config)#interface virtual-template 0
NXR(config-if-vt)#ip address 192.168.10.1/32

virtual-template0インタフェースのIPアドレスを設定します。
(☞) virtual-templateインタフェースは仮想的なインタフェースであり、実際に作成されるわけではありません。virtual-templateインタフェースを使用するとコールを受けた際にPPPのクローンを作成し、本ノードの設定内容を当該PPPに適用します。なおPPPクローンのインタフェース番号は本装置が自動的に割り当てます。

NXR(config-if-vt)#ip tcp adjust-mss auto
NXR(config-if-vt)#no ip redirects
NXR(config-if-vt)#no ip rebound
NXR(config-if-vt)#peer ip pool smartphoneip

TCP MSSの調整機能をオート、ICMPリダイレクト機能を無効、IPリバウンド機能を無効に設定します。またIPアドレスプールとしてsmartphoneipを設定します。

NXR(config-if-vt)#peer ip proxy-arp

プロキシARPを設定します。

 

12. <L2TPv2設定>
NXR(config)#l2tp udp source-port 1701

L2TPv2で使用する送信元ポートを設定します。

NXR(config)#l2tp 1

スマートデバイスとの接続で使用するL2TPv2を設定します。

NXR(config-l2tp)#tunnel address any ipsec

接続先にIPアドレスとしてanyを設定します。

またany指定時にバインドするプロトコルとしてIPsecを指定します。これによりIPsec SAの確立したクライアントからの接続のみ許可します。

NXR(config-l2tp)#tunnel mode lns

L2TPv2のトンネルモードを設定します。

NXR(config-l2tp)#tunnel virtual-template 0

LNS利用時に使用するvirtual-template0インタフェースを設定します。

 

13. <WAN側(ppp0)インタフェース設定>
NXR(config)#interface ppp 0
NXR(config-ppp)#ip address 10.10.10.1/32

ppp0インタフェースのIPアドレスを設定します。

NXR(config-ppp)#ip masquerade
NXR(config-ppp)#ip access-group in ppp0_in
NXR(config-ppp)#ip spi-filter
NXR(config-ppp)#ip tcp adjust-mss auto
NXR(config-ppp)#no ip redirects

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。またIPアクセスリストppp0_inをinフィルタに適用します。そしてTCP MSSの調整機能をオート、ICMPリダイレクト機能を無効に設定します。

NXR(config-ppp)#ppp username test1@example.jp
NXR(config-ppp)#ipsec policy 1

ISP接続用ユーザIDを設定します。またIPsecトンネルのエンドポイントとなるためIPsecローカルポリシー1を設定します。

 

14. <ethernet1インタフェース設定>
NXR(config)#interface ethernet 1
NXR(config-if)#no ip address
NXR(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

15. <DNS設定>
NXR(config)#dns
NXR(config-dns)#service enable

DNSサービスを有効にします。

 

16. <ファストフォワーディングの有効化>
NXR(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 スマートデバイスの設定例 】

〔Androidの設定〕

(☞) ここで記載した設定はあくまで一例ですので、ご利用頂いているAndroid端末によって設定が異なる場合があります。設定の詳細はご利用中のAndroid端末の取扱説明書等をご確認下さい。
(☞) この設定例はAndroid端末との接続性を保証するものではありません。ご利用頂く際には十分な検証を行った上でのご利用をお願い致します。

 

  1. メニュー画面から「設定」をタップします。
  2. 設定画面で「無線とネットワーク」をタップします。
  3. 無線とネットワーク画面で「VPN設定」をタップします。
    android1
  4. VPN設定画面で「VPNネットワークの追加」をタップします。
    android2
  5. VPNネットワークの編集で次の各項目を設定し保存します。
    android3

    設定項目 設定値 備考
    名前 NXR L2TP/IPsec PSK 任意の名称を設定します
    タイプ L2TP/IPSec PSK
    サーバーアドレス 10.10.10.1 NXRのWAN側IPアドレスを設定します
    L2TPセキュリティ保護 (未使用) この設定例では使用していません
    IPSec ID (未使用) この設定例では使用していません
    IPSec事前共有鍵 ipseckey NXRで設定した事前共有鍵を設定します
    詳細オプションを表示する 無効
  6. 設定保存後、VPN名「NXR L2TP/IPsec PSK」が作成されますので、作成した「NXR L2TP/IPsec PSK」をタップします。
    android4
  7. ユーザ名とパスワードの入力画面が表示されますので、L2TP/IPsec用に設定したPPPのユーザ名とパスワードを入力し、接続をタップするとVPN接続を開始します。
    android5
  8. 接続が完了(成功)するとVPN名の下に「接続されました」と表示されます。
    android6

 

〔iOSの設定〕

(☞) ここで記載した設定はあくまで一例ですので、ご利用頂いているiOS端末によって設定が異なる場合があります。設定の詳細はご利用中のiOS端末の取扱説明書等をご確認下さい。
(☞) この設定例はiOS端末との接続性を保証するものではありません。ご利用頂く際には十分な検証を行った上でのご利用をお願い致します。

 

  1. ホーム画面から「設定」をタップします。
    ios1
  2. 設定画面で「一般」をタップします。
    ios2
  3. 一般画面で「VPN」をタップします。
    ios3
  4. VPN画面で「VPN構成を追加…」をタップします。
    ※この例では「test」という設定が定義されているところにVPN設定を追加します。
    ios4
  5. 構成を追加画面で「L2TP」を選択し以下の各項目を設定し保存します。
    ios5

    設定項目 設定値 備考
    説明 NXR L2TP/IPsec PSK 任意の名称を設定します
    サーバ 10.10.10.1 NXRのWAN側IPアドレスを設定します
    アカウント ios01 PPP認証で使用するアカウントを設定します
    RSA SecurID オフ
    パスワード ios01pass PPP認証で使用するパスワードを設定します
    シークレット ipseckey NXRで設定した事前共有鍵を設定します
    すべての信号を送信 オン
    プロキシ オフ
  6. VPN構成「NXR L2TP/IPsec PSK」が作成されますので、チェックがついていることを確認します。
    チェックがついていない場合は作成したVPN構成をタップします。
    そしてVPNをオンにしVPN接続を開始します。
    ios6
  7. VPN接続完了後は以下のような画面が表示されます。
    ios7

【 補足 】

L2TP/IPsec接続時、IPアドレスの他にDNSサーバのIPアドレスを割り当てることもできます。

<DNSサーバアドレスの割り当て>
(config)#interface virtual-template 0
(config-if-vt)#ppp ipcp dns [プライマリDNSサーバアドレス] [セカンダリDNSサーバアドレス]

スマートデバイスに対してDNSサーバアドレスを割り当てます。