FutureNet

NXR,WXRシリーズ

IPv6編

8. transix IPv4接続(DS-Lite)接続設定

8-3. transix IPv4接続(DS-Lite)接続設定3

IPv4 over IPv6を利用してIPv4通信を可能にするtransix IPv4接続(DS-Lite)の設定例です。この例では、ひかり電話契約ありの場合を想定しています。またルータはホームゲートウェイ(以下HGW)と置き換えて接続します。

 

【対象機種】NXR-1300,NXR-650,NXR-530,NXR-350/C,NXR-230/C,NXR-G200シリーズ,NXR-G100シリーズ

 

コンテンツ
構成図 設定フロー 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • ひかり電話契約があり、ルータをHGWと置き換えて接続する場合、IPv6プレフィックスおよびDNSサーバアドレスはDHCPv6で取得します。
  • ルータ配下の端末にはIPv6プレフィックスはRAで、DNSサーバアドレスはDHCPv6で広告します。またIPv4アドレスはDHCPで配布します。

 

【 設定フロー 】

 

【 設定例 】

nxr230#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr230(config)#ipv6 dhcp-client ipv6dhcpc
nxr230(config-dhcp6c)#ia-pd dhcpv6pd
nxr230(config-dhcp6c)#option-request dns-servers
nxr230(config-dhcp6c)#exit
nxr230(config)#ipv6 dhcp-server ipv6dhcps
nxr230(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1
nxr230(config-dhcp6s)#exit
nxr230(config)#ip route 0.0.0.0/0 tunnel 1
nxr230(config)#ipv6 access-list eth1_in permit any any icmpv6
nxr230(config)#ipv6 access-list eth1_in permit any any udp any 546
nxr230(config)#ipv6 access-list eth1_in permit any any 4
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24
nxr230(config-if)#ipv6 address dhcpv6pd ::/64 eui-64
nxr230(config-if)#ipv6 nd send-ra
nxr230(config-if)#ipv6 nd other-config-flag
nxr230(config-if)#ipv6 dhcp server ipv6dhcps
nxr230(config-if)#exit
nxr230(config)#dhcp-server 1
nxr230(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxr230(config-dhcps)#gateway 192.168.10.1
nxr230(config-dhcps)#dns-server 192.168.10.1
nxr230(config-dhcps)#exit
nxr230(config)#interface ethernet 1
nxr230(config-if)#no ip address
nxr230(config-if)#ipv6 nd accept-ra
nxr230(config-if)#ipv6 dhcp client ipv6dhcpc
nxr230(config-if)#ipv6 access-group in eth1_in
nxr230(config-if)#ipv6 spi-filter
nxr230(config-if)#exit
nxr230(config)#interface tunnel 1
nxr230(config-tunnel)#tunnel mode ipipv6
nxr230(config-tunnel)#tunnel source ethernet 0
nxr230(config-tunnel)#tunnel destination AFTRのFQDN
nxr230(config-tunnel)#ip spi-filter
nxr230(config-tunnel)#ip tcp adjust-mss auto
nxr230(config-tunnel)#exit
nxr230(config)#dns
nxr230(config-dns)#service enable
nxr230(config-dns)#edns-query enable
nxr230(config-dns)#exit
nxr230(config)#fast-forwarding enable
nxr230(config)#exit
nxr230#save config

 

【 設定例解説 】

1. <DHCPv6クライアント設定>
nxr230(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

nxr230(config-dhcp6c)#ia-pd dhcpv6pd

Identity Association for Prefix Delegation(IAPD)を有効にし、IPv6プレフィックスの名前を定義します。

nxr230(config-dhcp6c)#option-request dns-servers

DHCPv6サーバに対してDNSサーバアドレスの通知を要求するように設定します。

 

2. <DHCPv6サーバ設定>
nxr230(config)#ipv6 dhcp-server ipv6dhcps

DHCPv6サーバ設定の名前を定義します。

nxr230(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1

DHCPv6 Reply送信時に、DNSサーバアドレスを通知するように設定します。
(☞) この設定例ではDHCPv6クライアントで取得したDNSサーバアドレスを広告します。

 

3. <スタティックルート設定>
nxr230(config)#ip route 0.0.0.0/0 tunnel 1

IPv4デフォルトルートを設定します。

 

4. <IPv6アクセスリスト設定>
nxr230(config)#ipv6 access-list eth1_in permit any any icmpv6
nxr230(config)#ipv6 access-list eth1_in permit any any udp any 546

IPv6アクセスリスト名をeth1_inとし、ICMPv6および宛先UDPポート546番(DHCPv6クライアント)を許可します。

nxr230(config)#ipv6 access-list eth1_in permit any any 4

IPv6アクセスリスト名をeth1_inとし、IPinIP(プロトコル番号4)を許可します。
なお、これらIPv6アクセスリスト設定はethernet1インタフェース設定で登録します。
(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

5. <LAN側(ethernet0)インタフェース設定>
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

nxr230(config-if)#ipv6 address dhcpv6pd ::/64 eui-64

ethernet0インタフェースのIPv6アドレスを設定します。
(☞) プレフィックスはDHCPv6クライアントで取得したIPv6プレフィックスを使用します。またインタフェースIDはEUI-64を使用して自動生成します。

nxr230(config-if)#ipv6 nd send-ra
nxr230(config-if)#ipv6 nd other-config-flag

IPv6 RA(Router Advertisement)を送信するように設定します。またRAパケットのOフラグ(other-config-flag)を設定します。

nxr230(config-if)#ipv6 dhcp server ipv6dhcps

DHCPv6サーバ名を指定し、DHCPv6サーバを有効にします。

 

6. <DHCPサーバ設定>
nxr230(config)#dhcp-server 1
nxr230(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxr230(config-dhcps)#gateway 192.168.10.1
nxr230(config-dhcps)#dns-server 192.168.10.1

DHCPサーバを設定します。

 

7. <ethernet1インタフェース設定>
nxr230(config)#interface ethernet 1
nxr230(config-if)#no ip address

ethernet1インタフェースのIPv4アドレスを無効にします。

nxr230(config-if)#ipv6 nd accept-ra

RAを受信するように設定します。

nxr230(config-if)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

nxr230(config-if)#ipv6 access-group in eth1_in

IPv6アクセスリストeth1_inをinフィルタに適用します。

nxr230(config-if)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

 

8. <トンネル1インタフェース設定>
nxr230(config)#interface tunnel 1
nxr230(config-tunnel)#tunnel mode ipipv6

トンネル1インタフェースのトンネルモードをipipv6に設定します。

nxr230(config-tunnel)#tunnel source ethernet 0
nxr230(config-tunnel)#tunnel destination AFTRのFQDN

トンネルの送信元にethernet0インタフェースを指定します。また宛先にAFTR(Address Family Transition Router)のFQDNを設定します。
(☞) AFTRにはIPv6アドレスを設定することも可能です。

nxr230(config-tunnel)#ip spi-filter
nxr230(config-tunnel)#ip tcp adjust-mss auto

ステートフルパケットインスペクションを有効にします。またTCP MSSの調整機能をオートに設定します。

 

9. <DNS設定>
nxr230(config)#dns
nxr230(config-dns)#service enable
nxr230(config-dns)#edns-query enable

DNSサービスを有効にします。またEDNSも有効にします。

 

10. <ファストフォワーディング設定>
nxr230(config)#fast-forwarding enable

ファストフォワーディングを有効にします。
※NXR-230/C,NXR-G100シリーズはIPv4overIPv6(IPinIP)のファストフォワーディングに対応しています。

 

【 端末の設定例 】

IPv4 アドレス DHCPサーバから自動取得
サブネットマスク
デフォルトゲートウェイ
DNSサーバアドレス
IPv6 プレフィックス ルータからRAで取得
アドレス プレフィックス情報を元に自動生成
デフォルトゲートウェイ ルータからRAで取得
DNSサーバアドレス ルータからDHCPv6で取得

 

【 付録 】