FutureNet

NXR,WXRシリーズ

IPv6編

8. transix IPv4接続(DS-Lite)接続設定

8-4. transix IPv4接続(DS-Lite)+IPv4 PPPoE接続設定1

transix IPv4接続(DS-Lite)とIPv4 PPPoEを組み合わせた設定例です。この例ではIPv4 PPPoEを組み合わせることで、transix IPv4接続(DS-Lite)環境のみではできないIPv4アドレスを使った外部へのサーバ公開を行います。

 

【対象機種】NXR-1300,NXR-650,NXR-530,NXR-350/C,NXR-230/C,NXR-G200シリーズ,NXR-G100シリーズ

 

コンテンツ
構成図 設定フロー 設定例 設定例解説 端末の設定例 付録

 

【 構成図 】

  • この例ではひかり電話契約なしの環境を想定しています。
  • ひかり電話契約なしの場合、IPv6プレフィックスはRAで、IPv6DNSサーバアドレスはDHCPv6で取得します。
  • ルータ配下の端末にはIPv6プレフィックスはRAで、DNSサーバアドレスはDHCPv6で広告します。またIPv4アドレスはDHCPで配布します。(WWWサーバは除く)
  • IPv4アドレスでWWWサーバを外部へ公開するためにPPPoE接続を行います。またWWWサーバ用の経路をポリシーベースルーティングで設定します。

 

【 設定フロー 】

 

【 設定例 】

nxr230#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr230(config)#ipv6 dhcp-client ipv6dhcpc
nxr230(config-dhcp6c)#information-only enable
nxr230(config-dhcp6c)#option-request dns-servers
nxr230(config-dhcp6c)#exit
nxr230(config)#ipv6 dhcp-server ipv6dhcps
nxr230(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1
nxr230(config-dhcp6s)#exit
nxr230(config)#ip policy access-list ppp0_pbr_out 192.168.10.10 any
nxr230(config)#route-map pbr permit 1
nxr230(config-route-map)#match ip address ppp0_pbr_out
nxr230(config-route-map)#set interface ppp 0
nxr230(config-route-map)#exit
nxr230(config)#ip route 0.0.0.0/0 tunnel 1
nxr230(config)#ip dnat ppp0_dnat tcp any any 192.0.2.1 80 192.168.10.10
nxr230(config)#ip access-list ppp0_forward-in permit any 192.168.10.10 tcp any 80
nxr230(config)#ipv6 access-list eth1_in permit any any icmpv6
nxr230(config)#ipv6 access-list eth1_in permit any any udp any 546
nxr230(config)#ipv6 access-list eth1_in permit any any 4
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24
nxr230(config-if)#ipv6 address autoconfig
nxr230(config-if)#ipv6 nd send-ra
nxr230(config-if)#ipv6 nd other-config-flag
nxr230(config-if)#ipv6 dhcp server ipv6dhcps
nxr230(config-if)#ip policy route-map pbr
nxr230(config-if)#exit
nxr230(config)#dhcp-server 1
nxr230(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxr230(config-dhcps)#gateway 192.168.10.1
nxr230(config-dhcps)#dns-server 192.168.10.1
nxr230(config-dhcps)#exit
nxr230(config)#ppp account username test1@example.jp password test1pass
nxr230(config)#interface ppp 0
nxr230(config-ppp)#ip address 192.0.2.1/32
nxr230(config-ppp)#ip dnat-group ppp0_dnat
nxr230(config-ppp)#ip access-group forward-in ppp0_forward-in
nxr230(config-ppp)#ip masquerade
nxr230(config-ppp)#ip spi-filter
nxr230(config-ppp)#ip tcp adjust-mss auto
nxr230(config-ppp)#ppp username test1@example.jp
nxr230(config-ppp)#exit
nxr230(config)#interface ethernet 1
nxr230(config-if)#no ip address
nxr230(config-if)#ipv6 nd accept-ra proxy ethernet 0
nxr230(config-if)#ipv6 dhcp client ipv6dhcpc
nxr230(config-if)#ipv6 access-group in eth1_in
nxr230(config-if)#ipv6 spi-filter
nxr230(config-if)#pppoe-client ppp 0
nxr230(config-if)#exit
nxr230(config)#interface tunnel 1
nxr230(config-tunnel)#tunnel mode ipipv6
nxr230(config-tunnel)#tunnel source ethernet 0
nxr230(config-tunnel)#tunnel destination AFTRのFQDN
nxr230(config-tunnel)#ip spi-filter
nxr230(config-tunnel)#ip tcp adjust-mss auto
nxr230(config-tunnel)#exit
nxr230(config)#dns
nxr230(config-dns)#service enable
nxr230(config-dns)#edns-query enable
nxr230(config-dns)#priority dhcpv6 1
nxr230(config-dns)#priority ppp 0 2
nxr230(config-dns)#timeout 5
nxr230(config-dns)#exit
nxr230(config)#fast-forwarding enable
nxr230(config)#exit
nxr230#save config

 

【 設定例解説 】

1. <DHCPv6クライアント設定>
nxr230(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

nxr230(config-dhcp6c)#information-only enable

information-only機能を有効にします。

nxr230(config-dhcp6c)#option-request dns-servers

DHCPv6サーバに対してDNSサーバアドレスの通知を要求するように設定します。

 

2. <DHCPv6サーバ設定>
nxr230(config)#ipv6 dhcp-server ipv6dhcps

DHCPv6サーバ設定の名前を定義します。

nxr230(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1

DHCPv6 Reply送信時に、DNSサーバアドレスを通知するように設定します。
(☞) この設定例ではDHCPv6クライアントで取得したDNSサーバアドレスを広告します。

 

3. <IPポリシーアクセスリスト設定>
nxr230(config)#ip policy access-list ppp0_pbr_out 192.168.10.10 any

IPポリシーアクセスリスト名をppp0_pbr_outとし、送信元IPアドレス192.168.10.10を登録します。
IPポリシーアクセスリスト設定は、ルートマップ設定で登録します。
(☞) IPポリシーアクセスリストを設定しただけでは、ポリシーベースルーティングは機能しません。ルートマップ設定およびパケット受信インタフェースでルートマップの登録が必要になります。

 

4. <ルートマップ設定>
nxr230(config)#route-map pbr permit 1

ルートマップ名をpbrとし、No.1のルールを作成します。

nxr230(config-route-map)#match ip address ppp0_pbr_out

マッチ条件として、IPポリシーアクセスリストで設定したppp0_pbr_outを設定します。

nxr230(config-route-map)#set interface ppp 0

該当条件にマッチした際のネクストホップとしてppp0を設定します。

 

5. <スタティックルート設定>
nxr230(config)#ip route 0.0.0.0/0 tunnel 1

IPv4デフォルトルートを設定します。

 

6. <DNAT設定>
nxr230(config)#ip dnat ppp0_dnat tcp any any 192.0.2.1 80 192.168.10.10

DNAT名をppp0_dnatとし、宛先IPアドレス192.0.2.1,宛先TCPポート番号80のパケットの宛先IPアドレスを192.168.10.10に変換します。
(☞) DNATを設定しただけでは、宛先IPアドレスの変換機能は有効になりません。宛先IPアドレスの変換を行うインタフェースでの登録が必要になります。

 

7. <IPv4アクセスリスト設定>
nxr230(config)#ip access-list ppp0_forward-in permit any 192.168.10.10 tcp any 80

IPアクセスリスト名をppp0_forward-inとし、宛先IPアドレス192.168.10.10,宛先TCPポート番号80のパケットを許可します。
(☞) IPv4アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

8. <IPv6アクセスリスト設定>
nxr230(config)#ipv6 access-list eth1_in permit any any icmpv6
nxr230(config)#ipv6 access-list eth1_in permit any any udp any 546

IPv6アクセスリスト名をeth1_inとし、ICMPv6および宛先UDPポート546番(DHCPv6クライアント)を許可します。

nxr230(config)#ipv6 access-list eth1_in permit any any 4

IPv6アクセスリスト名をeth1_inとし、IPinIP(プロトコル番号4)を許可します。
(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

9. <LAN側(ethernet0)インタフェース設定>
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

nxr230(config-if)#ipv6 address autoconfig

ethernet0インタフェースのIPv6アドレスを設定します。

nxr230(config-if)#ipv6 nd send-ra
nxr230(config-if)#ipv6 nd other-config-flag

IPv6 RA(Router Advertisement)を送信するように設定します。またRAパケットのOフラグ(other-config-flag)を設定します。

nxr230(config-if)#ipv6 dhcp server ipv6dhcps

DHCPv6サーバ名を指定し、DHCPv6サーバを有効にします。

nxr230(config-if)#ip policy route-map pbr

ポリシーベースルーティング用のルートマップを登録します。

 

10. <DHCPサーバ設定>
nxr230(config)#dhcp-server 1
nxr230(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxr230(config-dhcps)#gateway 192.168.10.1
nxr230(config-dhcps)#dns-server 192.168.10.1

DHCPサーバを設定します。

 

11. <PPPアカウント設定>
nxr230(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で指定します。

 

12. <WAN側(ppp0)インタフェース設定>
nxr230(config)#interface ppp 0
nxr230(config-ppp)#ip address 192.0.2.1/32

ppp0インタフェースのIPアドレスを設定します。

nxr230(config-ppp)#ip dnat-group ppp0_dnat

DNATで設定したppp0_dnatを適用します。

nxr230(config-ppp)#ip access-group forward-in ppp0_forward-in

IPv4アクセスリストppp0_forward-inをforward-inフィルタに適用します。

nxr230(config-ppp)#ip masquerade
nxr230(config-ppp)#ip spi-filter
nxr230(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効にします。またTCP MSSの調整機能をオートに設定します。

nxr230(config-ppp)#ppp username test1@example.jp

ISP接続用ユーザIDを設定します。
(☞) PPPアカウント設定で登録したアカウントを設定します。

 

13. <WAN側(ethernet1)インタフェース設定>
nxr230(config)#interface ethernet 1
nxr230(config-if)#no ip address

ethernet1インタフェースのIPv4アドレスを無効にします。

nxr230(config-if)#ipv6 nd accept-ra proxy ethernet 0

RAプロキシを有効にします。

nxr230(config-if)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

nxr230(config-if)#ipv6 access-group in eth1_in

IPv6アクセスリストeth1_inをinフィルタに適用します。

nxr230(config-if)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

nxr230(config-if)#pppoe-client ppp 0

PPPoEクライアントを設定します。また使用するPPPインタフェースとしてppp0を指定します。

 

14. <トンネル1インタフェース設定>
nxr230(config)#interface tunnel 1
nxr230(config-tunnel)#tunnel mode ipipv6

トンネル1インタフェースのトンネルモードをipipv6に設定します。

nxr230(config-tunnel)#tunnel source ethernet 0
nxr230(config-tunnel)#tunnel destination AFTRのFQDN

トンネルの送信元にethernet0インタフェースを指定します。また宛先にAFTR(Address Family Transition Router)のFQDNを設定します。
(☞) AFTRにはIPv6アドレスを設定することも可能です。

nxr230(config-tunnel)#ip spi-filter
nxr230(config-tunnel)#ip tcp adjust-mss auto

ステートフルパケットインスペクションを有効にします。またTCP MSSの調整機能をオートに設定します。

 

15. <DNS設定>
nxr230(config)#dns
nxr230(config-dns)#service enable
nxr230(config-dns)#edns-query enable

DNSサービスを有効にします。またEDNSも有効にします。

nxr230(config-dns)#priority dhcpv6 1
nxr230(config-dns)#priority ppp 0 2
nxr230(config-dns)#timeout 5

DNSサーバの優先度を変更します。DHCPv6で取得したDNSサーバアドレスを、ppp0で取得したDNSサーバアドレスよりも優先するように設定します。
またタイムアウト時間も設定します。

 

16. <ファストフォワーディング設定>
nxr230(config)#fast-forwarding enable

ファストフォワーディングを有効にします。
※NXR-230/C,NXR-G100シリーズはIPv4overIPv6(IPinIP)のファストフォワーディングに対応しています。

 

【 端末の設定例 】

IPv4 アドレス DHCPサーバから自動取得
サブネットマスク
デフォルトゲートウェイ
DNSサーバアドレス
IPv6 プレフィックス ルータからRAで取得
アドレス プレフィックス情報を元に自動生成
デフォルトゲートウェイ ルータからRAで取得
DNSサーバアドレス ルータからDHCPv6で取得

 

【 付録 】