FutureNet

NXR,WXRシリーズ

WANインタフェース編

8. 冗長化設定

8-3. PPPoE冗長化構成(回線冗長)+PBR設定

この設定例は、PPPoE回線の冗長化を行う設定例です。そして、PBR(ポリシーベースルーティング)機能を利用して、同一の宛先でもppp0,ppp1インタフェースに通信を振り分けます。

 

【 構成図 】

 <正常時>

<ppp0インタフェース障害時>

  • PBR(ポリシーベースルーティング)機能を利用して送信元IPアドレスの範囲を2つに分け、同一の宛先でもppp0,ppp1インタフェースに振り分けます。さらに、どちらかのPPPインタフェースがダウンした場合は、アップしているPPPインタフェースを利用して通信を継続します。
  • IPCPで取得したDNSサーバのIPアドレス参照順を、以下のように設定します。
    1. プロバイダ1(ppp0インタフェース)で取得したプライマリDNSサーバ
    2. プロバイダ1(ppp0インタフェース)で取得したセカンダリDNSサーバ
    3. プロバイダ2(ppp1インタフェース)で取得したプライマリDNSサーバ
    4. プロバイダ2(ppp1インタフェース)で取得したセカンダリDNSサーバ

 

【 設定データ 】

設定項目 設定内容
LAN側インタフェース ethernet0のIPアドレス 192.168.10.1/24
IPポリシルートマップ pbr
WAN側インタフェース PPPoEクライアント(ethernet1) ppp0
ppp0インタフェース
(ISP1側)
ppp0のIPアドレス 動的IPアドレス
IPマスカレード 有効
SPIフィルタ 有効
MSS自動調整 オート
ISP1接続用ユーザID test1@example.jp
ISP1接続用パスワード test1pass
PPPoEクライアント(ethernet2) ppp1
ppp1インタフェース
(ISP2側)
ppp1のIPアドレス 動的IPアドレス
IPマスカレード 有効
SPIフィルタ 有効
MSS自動調整 オート
ISP2接続用ユーザID test1@example.ne.jp
ISP2接続用パスワード test1pass
スタティックルート No.1 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp0
ディスタンス 1
No.2 宛先IPアドレス 0.0.0.0/0
ゲートウェイ(インタフェース) ppp1
ディスタンス 10
IPポリシアクセスリスト ポリシ名 ppp0_pbr_out
ppp0_pbr_out 送信元IPアドレス 192.168.10.0/25
宛先IPアドレス any
ポリシ名 ppp1_pbr_out
ppp1_pbr_out 送信元IPアドレス 192.168.10.128/25
宛先IPアドレス any
ルートマップ ルートマップ名 pbr
pbr No.1 マッチIPアドレス ppp0_pbr_out
セットインタフェース ppp0
No.2 マッチIPアドレス ppp1_pbr_out
セットインタフェース ppp1
LED AUX1 ppp0アップ時点灯
AUX2 ppp1アップ時点灯
DNS サービス 有効
プライオリティ ppp0 1
ppp1 2
FastFowarding 有効

【 設定例 】

nxr230#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxr230(config)#ip policy access-list ppp0_pbr_out 192.168.10.0/25 any
nxr230(config)#ip policy access-list ppp1_pbr_out 192.168.10.128/25 any
nxr230(config)#route-map pbr permit 1
nxr230(config-route-map)#match ip address ppp0_pbr_out
nxr230(config-route-map)#set interface ppp 0
nxr230(config-route-map)#exit
nxr230(config)#route-map pbr permit 2
nxr230(config-route-map)#match ip address ppp1_pbr_out
nxr230(config-route-map)#set interface ppp 1
nxr230(config-route-map)#exit
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24
nxr230(config-if)#ip policy route-map pbr
nxr230(config-if)#exit
nxr230(config)#ip route 0.0.0.0/0 ppp 0 1
nxr230(config)#ip route 0.0.0.0/0 ppp 1 10
nxr230(config)#ppp account username test1@example.jp password test1pass
nxr230(config)#ppp account username test1@example.ne.jp password test1pass
nxr230(config)#interface ppp 0
nxr230(config-ppp)#ip address negotiated
nxr230(config-ppp)#ip masquerade
nxr230(config-ppp)#ip spi-filter
nxr230(config-ppp)#ip tcp adjust-mss auto
nxr230(config-ppp)#ppp username test1@example.jp
nxr230(config-ppp)#exit
nxr230(config)#interface ppp 1
nxr230(config-ppp)#ip address negotiated
nxr230(config-ppp)#ip masquerade
nxr230(config-ppp)#ip spi-filter
nxr230(config-ppp)#ip tcp adjust-mss auto
nxr230(config-ppp)#ppp username test1@example.ne.jp
nxr230(config-ppp)#exit
nxr230(config)#interface ethernet 1
nxr230(config-if)#no ip address
nxr230(config-if)#pppoe-client ppp 0
nxr230(config-if)#exit
nxr230(config)#interface ethernet 2
nxr230(config-if)#no ip address
nxr230(config-if)#pppoe-client ppp 1
nxr230(config-if)#exit
nxr230(config)#system led aux 1 interface ppp 0
nxr230(config)#system led aux 2 interface ppp 1
nxr230(config)#dns
nxr230(config-dns)#service enable
nxr230(config-dns)#priority ppp 0 1
nxr230(config-dns)#priority ppp 1 2
nxr230(config-dns)#exit
nxr230(config)#fast-forwarding enable
nxr230(config)#exit
nxr230#save config

【 設定例解説 】

1. <IPポリシアクセスリスト設定>
nxr230(config)#ip policy access-list ppp0_pbr_out 192.168.10.0/25 any

ポリシルーティングの動作ルールを作成します。

IPポリシアクセスリスト名をppp0_pbr_outとし、送信元IPアドレス192.168.10.0/25を登録します。

nxr230(config)#ip policy access-list ppp1_pbr_out 192.168.10.128/25 any

IPポリシアクセスリスト名をppp1_pbr_outとし、送信元IPアドレス192.168.10.128/25を登録します。

これらIPポリシアクセスリスト設定は、ルートマップ設定で登録します。
(☞) IPポリシアクセスリスト設定を設定しただけでは、ポリシベースルーティングは機能しません。ルートマップ設定、パケット受信インタフェースでの登録が必要になります。

 

2. <ルートマップ設定>
nxr230(config)#route-map pbr permit 1

ルートマップ名をpbrとし、No.1のルールを作成します。

nxr230(config-route-map)#match ip address ppp0_pbr_out

マッチ条件として、IPポリシアクセスリストで設定したppp0_pbr_outを設定します。

nxr230(config-route-map)#set interface ppp 0

該当条件にマッチした際の出力インタフェースとして、ppp0インタフェースを設定します。

nxr230(config)#route-map pbr permit 2
nxr230(config-route-map)#match ip address ppp1_pbr_out
nxr230(config-route-map)#set interface ppp 1

次にルートマップ名pbrにNo.2のルールを作成します。
マッチ条件として、IPポリシアクセスリストで設定したppp1_pbr_outを、該当条件にマッチした際の出力インタフェースとしてppp1インタフェースを設定します。
(☞) ルートマップ設定を設定しただけでは、ポリシベースルーティングは機能しません。パケット受信インタフェースでの登録が必要になります。

 

3. <LAN側(ethernet0)インタフェース設定>
nxr230(config)#interface ethernet 0
nxr230(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPアドレスを設定します。

nxr230(config-if)#ip policy route-map pbr

ルートマップを登録します。

 

4. <スタティックルート設定>
nxr230(config)#ip route 0.0.0.0/0 ppp 0 1
nxr230(config)#ip route 0.0.0.0/0 ppp 1 10

デフォルトルートを設定します。
(☞) ECMPではないため、ディスタンス値でルートの重みづけを行います。

 

5. <PPPアカウント設定>
nxr230(config)#ppp account username test1@example.jp password test1pass

ppp0インタフェースで使用するISP1接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp0インタフェースの設定で利用します。

nxr230(config)#ppp account username test1@example.ne.jp password test1pass

ppp1インタフェースで使用するISP2接続用ユーザID,パスワードを設定します。
(☞) ここで設定したアカウントはppp1インタフェースの設定で利用します。

 

6. <WAN ISP1側(ppp0)インタフェース設定>
nxr230(config)#interface ppp 0
nxr230(config-ppp)#ip address negotiated

ppp0インタフェースのIPアドレスが動的IPアドレスの場合は、negotiatedを設定します。

nxr230(config-ppp)#ip masquerade
nxr230(config-ppp)#ip spi-filter
nxr230(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。また、TCP MSSの調整機能をオートに設定します。

nxr230(config-ppp)#ppp username test1@example.jp

ISP1接続用ユーザIDを設定します。

 

7. <WAN ISP2側(ppp1)インタフェース設定>
nxr230(config)#interface ppp 1
nxr230(config-ppp)#ip address negotiated

ppp1インタフェースのIPアドレスが動的IPアドレスの場合は、negotiatedを設定します。

nxr230(config-ppp)#ip masquerade
nxr230(config-ppp)#ip spi-filter
nxr230(config-ppp)#ip tcp adjust-mss auto

IPマスカレード、ステートフルパケットインスペクションを有効に設定します。また、TCP MSSの調整機能をオートに設定します。

nxr230(config-ppp)#ppp username test1@example.ne.jp

ISP2接続用ユーザIDを設定します。

 

8. <ethernet1インタフェース設定>
nxr230(config)#interface ethernet 1
nxr230(config-if)#no ip address
nxr230(config-if)#pppoe-client ppp 0

PPPoEクライアントとしてppp0インタフェースを使用できるように設定します。

 

9. <ethernet2インタフェース設定>
nxr230(config)#interface ethernet 2
nxr230(config-if)#no ip address
nxr230(config-if)#pppoe-client ppp 1

PPPoEクライアントとしてppp1インタフェースを使用できるように設定します。

 

10. <システムLED設定>
nxr230(config)#system led aux 1 interface ppp 0
nxr230(config)#system led aux 2 interface ppp 1

ppp0インタフェースのアップ/ダウンをaux1 LEDで、ppp1インタフェースのアップ/ダウンをaux2 LEDで表示するように設定します。

 

11. <DNS設定>
nxr230(config)#dns
nxr230(config-dns)#service enable

DNSサービスを有効にします。

nxr230(config-dns)#priority ppp 0 1
nxr230(config-dns)#priority ppp 1 2

DNSサーバの優先度を変更します。
プロバイダ1(ppp0インタフェース)より取得したDNSサーバアドレスを、プロバイダ2(ppp1インタフェース)より取得したDNSサーバアドレスよりも優先するように設定します。
(☞) この設定例では、異なるプロバイダを利用することを想定しています。そのため、プロバイダ1のDNSサーバが障害等で利用不可の場合、プロバイダ2のDNSサーバを利用して名前解決を試みます。この際、名前解決時のパケットの送信元IPアドレスは、プロバイダ1のアドレス、宛先IPアドレスはプロバイダ2のDNSサーバのアドレスといった場合、プロバイダ2のDNSサーバがオープンリゾルバ対策済みの場合、名前解決できない状況が発生します。このような場合、各回線で同じプロバイダを利用する、パブリックDNSサーバなどどのプロバイダからも参照可能なDNSサーバを指定するなどの方法があります。

 

12. <ファストフォワーディングの有効化>
nxr230(config)#fast-forwarding enable

ファストフォワーディングを有効にします。ファストフォワーディングを設定することによりパケット転送の高速化を行うことができます。
(☞) ファストフォワーディングの詳細および利用時の制約については、NXR,WXRシリーズのユーザーズガイド(CLI版)に記載されているファストフォワーディングの解説をご参照ください。

 

【 端末の設定例 】

端末1 端末2
IP アドレス 192.168.10.100 192.168.10.200
サブネットマスク 255.255.255.0
デフォルトゲートウェイ 192.168.10.1
DNS サーバ