FutureNet

NXR,WXRシリーズ

IPv6編

7.「v6プラス」接続設定

7-2. 「v6プラス」接続設定2

日本ネットワークイネイブラー株式会社(以下JPNE社)が提供する「v6プラス」を利用する設定例です。この設定例ではひかり電話契約ありの場合を想定しています。またルータはホームゲートウェイ(以下HGW)配下に接続します。
※「v6プラス」は、日本ネットワークイネイブラー株式会社の登録商標(または商標)です。

 

【対象機種】NXR-650,NXR-530,NXR-G200シリーズ

 

コンテンツ
構成図 設定フロー 設定例 設定例解説 端末の設定例 補足 付録

 

【 構成図 】

  • HGWで「v6プラス」の状態が有効になっている場合、動作しません。
  • ひかり電話契約があり、HGW配下にルータを接続する場合、IPv6プレフィックスはRAで、DNSサーバアドレスはDHCPv6で取得します。
  • ルータ配下の端末にはIPv6プレフィックスはRAで、DNSサーバアドレスはDHCPv6で広告します。またIPv4アドレスはDHCPで配布します。

 

【 設定フロー 】

 

【 設定例 】

nxrg240#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
nxrg240(config)#ipv6 dhcp-client ipv6dhcpc
nxrg240(config-dhcp6c)#ia-pd dhcpv6pd
nxrg240(config-dhcp6c)#option-request dns-servers
nxrg240(config-dhcp6c)#exit
nxrg240(config)#ipv6 dhcp-server ipv6dhcps
nxrg240(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1
nxrg240(config-dhcp6s)#exit
nxrg240(config)#mape-rule v6plus type jpne auto
nxrg240(config)#interface map 0
nxrg240(config-map)#tunnel mode ipipv6 mape-rule v6plus
nxrg240(config-map)#ip spi-filter
nxrg240(config-map)#ip tcp adjust-mss auto
nxrg240(config-map)#no tunnel encap-limit
nxrg240(config-map)#exit
nxrg240(config)#ip route 0.0.0.0/0 map 0
nxrg240(config)#ipv6 access-list eth1_in permit any any icmpv6
nxrg240(config)#ipv6 access-list eth1_in permit any any udp any 546
nxrg240(config)#ipv6 access-list eth1_in permit any any 4
nxrg240(config)#interface ethernet 0
nxrg240(config-if)#ip address 192.168.10.1/24
nxrg240(config-if)#ipv6 address dhcpv6pd ::/64 eui-64
nxrg240(config-if)#ipv6 nd send-ra
nxrg240(config-if)#ipv6 nd other-config-flag
nxrg240(config-if)#ipv6 dhcp server ipv6dhcps
nxrg240(config-if)#exit
nxrg240(config)#dhcp-server 1
nxrg240(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg240(config-dhcps)#gateway 192.168.10.1
nxrg240(config-dhcps)#dns-server 192.168.10.1
nxrg240(config-dhcps)#exit
nxrg240(config)#interface ethernet 1
nxrg240(config-if)#ip address dhcp
nxrg240(config-if)#ipv6 address autoconfig interface-id mape-rule v6plus
nxrg240(config-if)#ipv6 dhcp client ipv6dhcpc
nxrg240(config-if)#ipv6 access-group in eth1_in
nxrg240(config-if)#ipv6 spi-filter
nxrg240(config-if)#exit
nxrg240(config)#dns
nxrg240(config-dns)#service enable
nxrg240(config-dns)#edns-query enable
nxrg240(config-dns)#priority dhcpv6 1
nxrg240(config-dns)#priority dhcp 2
nxrg240(config-dns)#timeout 5
nxrg240(config-dns)#exit
nxrg240(config)#exit
nxrg240#save config

 

【 設定例解説 】

1. <DHCPv6クライアント設定>
nxrg240(config)#ipv6 dhcp-client ipv6dhcpc

DHCPv6クライアント設定の名前を定義します。

nxrg240(config-dhcp6c)#ia-pd dhcpv6pd

Identity Association for Prefix Delegation(IAPD)を有効にし、IPv6プレフィックスの名前を定義します。

nxrg240(config-dhcp6c)#option-request dns-servers

DHCPv6サーバに対してDNSサーバアドレスの通知を要求するように設定します。

 

2. <DHCPv6サーバ設定>
nxrg240(config)#ipv6 dhcp-server ipv6dhcps

DHCPv6サーバ設定の名前を定義します。

nxrg240(config-dhcp6s)#option-send dns-server add dhcp-client ethernet 1

DHCPv6 Reply送信時に、DNSサーバアドレスを通知するように設定します。
(☞) この設定例ではDHCPv6クライアントで取得したDNSサーバアドレスを広告します。

 

3. <MAP-Eルール設定>
nxrg240(config)#mape-rule v6plus type jpne auto

MAP-Eルール名をv6plusとし、MAP-Eのルールタイプをjpne,取得方法をautoに設定します。

 

4. <map0インタフェース設定>
nxrg240(config)#interface map 0
nxrg240(config-map)#tunnel mode ipipv6 mape-rule v6plus

map0インタフェースでトンネルモードとMAP-Eルール名を設定します。

nxrg240(config-map)#ip spi-filter
nxrg240(config-map)#ip tcp adjust-mss auto

ステートフルパケットインスペクションを有効にします。またTCP MSSの調整機能をオートに設定します。

nxrg240(config-map)#no tunnel encap-limit

encap-limit設定を無効にします。

 

5. <スタティックルート設定>
nxrg240(config)#ip route 0.0.0.0/0 map 0

IPv4デフォルトルートを設定します。

 

6. <IPv6アクセスリスト設定>
nxrg240(config)#ipv6 access-list eth1_in permit any any icmpv6
nxrg240(config)#ipv6 access-list eth1_in permit any any udp any 546

IPv6アクセスリスト名をeth1_inとし、ICMPv6および宛先UDPポート546番(DHCPv6クライアント)を許可します。

nxrg240(config)#ipv6 access-list eth1_in permit any any 4

IPv6アクセスリスト名をeth1_inとし、IPinIP(プロトコル番号4)を許可します。
なお、これらIPv6アクセスリスト設定はethernet1インタフェース設定で登録します。
(☞) IPv6アクセスリストを設定しただけではフィルタとして有効にはなりません。フィルタリングしたいインタフェースでの登録が必要になります。

 

7. <LAN側(ethernet0)インタフェース設定>
nxrg240(config)#interface ethernet 0
nxrg240(config-if)#ip address 192.168.10.1/24

ethernet0インタフェースのIPv4アドレスを設定します。

nxrg240(config-if)#ipv6 address dhcpv6pd ::/64 eui-64

ethernet0インタフェースのIPv6アドレスを設定します。
(☞) プレフィックスはDHCPv6クライアントで取得したIPv6プレフィックスを使用します。またインタフェースIDはEUI-64を使用して自動生成します。

nxrg240(config-if)#ipv6 nd send-ra
nxrg240(config-if)#ipv6 nd other-config-flag

IPv6 RA(Router Advertisement)を送信するように設定します。またRAパケットのOフラグ(other-config-flag)を設定します。

nxrg240(config-if)#ipv6 dhcp server ipv6dhcps

DHCPv6サーバ名を指定し、DHCPv6サーバを有効にします。

 

8. <DHCPサーバ設定>
nxrg240(config)#dhcp-server 1
nxrg240(config-dhcps)#network 192.168.10.0/24 range 192.168.10.200 192.168.10.210
nxrg240(config-dhcps)#gateway 192.168.10.1
nxrg240(config-dhcps)#dns-server 192.168.10.1

DHCPサーバを設定します。

 

9. <ethernet1インタフェース設定>
nxrg240(config)#interface ethernet 1
nxrg240(config-if)#ip address dhcp

ethernet1インタフェースのIPv4アドレスをdhcpにします。

nxrg240(config-if)#ipv6 address autoconfig interface-id mape-rule v6plus

ethernet1インタフェースのIPv6アドレスを設定します。なおインタフェースIDにはMAP-Eルール名を設定します。

nxrg240(config-if)#ipv6 dhcp client ipv6dhcpc

DHCPv6クライアント名を指定し、DHCPv6クライアントを有効にします。

nxrg240(config-if)#ipv6 access-group in eth1_in

IPv6アクセスリストeth1_inをinフィルタに適用します。

nxrg240(config-if)#ipv6 spi-filter

IPv6ステートフルパケットインスペクションを有効にします。

 

10. <DNS設定>
nxrg240(config)#dns
nxrg240(config-dns)#service enable
nxrg240(config-dns)#edns-query enable

DNSサービスを有効にします。またEDNSも有効にします。

nxrg240(config-dns)#priority dhcpv6 1
nxrg240(config-dns)#priority dhcp 2
nxrg240(config-dns)#timeout 5

DNSサーバの優先度を変更します。DHCPv6で取得したDNSサーバアドレスを、DHCPで取得したDNSサーバアドレスよりも優先するように設定します。
またタイムアウト時間も設定します。

 

【 端末の設定例 】

IPv4 アドレス DHCPサーバから自動取得
サブネットマスク
デフォルトゲートウェイ
DNSサーバアドレス
IPv6 プレフィックス ルータからRAで取得
アドレス プレフィックス情報を元に自動生成
デフォルトゲートウェイ ルータからRAで取得
DNSサーバアドレス ルータからDHCPv6で取得

 

【 補足 】

map0インタフェースにMAPルールで割り当てられたIPv4アドレスを割り当てる場合、下記のように設定します。

<map0インタフェースのIPv4アドレス設定>
nxrg240(config)#interface map 0
nxrg240(config-map)#ip address mape-rule

 

【 付録 】